5 # Sample debian/rules that uses debhelper.
6 # This file was originally written by Joey Hess and Craig Small.
7 # As a special exception, when this file is copied by dh-make into a
8 # dh-make output file, you may use that output file without restriction.
9 # This special exception was added by Craig Small in version 0.37 of dh-make.
11 # Uncomment this to turn on verbose mode.
14 # these are used to override the variables in the upstream makefile
16 export libdir = $(prefix)/share
/cogito
18 DESTDIR
= $(CURDIR
)/debian
/cogito
21 # On PowerPC we compile against the hand-crafted assembly, on all
22 # other architectures we compile against GPL'ed sha1 code lifted
25 HOST_ARCH
=$(shell dpkg-architecture
-qDEB_HOST_ARCH
)
26 ifeq (${HOST_ARCH},powerpc
)
27 export PPC_SHA1
=YesPlease
29 export MOZILLA_SHA1
=YesPlease
34 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
40 configure
: configure-stamp
48 build-stamp
: configure-stamp
51 $(MAKE
) -C Documentation
all
57 rm -f build-stamp configure-stamp
59 $(MAKE
) -C Documentation
clean
67 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/cogito
prefix=/usr
68 # $(RM) $(DESTDIR)/usr/bin/cg
69 install -m
0644 Documentation
/*.html
$(DESTDIR
)/usr
/share
/doc
/cogito
/html
70 install -m
0644 Documentation
/cg-
*.txt
$(DESTDIR
)/usr
/share
/doc
/cogito
/txt
71 install -m
0644 Documentation
/cogito.txt
$(DESTDIR
)/usr
/share
/doc
/cogito
/txt
72 install -m
0644 Documentation
/*.1 $(DESTDIR
)/usr
/share
/man
/man1
73 install -m
0644 Documentation
/*.7 $(DESTDIR
)/usr
/share
/man
/man7
75 # Build architecture-independent files here.
76 binary-indep
: build
install
77 # We have nothing to do by default.
79 # Build architecture-dependent files here.
80 binary-arch
: build
install
110 binary
: binary-indep binary-arch
111 .PHONY
: build
clean binary-indep binary-arch binary
install configure