3 # Uncomment this to turn on verbose mode.
6 # Generating a xulrunner build id and other strings
7 DEBIAN_VERSION
:= $(shell echo
-n
`head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
8 BUILDID
:= $(shell echo
-n
`whoami`@
`hostname`)_
$(shell date
+%s
)
9 USC
= $(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
14 override_dh_install-indep
:
17 # Add generated Build ID and Debian version to version output
18 sed
-e
's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' \
19 -i
$(USC
)/application.ini
21 # Use Debian version for M-x version output
22 sed
-e
's/Version=\(.*\)/Version=\1 (Debian-${DEBIAN_VERSION})/' \
23 -i
$(USC
)/components
/application.js