Debian package: Make patches conform to DEP-3
[conkeror.git] / debian / patches / deb-webjumps.diff
blob36302fbaea50d51c8dd39ab68dacc601e482f2ce
1 Description: Adds and enables some Debian and Ubuntu related webjumps
2 They're not suitable for being inlcuded in upstream by default.
3 Forwarded: not-needed
4 Author: Axel Beckert <abe@debian.org>
6 Index: conkeror/modules/debian/debian-webjumps.js
7 ===================================================================
8 --- /dev/null 1970-01-01 00:00:00.000000000 +0000
9 +++ conkeror/modules/debian/debian-webjumps.js 2010-09-29 07:55:36.000000000 +0200
10 @@ -0,0 +1,31 @@
11 +/**
12 + * (C) Copyright 2008-2010, 2012, 2014 Axel Beckert
13 + *
14 + * Use, modification, and distribution are subject to the terms specified in the
15 + * COPYING file.
16 + *
17 + * Webjumps to interact with Debian and Ubuntu websites
18 +**/
20 +require("webjump.js");
22 +// Debian //
23 +define_webjump("debpkg", "https://packages.debian.org/%s");
24 +define_webjump("debfile", "https://packages.debian.org/file:%s");
25 +define_webjump("debbugs", "https://bugs.debian.org/%s");
26 +define_webjump("debpts", "https://packages.qa.debian.org/%s");
27 +define_webjump("debpopcon", "https://qa.debian.org/popcon.php?package=%s");
28 +define_webjump("buildd", "https://buildd.debian.org/%s");
29 +define_webjump("buildd-ports", "http://buildd.debian-ports.org/%s");
30 +define_webjump("debqa", "https://qa.debian.org/developer.php?login=%s");
31 +define_webjump("debpopcon", "https://qa.debian.org/popcon.php?package=%s");
32 +define_webjump("debtracker", "https://tracker.debian.org/%s");
34 +// Ubuntu //
35 +define_webjump("ubuntupkg", "http://packages.ubuntu.com/%s");
36 +define_webjump("ubuntufile", "http://packages.ubuntu.com/search?searchon=contents&keywords=%s&mode=path&arch=any");
37 +define_webjump("ubuntubugs", "http://bugs.launchpad.net/ubuntu/+source/%s");
38 +define_webjump("lpbugnr", "http://bugs.launchpad.net/bugs/%s");
39 +define_webjump("launchpad", "https://launchpad.net/+search?field.text=%s");
41 +provide("debian-webjumps");
42 Index: conkeror/defaults/preferences/debian-default-modules.js
43 ===================================================================
44 --- conkeror.orig/defaults/preferences/debian-default-modules.js 2010-09-28 01:47:21.000000000 +0200
45 +++ conkeror/defaults/preferences/debian-default-modules.js 2010-09-29 07:57:40.000000000 +0200
46 @@ -0,0 +1,1 @@
47 +pref("conkeror.load.debian/debian-webjumps", 1);