1 Description: Use sensible-editor and xdg-open instead of hardcoded applications
2 Let Debian's sensible-editor guess the editor and let xdg-open find
3 the right application to open an file instead of hardcoded
4 applications which may not be installed.
5 Bug-Debian: https://bugs.debian.org/570086
6 Author: Axel Beckert <abe@debian.org>
8 Index: conkeror/modules/external-editor.js
9 ===================================================================
10 --- conkeror.orig/modules/external-editor.js 2012-01-31 18:28:37.000000000 +0100
11 +++ conkeror/modules/external-editor.js 2012-01-31 18:35:45.000000000 +0100
16 -define_variable("editor_shell_command", getenv("VISUAL") || getenv("EDITOR") || "emacs",
17 +define_variable("editor_shell_command", "/usr/bin/sensible-editor",
18 "Shell command used to invoke an external editor.\n" +
19 "This defaults to the value of the EDITOR environment variable. If " +
20 "`run_external_editor_function' is non-null, it is used instead to " +
21 Index: conkeror-1.0~~pre+git120518/modules/mime.js
22 ===================================================================
23 --- conkeror-1.0~~pre+git120518.orig/modules/mime.js 2012-02-22 23:15:54.000000000 +0100
24 +++ conkeror-1.0~~pre+git120518/modules/mime.js 2012-05-19 00:52:56.000000000 +0200
27 define_mime_type_table("external_content_handlers",
29 - "*": getenv("EDITOR"),
30 - text: { "*": getenv("EDITOR") },
31 - image: { "*": "feh" },
32 - video: { "*": "mplayer" },
33 - audio: { "*": "mplayer" },
36 - postscript: "evince",
40 + text: { "*": "sensible-editor" }
42 "Structure associating MIME types and MIME type patterns with "+
43 "the names of programs for handling those them. The key \"*\" "+