mb/google/nissa/var/rull: when using pcie wifi7, turn off CNVI BT
[coreboot2.git] / util / nixshell / devshell-i386.nix
blob88a67dcef4fcfde8106912430d9b8f9d24787d11
1 with import <nixpkgs> {};
3 pkgs.mkShell {
4         name = "coreboot-devshell-i386";
6         packages = [
7                 cacert
8                 gdb
9                 git
10                 qemu
11         ];
13         buildInputs = [
14                 ncurses
15                 openssl
16         ];
18         nativeBuildInputs = [
19                 coreboot-toolchain.i386
20                 pkg-config
21                 openssh
22         ];
24         shellHook = ''
25                 # In Nix, stdenv sets a STRIP environment variable, which has conflict
26                 # with libpayload/Makefile.payload. Unset the variable.
27                 unset STRIP
28         '';