mb/starlabs/starlite_adl: Configure CNVi Bluetooth I2S GPIOs
[coreboot2.git] / util / coreboot-configurator / contrib / PKGBUILD
blob931dff2468d0f356ec1e896c0ab0ea529e3cf65c
1 # Maintainer: Bernhard Landauer <bernhard@manjaro.org>
3 pkgname=coreboot-configurator
4 pkgver=8
5 pkgrel=2
6 pkgdesc="A graphical interface to set options on devices with coreboot firmware"
7 arch=('x86_64')
8 url="https://github.com/StarLabsLtd/coreboot-configurator"
9 license=('GPL3')
10 depends=('nvramtool' 'qt5-base' 'qt5-svg' 'yaml-cpp')
11 makedepends=('inkscape' 'meson' 'qt5-tools' 'cmake')
12 source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
13 sha256sums=('176d7f64ee32d3d03bbc3674d48ffe479d8450068a4b7bd26d328ed80d2a1c75')
15 build() {
16   arch-meson "$pkgname-$pkgver" build
17   meson compile -C build
20 package() {
21   meson install -C build --destdir "$pkgdir"
23   install -d "$pkgdir/usr/bin/"