version bumps and a few new packages
[dbus-free.git] / dev-python / pyctr / pyctr-0.7.5.ebuild
blob91ecf34455057d5e5101855025d6123a9e84c15c
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_{10..12} )
7 DISTUTILS_USE_PEP517=setuptools
8 inherit distutils-r1
10 DESCRIPTION="A constructing graphs, BFS and DFS traversals, etc"
11 HOMEPAGE="https://altgraph.readthedocs.io/en/latest/"
12 SRC_URI="https://github.com/ihaveamac/pyctr/archive/refs/tags/v"${PV}".tar.gz -> "${P}".tar.gz"
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 x86"
17 IUSE="test"
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20 RESTRICT="!test? ( test )"
22 RDEPEND="${PYTHON_DEPS}"
23 DEPEND="${RDEPEND}"
24 #S=${WORKDIR}/pyctr-master/
25 distutils_enable_tests unittest