version bumps and a few new packages
[dbus-free.git] / x11-plugins / pidgin-telegram / pidgin-telegram-9999.ebuild
blob459ccf9a706d87781cf0ef14a82e64bd8b5484b6
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit git-r3 cmake
8 DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
9 HOMEPAGE="https://github.com/majn/telegram-purple"
10 EGIT_REPO_URI="https://github.com/BenWiederhake/tdlib-purple.git"
12 LICENSE="GPL-2+"
13 SLOT="0"
14 IUSE="gcrypt +nls +png +webp"
16 RDEPEND="
17         x11-plugins/purple-xmpp-http-upload
18         x11-plugins/Pidgin-XEP-0136-plugin
19         net-libs/tdlib
20         media-libs/libtgvoip
21         x11-plugins/purple-carbons
22         x11-plugins/pidgin-xmpp-receipts
23         net-im/pidgin
24         sys-libs/zlib:=
25         gcrypt? ( dev-libs/libgcrypt:0= )
26         !gcrypt? ( dev-libs/openssl:0= )
27         png? ( media-libs/libpng:0= )
28         webp? ( media-libs/libwebp:= )
31 DEPEND="${RDEPEND}"
33 BDEPEND="
34         nls? ( sys-devel/gettext )
35         virtual/pkgconfig
38 DOCS=( "README.md" )
40 src_prepare() {
41         default
43         # Remove '-Werror' to make it compile#
44         find -name 'CMakeLists.txt' -exec sed -i -e 's/target_link_libraries(telegram-tdlib PRIVATE Td::TdStatic ${Purple_LIBRARIES})/target_link_libraries(telegram-tdlib PRIVATE Td::TdStatic ${Purple_LIBRARIES} ZLIB::ZLIB)\nfind_package(ZLIB)/' {} + || die
45 cmake_src_prepare
48 #src_configure() {
49 #       local myeconfargs=(
50 #               $(use_enable gcrypt)
51 #               $(use_enable nls translation)
52 #               $(use_enable png libpng)
53 #               $(use_enable webp libwebp)
54 #       )
55 #       default
56 #       econf "${myeconfargs[@]}"