1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
9 HOMEPAGE="https://github.com/majn/telegram-purple"
10 EGIT_REPO_URI="https://github.com/BenWiederhake/tdlib-purple.git"
14 IUSE="gcrypt +nls +png +webp"
17 x11-plugins/purple-xmpp-http-upload
18 x11-plugins/Pidgin-XEP-0136-plugin
21 x11-plugins/purple-carbons
22 x11-plugins/pidgin-xmpp-receipts
25 gcrypt? ( dev-libs/libgcrypt:0= )
26 !gcrypt? ( dev-libs/openssl:0= )
27 png? ( media-libs/libpng:0= )
28 webp? ( media-libs/libwebp:= )
34 nls? ( sys-devel/gettext )
43 # Remove '-Werror' to make it compile#
44 find -name 'CMakeLists.txt' -exec sed -i -e 's/target_link_libraries(telegram-tdlib PRIVATE Td::TdStatic ${Purple_LIBRARIES})/target_link_libraries(telegram-tdlib PRIVATE Td::TdStatic ${Purple_LIBRARIES} ZLIB::ZLIB)\nfind_package(ZLIB)/' {} + || die
50 # $(use_enable gcrypt)
51 # $(use_enable nls translation)
52 # $(use_enable png libpng)
53 # $(use_enable webp libwebp)
56 # econf "${myeconfargs[@]}"