4 # Uncomment this to turn on verbose mode.
7 BUILDMASTER_PKG_NAME
= buildbot-master
8 BUILDMASTER_DIR
= master
9 BUILDMASTER_TMP_DIR
= debian
/$(BUILDMASTER_PKG_NAME
)
11 BUILDSLAVE_PKG_NAME
= buildbot-slave
12 BUILDSLAVE_DIR
= slave
13 BUILDSLAVE_TMP_DIR
= debian
/$(BUILDSLAVE_PKG_NAME
)
16 echo
"Tests temporary disabled"
17 #(cd $(BUILDMASTER_DIR) && python setup.py test)
23 (cd
$(BUILDMASTER_DIR
) && python setup.py build
)
24 (cd
$(BUILDSLAVE_DIR
) && python setup.py build
)
25 make
-C master
/docs buildbot.
info buildbot.html
32 rm -f master
/docs
/buildbot.html master
/docs
/buildbot.
info* master
/docs
/version.texinfo
33 rm -fR master
/build master
/buildbot.egg-info
34 rm -fR slave
/build slave
/buildbot_slave.egg-info
35 -find
-name
'*.py[co]' | xargs
rm -f
44 (cd
$(BUILDSLAVE_DIR
) && python setup.py
install \
45 --root
=..
/$(BUILDSLAVE_TMP_DIR
) \
46 --install-layout
=deb
--no-compile
)
47 (cd
$(BUILDMASTER_DIR
) && python setup.py
install \
48 --root
=..
/$(BUILDMASTER_TMP_DIR
) \
49 --install-layout
=deb
--no-compile
)
50 -find debian
-name
'*.py[co]' | xargs
rm -f
52 : # Replace all '#!' calls to python with /usr/bin/python
53 : # and make them executable
54 for i in
`find $(BUILDMASTER_TMP_DIR) $(BUILDSLAVE_TMP_DIR) -type f`; do \
55 sed
'1s,#!.*[pj]ython[^ ]*\(.*\),#! /usr/bin/python\1,' \
57 if cmp
--quiet
$$i $$i.temp
; then \
62 echo
"fixed interpreter: $$i"; \
66 # Remove VCS special files
67 find
$(BUILDMASTER_TMP_DIR
) $(BUILDSLAVE_TMP_DIR
) -type f
-name .gitignore
-prune
70 # Build architecture-independent files here.
71 binary-indep
: build
install
74 dh_installchangelogs
-A
75 dh_installdocs
--exclude
=gitignore
78 dh_installinit
--no-restart-on-upgrade
--no-start
83 # Remove VCS special files
84 find
$(BUILDMASTER_TMP_DIR
) $(BUILDSLAVE_TMP_DIR
) -type f
-name .gitignore
-prune
93 # Build architecture-dependent files here.
94 binary-arch
: build
install
95 # We have nothing to do by default.
97 binary
: binary-indep binary-arch
98 .PHONY
: build
clean binary-indep binary-arch binary
install