Restore the override of ‘dh_auto_clean’; the upstream makefile isn't good enough...
[debian_comixcursors.git] / debian / rules
blob9e1b4003283dc122d19123bd32b406a5049eaec0
1 #! /usr/bin/make -f
3 # debian/rules
5 # Copyright © 2010 Ben Finney <ben+debian@benfinney.id.au>
6 # This is free software; you may copy, modify and/or distribute this work
7 # under the terms of the GNU General Public License, version 2 or later.
8 # No warranty expressed or implied.
9 # See the file ‘/usr/share/common-licenses/GPL-2’ for details.
11 # Uncomment this to turn on verbose mode.
12 #export DH_VERBOSE=1
14 PACKAGE_BUILDDIR = $(CURDIR)/debian/build
15 INSTALLDIR = $(CURDIR)/debian/tmp
16 ICONS_DIR = usr/share/icons
17 icons_builddir = ${PACKAGE_BUILDDIR}/${ICONS_DIR}
18 icons_wrapdir = ${PACKAGE_BUILDDIR}/etc/X11/cursors
19 icons_installdir = ${INSTALLDIR}/${ICONS_DIR}
20 icons_destdir = ${DESTDIR}/${ICONS_DIR}
22 INSTALL = install
23 WRAP_THEMES = ./debian/wrap-cursor-themes
26 .PHONY: build
27 build: export DESTDIR=${PACKAGE_BUILDDIR}
28 build:
29 $(INSTALL) -d ${PACKAGE_BUILDDIR}
30 dh build
32 .PHONY: clean
33 clean:
34 dh clean
36 .PHONY: install
37 install: build
38 $(INSTALL) -d ${icons_wrapdir}
39 chmod +x ${WRAP_THEMES}
40 PACKAGE_BUILDDIR=${PACKAGE_BUILDDIR} $(WRAP_THEMES)
42 dh install
44 .PHONY: binary-indep
45 binary-indep: build install
46 dh binary-indep
48 .PHONY: binary-arch
49 binary-arch: build install
51 .PHONY: binary
52 binary: build binary-indep binary-arch
54 .PHONY: override_dh_auto_clean
55 override_dh_auto_clean:
56 # Skip auto-detection of build tool.
57 make clean
59 .PHONY: override_dh_auto_build
60 override_dh_auto_build:
61 # Skip auto-detection of build tool.
62 DESTDIR=${PACKAGE_BUILDDIR} ./install-all
63 rmdir ${icons_builddir}/default
65 .PHONY: override_dh_auto_test
66 override_dh_auto_test:
67 # Skip auto-detection of build tool.
69 .PHONY: override_dh_auto_install
70 override_dh_auto_install:
71 # Skip auto-detection of build tool.
72 $(INSTALL) -d ${INSTALLDIR}
73 cp -a ${PACKAGE_BUILDDIR}/. ${INSTALLDIR}/.
75 .PHONY: override_dh_installchangelogs
76 override_dh_installchangelogs:
77 dh_installchangelogs NEWS
80 # Local variables:
81 # mode: makefile
82 # coding: utf-8
83 # End:
84 # vim: filetype=make fileencoding=utf-8 :