wmclockmon: remove generated autotools files
[dockapps.git] / wmclockmon / debian / rules
blob72361844c55b04b14379dedd70bf7746101873b8
1 #!/usr/bin/make -f
2 export DH_COMPAT=3
4 TMP=$(CURDIR)/debian/wmclockmon
6 CFLAGS = -Wall -g
7 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
8 CFLAGS += -O0
9 else
10 CFLAGS += -O2
11 endif
13 configure: configure-stamp
14 configure-stamp:
15 dh_testdir
16 CFLAGS="$(CFLAGS)" ./configure --prefix=$(TMP)/usr --mandir=$(TMP)/usr/share/man
17 touch configure-stamp
19 build: configure build-stamp
20 build-stamp:
21 dh_testdir
22 $(MAKE)
23 touch build-stamp
25 clean:
26 dh_testdir
27 dh_testroot
28 rm -f build-stamp install-stamp configure-stamp
29 -$(MAKE) clean
30 rm -f config.h config.log config.status stamp-h Makefile src/Makefile doc/Makefile wmclockmon-config/Makefile
31 dh_clean
33 install: install-stamp
34 install-stamp: build-stamp
35 dh_testdir
36 dh_testroot
37 dh_clean -k
38 $(MAKE) install-strip
39 touch install-stamp
41 # Build architecture-independent files here.
42 binary-indep: build install
43 # We have nothing to do by default.
45 # Build architecture-dependent files here.
46 binary-arch: build install
47 dh_testdir
48 dh_testroot
49 dh_installdocs
50 dh_installexamples
51 dh_installmenu
52 dh_installmanpages
53 dh_installchangelogs ChangeLog
54 dh_strip
55 dh_compress
56 dh_fixperms
57 dh_installdeb
58 dh_shlibdeps
59 dh_gencontrol
60 dh_md5sums
61 dh_builddeb
63 binary: binary-indep binary-arch
64 .PHONY: build clean binary-indep binary-arch binary