repo.or.cz
/
dpkg.git
/
blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
log
|
graphiclog1
|
graphiclog2
|
commit
|
commitdiff
|
tree
|
refs
|
edit
|
fork
blame
|
history
|
raw
|
HEAD
Dpkg::Vendor::Debian: Sync builtin pie arches with gcc-13
[dpkg.git]
/
debian
/
tests
/
test-func-root
blob
4b26aa9f941acbb09076a564d69fffca21a45b1c
1
#!/bin/sh
2
3
set -e
4
5
if
[
"$(id -u)"
!=
'0'
];
then
6
# Fail, we declared needing root as a restriction.
7
exit
1
8
fi
9
10
export
DPKG_TESTSUITE_OPTIONS
=
"debug as-root"
11
export
DPKG_ADMINDIR
=
"
$AUTOPKGTEST_TMP
/db"
12
13
eatmydata
make
-C
tests
test
DPKG_ADMINDIR
=
"
$DPKG_ADMINDIR
"