repo.or.cz
/
dpkg.git
/
blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
log
|
graphiclog1
|
graphiclog2
|
commit
|
commitdiff
|
tree
|
refs
|
edit
|
fork
blame
|
history
|
raw
|
HEAD
Dpkg::Vendor::Debian: Sync builtin pie arches with gcc-13
[dpkg.git]
/
debian
/
tests
/
test-not-root
blob
cf6db127b9f36ddd064dfd62d4303c5506e41a35
1
#!/bin/sh
2
3
set -e
4
5
if
[
"$(id -u)"
=
'0'
];
then
6
# Skip, we cannot declare we do not want root.
7
exit
77
8
fi
9
10
srcdir
=
"$(pwd)"
11
12
cd
$AUTOPKGTEST_TMP
13
"
$srcdir
/configure"
\
14
--disable-nls
\
15
--disable-dselect
\
16
--prefix
=/
usr \
17
--sbindir
=/
sbin \
18
--libexecdir
=
'
${exec_prefix}
/lib'
\
19
--sysconfdir
=/
etc \
20
--localstatedir
=/
var \
21
# EOL
22
make
installcheck TESTSUITEFLAGS
=
--verbose