Bump version to 1.22.16
[dpkg.git] / debian / dpkg.postinst
blob5b3a248a09735abeff7a877a891ddbfd462ca647
1 #!/bin/sh
2 # See deb-postinst(5).
4 set -e
6 PROGNAME=dpkg
8 . /usr/share/dpkg/sh/dpkg-error.sh
10 setup_aliases()
12 local prog=start-stop-daemon
14 # Add a backward compatibility symlink alias for s-s-d, which is now
15 # installed in its canonical location.
16 if [ ! -f "$DPKG_ROOT/sbin/$prog" ] && [ -d "$DPKG_ROOT/sbin" ]; then
17 ln -s "/usr/sbin/$prog" "$DPKG_ROOT/sbin/$prog"
21 case "$1" in
22 configure)
23 setup_aliases
25 abort-upgrade|abort-deconfigure|abort-remove)
28 error "called with unknown argument '$1'"
30 esac
32 # Due to #932360 in debhelper we need to explicitly tell systemd to reload.
33 case "$1" in
34 configure|abort-upgrade|abort-deconfigure|abort-remove)
35 if [ -d /run/systemd/system ]; then
36 systemctl --system daemon-reload >/dev/null || true
39 esac
41 #DEBHELPER#
42 exit 0