New Python bindings wrapper made by Inkvi <inkvi@yandex-team.ru>
[elliptics.git] / elliptics-bf.spec
blob0a98f9e214c8e0c88deb353afbffaaf01d47643d
1 Summary: Distributed hash table storage
2 Name: elliptics
3 Version: 2.18.2.1
4 Release: 1%{?dist}
6 License: GPLv2+
7 Group: System Environment/Libraries
8 URL: http://www.ioremap.net/projects/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 %if 0%{?rhel} < 6
13 BuildRequires: python26-devel, boost141-python, boost141-devel
14 BuildRequires: boost141-iostreams, boost141-thread, boost141-python, boost141-system
15 %else
16 BuildRequires: python-devel, boost-python, boost-devel, boost-iostreams, boost-thread, boost-python, boost-system
17 %endif
18 BuildRequires: eblob-devel >= 0.17.1
19 BuildRequires: smack >= 0.5.0
20 BuildRequires: cmake
22 Obsoletes: srw
24 %description
25 Elliptics network is a fault tolerant distributed hash table
26 object storage.
29 %package devel
30 Summary: Development files for %{name}
31 Group: Development/Libraries
32 Requires: %{name} = %{version}-%{release}
35 %description devel
36 Elliptics network is a fault tolerant distributed hash table
37 object storage.
39 This package contains libraries, header files and developer documentation
40 needed for developing software which uses the cairo graphics library.
42 %package python
43 Summary: Elliptics library Python binding
44 Group: Development/Libraries
45 Requires: %{name} = %{version}-%{release}
47 %description python
48 Elliptics Python Language bindings.
51 %package python-devel
52 Summary: Elliptics library Python binding
53 Group: Development/Libraries
54 Requires: elliptics-python = %{version}-%{release}
57 %description python-devel
58 Elliptics Python Language bindings development headers and libraries.
61 %package c++
62 Summary: Elliptics library C++ binding
63 Group: Development/Libraries
64 Requires: elliptics = %{version}-%{release}
67 %description c++
68 Elliptics library C++ language binding.
71 %package c++-devel
72 Summary: Elliptics library C++ binding development headers and libraries
73 Group: Development/Libraries
74 Requires: elliptics-devel = %{version}-%{release}
75 Requires: elliptics-c++ = %{version}-%{release}
78 %description c++-devel
79 Elliptics library C++ binding development headers and libraries
80 for building C++ applications with elliptics.
82 %prep
83 %setup -q
85 %build
86 export LDFLAGS="-Wl,-z,defs"
87 export DESTDIR="%{buildroot}"
88 %if 0%{?rhel} < 6
89 export PYTHON=/usr/bin/python26
90 CXXFLAGS="-pthread -I/usr/include/boost141" LDFLAGS="-L/usr/lib64/boost141" %{cmake} -DBoost_DIR=/usr/lib64/boost141 .
91 %else
92 %{cmake} .
93 %endif
94 make %{?_smp_mflags}
96 %install
97 rm -rf %{buildroot}
98 make install DESTDIR=%{buildroot}
99 rm -f %{buildroot}%{_libdir}/*.a
100 rm -f %{buildroot}%{_libdir}/*.la
102 %post -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
105 %post python -p /sbin/ldconfig
106 %postun python -p /sbin/ldconfig
108 %post c++ -p /sbin/ldconfig
109 %postun c++ -p /sbin/ldconfig
111 %clean
112 rm -rf %{buildroot}
114 %files
115 %defattr(-,root,root,-)
116 %doc README doc/design_notes.txt doc/io_storage_backend.txt
117 %{_bindir}/*
118 %{_libdir}/libelliptics.so.*
119 %{_libdir}/libelliptics_client.so.*
120 %{_libdir}/libelliptics_cocaine.so.*
121 %{_libdir}/libelliptics_cache.so.*
124 %files devel
125 %defattr(-,root,root,-)
126 %{_includedir}/*
127 %{_libdir}/libelliptics.so
128 %{_libdir}/libelliptics_client.so
129 %{_libdir}/libelliptics_cocaine.so
130 %{_libdir}/libelliptics_cache.so
132 %files python
133 %defattr(-,root,root,-)
134 %{_libdir}/libelliptics_python.so.*
135 %{python_sitelib}/elliptics*
138 %files python-devel
139 %defattr(-,root,root,-)
140 %{_libdir}/libelliptics_python.so
143 %files c++
144 %defattr(-,root,root,-)
145 %{_libdir}/libelliptics_cpp.so.*
148 %files c++-devel
149 %defattr(-,root,root,-)
150 %{_libdir}/libelliptics_cpp.so
153 %changelog
154 * Thu Sep 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.2.1
155 - Added c++/python bindings for cache write operations (including timeout)
156 - Added remove-from-disk cache operation: when such flag is set (at write time)"
157 - if object is removed from cache, it is also removed from disk
158 - Increase example number of non-blocking io threads
159 - Added 'overwrite commits write' comment
161 * Mon Sep 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.2
162 - dnet_backend_log_raw() should use dnet_backend_check_log_level() to check log level
163 - Added startup stack size check
164 - Cocaine job has to be created only when it can be queued
166 * Fri Sep 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.1
167 - Update version num
169 * Thu Sep 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.0.1
170 - New interface for execution, reply and chaining
171 - Do not strip rpath
172 - Fixed server node cleanup bug when it destroyed locks first while IO threads could still use them
173 - dnet_send_cmd_raw() must always wait for ack
174 - Fixed thread creation bug in app_watcher when application does not exist
175 - Added -g flag to elliptics build
176 - Use weak symbols instead of stubs in client lib, since server also links to it and in Fedora it ends up using stubs from client lib
177 - Search for 0mq only of cocaine is enabled
178 - Update debian packaging
179 - Fixed build-depends
181 * Fri Aug 31 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.4
182 - elliptics-client must replace old-school elliptics-2.10
184 * Thu Aug 30 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.3
185 - Added python-support to dep list
186 - Use correct package name in shlibs
188 * Wed Aug 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.2
189 - Switch to cmake from autoconf
191 * Mon Aug 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.1
192 - Depend on eblob 0.17.1 and higher
193 - Use log level instead of log mask
194 - Depend on smack 0.5.0 and higher
195 - Added cdbs dep
196 - Added in-memory (optionally disk-backed) LRU cache
197 - Get rid of boost-filesystem
198 - Split code (and debian package) to client/server libs
199 - New unlink interfaces
200 - Added ioflags to ioclient
201 - If lookup returned error, proceed read-latest with default order
202 - Let DNET_CMD_DEL use dnet_io_attr structure too
204 * Wed Aug 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.16.0.1
205 - Added possibility to start defragmentation on demand
206 - Added reserved 'hostname' word for local address
207 - Added cleanup call into node destruction path, which fixes double free error in config error path
208 - Implemented blocking exec commands
209 - Refactor pools of workers
210 - Set cocaine log level based on elliptics log mask
211 - Completely created client library
212 - Fixed json example path
214 * Tue Jul 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.15.0.1
215 - Send correct answer in smack_write
216 - New bulk_read()
217 - New event string for application invocation
218 - Corrected changelog
219 - Depend on smack 0.4.0 and higher
221 * Mon Jul 02 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.4
222 - Log all client job errorrs into app/.log file in elliptics
223 - Set nocsum flags in io-attr when it is set in global node's config
225 * Wed Jun 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.3-1
226 - Depend on smack 0.3.0 and higher
228 * Tue Jun 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.2-1
229 - Use smack_total_elements() to get number of records
231 * Mon Jun 25 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.1-1
232 - Disable signals in library and enable in server and ioclient
233 - Added cocaine library documentation
234 - Added smack configuration
235 - Sync with upstream smack repo
237 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.7-1
238 - Fixed typo in smack config parser
240 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.6-1
241 - Sink srw log into app + ".log" object in elliptics
243 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.5-1
244 - Added SMACK backend depends
246 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.4-1
247 - Drop cocaine plugin dependencies
249 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.3-1
250 - Added new cocaine debian package deps
251 - Drop cocaine deps in RHEL/Fedora build
253 * Thu Jun 21 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.2-1
254 - Build srw fix (use weak symbol for dnet_log_raw())
255 - Added new eblob bit to config documentation, drop unused parameters
256 - Fixed write response generation
258 * Fri Jun 15 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.1-1
259 - Use cocaine workers for server-side
260 - Drop dnet_attr structure
261 - Optimize read (do not send ack if there is data)
262 - Use ioremap::elliptics namespace
263 - Added ::push() - nonblocking exec
265 * Sun Apr 28 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.9-1
266 - Do not allow zero-sized reads
267 - Do not double-close python init file
269 * Sat Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.8-1
270 - Added new lookup() methods to c++/python bindings. Patch by Anton Kortunov <toshik@yandex-team.ru>
271 - If we fail to open log file, dup2() stdout/stderr to /dev/null in spawned worker process
273 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.7-1
274 - More mess with 012 file descriptors - dup them to /dev/null when going background, reopen to log file in srw worker
275 - Use correct F_SETFD/FD_CLOEXEC
276 - Use old-school fcntl() instead of accept4() and epoll_create1()
277 - Allow script execution without cmd-line
279 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.6-1
280 - Added srw config options
281 - Added O_CLOEXEC flags
282 - Added new configs (for nginx and fastcgi frontend) and python example
283 - Return sub data from smack_write() call - this is needed for fastcgi frontend
284 - Let dnet_ioclient write file by ID
285 - Added smack backend wrapper
287 * Fri Apr 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.5-1
288 - Build dependencies update
289 - Do not write metadata when appropirate bit is set in node->flags
290 - Update documentation about blob flags
292 * Fri Mar 23 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.4-1
293 - Updated state mixing algorithm
294 - Added defrag_timeout, defrag_percentage and blob_size options to file backend
296 * Mon Mar 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.3-1
297 - Allow ioclient to read/write data in different columns
298 - Hardlink script should overwrite data
299 - Fixed file read/write with different column
300 - Use correct pipe path, which includes pid
301 - Use correct structure size for dentries and extended logging
302 - Do not set name for main process
304 * Sun Mar 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.2-1
305 - Use exactly specified in config socket family
306 - Obsolete srw by ellipitcs
307 - Revert "Use X bits from operation key to find a lock instead of random hashing"
308 - Added proper sigchild handling
309 - spec update - added libsrw.so* files
310 - Dropped srw dependancy
312 * Sun Mar 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.1-1
313 - Added srw
315 * Wed Feb 29 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.12.0.1-1
316 - Depend on 0.15 eblob: added new defragmentation parameters into config
317 - Propagate prepare_write() and friends return values back to callers - changed API
319 * Sun Feb 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.7-1
320 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
321 - Updated python scripts to use new eblob class
322 - exec is reserved name in python, use exec_script for execution method name
324 * Thu Feb 16 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.6-1
325 - Added possibility to read metadata from file and dump to log
326 - Added remove_keys_from_storage_found_removed_in_eblob.py
327 - Added local merge iterator written in python. Is not optimal, but quite fast.
329 * Tue Feb 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.5-1
330 - Execute CHECK commands with NOLOCK flag
332 * Sat Feb 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.4-1
333 - Use correct eblob path for statvfs() request
335 * Mon Feb 8 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.3-1
336 - Set id.type to 0 where appropriate
337 - Request statistics with DNET_ATTR_NOLOCK flag set
338 - Fixed pohmelfs_rename.py
340 * Mon Feb 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.2-1
341 - Process checksum flags according to aflags and ioflags
343 * Wed Feb 1 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.1-1
344 - Added start/num parameters to iterate over selected number of blobs.
345 - Depend on 0.14.1 blob and higher where it is implemented.
347 * Thu Jan 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.15-1
348 - Added readdir script
349 - Dropped content length manipulation from srw/pohmelfs_inode_info_insert.py
350 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
352 * Tue Jan 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.14-1
353 - Reserve some space for directory content
354 - Added pohmelfs_read_latest_groups.py script
355 - Implemented prepare-latest helper, which returns timestamp sorted groups which contain requested id
356 - If we have more data to send, set only DNET_FLAGS_MORE flag, not erase others
357 - Rename cpp bindings
358 - Fixed range requests without limits
360 * Tue Jan 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.13-1
361 - Sort keys on server side in range requests
362 - Disable eblob_gen for now
363 - Address new binutils issues (gcc 4.6 compilation fixes)
365 * Wed Dec 21 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.12-1
366 - Trying to address new binutils issues
367 - Fill with zeroes all io threads structures
368 - Set io.num to content size+offset in write_data_wait() - it allows to use prepare/commit flags
370 * Tue Dec 20 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.11-1
371 - Implemented check for start/stop update timestamp
372 - Added cache tests in test.cpp
374 * Thu Dec 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.10-1
375 - Added configurable two-queue cache for read data by Anton Kortunov <toshic.toshic@gmail.com>
377 * Mon Dec 12 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.9-1
378 - Reopen log file on sighup
380 * Fri Dec 9 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.8-1
381 - Set DNET_FLAGS_NOLOCK for route/reverse lookup request/reply commands
382 - Added memory_test_pohmelfs() autotest
383 - Added gc calls into pohmelfs methods
384 - Fixed exception string generation for null ids
385 - Added small memory/leak test
387 * Fri Dec 2 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.7-1
388 - Use eblob_read_nocsum() if DNET_IO_FLAGS_NOCSUM is set
390 * Thu Dec 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.6-1
391 - Cleanup unused variables
392 - Fixed reply cmd->flags initialization
393 - Use boost::filesystem v2
394 - Fixes in bulk_read and bulk_write
396 * Mon Nov 28 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.5-1
397 - Implemented pool of non-blocking threads for recursive commands.
398 - Dropped metadata csum support in favour of eblob embedded checksums.
399 - Added bulk_write operation.
400 - Added sstable parser into python module
402 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.4-1
403 - Added nolocking IO thread
405 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.3-1
406 - Added oplock_num config parameter
407 - Added non-blocking thread checks
409 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.2-1
410 - Aflags/lock cleanups
412 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.1-1
413 - Added operations locks. Now all commands are processed with single-machine-atomicity
414 - Added server-side scripts
416 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.13-1
417 - Only perform blob write if io->size is not zero
419 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.12-1
420 - Initialize srw after node
422 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.11-1
423 - Do not chroot into history environment, since it is most likely incomplete
425 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.10-1
426 - Do not csum read when DNET_IO_FLAGS_NOCSUM ioflag is set
427 - When doing partial read, checksum whole file
429 * Sat Nov 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.9-1
430 - cpp tests update
431 - Return -ENOTSUP if srw is not initialized
432 - Do not reset join state to RECONNECT after it has been created
433 - Added stall_count as a configurable parameter
434 - Added BULK_READ command
436 * Tue Nov 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.8-1
437 - Fixed range counters
438 - Added ::remove() methods into python binding
439 - Remove all types if -1 as id->type is specified
440 - RHEL build must depend on eblob-devel >= 0.12.18 libsrw-devel >= 0.2.2
442 * Mon Nov 14 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.7-1
443 - Moved some objects from interface.h to packet.h
444 - Added range counters
445 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
446 - Use IP_TOS instead of SO_PRIORITY to set tos bits
447 - srw is called libsrw in rhel builds
448 - Depend on 0.12.18 eblob and 0.2.2 srw
450 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.6-1
451 - Depend on 0.2.1 srw and higher
453 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.5-1
454 - Added binary data support in srw
456 * Tue Nov 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.4-1
457 - Do not fail node initialization if srw is not initialized
459 * Mon Oct 31 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.3-1
460 - blob_send modified to send all columns if id.type == -1
461 - Do not depend elliptics build on libssl
462 - eblob/srw autoconf updates
463 - Do not return 1 from blob_write when data was compressed, return 0, since
464 there was no error
466 * Tue Oct 25 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.2-1
467 - Added srw dependency
468 - Do not call dnet_convert_io_attr for DNET_CMD_DEL command
470 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.1-1
471 - Decreased WRITE latency
472 - Use CORK for write blocks
474 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.0-1
475 - Added ioprio call inside check
476 - More example ioserv.conf comments
477 - Added client/server network priorities (man 7 socket -> IP_PRIORITY)
479 * Sat Oct 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.9-1
480 - Fixed memory allocation in range-delete
482 * Tue Oct 11 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.7-1
483 - Only set BLOB_DISK_CTL_NOCSUM if DNET_IO_FLAGS_NOCSUM is set
484 - Added dnet_get_routes function
485 - Added server-side scripting support
486 - Example ioserv.conf update
487 - Spec update
489 * Thu Dec 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.2-1
490 - Implemented multiple read in elliptics core and FCGI frontend.
491 - Implemented very user-friendly C++/Python interface.
492 - Extended FCGI xml output for POST request: added data crc, size,
493 per-group addresses and path to the destination object on file backend.
495 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.1-1
496 - Documentation update.
498 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.8-1
499 - Fixed fcgi reading with new groups URI.
501 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.7-1
502 - Implemented automatic groups selection by free space.
503 - Bug fixes.
505 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.6-1
506 - Fixed eblob_send().
507 - Use 50 check threads.
509 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.5-1
510 - Multi-threaded fsck.
511 - Bug fixes (including 2.9.4.4 version).
513 * Thu Nov 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.3-1
514 - Implemented bdb fsck (both merge and copy check).
516 * Thu Nov 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.2-1
517 - Switched to random ids (1024 ids are generated at first start)
519 * Fri Nov 19 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.1-1
520 - Switched to new addressing model
522 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.14-1
523 - Remove direct object if it can not be uploaded to the storage.
525 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.13-1
526 - Remove empty/broken history objects during merge.
528 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.12-1
529 - Added more debug about processed objects in fsck tools.
530 - Delete directly read object if its history can not be mapped.
531 - Return error from dnet_merge_direct() when merge falls back to direct
532 merge during common merge.
534 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.11-1
535 - Attempt to do direct merge when we can not parse non-direct history stored in main storage.
537 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.10-1
538 - Fixed bit directory generation in file_backend_get_dir_bits()
540 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.9-1
541 - Fixed state leak in lookup processing.
543 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.8-1
544 - Always use local address for succeeded local lookup.
546 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.7-1
547 - Kill state when check thread got error. (7)
548 - Extended fire time debug. (6)
550 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.5-1
551 - Update transaction fire time to include check timeout.
553 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.4-1
554 - Extend dnet_send_read_data() to get offset from parameters and do not abuse dnet_io_attr structure.
556 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.3-1
557 - Unmap history after selecting transaction with the last update time in dnet_merge_get_latest_transactions()
559 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
560 - Added full object ID dump and request error.
561 - Exit merge early if no id file was provided.
562 - Do not dereference state in dnet_read_complete() if it is NULL.
563 - Added -N (do not request ids and use prevously downloaded) option comment into fsck help.
565 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
566 - Extended alloc/free debug.
567 - Allow zero-sized writes.
569 * Wed Oct 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3-1
570 - New minor release. No changes from 2.9.2.32.
572 * Mon Oct 11 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.32-1
573 - Added configurable value to check header for remote node IP address.
574 - Added joining client check: returned address must be reachable to be
575 inserted into route table.
577 * Fri Oct 8 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.31-1
578 - Fixed LA sorting.
580 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.29-1
581 - Added id-by-LA generation and sorting.
582 - Debug cleanups.
584 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.28-1
585 - Added timed statistics request which also works as timed connection checker.
586 - Added seconds-only check time wait.
588 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.27-1
589 - Added keep-alive options.
591 * Mon Oct 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.26-1
592 - Unlink transaction and history after direct merge.
593 - Do not log error when state is NULL in completion callback.
595 * Sat Oct 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.25-1
596 - Added norequest flag to fsck util (will use existing file).
597 - Fixed remotes processing typo.
599 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.24-1
600 - Do not traverse the whole transaction tree after we found the
601 first one which fire time has not yet elapsed.
603 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.23-1
604 - Remove io_thread_num and max_pending config parameters.
605 - Added stack size parameter to check tools.
607 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.22-1
608 - Moved transaction debug output into the place where it can not dereference stale data.
609 - Decrease debug level for allocations.
610 - Added addrinfo null check. Should be useless though.
612 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.21-1
613 - Do not dereference null state in dnet_fcgi_read_complete.
615 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.20-1
616 - Added thread stack size parameter.
617 - Added malloc mmap threshold config parameter. (19)
619 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.18-1
620 - Really fixed recv state transaction processing leak.
622 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.16-1
623 -Do not try to dereferece null state. Happens when transaction is completed
624 on timeout.
625 - Use lineary (+60 seconds each turn) growing reconnection timeout. Added
626 reconnection limit of 1 day.
627 - Fixed recv state transaction processing leak.
629 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.15-1
630 - Compilation typo fixed.
632 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.14-1
633 - Fill all allocated memory with zeroes.
635 * Thu Sep 16 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.13-1
636 - Put transaction after it was executed. Its refcnt was increased during
637 search call.
638 - Do not try to dereference state when it can be null.
639 - Do not create unneded listening state when node does not join network. (12)
640 - Reset accept state on error.
641 - Do not join to states in state lists, since they can be freed in own
642 threads. (11)
643 - Drop transaction resending support. (10)
644 - Extended local command processing log. (9)
645 - Also print pid in common logger. (8)
646 - Use pthread_self() instead of getpid() to get uniq thread id. (7)
648 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.6-1
649 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was set for read command, do not
650 send data reply. Used in local stat command.
651 - Debug cleanup.
652 - From previous releases:
653 Do not deal with NULL transactions.
654 Start state IO thread after state initialization.
655 Join to io state thread instead of freeing it directly.
656 Do not exit from accept loop on error.
657 Initialize state list entry prior other usage.
659 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2-1
660 - Switched from libevent state machine to thread-per-client model.
662 * Fri Aug 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1.1-1
663 - Added DNET_FCGI_PUT_REGION config option to optionally enable region tag
664 - Added wildcard direct download pattern (*)
665 - Force direct download patterns to be checked against ID ending and
666 just by having this substring somewhere in the query.
668 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1-1
669 - New elliptics network release: 2.9.1
671 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.31-1
672 - Logger cleanups.
673 - Fixed resend locking bug.
675 * Mon Aug 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.30-1
676 - Fixed lock/unlock typo in dnet_data_ready().
678 * Sat Aug 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.29-1
679 - Refactor fcgi logging (29)
680 - Return read error when key was not found. Use right config file options. (28)
682 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.27-1
683 - Added sanity checks for embedded reading.
685 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.26-1
686 - Disabled per-client statistics request in fcgi daemon.
687 - Added subtle timeout and data rewrite when FCGX_PutStr() returns error.
689 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.25-1
690 - Copy resolved address into buffer (later used for reconnection)
691 before trying to connect.
693 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.24-1
694 - Refactor fcgi/check loggers to write pid/thread id into single log file.
696 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.23-1
697 - Added <region> tag into download-info XML output
698 - Changed sending locking.
700 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.22-1
701 - Guard multiple 'logical' xml writes against parallel write
703 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.21-1
704 - Implemented direct transaction merge.
705 - If reading size was set to 0 map ~0ULL size, i.e. the whole file.
706 - Remove object from the storage if its history log says so.
707 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
708 DNET_FCGI_EMBED_PATTERN option.
710 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.20-1
711 - Fixed several fd leaks.
713 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.19-1
714 - Unmap history file when failed to read transaction.
716 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.18-1
717 - Guard OpenSSL_add_all_digests() and initialize it only once per thread
718 group.
719 - Force dnet_check_process_request() to wait for all sent transactions, do
720 not wakeup after receiving reply from the first one.
722 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.17-1
723 - Fixed compilation warnings on 64bit platform (uint64_t to unsigned long
724 long and void * to unsigned long)
725 - Try only requested transformation function, do not continue with the next
726 one.
727 - Use errno to differentiate reconnection state.
729 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.15-1
730 - Made elliptics depend on eblob
731 - Updated checker's logger.
732 - Increase example/check/common.c waiting timeout.
733 - Added logs into file io backend listing processor.
735 * Sun Jul 26 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.12-1
736 - Let check applications to sleep longer waiting for replies.
737 - Reduce number of ids sent via DNET_CMD_LIST command to 1024 per reply.
738 - Mark states added via dnet_add_state() as reconnect-friendly.
739 - Do not add reconnection addresses which do not have joining flags.
740 - Updated to the latest eblob lib (moved blob code outside to libeblob).
741 - Reschedule transaction's fire time when (non-last) reply is received.
742 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
744 * Sun Jul 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.11-1
745 - Added embedded URI parameter, which will force timestamp to be embedded
746 with data. It is possible to embed other parameters too.
748 post: wget -O /tmp/1111 -S --post-file=elliptics.spec
749 "http://devfs1/test.mp3?name=qwerty.xml&embed&timestamp=123"
751 get: wget -O /tmp/1111 -S --header="If-Modified-Since: Thu, 01 Jan 1970
752 00:02:00 GMT" "http://devfs1/test.mp3?name=qwerty.xml&embed&direct=1"
753 - fixed random hash selection in fcgi frontend.
755 * Fri Jul 23 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.10-1
756 -return back addressing magic^W logic in dnet_write_object_raw()
758 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.9-1
759 - return back virtual datacenters.
761 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.8-1
762 - BLOB IO backend updates (multiple threads, index, bug fixes).
763 - file IO backend fixes
764 - python bindings
765 - c++ binding fixes
767 * Mon Jul 19 2010 Arkady L. Shane <ashejn@yandex-team.ru> - 2.9.0.7-1
768 - initial build for Fedora