1 Summary: Distributed
hash table storage
7 Group: System Environment
/Libraries
8 URL: http
://www.ioremap.net
/projects
/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
13 BuildRequires
: python26
-devel
, boost141
-python
, boost141
-devel
14 BuildRequires
: boost141
-iostreams
, boost141
-thread
, boost141
-python
, boost141
-system
16 BuildRequires
: python
-devel
, boost
-python
, boost
-devel
, boost
-iostreams
, boost
-thread
, boost
-python
, boost
-system
18 BuildRequires
: eblob
-devel
>= 0.17.1
19 BuildRequires
: smack
>= 0.5.0
25 Elliptics network is a fault tolerant distributed
hash table
30 Summary: Development files
for %{name}
31 Group: Development
/Libraries
32 Requires: %{name} = %{version}-%{release}
36 Elliptics network is a fault tolerant distributed
hash table
39 This package contains libraries
, header files and developer documentation
40 needed
for developing software which uses the cairo graphics library.
43 Summary: Elliptics library Python binding
44 Group: Development
/Libraries
45 Requires: %{name} = %{version}-%{release}
48 Elliptics Python Language bindings.
52 Summary: Elliptics library Python binding
53 Group: Development
/Libraries
54 Requires: elliptics
-python
= %{version}-%{release}
57 %description python
-devel
58 Elliptics Python Language bindings development headers and libraries.
62 Summary: Elliptics library C
++ binding
63 Group: Development
/Libraries
64 Requires: elliptics
= %{version}-%{release}
68 Elliptics library C
++ language binding.
72 Summary: Elliptics library C
++ binding development headers and libraries
73 Group: Development
/Libraries
74 Requires: elliptics
-devel
= %{version}-%{release}
75 Requires: elliptics
-c
++ = %{version}-%{release}
78 %description c
++-devel
79 Elliptics library C
++ binding development headers and libraries
80 for building C
++ applications with elliptics.
86 export LDFLAGS
="
-Wl
,-z
,defs"
87 export DESTDIR
="
%{buildroot}"
89 export PYTHON
=/usr
/bin
/python26
90 CXXFLAGS
="
-pthread
-I
/usr
/include
/boost141" LDFLAGS
="
-L
/usr
/lib64
/boost141"
%{cmake} -DBoost_DIR
=/usr
/lib64
/boost141 .
98 make install DESTDIR
=%{buildroot}
99 rm -f
%{buildroot}%{_libdir}/*.a
100 rm -f
%{buildroot}%{_libdir}/*.la
102 %post -p
/sbin
/ldconfig
103 %postun -p
/sbin
/ldconfig
105 %post python
-p
/sbin
/ldconfig
106 %postun python
-p
/sbin
/ldconfig
108 %post c
++ -p
/sbin
/ldconfig
109 %postun c
++ -p
/sbin
/ldconfig
115 %defattr(-,root
,root
,-)
116 %doc README doc
/design_notes.txt doc
/io_storage_backend.txt
118 %{_libdir}/libelliptics.so.
*
119 %{_libdir}/libelliptics_client.so.
*
120 %{_libdir}/libelliptics_cocaine.so.
*
121 %{_libdir}/libelliptics_cache.so.
*
125 %defattr(-,root
,root
,-)
127 %{_libdir}/libelliptics.so
128 %{_libdir}/libelliptics_client.so
129 %{_libdir}/libelliptics_cocaine.so
130 %{_libdir}/libelliptics_cache.so
133 %defattr(-,root
,root
,-)
134 %{_libdir}/libelliptics_python.so.
*
135 %{python_sitelib}/elliptics
*
139 %defattr(-,root
,root
,-)
140 %{_libdir}/libelliptics_python.so
144 %defattr(-,root
,root
,-)
145 %{_libdir}/libelliptics_cpp.so.
*
149 %defattr(-,root
,root
,-)
150 %{_libdir}/libelliptics_cpp.so
154 * Mon Oct
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.1
155 - When running recovery
-on
-read do not write io attribute header
157 * Mon Oct
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.0
158 - Grow IO pools on demand
159 - Added automatic recovery on
read command:
160 - if object didn't exist
in previously
read group
,
161 - it will be written when
read from the next group succeed
162 - Documentation update
163 - Added multicast autodiscovery
164 - If state is already exist
, do not fail with error
165 - Fixed the ugliest debian python installation
166 - Added new python bindings
167 - Do not try to run
command if srw was not initialized
168 - Populate cache on READ
command when DNET_IO_FLAGS_CACHE ioflag is
set
170 * Thu Sep
20 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.2.1
171 - Added c
++/python bindings
for cache write operations
(including timeout
)
172 - Added remove
-from
-disk cache operation
: when such flag is
set (at write
time)"
173 - if object is removed from cache
, it is also removed from disk
174 - Increase example number of non
-blocking io threads
175 - Added 'overwrite commits write' comment
177 * Mon Sep
17 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.1.2
178 - dnet_backend_log_raw
() should use dnet_backend_check_log_level
() to check log level
179 - Added startup stack size check
180 - Cocaine job has to be created only when it can be queued
182 * Fri Sep
14 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.1.1
185 * Thu Sep
13 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.0.1
186 - New interface
for execution
, reply and chaining
188 - Fixed server node cleanup bug when it destroyed locks first
while IO threads could still use them
189 - dnet_send_cmd_raw
() must always
wait for ack
190 - Fixed thread creation bug
in app_watcher when application does not exist
191 - Added
-g flag to elliptics build
192 - Use weak symbols instead of stubs
in client lib
, since server also links to it and
in Fedora it ends up using stubs from client lib
193 - Search
for 0mq only of cocaine is enabled
194 - Update debian packaging
195 - Fixed build
-depends
197 * Fri Aug
31 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.4
198 - elliptics
-client must replace old
-school elliptics
-2.10
200 * Thu Aug
30 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.3
201 - Added python
-support to dep list
202 - Use correct package name
in shlibs
204 * Wed Aug
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.2
205 - Switch to cmake from autoconf
207 * Mon Aug
20 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.1
208 - Depend on eblob
0.17.1 and higher
209 - Use log level instead of log mask
210 - Depend on smack
0.5.0 and higher
212 - Added
in-memory
(optionally disk
-backed
) LRU cache
213 - Get rid of boost
-filesystem
214 - Split code
(and debian package
) to client
/server libs
215 - New unlink interfaces
216 - Added ioflags to ioclient
217 - If lookup returned error
, proceed
read-latest with default order
218 - Let DNET_CMD_DEL use dnet_io_attr structure too
220 * Wed Aug
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.16.0.1
221 - Added possibility to start defragmentation on demand
222 - Added reserved 'hostname' word
for local address
223 - Added cleanup call into node destruction path
, which fixes double free error
in config error path
224 - Implemented blocking
exec commands
225 - Refactor pools of workers
226 - Set cocaine log level based on elliptics log mask
227 - Completely created client library
228 - Fixed json example path
230 * Tue Jul
24 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.15.0.1
231 - Send correct answer
in smack_write
233 - New event string
for application invocation
234 - Corrected changelog
235 - Depend on smack
0.4.0 and higher
237 * Mon Jul
02 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.4
238 - Log all client job errorrs into app
/.log file
in elliptics
239 - Set nocsum flags
in io
-attr when it is
set in global node's config
241 * Wed Jun
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.3-1
242 - Depend on smack
0.3.0 and higher
244 * Tue Jun
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.2-1
245 - Use smack_total_elements
() to get number of records
247 * Mon Jun
25 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.1-1
248 - Disable signals
in library and
enable in server and ioclient
249 - Added cocaine library documentation
250 - Added smack configuration
251 - Sync with upstream smack repo
253 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.7-1
254 - Fixed typo
in smack config parser
256 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.6-1
257 - Sink srw log into app
+ ".log" object
in elliptics
259 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.5-1
260 - Added SMACK backend depends
262 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.4-1
263 - Drop cocaine plugin dependencies
265 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.3-1
266 - Added new cocaine debian package deps
267 - Drop cocaine deps
in RHEL
/Fedora build
269 * Thu Jun
21 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.2-1
270 - Build srw fix
(use weak symbol
for dnet_log_raw
())
271 - Added new eblob bit to config documentation
, drop unused parameters
272 - Fixed write response generation
274 * Fri Jun
15 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.1-1
275 - Use cocaine workers
for server
-side
276 - Drop dnet_attr structure
277 - Optimize
read (do not send ack
if there is data
)
278 - Use ioremap
::elliptics namespace
279 - Added
::push
() - nonblocking
exec
281 * Sun Apr
28 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.9-1
282 - Do not allow zero
-sized reads
283 - Do not double
-close python init file
285 * Sat Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.8-1
286 - Added new lookup
() methods to c
++/python bindings.
Patch by Anton Kortunov
<toshik@yandex
-team.ru
>
287 - If we fail to open log file
, dup2
() stdout
/stderr to
/dev
/null
in spawned worker process
289 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.7-1
290 - More mess with
012 file descriptors
- dup them to
/dev
/null when going background
, reopen to log file
in srw worker
291 - Use correct F_SETFD
/FD_CLOEXEC
292 - Use old
-school fcntl
() instead of accept4
() and epoll_create1
()
293 - Allow script execution without cmd
-line
295 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.6-1
296 - Added srw config options
297 - Added O_CLOEXEC flags
298 - Added new configs
(for nginx and fastcgi frontend
) and python example
299 - Return sub data from smack_write
() call
- this is needed
for fastcgi frontend
300 - Let dnet_ioclient write file by ID
301 - Added smack backend wrapper
303 * Fri Apr
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.5-1
304 - Build dependencies update
305 - Do not write metadata when appropirate bit is
set in node
->flags
306 - Update documentation about blob flags
308 * Fri Mar
23 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.4-1
309 - Updated state mixing algorithm
310 - Added defrag_timeout
, defrag_percentage and blob_size options to file backend
312 * Mon Mar
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.3-1
313 - Allow ioclient to
read/write data
in different columns
314 - Hardlink script should overwrite data
315 - Fixed file
read/write with different column
316 - Use correct pipe path
, which includes pid
317 - Use correct structure size
for dentries and extended logging
318 - Do not
set name
for main process
320 * Sun Mar
13 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.2-1
321 - Use exactly specified
in config socket family
322 - Obsolete srw by ellipitcs
323 - Revert "Use X bits from operation key to find a lock instead of random hashing"
324 - Added proper sigchild handling
325 - spec update
- added libsrw.so
* files
326 - Dropped srw dependancy
328 * Sun Mar
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.1-1
331 * Wed Feb
29 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.12.0.1-1
332 - Depend on
0.15 eblob
: added new defragmentation parameters into config
333 - Propagate prepare_write
() and friends
return values back to callers
- changed API
335 * Sun Feb
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.7-1
336 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
337 - Updated python scripts to use new eblob class
338 - exec is reserved name
in python
, use exec_script
for execution method name
340 * Thu Feb
16 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.6-1
341 - Added possibility to
read metadata from file and dump to log
342 - Added remove_keys_from_storage_found_removed_in_eblob.py
343 - Added
local merge iterator written
in python. Is not optimal
, but quite fast.
345 * Tue Feb
14 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.5-1
346 - Execute CHECK commands with NOLOCK flag
348 * Sat Feb
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.4-1
349 - Use correct eblob path
for statvfs
() request
351 * Mon Feb
8 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.3-1
352 - Set id.
type to
0 where appropriate
353 - Request statistics with DNET_ATTR_NOLOCK flag
set
354 - Fixed pohmelfs_rename.py
356 * Mon Feb
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.2-1
357 - Process checksum flags according to aflags and ioflags
359 * Wed Feb
1 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.1-1
360 - Added start
/num parameters to iterate over selected number of blobs.
361 - Depend on
0.14.1 blob and higher where it is implemented.
363 * Thu Jan
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.15-1
364 - Added readdir script
365 - Dropped content length manipulation from srw
/pohmelfs_inode_info_insert.py
366 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
368 * Tue Jan
24 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.14-1
369 - Reserve some space
for directory content
370 - Added pohmelfs_read_latest_groups.py script
371 - Implemented prepare
-latest helper
, which returns timestamp sorted groups which contain requested id
372 - If we have more data to send
, set only DNET_FLAGS_MORE flag
, not erase others
373 - Rename cpp bindings
374 - Fixed range requests without limits
376 * Tue Jan
17 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.13-1
377 - Sort keys on server side
in range requests
378 - Disable eblob_gen
for now
379 - Address new binutils issues
(gcc
4.6 compilation fixes
)
381 * Wed Dec
21 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.12-1
382 - Trying to address new binutils issues
383 - Fill with zeroes all io threads structures
384 - Set io.num to content size
+offset
in write_data_wait
() - it allows to use prepare
/commit flags
386 * Tue Dec
20 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.11-1
387 - Implemented check
for start
/stop update timestamp
388 - Added cache tests
in test.cpp
390 * Thu Dec
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.10-1
391 - Added configurable two
-queue cache
for read data by Anton Kortunov
<toshic.toshic@gmail.com
>
393 * Mon Dec
12 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.9-1
394 - Reopen log file on sighup
396 * Fri Dec
9 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.8-1
397 - Set DNET_FLAGS_NOLOCK
for route
/reverse lookup request
/reply commands
398 - Added memory_test_pohmelfs
() autotest
399 - Added gc calls into pohmelfs methods
400 - Fixed exception string generation
for null ids
401 - Added small memory
/leak
test
403 * Fri Dec
2 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.7-1
404 - Use eblob_read_nocsum
() if DNET_IO_FLAGS_NOCSUM is
set
406 * Thu Dec
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.6-1
407 - Cleanup unused variables
408 - Fixed reply cmd
->flags initialization
409 - Use boost
::filesystem v2
410 - Fixes
in bulk_read and bulk_write
412 * Mon Nov
28 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.5-1
413 - Implemented pool of non
-blocking threads
for recursive commands.
414 - Dropped metadata csum support
in favour of eblob embedded checksums.
415 - Added bulk_write operation.
416 - Added sstable parser into python module
418 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.4-1
419 - Added nolocking IO thread
421 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.3-1
422 - Added oplock_num config parameter
423 - Added non
-blocking thread checks
425 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.2-1
426 - Aflags
/lock cleanups
428 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.1-1
429 - Added operations locks. Now all commands are processed with single
-machine
-atomicity
430 - Added server
-side scripts
432 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.13-1
433 - Only perform blob write
if io
->size is not zero
435 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.12-1
436 - Initialize srw after node
438 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.11-1
439 - Do not chroot into
history environment
, since it is most likely incomplete
441 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.10-1
442 - Do not csum
read when DNET_IO_FLAGS_NOCSUM ioflag is
set
443 - When doing partial
read, checksum whole file
445 * Sat Nov
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.9-1
447 - Return
-ENOTSUP
if srw is not initialized
448 - Do not reset join state to RECONNECT after it has been created
449 - Added stall_count as a configurable parameter
450 - Added BULK_READ
command
452 * Tue Nov
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.8-1
453 - Fixed range counters
454 - Added
::remove
() methods into python binding
455 - Remove all types
if -1 as id
->type is specified
456 - RHEL build must depend on eblob
-devel
>= 0.12.18 libsrw
-devel
>= 0.2.2
458 * Mon Nov
14 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.7-1
459 - Moved some objects from interface.h to packet.h
460 - Added range counters
461 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
462 - Use IP_TOS instead of SO_PRIORITY to
set tos bits
463 - srw is called libsrw
in rhel builds
464 - Depend on
0.12.18 eblob and
0.2.2 srw
466 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.6-1
467 - Depend on
0.2.1 srw and higher
469 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.5-1
470 - Added binary data support
in srw
472 * Tue Nov
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.4-1
473 - Do not fail node initialization
if srw is not initialized
475 * Mon Oct
31 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.3-1
476 - blob_send modified to send all columns
if id.
type == -1
477 - Do not depend elliptics build on libssl
478 - eblob
/srw autoconf updates
479 - Do not
return 1 from blob_write when data was compressed
, return 0, since
482 * Tue Oct
25 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.2-1
483 - Added srw dependency
484 - Do not call dnet_convert_io_attr
for DNET_CMD_DEL
command
486 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.1-1
487 - Decreased WRITE latency
488 - Use CORK
for write blocks
490 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.0-1
491 - Added ioprio call inside check
492 - More example ioserv.conf comments
493 - Added client
/server network priorities
(man
7 socket
-> IP_PRIORITY
)
495 * Sat Oct
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.9-1
496 - Fixed memory allocation
in range
-delete
498 * Tue Oct
11 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.7-1
499 - Only
set BLOB_DISK_CTL_NOCSUM
if DNET_IO_FLAGS_NOCSUM is
set
500 - Added dnet_get_routes
function
501 - Added server
-side scripting support
502 - Example ioserv.conf update
505 * Thu Dec
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.2-1
506 - Implemented multiple
read in elliptics core and FCGI frontend.
507 - Implemented very user
-friendly C
++/Python interface.
508 - Extended FCGI xml output
for POST request
: added data crc
, size
,
509 per
-group addresses and path to the destination object on file backend.
511 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.1-1
512 - Documentation update.
514 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.8-1
515 - Fixed fcgi reading with new groups URI.
517 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.7-1
518 - Implemented automatic groups selection by free space.
521 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.6-1
522 - Fixed eblob_send
().
523 - Use
50 check threads.
525 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.5-1
526 - Multi
-threaded fsck.
527 - Bug fixes
(including
2.9.4.4 version
).
529 * Thu Nov
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.3-1
530 - Implemented bdb fsck
(both merge and copy check
).
532 * Thu Nov
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.2-1
533 - Switched to random ids
(1024 ids are generated at first start
)
535 * Fri Nov
19 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.1-1
536 - Switched to new addressing model
538 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.14-1
539 - Remove direct object
if it can not be uploaded to the storage.
541 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.13-1
542 - Remove empty
/broken
history objects during merge.
544 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.12-1
545 - Added more debug about processed objects
in fsck tools.
546 - Delete directly
read object
if its
history can not be mapped.
547 - Return error from dnet_merge_direct
() when merge falls back to direct
548 merge during common merge.
550 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.11-1
551 - Attempt to
do direct merge when we can not parse non
-direct
history stored
in main storage.
553 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.10-1
554 - Fixed bit directory generation
in file_backend_get_dir_bits
()
556 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.9-1
557 - Fixed state leak
in lookup processing.
559 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.8-1
560 - Always use
local address
for succeeded
local lookup.
562 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.7-1
563 - Kill state when check thread got error.
(7)
564 - Extended fire
time debug.
(6)
566 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.5-1
567 - Update transaction fire
time to include check timeout.
569 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.4-1
570 - Extend dnet_send_read_data
() to get offset from parameters and
do not abuse dnet_io_attr structure.
572 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.3-1
573 - Unmap
history after selecting transaction with the last update
time in dnet_merge_get_latest_transactions
()
575 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
576 - Added full object ID dump and request error.
577 - Exit merge early
if no id file was provided.
578 - Do not dereference state
in dnet_read_complete
() if it is NULL.
579 - Added
-N
(do not request ids and use prevously downloaded
) option comment into fsck
help.
581 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
582 - Extended alloc
/free debug.
583 - Allow zero
-sized writes.
585 * Wed Oct
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3-1
586 - New minor release. No changes from
2.9.2.32.
588 * Mon Oct
11 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.32-1
589 - Added configurable value to check header
for remote node IP address.
590 - Added joining client check
: returned address must be reachable to be
591 inserted into route table.
593 * Fri Oct
8 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.31-1
596 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.29-1
597 - Added id
-by
-LA generation and sorting.
600 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.28-1
601 - Added timed statistics request which also works as timed connection checker.
602 - Added seconds
-only check
time wait.
604 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.27-1
605 - Added keep
-alive options.
607 * Mon Oct
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.26-1
608 - Unlink transaction and
history after direct merge.
609 - Do not log error when state is NULL
in completion callback.
611 * Sat Oct
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.25-1
612 - Added norequest flag to fsck util
(will use existing file
).
613 - Fixed remotes processing typo.
615 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.24-1
616 - Do not traverse the whole transaction tree after we found the
617 first one which fire
time has not yet elapsed.
619 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.23-1
620 - Remove io_thread_num and max_pending config parameters.
621 - Added stack size parameter to check tools.
623 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.22-1
624 - Moved transaction debug output into the place where it can not dereference stale data.
625 - Decrease debug level
for allocations.
626 - Added addrinfo null check. Should be useless though.
628 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.21-1
629 - Do not dereference null state
in dnet_fcgi_read_complete.
631 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.20-1
632 - Added thread stack size parameter.
633 - Added malloc mmap threshold config parameter.
(19)
635 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.18-1
636 - Really fixed recv state transaction processing leak.
638 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.16-1
639 -Do not try to dereferece null state. Happens when transaction is completed
641 - Use lineary
(+60 seconds each turn
) growing reconnection timeout. Added
642 reconnection limit of
1 day.
643 - Fixed recv state transaction processing leak.
645 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.15-1
646 - Compilation typo fixed.
648 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.14-1
649 - Fill all allocated memory with zeroes.
651 * Thu Sep
16 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.13-1
652 - Put transaction after it was executed. Its refcnt was increased during
654 - Do not try to dereference state when it can be null.
655 - Do not create unneded listening state when node does not join network.
(12)
656 - Reset accept state on error.
657 - Do not join to states
in state lists
, since they can be freed
in own
659 - Drop transaction resending support.
(10)
660 - Extended
local command processing log.
(9)
661 - Also print pid
in common logger.
(8)
662 - Use pthread_self
() instead of getpid
() to get uniq thread id.
(7)
664 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.6-1
665 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was
set for read command, do not
666 send data reply. Used
in local stat
command.
668 - From previous releases
:
669 Do not deal with NULL transactions.
670 Start state IO thread after state initialization.
671 Join to io state thread instead of freeing it directly.
672 Do not
exit from accept loop on error.
673 Initialize state list entry prior other usage.
675 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2-1
676 - Switched from libevent state machine to thread
-per
-client model.
678 * Fri Aug
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1.1-1
679 - Added DNET_FCGI_PUT_REGION config option to optionally
enable region tag
680 - Added wildcard direct download pattern
(*)
681 - Force direct download patterns to be checked against ID ending and
682 just by having this substring somewhere
in the query.
684 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1-1
685 - New elliptics network release
: 2.9.1
687 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.31-1
689 - Fixed resend locking bug.
691 * Mon Aug
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.30-1
692 - Fixed lock
/unlock typo
in dnet_data_ready
().
694 * Sat Aug
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.29-1
695 - Refactor fcgi logging
(29)
696 - Return
read error when key was not found. Use right config file options.
(28)
698 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.27-1
699 - Added sanity checks
for embedded reading.
701 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.26-1
702 - Disabled per
-client statistics request
in fcgi daemon.
703 - Added subtle timeout and data rewrite when FCGX_PutStr
() returns error.
705 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.25-1
706 - Copy resolved address into buffer
(later used
for reconnection
)
707 before trying to connect.
709 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.24-1
710 - Refactor fcgi
/check loggers to write pid
/thread id into single log file.
712 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.23-1
713 - Added
<region
> tag into download
-info XML output
714 - Changed sending locking.
716 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.22-1
717 - Guard multiple 'logical' xml writes against parallel write
719 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.21-1
720 - Implemented direct transaction merge.
721 - If reading size was
set to
0 map ~
0ULL size
, i.e. the whole file.
722 - Remove object from the storage
if its
history log says so.
723 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
724 DNET_FCGI_EMBED_PATTERN option.
726 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.20-1
727 - Fixed several fd leaks.
729 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.19-1
730 - Unmap
history file when failed to
read transaction.
732 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.18-1
733 - Guard OpenSSL_add_all_digests
() and initialize it only once per thread
735 - Force dnet_check_process_request
() to
wait for all sent transactions
, do
736 not wakeup after receiving reply from the first one.
738 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.17-1
739 - Fixed compilation warnings on
64bit platform
(uint64_t to unsigned long
740 long and void
* to unsigned long
)
741 - Try only requested transformation
function, do not
continue with the next
743 - Use errno to differentiate reconnection state.
745 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.15-1
746 - Made elliptics depend on eblob
747 - Updated checker's logger.
748 - Increase example
/check
/common.c waiting timeout.
749 - Added logs into file io backend listing processor.
751 * Sun Jul
26 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.12-1
752 - Let check applications to sleep longer waiting
for replies.
753 - Reduce number of ids sent via DNET_CMD_LIST
command to
1024 per reply.
754 - Mark states added via dnet_add_state
() as reconnect
-friendly.
755 - Do not add reconnection addresses which
do not have joining flags.
756 - Updated to the latest eblob lib
(moved blob code outside to libeblob
).
757 - Reschedule transaction's fire
time when
(non
-last
) reply is received.
758 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
760 * Sun Jul
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.11-1
761 - Added embedded URI parameter
, which will force timestamp to be embedded
762 with data. It is possible to embed other parameters too.
764 post
: wget
-O
/tmp
/1111 -S
--post
-file
=elliptics.spec
765 "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
×tamp
=123"
767 get
: wget
-O
/tmp
/1111 -S
--header
="If
-Modified
-Since
: Thu
, 01 Jan
1970
768 00:02:00 GMT" "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
&direct
=1"
769 - fixed random
hash selection
in fcgi frontend.
771 * Fri Jul
23 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.10-1
772 -return back addressing magic^W logic
in dnet_write_object_raw
()
774 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.9-1
775 - return back virtual datacenters.
777 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.8-1
778 - BLOB IO backend updates
(multiple threads
, index
, bug fixes
).
779 - file IO backend fixes
783 * Mon Jul
19 2010 Arkady L. Shane
<ashejn@yandex
-team.ru
> - 2.9.0.7-1
784 - initial build
for Fedora