Merge branch 'master' of https://github.com/resetius/elliptics
[elliptics.git] / elliptics-bf.spec
blob0a477dd47b7598c5f3f24fb5f72e09574e950e9c
1 Summary: Distributed hash table storage
2 Name: elliptics
3 Version: 2.19.2.6
4 Release: 1%{?dist}
6 License: GPLv2+
7 Group: System Environment/Libraries
8 URL: http://www.ioremap.net/projects/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 %if 0%{?rhel} < 6
13 BuildRequires: python26-devel, boost141-python, boost141-devel
14 BuildRequires: boost141-iostreams, boost141-thread, boost141-python, boost141-system
15 %else
16 BuildRequires: python-devel, boost-python, boost-devel, boost-iostreams, boost-thread, boost-python, boost-system
17 %endif
18 BuildRequires: eblob-devel >= 0.17.1
19 BuildRequires: smack >= 0.5.0
20 BuildRequires: leveldb-devel
21 BuildRequires: cmake
23 Obsoletes: srw
25 %description
26 Elliptics network is a fault tolerant distributed hash table
27 object storage.
30 %package devel
31 Summary: Development files for %{name}
32 Group: Development/Libraries
33 Requires: %{name} = %{version}-%{release}
36 %description devel
37 Elliptics network is a fault tolerant distributed hash table
38 object storage.
40 This package contains libraries, header files and developer documentation
41 needed for developing software which uses the cairo graphics library.
43 %package python
44 Summary: Elliptics library Python binding
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
48 %description python
49 Elliptics Python Language bindings.
52 %package python-devel
53 Summary: Elliptics library Python binding
54 Group: Development/Libraries
55 Requires: elliptics-python = %{version}-%{release}
58 %description python-devel
59 Elliptics Python Language bindings development headers and libraries.
62 %package c++
63 Summary: Elliptics library C++ binding
64 Group: Development/Libraries
65 Requires: elliptics = %{version}-%{release}
68 %description c++
69 Elliptics library C++ language binding.
72 %package c++-devel
73 Summary: Elliptics library C++ binding development headers and libraries
74 Group: Development/Libraries
75 Requires: elliptics-devel = %{version}-%{release}
76 Requires: elliptics-c++ = %{version}-%{release}
79 %description c++-devel
80 Elliptics library C++ binding development headers and libraries
81 for building C++ applications with elliptics.
83 %prep
84 %setup -q
86 %build
87 export LDFLAGS="-Wl,-z,defs"
88 export DESTDIR="%{buildroot}"
89 %if 0%{?rhel} < 6
90 export PYTHON=/usr/bin/python26
91 CXXFLAGS="-pthread -I/usr/include/boost141" LDFLAGS="-L/usr/lib64/boost141" %{cmake} -DBoost_DIR=/usr/lib64/boost141 .
92 %else
93 %{cmake} .
94 %endif
95 make %{?_smp_mflags}
97 %install
98 rm -rf %{buildroot}
99 make install DESTDIR=%{buildroot}
100 rm -f %{buildroot}%{_libdir}/*.a
101 rm -f %{buildroot}%{_libdir}/*.la
103 %post -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
106 %post python -p /sbin/ldconfig
107 %postun python -p /sbin/ldconfig
109 %post c++ -p /sbin/ldconfig
110 %postun c++ -p /sbin/ldconfig
112 %clean
113 rm -rf %{buildroot}
115 %files
116 %defattr(-,root,root,-)
117 %doc README doc/design_notes.txt doc/io_storage_backend.txt
118 %{_bindir}/*
119 %{_libdir}/libelliptics.so.*
120 %{_libdir}/libelliptics_client.so.*
121 %{_libdir}/libelliptics_cocaine.so.*
122 %{_libdir}/libelliptics_cache.so.*
125 %files devel
126 %defattr(-,root,root,-)
127 %{_includedir}/*
128 %{_libdir}/libelliptics.so
129 %{_libdir}/libelliptics_client.so
130 %{_libdir}/libelliptics_cocaine.so
131 %{_libdir}/libelliptics_cache.so
133 %files python
134 %defattr(-,root,root,-)
135 %{_libdir}/libelliptics_python.so.*
136 %{python_sitelib}/elliptics*
139 %files python-devel
140 %defattr(-,root,root,-)
141 %{_libdir}/libelliptics_python.so
144 %files c++
145 %defattr(-,root,root,-)
146 %{_libdir}/libelliptics_cpp.so.*
149 %files c++-devel
150 %defattr(-,root,root,-)
151 %{_libdir}/libelliptics_cpp.so
154 %changelog
155 * Wed Nov 21 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.6
156 - Tune nonblocking pool growing policy
157 - All dnet_remove*() functions should return error, if ack returned negative status.
158 - poll() uses msecs as timeout
160 * Mon Nov 12 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.5
161 - Added atomic number of available IO threads, only grow up pool if we have blocked sph and there are no threads available.
163 * Mon Nov 12 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.4
164 - Added atomic number of available IO threads, only grow up pool if we have blocked sph and there are no threads available.
166 * Wed Nov 07 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.4
167 - Added temoporary debug
169 * Tue Nov 06 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.3
170 - Only enlarge non-blocking pool when there is blocking sph in the pool.
172 * Fri Nov 02 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.2
173 - Fixed python installation in Lucid
174 - Remove signal setup in library. Do not block signals on ioserv exit
175 - Only write error message when real error occurs in leveldb_backend_read()
177 * Fri Oct 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.1
178 - Fixed precise build
180 * Fri Oct 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.0
181 - When creating new state we should not send auth/join commands to itself
182 - Return back periodic route table check
183 - Added LevelDB backend
185 * Thu Oct 25 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.1.0
186 - Depend elliptics-dev on elliptics with (>= ${Source-Version}) version
187 - Do not check for n->st when setting up new server node
188 - When it is called from dnet_server_node_create()->dnet_state_create()
189 - there is no n->st, and that's exactly the path where server
191 * Fri Oct 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.0.1
192 - Use autogenerated major/minor elliptics versions. Whole version is being read from debian/changelog file
193 - Fix CMake file with missing boost libraries
194 - Bump ABI version (missed from 2.18->2.19 upgrade)
195 - Drop site-packages from elliptics-client
196 - Depend on >= 0.9.4 cocaine
198 * Wed Oct 10 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.0.0
199 - Added sessions - this allows to configure and set per-request parameters (like groups)
201 * Wed Oct 10 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.2
202 - Fixed reply size calculation
203 - Unify srw log rules
204 - Fixed pool growing policy
205 - Updated debian package rules
207 * Mon Oct 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.1
208 - When running recovery-on-read do not write io attribute header
210 * Mon Oct 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.0
211 - Grow IO pools on demand
212 - Added automatic recovery on read command:
213 - if object didn't exist in previously read group,
214 - it will be written when read from the next group succeed
215 - Documentation update
216 - Added multicast autodiscovery
217 - If state is already exist, do not fail with error
218 - Fixed the ugliest debian python installation
219 - Added new python bindings
220 - Do not try to run command if srw was not initialized
221 - Populate cache on READ command when DNET_IO_FLAGS_CACHE ioflag is set
223 * Thu Sep 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.2.1
224 - Added c++/python bindings for cache write operations (including timeout)
225 - Added remove-from-disk cache operation: when such flag is set (at write time)"
226 - if object is removed from cache, it is also removed from disk
227 - Increase example number of non-blocking io threads
228 - Added 'overwrite commits write' comment
230 * Mon Sep 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.2
231 - dnet_backend_log_raw() should use dnet_backend_check_log_level() to check log level
232 - Added startup stack size check
233 - Cocaine job has to be created only when it can be queued
235 * Fri Sep 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.1
236 - Update version num
238 * Thu Sep 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.0.1
239 - New interface for execution, reply and chaining
240 - Do not strip rpath
241 - Fixed server node cleanup bug when it destroyed locks first while IO threads could still use them
242 - dnet_send_cmd_raw() must always wait for ack
243 - Fixed thread creation bug in app_watcher when application does not exist
244 - Added -g flag to elliptics build
245 - Use weak symbols instead of stubs in client lib, since server also links to it and in Fedora it ends up using stubs from client lib
246 - Search for 0mq only of cocaine is enabled
247 - Update debian packaging
248 - Fixed build-depends
250 * Fri Aug 31 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.4
251 - elliptics-client must replace old-school elliptics-2.10
253 * Thu Aug 30 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.3
254 - Added python-support to dep list
255 - Use correct package name in shlibs
257 * Wed Aug 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.2
258 - Switch to cmake from autoconf
260 * Mon Aug 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.1
261 - Depend on eblob 0.17.1 and higher
262 - Use log level instead of log mask
263 - Depend on smack 0.5.0 and higher
264 - Added cdbs dep
265 - Added in-memory (optionally disk-backed) LRU cache
266 - Get rid of boost-filesystem
267 - Split code (and debian package) to client/server libs
268 - New unlink interfaces
269 - Added ioflags to ioclient
270 - If lookup returned error, proceed read-latest with default order
271 - Let DNET_CMD_DEL use dnet_io_attr structure too
273 * Wed Aug 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.16.0.1
274 - Added possibility to start defragmentation on demand
275 - Added reserved 'hostname' word for local address
276 - Added cleanup call into node destruction path, which fixes double free error in config error path
277 - Implemented blocking exec commands
278 - Refactor pools of workers
279 - Set cocaine log level based on elliptics log mask
280 - Completely created client library
281 - Fixed json example path
283 * Tue Jul 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.15.0.1
284 - Send correct answer in smack_write
285 - New bulk_read()
286 - New event string for application invocation
287 - Corrected changelog
288 - Depend on smack 0.4.0 and higher
290 * Mon Jul 02 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.4
291 - Log all client job errorrs into app/.log file in elliptics
292 - Set nocsum flags in io-attr when it is set in global node's config
294 * Wed Jun 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.3-1
295 - Depend on smack 0.3.0 and higher
297 * Tue Jun 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.2-1
298 - Use smack_total_elements() to get number of records
300 * Mon Jun 25 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.1-1
301 - Disable signals in library and enable in server and ioclient
302 - Added cocaine library documentation
303 - Added smack configuration
304 - Sync with upstream smack repo
306 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.7-1
307 - Fixed typo in smack config parser
309 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.6-1
310 - Sink srw log into app + ".log" object in elliptics
312 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.5-1
313 - Added SMACK backend depends
315 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.4-1
316 - Drop cocaine plugin dependencies
318 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.3-1
319 - Added new cocaine debian package deps
320 - Drop cocaine deps in RHEL/Fedora build
322 * Thu Jun 21 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.2-1
323 - Build srw fix (use weak symbol for dnet_log_raw())
324 - Added new eblob bit to config documentation, drop unused parameters
325 - Fixed write response generation
327 * Fri Jun 15 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.1-1
328 - Use cocaine workers for server-side
329 - Drop dnet_attr structure
330 - Optimize read (do not send ack if there is data)
331 - Use ioremap::elliptics namespace
332 - Added ::push() - nonblocking exec
334 * Sun Apr 28 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.9-1
335 - Do not allow zero-sized reads
336 - Do not double-close python init file
338 * Sat Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.8-1
339 - Added new lookup() methods to c++/python bindings. Patch by Anton Kortunov <toshik@yandex-team.ru>
340 - If we fail to open log file, dup2() stdout/stderr to /dev/null in spawned worker process
342 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.7-1
343 - More mess with 012 file descriptors - dup them to /dev/null when going background, reopen to log file in srw worker
344 - Use correct F_SETFD/FD_CLOEXEC
345 - Use old-school fcntl() instead of accept4() and epoll_create1()
346 - Allow script execution without cmd-line
348 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.6-1
349 - Added srw config options
350 - Added O_CLOEXEC flags
351 - Added new configs (for nginx and fastcgi frontend) and python example
352 - Return sub data from smack_write() call - this is needed for fastcgi frontend
353 - Let dnet_ioclient write file by ID
354 - Added smack backend wrapper
356 * Fri Apr 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.5-1
357 - Build dependencies update
358 - Do not write metadata when appropirate bit is set in node->flags
359 - Update documentation about blob flags
361 * Fri Mar 23 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.4-1
362 - Updated state mixing algorithm
363 - Added defrag_timeout, defrag_percentage and blob_size options to file backend
365 * Mon Mar 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.3-1
366 - Allow ioclient to read/write data in different columns
367 - Hardlink script should overwrite data
368 - Fixed file read/write with different column
369 - Use correct pipe path, which includes pid
370 - Use correct structure size for dentries and extended logging
371 - Do not set name for main process
373 * Sun Mar 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.2-1
374 - Use exactly specified in config socket family
375 - Obsolete srw by ellipitcs
376 - Revert "Use X bits from operation key to find a lock instead of random hashing"
377 - Added proper sigchild handling
378 - spec update - added libsrw.so* files
379 - Dropped srw dependancy
381 * Sun Mar 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.1-1
382 - Added srw
384 * Wed Feb 29 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.12.0.1-1
385 - Depend on 0.15 eblob: added new defragmentation parameters into config
386 - Propagate prepare_write() and friends return values back to callers - changed API
388 * Sun Feb 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.7-1
389 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
390 - Updated python scripts to use new eblob class
391 - exec is reserved name in python, use exec_script for execution method name
393 * Thu Feb 16 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.6-1
394 - Added possibility to read metadata from file and dump to log
395 - Added remove_keys_from_storage_found_removed_in_eblob.py
396 - Added local merge iterator written in python. Is not optimal, but quite fast.
398 * Tue Feb 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.5-1
399 - Execute CHECK commands with NOLOCK flag
401 * Sat Feb 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.4-1
402 - Use correct eblob path for statvfs() request
404 * Mon Feb 8 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.3-1
405 - Set id.type to 0 where appropriate
406 - Request statistics with DNET_ATTR_NOLOCK flag set
407 - Fixed pohmelfs_rename.py
409 * Mon Feb 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.2-1
410 - Process checksum flags according to aflags and ioflags
412 * Wed Feb 1 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.1-1
413 - Added start/num parameters to iterate over selected number of blobs.
414 - Depend on 0.14.1 blob and higher where it is implemented.
416 * Thu Jan 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.15-1
417 - Added readdir script
418 - Dropped content length manipulation from srw/pohmelfs_inode_info_insert.py
419 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
421 * Tue Jan 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.14-1
422 - Reserve some space for directory content
423 - Added pohmelfs_read_latest_groups.py script
424 - Implemented prepare-latest helper, which returns timestamp sorted groups which contain requested id
425 - If we have more data to send, set only DNET_FLAGS_MORE flag, not erase others
426 - Rename cpp bindings
427 - Fixed range requests without limits
429 * Tue Jan 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.13-1
430 - Sort keys on server side in range requests
431 - Disable eblob_gen for now
432 - Address new binutils issues (gcc 4.6 compilation fixes)
434 * Wed Dec 21 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.12-1
435 - Trying to address new binutils issues
436 - Fill with zeroes all io threads structures
437 - Set io.num to content size+offset in write_data_wait() - it allows to use prepare/commit flags
439 * Tue Dec 20 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.11-1
440 - Implemented check for start/stop update timestamp
441 - Added cache tests in test.cpp
443 * Thu Dec 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.10-1
444 - Added configurable two-queue cache for read data by Anton Kortunov <toshic.toshic@gmail.com>
446 * Mon Dec 12 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.9-1
447 - Reopen log file on sighup
449 * Fri Dec 9 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.8-1
450 - Set DNET_FLAGS_NOLOCK for route/reverse lookup request/reply commands
451 - Added memory_test_pohmelfs() autotest
452 - Added gc calls into pohmelfs methods
453 - Fixed exception string generation for null ids
454 - Added small memory/leak test
456 * Fri Dec 2 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.7-1
457 - Use eblob_read_nocsum() if DNET_IO_FLAGS_NOCSUM is set
459 * Thu Dec 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.6-1
460 - Cleanup unused variables
461 - Fixed reply cmd->flags initialization
462 - Use boost::filesystem v2
463 - Fixes in bulk_read and bulk_write
465 * Mon Nov 28 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.5-1
466 - Implemented pool of non-blocking threads for recursive commands.
467 - Dropped metadata csum support in favour of eblob embedded checksums.
468 - Added bulk_write operation.
469 - Added sstable parser into python module
471 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.4-1
472 - Added nolocking IO thread
474 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.3-1
475 - Added oplock_num config parameter
476 - Added non-blocking thread checks
478 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.2-1
479 - Aflags/lock cleanups
481 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.1-1
482 - Added operations locks. Now all commands are processed with single-machine-atomicity
483 - Added server-side scripts
485 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.13-1
486 - Only perform blob write if io->size is not zero
488 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.12-1
489 - Initialize srw after node
491 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.11-1
492 - Do not chroot into history environment, since it is most likely incomplete
494 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.10-1
495 - Do not csum read when DNET_IO_FLAGS_NOCSUM ioflag is set
496 - When doing partial read, checksum whole file
498 * Sat Nov 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.9-1
499 - cpp tests update
500 - Return -ENOTSUP if srw is not initialized
501 - Do not reset join state to RECONNECT after it has been created
502 - Added stall_count as a configurable parameter
503 - Added BULK_READ command
505 * Tue Nov 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.8-1
506 - Fixed range counters
507 - Added ::remove() methods into python binding
508 - Remove all types if -1 as id->type is specified
509 - RHEL build must depend on eblob-devel >= 0.12.18 libsrw-devel >= 0.2.2
511 * Mon Nov 14 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.7-1
512 - Moved some objects from interface.h to packet.h
513 - Added range counters
514 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
515 - Use IP_TOS instead of SO_PRIORITY to set tos bits
516 - srw is called libsrw in rhel builds
517 - Depend on 0.12.18 eblob and 0.2.2 srw
519 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.6-1
520 - Depend on 0.2.1 srw and higher
522 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.5-1
523 - Added binary data support in srw
525 * Tue Nov 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.4-1
526 - Do not fail node initialization if srw is not initialized
528 * Mon Oct 31 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.3-1
529 - blob_send modified to send all columns if id.type == -1
530 - Do not depend elliptics build on libssl
531 - eblob/srw autoconf updates
532 - Do not return 1 from blob_write when data was compressed, return 0, since
533 there was no error
535 * Tue Oct 25 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.2-1
536 - Added srw dependency
537 - Do not call dnet_convert_io_attr for DNET_CMD_DEL command
539 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.1-1
540 - Decreased WRITE latency
541 - Use CORK for write blocks
543 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.0-1
544 - Added ioprio call inside check
545 - More example ioserv.conf comments
546 - Added client/server network priorities (man 7 socket -> IP_PRIORITY)
548 * Sat Oct 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.9-1
549 - Fixed memory allocation in range-delete
551 * Tue Oct 11 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.7-1
552 - Only set BLOB_DISK_CTL_NOCSUM if DNET_IO_FLAGS_NOCSUM is set
553 - Added dnet_get_routes function
554 - Added server-side scripting support
555 - Example ioserv.conf update
556 - Spec update
558 * Thu Dec 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.2-1
559 - Implemented multiple read in elliptics core and FCGI frontend.
560 - Implemented very user-friendly C++/Python interface.
561 - Extended FCGI xml output for POST request: added data crc, size,
562 per-group addresses and path to the destination object on file backend.
564 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.1-1
565 - Documentation update.
567 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.8-1
568 - Fixed fcgi reading with new groups URI.
570 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.7-1
571 - Implemented automatic groups selection by free space.
572 - Bug fixes.
574 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.6-1
575 - Fixed eblob_send().
576 - Use 50 check threads.
578 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.5-1
579 - Multi-threaded fsck.
580 - Bug fixes (including 2.9.4.4 version).
582 * Thu Nov 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.3-1
583 - Implemented bdb fsck (both merge and copy check).
585 * Thu Nov 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.2-1
586 - Switched to random ids (1024 ids are generated at first start)
588 * Fri Nov 19 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.1-1
589 - Switched to new addressing model
591 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.14-1
592 - Remove direct object if it can not be uploaded to the storage.
594 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.13-1
595 - Remove empty/broken history objects during merge.
597 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.12-1
598 - Added more debug about processed objects in fsck tools.
599 - Delete directly read object if its history can not be mapped.
600 - Return error from dnet_merge_direct() when merge falls back to direct
601 merge during common merge.
603 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.11-1
604 - Attempt to do direct merge when we can not parse non-direct history stored in main storage.
606 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.10-1
607 - Fixed bit directory generation in file_backend_get_dir_bits()
609 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.9-1
610 - Fixed state leak in lookup processing.
612 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.8-1
613 - Always use local address for succeeded local lookup.
615 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.7-1
616 - Kill state when check thread got error. (7)
617 - Extended fire time debug. (6)
619 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.5-1
620 - Update transaction fire time to include check timeout.
622 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.4-1
623 - Extend dnet_send_read_data() to get offset from parameters and do not abuse dnet_io_attr structure.
625 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.3-1
626 - Unmap history after selecting transaction with the last update time in dnet_merge_get_latest_transactions()
628 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
629 - Added full object ID dump and request error.
630 - Exit merge early if no id file was provided.
631 - Do not dereference state in dnet_read_complete() if it is NULL.
632 - Added -N (do not request ids and use prevously downloaded) option comment into fsck help.
634 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
635 - Extended alloc/free debug.
636 - Allow zero-sized writes.
638 * Wed Oct 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3-1
639 - New minor release. No changes from 2.9.2.32.
641 * Mon Oct 11 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.32-1
642 - Added configurable value to check header for remote node IP address.
643 - Added joining client check: returned address must be reachable to be
644 inserted into route table.
646 * Fri Oct 8 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.31-1
647 - Fixed LA sorting.
649 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.29-1
650 - Added id-by-LA generation and sorting.
651 - Debug cleanups.
653 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.28-1
654 - Added timed statistics request which also works as timed connection checker.
655 - Added seconds-only check time wait.
657 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.27-1
658 - Added keep-alive options.
660 * Mon Oct 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.26-1
661 - Unlink transaction and history after direct merge.
662 - Do not log error when state is NULL in completion callback.
664 * Sat Oct 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.25-1
665 - Added norequest flag to fsck util (will use existing file).
666 - Fixed remotes processing typo.
668 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.24-1
669 - Do not traverse the whole transaction tree after we found the
670 first one which fire time has not yet elapsed.
672 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.23-1
673 - Remove io_thread_num and max_pending config parameters.
674 - Added stack size parameter to check tools.
676 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.22-1
677 - Moved transaction debug output into the place where it can not dereference stale data.
678 - Decrease debug level for allocations.
679 - Added addrinfo null check. Should be useless though.
681 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.21-1
682 - Do not dereference null state in dnet_fcgi_read_complete.
684 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.20-1
685 - Added thread stack size parameter.
686 - Added malloc mmap threshold config parameter. (19)
688 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.18-1
689 - Really fixed recv state transaction processing leak.
691 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.16-1
692 -Do not try to dereferece null state. Happens when transaction is completed
693 on timeout.
694 - Use lineary (+60 seconds each turn) growing reconnection timeout. Added
695 reconnection limit of 1 day.
696 - Fixed recv state transaction processing leak.
698 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.15-1
699 - Compilation typo fixed.
701 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.14-1
702 - Fill all allocated memory with zeroes.
704 * Thu Sep 16 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.13-1
705 - Put transaction after it was executed. Its refcnt was increased during
706 search call.
707 - Do not try to dereference state when it can be null.
708 - Do not create unneded listening state when node does not join network. (12)
709 - Reset accept state on error.
710 - Do not join to states in state lists, since they can be freed in own
711 threads. (11)
712 - Drop transaction resending support. (10)
713 - Extended local command processing log. (9)
714 - Also print pid in common logger. (8)
715 - Use pthread_self() instead of getpid() to get uniq thread id. (7)
717 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.6-1
718 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was set for read command, do not
719 send data reply. Used in local stat command.
720 - Debug cleanup.
721 - From previous releases:
722 Do not deal with NULL transactions.
723 Start state IO thread after state initialization.
724 Join to io state thread instead of freeing it directly.
725 Do not exit from accept loop on error.
726 Initialize state list entry prior other usage.
728 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2-1
729 - Switched from libevent state machine to thread-per-client model.
731 * Fri Aug 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1.1-1
732 - Added DNET_FCGI_PUT_REGION config option to optionally enable region tag
733 - Added wildcard direct download pattern (*)
734 - Force direct download patterns to be checked against ID ending and
735 just by having this substring somewhere in the query.
737 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1-1
738 - New elliptics network release: 2.9.1
740 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.31-1
741 - Logger cleanups.
742 - Fixed resend locking bug.
744 * Mon Aug 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.30-1
745 - Fixed lock/unlock typo in dnet_data_ready().
747 * Sat Aug 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.29-1
748 - Refactor fcgi logging (29)
749 - Return read error when key was not found. Use right config file options. (28)
751 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.27-1
752 - Added sanity checks for embedded reading.
754 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.26-1
755 - Disabled per-client statistics request in fcgi daemon.
756 - Added subtle timeout and data rewrite when FCGX_PutStr() returns error.
758 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.25-1
759 - Copy resolved address into buffer (later used for reconnection)
760 before trying to connect.
762 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.24-1
763 - Refactor fcgi/check loggers to write pid/thread id into single log file.
765 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.23-1
766 - Added <region> tag into download-info XML output
767 - Changed sending locking.
769 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.22-1
770 - Guard multiple 'logical' xml writes against parallel write
772 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.21-1
773 - Implemented direct transaction merge.
774 - If reading size was set to 0 map ~0ULL size, i.e. the whole file.
775 - Remove object from the storage if its history log says so.
776 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
777 DNET_FCGI_EMBED_PATTERN option.
779 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.20-1
780 - Fixed several fd leaks.
782 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.19-1
783 - Unmap history file when failed to read transaction.
785 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.18-1
786 - Guard OpenSSL_add_all_digests() and initialize it only once per thread
787 group.
788 - Force dnet_check_process_request() to wait for all sent transactions, do
789 not wakeup after receiving reply from the first one.
791 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.17-1
792 - Fixed compilation warnings on 64bit platform (uint64_t to unsigned long
793 long and void * to unsigned long)
794 - Try only requested transformation function, do not continue with the next
795 one.
796 - Use errno to differentiate reconnection state.
798 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.15-1
799 - Made elliptics depend on eblob
800 - Updated checker's logger.
801 - Increase example/check/common.c waiting timeout.
802 - Added logs into file io backend listing processor.
804 * Sun Jul 26 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.12-1
805 - Let check applications to sleep longer waiting for replies.
806 - Reduce number of ids sent via DNET_CMD_LIST command to 1024 per reply.
807 - Mark states added via dnet_add_state() as reconnect-friendly.
808 - Do not add reconnection addresses which do not have joining flags.
809 - Updated to the latest eblob lib (moved blob code outside to libeblob).
810 - Reschedule transaction's fire time when (non-last) reply is received.
811 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
813 * Sun Jul 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.11-1
814 - Added embedded URI parameter, which will force timestamp to be embedded
815 with data. It is possible to embed other parameters too.
817 post: wget -O /tmp/1111 -S --post-file=elliptics.spec
818 "http://devfs1/test.mp3?name=qwerty.xml&embed&timestamp=123"
820 get: wget -O /tmp/1111 -S --header="If-Modified-Since: Thu, 01 Jan 1970
821 00:02:00 GMT" "http://devfs1/test.mp3?name=qwerty.xml&embed&direct=1"
822 - fixed random hash selection in fcgi frontend.
824 * Fri Jul 23 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.10-1
825 -return back addressing magic^W logic in dnet_write_object_raw()
827 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.9-1
828 - return back virtual datacenters.
830 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.8-1
831 - BLOB IO backend updates (multiple threads, index, bug fixes).
832 - file IO backend fixes
833 - python bindings
834 - c++ binding fixes
836 * Mon Jul 19 2010 Arkady L. Shane <ashejn@yandex-team.ru> - 2.9.0.7-1
837 - initial build for Fedora