1 Summary: Distributed
hash table storage
7 Group: System Environment
/Libraries
8 URL: http
://www.ioremap.net
/projects
/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
13 BuildRequires
: python26
-devel
, boost141
-python
, boost141
-devel
14 BuildRequires
: boost141
-iostreams
, boost141
-thread
, boost141
-python
, boost141
-system
16 BuildRequires
: python
-devel
, boost
-python
, boost
-devel
, boost
-iostreams
, boost
-thread
, boost
-python
, boost
-system
18 BuildRequires
: eblob
-devel
>= 0.17.1
19 BuildRequires
: smack
>= 0.5.0
25 Elliptics network is a fault tolerant distributed
hash table
30 Summary: Development files
for %{name}
31 Group: Development
/Libraries
32 Requires: %{name} = %{version}-%{release}
36 Elliptics network is a fault tolerant distributed
hash table
39 This package contains libraries
, header files and developer documentation
40 needed
for developing software which uses the cairo graphics library.
43 Summary: Elliptics library Python binding
44 Group: Development
/Libraries
45 Requires: %{name} = %{version}-%{release}
48 Elliptics Python Language bindings.
52 Summary: Elliptics library Python binding
53 Group: Development
/Libraries
54 Requires: elliptics
-python
= %{version}-%{release}
57 %description python
-devel
58 Elliptics Python Language bindings development headers and libraries.
62 Summary: Elliptics library C
++ binding
63 Group: Development
/Libraries
64 Requires: elliptics
= %{version}-%{release}
68 Elliptics library C
++ language binding.
72 Summary: Elliptics library C
++ binding development headers and libraries
73 Group: Development
/Libraries
74 Requires: elliptics
-devel
= %{version}-%{release}
75 Requires: elliptics
-c
++ = %{version}-%{release}
78 %description c
++-devel
79 Elliptics library C
++ binding development headers and libraries
80 for building C
++ applications with elliptics.
86 export LDFLAGS
="
-Wl
,-z
,defs"
87 export DESTDIR
="
%{buildroot}"
89 export PYTHON
=/usr
/bin
/python26
90 CXXFLAGS
="
-pthread
-I
/usr
/include
/boost141" LDFLAGS
="
-L
/usr
/lib64
/boost141"
%{cmake} -DBoost_DIR
=/usr
/lib64
/boost141 .
98 make install DESTDIR
=%{buildroot}
99 rm -f
%{buildroot}%{_libdir}/*.a
100 rm -f
%{buildroot}%{_libdir}/*.la
102 %post -p
/sbin
/ldconfig
103 %postun -p
/sbin
/ldconfig
105 %post python
-p
/sbin
/ldconfig
106 %postun python
-p
/sbin
/ldconfig
108 %post c
++ -p
/sbin
/ldconfig
109 %postun c
++ -p
/sbin
/ldconfig
115 %defattr(-,root
,root
,-)
116 %doc README doc
/design_notes.txt doc
/io_storage_backend.txt
118 %{_libdir}/libelliptics.so.
*
119 %{_libdir}/libelliptics_client.so.
*
120 %{_libdir}/libelliptics_cocaine.so.
*
121 %{_libdir}/libelliptics_cache.so.
*
125 %defattr(-,root
,root
,-)
127 %{_libdir}/libelliptics.so
128 %{_libdir}/libelliptics_client.so
129 %{_libdir}/libelliptics_cocaine.so
130 %{_libdir}/libelliptics_cache.so
133 %defattr(-,root
,root
,-)
134 %{_libdir}/libelliptics_python.so.
*
135 %{python_sitelib}/elliptics
*
139 %defattr(-,root
,root
,-)
140 %{_libdir}/libelliptics_python.so
144 %defattr(-,root
,root
,-)
145 %{_libdir}/libelliptics_cpp.so.
*
149 %defattr(-,root
,root
,-)
150 %{_libdir}/libelliptics_cpp.so
154 * Fri Oct
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.0.1
155 - Use autogenerated major
/minor elliptics versions. Whole version is being
read from debian
/changelog file
156 - Fix CMake file with missing boost libraries
157 - Bump ABI version
(missed from
2.18->2.19 upgrade
)
158 - Drop site
-packages from elliptics
-client
159 - Depend on
>= 0.9.4 cocaine
161 * Wed Oct
10 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.0.0
162 - Added sessions
- this allows to configure and
set per
-request parameters
(like groups
)
164 * Wed Oct
10 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.2
165 - Fixed reply size calculation
166 - Unify srw log rules
167 - Fixed pool growing policy
168 - Updated debian package rules
170 * Mon Oct
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.1
171 - When running recovery
-on
-read do not write io attribute header
173 * Mon Oct
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.0
174 - Grow IO pools on demand
175 - Added automatic recovery on
read command:
176 - if object didn't exist
in previously
read group
,
177 - it will be written when
read from the next group succeed
178 - Documentation update
179 - Added multicast autodiscovery
180 - If state is already exist
, do not fail with error
181 - Fixed the ugliest debian python installation
182 - Added new python bindings
183 - Do not try to run
command if srw was not initialized
184 - Populate cache on READ
command when DNET_IO_FLAGS_CACHE ioflag is
set
186 * Thu Sep
20 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.2.1
187 - Added c
++/python bindings
for cache write operations
(including timeout
)
188 - Added remove
-from
-disk cache operation
: when such flag is
set (at write
time)"
189 - if object is removed from cache
, it is also removed from disk
190 - Increase example number of non
-blocking io threads
191 - Added 'overwrite commits write' comment
193 * Mon Sep
17 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.1.2
194 - dnet_backend_log_raw
() should use dnet_backend_check_log_level
() to check log level
195 - Added startup stack size check
196 - Cocaine job has to be created only when it can be queued
198 * Fri Sep
14 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.1.1
201 * Thu Sep
13 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.0.1
202 - New interface
for execution
, reply and chaining
204 - Fixed server node cleanup bug when it destroyed locks first
while IO threads could still use them
205 - dnet_send_cmd_raw
() must always
wait for ack
206 - Fixed thread creation bug
in app_watcher when application does not exist
207 - Added
-g flag to elliptics build
208 - Use weak symbols instead of stubs
in client lib
, since server also links to it and
in Fedora it ends up using stubs from client lib
209 - Search
for 0mq only of cocaine is enabled
210 - Update debian packaging
211 - Fixed build
-depends
213 * Fri Aug
31 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.4
214 - elliptics
-client must replace old
-school elliptics
-2.10
216 * Thu Aug
30 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.3
217 - Added python
-support to dep list
218 - Use correct package name
in shlibs
220 * Wed Aug
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.2
221 - Switch to cmake from autoconf
223 * Mon Aug
20 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.1
224 - Depend on eblob
0.17.1 and higher
225 - Use log level instead of log mask
226 - Depend on smack
0.5.0 and higher
228 - Added
in-memory
(optionally disk
-backed
) LRU cache
229 - Get rid of boost
-filesystem
230 - Split code
(and debian package
) to client
/server libs
231 - New unlink interfaces
232 - Added ioflags to ioclient
233 - If lookup returned error
, proceed
read-latest with default order
234 - Let DNET_CMD_DEL use dnet_io_attr structure too
236 * Wed Aug
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.16.0.1
237 - Added possibility to start defragmentation on demand
238 - Added reserved 'hostname' word
for local address
239 - Added cleanup call into node destruction path
, which fixes double free error
in config error path
240 - Implemented blocking
exec commands
241 - Refactor pools of workers
242 - Set cocaine log level based on elliptics log mask
243 - Completely created client library
244 - Fixed json example path
246 * Tue Jul
24 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.15.0.1
247 - Send correct answer
in smack_write
249 - New event string
for application invocation
250 - Corrected changelog
251 - Depend on smack
0.4.0 and higher
253 * Mon Jul
02 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.4
254 - Log all client job errorrs into app
/.log file
in elliptics
255 - Set nocsum flags
in io
-attr when it is
set in global node's config
257 * Wed Jun
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.3-1
258 - Depend on smack
0.3.0 and higher
260 * Tue Jun
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.2-1
261 - Use smack_total_elements
() to get number of records
263 * Mon Jun
25 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.1-1
264 - Disable signals
in library and
enable in server and ioclient
265 - Added cocaine library documentation
266 - Added smack configuration
267 - Sync with upstream smack repo
269 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.7-1
270 - Fixed typo
in smack config parser
272 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.6-1
273 - Sink srw log into app
+ ".log" object
in elliptics
275 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.5-1
276 - Added SMACK backend depends
278 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.4-1
279 - Drop cocaine plugin dependencies
281 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.3-1
282 - Added new cocaine debian package deps
283 - Drop cocaine deps
in RHEL
/Fedora build
285 * Thu Jun
21 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.2-1
286 - Build srw fix
(use weak symbol
for dnet_log_raw
())
287 - Added new eblob bit to config documentation
, drop unused parameters
288 - Fixed write response generation
290 * Fri Jun
15 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.1-1
291 - Use cocaine workers
for server
-side
292 - Drop dnet_attr structure
293 - Optimize
read (do not send ack
if there is data
)
294 - Use ioremap
::elliptics namespace
295 - Added
::push
() - nonblocking
exec
297 * Sun Apr
28 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.9-1
298 - Do not allow zero
-sized reads
299 - Do not double
-close python init file
301 * Sat Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.8-1
302 - Added new lookup
() methods to c
++/python bindings.
Patch by Anton Kortunov
<toshik@yandex
-team.ru
>
303 - If we fail to open log file
, dup2
() stdout
/stderr to
/dev
/null
in spawned worker process
305 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.7-1
306 - More mess with
012 file descriptors
- dup them to
/dev
/null when going background
, reopen to log file
in srw worker
307 - Use correct F_SETFD
/FD_CLOEXEC
308 - Use old
-school fcntl
() instead of accept4
() and epoll_create1
()
309 - Allow script execution without cmd
-line
311 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.6-1
312 - Added srw config options
313 - Added O_CLOEXEC flags
314 - Added new configs
(for nginx and fastcgi frontend
) and python example
315 - Return sub data from smack_write
() call
- this is needed
for fastcgi frontend
316 - Let dnet_ioclient write file by ID
317 - Added smack backend wrapper
319 * Fri Apr
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.5-1
320 - Build dependencies update
321 - Do not write metadata when appropirate bit is
set in node
->flags
322 - Update documentation about blob flags
324 * Fri Mar
23 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.4-1
325 - Updated state mixing algorithm
326 - Added defrag_timeout
, defrag_percentage and blob_size options to file backend
328 * Mon Mar
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.3-1
329 - Allow ioclient to
read/write data
in different columns
330 - Hardlink script should overwrite data
331 - Fixed file
read/write with different column
332 - Use correct pipe path
, which includes pid
333 - Use correct structure size
for dentries and extended logging
334 - Do not
set name
for main process
336 * Sun Mar
13 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.2-1
337 - Use exactly specified
in config socket family
338 - Obsolete srw by ellipitcs
339 - Revert "Use X bits from operation key to find a lock instead of random hashing"
340 - Added proper sigchild handling
341 - spec update
- added libsrw.so
* files
342 - Dropped srw dependancy
344 * Sun Mar
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.1-1
347 * Wed Feb
29 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.12.0.1-1
348 - Depend on
0.15 eblob
: added new defragmentation parameters into config
349 - Propagate prepare_write
() and friends
return values back to callers
- changed API
351 * Sun Feb
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.7-1
352 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
353 - Updated python scripts to use new eblob class
354 - exec is reserved name
in python
, use exec_script
for execution method name
356 * Thu Feb
16 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.6-1
357 - Added possibility to
read metadata from file and dump to log
358 - Added remove_keys_from_storage_found_removed_in_eblob.py
359 - Added
local merge iterator written
in python. Is not optimal
, but quite fast.
361 * Tue Feb
14 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.5-1
362 - Execute CHECK commands with NOLOCK flag
364 * Sat Feb
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.4-1
365 - Use correct eblob path
for statvfs
() request
367 * Mon Feb
8 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.3-1
368 - Set id.
type to
0 where appropriate
369 - Request statistics with DNET_ATTR_NOLOCK flag
set
370 - Fixed pohmelfs_rename.py
372 * Mon Feb
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.2-1
373 - Process checksum flags according to aflags and ioflags
375 * Wed Feb
1 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.1-1
376 - Added start
/num parameters to iterate over selected number of blobs.
377 - Depend on
0.14.1 blob and higher where it is implemented.
379 * Thu Jan
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.15-1
380 - Added readdir script
381 - Dropped content length manipulation from srw
/pohmelfs_inode_info_insert.py
382 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
384 * Tue Jan
24 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.14-1
385 - Reserve some space
for directory content
386 - Added pohmelfs_read_latest_groups.py script
387 - Implemented prepare
-latest helper
, which returns timestamp sorted groups which contain requested id
388 - If we have more data to send
, set only DNET_FLAGS_MORE flag
, not erase others
389 - Rename cpp bindings
390 - Fixed range requests without limits
392 * Tue Jan
17 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.13-1
393 - Sort keys on server side
in range requests
394 - Disable eblob_gen
for now
395 - Address new binutils issues
(gcc
4.6 compilation fixes
)
397 * Wed Dec
21 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.12-1
398 - Trying to address new binutils issues
399 - Fill with zeroes all io threads structures
400 - Set io.num to content size
+offset
in write_data_wait
() - it allows to use prepare
/commit flags
402 * Tue Dec
20 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.11-1
403 - Implemented check
for start
/stop update timestamp
404 - Added cache tests
in test.cpp
406 * Thu Dec
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.10-1
407 - Added configurable two
-queue cache
for read data by Anton Kortunov
<toshic.toshic@gmail.com
>
409 * Mon Dec
12 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.9-1
410 - Reopen log file on sighup
412 * Fri Dec
9 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.8-1
413 - Set DNET_FLAGS_NOLOCK
for route
/reverse lookup request
/reply commands
414 - Added memory_test_pohmelfs
() autotest
415 - Added gc calls into pohmelfs methods
416 - Fixed exception string generation
for null ids
417 - Added small memory
/leak
test
419 * Fri Dec
2 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.7-1
420 - Use eblob_read_nocsum
() if DNET_IO_FLAGS_NOCSUM is
set
422 * Thu Dec
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.6-1
423 - Cleanup unused variables
424 - Fixed reply cmd
->flags initialization
425 - Use boost
::filesystem v2
426 - Fixes
in bulk_read and bulk_write
428 * Mon Nov
28 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.5-1
429 - Implemented pool of non
-blocking threads
for recursive commands.
430 - Dropped metadata csum support
in favour of eblob embedded checksums.
431 - Added bulk_write operation.
432 - Added sstable parser into python module
434 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.4-1
435 - Added nolocking IO thread
437 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.3-1
438 - Added oplock_num config parameter
439 - Added non
-blocking thread checks
441 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.2-1
442 - Aflags
/lock cleanups
444 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.1-1
445 - Added operations locks. Now all commands are processed with single
-machine
-atomicity
446 - Added server
-side scripts
448 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.13-1
449 - Only perform blob write
if io
->size is not zero
451 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.12-1
452 - Initialize srw after node
454 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.11-1
455 - Do not chroot into
history environment
, since it is most likely incomplete
457 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.10-1
458 - Do not csum
read when DNET_IO_FLAGS_NOCSUM ioflag is
set
459 - When doing partial
read, checksum whole file
461 * Sat Nov
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.9-1
463 - Return
-ENOTSUP
if srw is not initialized
464 - Do not reset join state to RECONNECT after it has been created
465 - Added stall_count as a configurable parameter
466 - Added BULK_READ
command
468 * Tue Nov
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.8-1
469 - Fixed range counters
470 - Added
::remove
() methods into python binding
471 - Remove all types
if -1 as id
->type is specified
472 - RHEL build must depend on eblob
-devel
>= 0.12.18 libsrw
-devel
>= 0.2.2
474 * Mon Nov
14 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.7-1
475 - Moved some objects from interface.h to packet.h
476 - Added range counters
477 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
478 - Use IP_TOS instead of SO_PRIORITY to
set tos bits
479 - srw is called libsrw
in rhel builds
480 - Depend on
0.12.18 eblob and
0.2.2 srw
482 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.6-1
483 - Depend on
0.2.1 srw and higher
485 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.5-1
486 - Added binary data support
in srw
488 * Tue Nov
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.4-1
489 - Do not fail node initialization
if srw is not initialized
491 * Mon Oct
31 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.3-1
492 - blob_send modified to send all columns
if id.
type == -1
493 - Do not depend elliptics build on libssl
494 - eblob
/srw autoconf updates
495 - Do not
return 1 from blob_write when data was compressed
, return 0, since
498 * Tue Oct
25 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.2-1
499 - Added srw dependency
500 - Do not call dnet_convert_io_attr
for DNET_CMD_DEL
command
502 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.1-1
503 - Decreased WRITE latency
504 - Use CORK
for write blocks
506 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.0-1
507 - Added ioprio call inside check
508 - More example ioserv.conf comments
509 - Added client
/server network priorities
(man
7 socket
-> IP_PRIORITY
)
511 * Sat Oct
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.9-1
512 - Fixed memory allocation
in range
-delete
514 * Tue Oct
11 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.7-1
515 - Only
set BLOB_DISK_CTL_NOCSUM
if DNET_IO_FLAGS_NOCSUM is
set
516 - Added dnet_get_routes
function
517 - Added server
-side scripting support
518 - Example ioserv.conf update
521 * Thu Dec
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.2-1
522 - Implemented multiple
read in elliptics core and FCGI frontend.
523 - Implemented very user
-friendly C
++/Python interface.
524 - Extended FCGI xml output
for POST request
: added data crc
, size
,
525 per
-group addresses and path to the destination object on file backend.
527 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.1-1
528 - Documentation update.
530 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.8-1
531 - Fixed fcgi reading with new groups URI.
533 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.7-1
534 - Implemented automatic groups selection by free space.
537 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.6-1
538 - Fixed eblob_send
().
539 - Use
50 check threads.
541 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.5-1
542 - Multi
-threaded fsck.
543 - Bug fixes
(including
2.9.4.4 version
).
545 * Thu Nov
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.3-1
546 - Implemented bdb fsck
(both merge and copy check
).
548 * Thu Nov
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.2-1
549 - Switched to random ids
(1024 ids are generated at first start
)
551 * Fri Nov
19 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.1-1
552 - Switched to new addressing model
554 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.14-1
555 - Remove direct object
if it can not be uploaded to the storage.
557 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.13-1
558 - Remove empty
/broken
history objects during merge.
560 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.12-1
561 - Added more debug about processed objects
in fsck tools.
562 - Delete directly
read object
if its
history can not be mapped.
563 - Return error from dnet_merge_direct
() when merge falls back to direct
564 merge during common merge.
566 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.11-1
567 - Attempt to
do direct merge when we can not parse non
-direct
history stored
in main storage.
569 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.10-1
570 - Fixed bit directory generation
in file_backend_get_dir_bits
()
572 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.9-1
573 - Fixed state leak
in lookup processing.
575 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.8-1
576 - Always use
local address
for succeeded
local lookup.
578 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.7-1
579 - Kill state when check thread got error.
(7)
580 - Extended fire
time debug.
(6)
582 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.5-1
583 - Update transaction fire
time to include check timeout.
585 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.4-1
586 - Extend dnet_send_read_data
() to get offset from parameters and
do not abuse dnet_io_attr structure.
588 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.3-1
589 - Unmap
history after selecting transaction with the last update
time in dnet_merge_get_latest_transactions
()
591 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
592 - Added full object ID dump and request error.
593 - Exit merge early
if no id file was provided.
594 - Do not dereference state
in dnet_read_complete
() if it is NULL.
595 - Added
-N
(do not request ids and use prevously downloaded
) option comment into fsck
help.
597 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
598 - Extended alloc
/free debug.
599 - Allow zero
-sized writes.
601 * Wed Oct
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3-1
602 - New minor release. No changes from
2.9.2.32.
604 * Mon Oct
11 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.32-1
605 - Added configurable value to check header
for remote node IP address.
606 - Added joining client check
: returned address must be reachable to be
607 inserted into route table.
609 * Fri Oct
8 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.31-1
612 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.29-1
613 - Added id
-by
-LA generation and sorting.
616 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.28-1
617 - Added timed statistics request which also works as timed connection checker.
618 - Added seconds
-only check
time wait.
620 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.27-1
621 - Added keep
-alive options.
623 * Mon Oct
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.26-1
624 - Unlink transaction and
history after direct merge.
625 - Do not log error when state is NULL
in completion callback.
627 * Sat Oct
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.25-1
628 - Added norequest flag to fsck util
(will use existing file
).
629 - Fixed remotes processing typo.
631 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.24-1
632 - Do not traverse the whole transaction tree after we found the
633 first one which fire
time has not yet elapsed.
635 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.23-1
636 - Remove io_thread_num and max_pending config parameters.
637 - Added stack size parameter to check tools.
639 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.22-1
640 - Moved transaction debug output into the place where it can not dereference stale data.
641 - Decrease debug level
for allocations.
642 - Added addrinfo null check. Should be useless though.
644 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.21-1
645 - Do not dereference null state
in dnet_fcgi_read_complete.
647 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.20-1
648 - Added thread stack size parameter.
649 - Added malloc mmap threshold config parameter.
(19)
651 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.18-1
652 - Really fixed recv state transaction processing leak.
654 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.16-1
655 -Do not try to dereferece null state. Happens when transaction is completed
657 - Use lineary
(+60 seconds each turn
) growing reconnection timeout. Added
658 reconnection limit of
1 day.
659 - Fixed recv state transaction processing leak.
661 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.15-1
662 - Compilation typo fixed.
664 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.14-1
665 - Fill all allocated memory with zeroes.
667 * Thu Sep
16 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.13-1
668 - Put transaction after it was executed. Its refcnt was increased during
670 - Do not try to dereference state when it can be null.
671 - Do not create unneded listening state when node does not join network.
(12)
672 - Reset accept state on error.
673 - Do not join to states
in state lists
, since they can be freed
in own
675 - Drop transaction resending support.
(10)
676 - Extended
local command processing log.
(9)
677 - Also print pid
in common logger.
(8)
678 - Use pthread_self
() instead of getpid
() to get uniq thread id.
(7)
680 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.6-1
681 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was
set for read command, do not
682 send data reply. Used
in local stat
command.
684 - From previous releases
:
685 Do not deal with NULL transactions.
686 Start state IO thread after state initialization.
687 Join to io state thread instead of freeing it directly.
688 Do not
exit from accept loop on error.
689 Initialize state list entry prior other usage.
691 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2-1
692 - Switched from libevent state machine to thread
-per
-client model.
694 * Fri Aug
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1.1-1
695 - Added DNET_FCGI_PUT_REGION config option to optionally
enable region tag
696 - Added wildcard direct download pattern
(*)
697 - Force direct download patterns to be checked against ID ending and
698 just by having this substring somewhere
in the query.
700 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1-1
701 - New elliptics network release
: 2.9.1
703 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.31-1
705 - Fixed resend locking bug.
707 * Mon Aug
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.30-1
708 - Fixed lock
/unlock typo
in dnet_data_ready
().
710 * Sat Aug
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.29-1
711 - Refactor fcgi logging
(29)
712 - Return
read error when key was not found. Use right config file options.
(28)
714 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.27-1
715 - Added sanity checks
for embedded reading.
717 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.26-1
718 - Disabled per
-client statistics request
in fcgi daemon.
719 - Added subtle timeout and data rewrite when FCGX_PutStr
() returns error.
721 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.25-1
722 - Copy resolved address into buffer
(later used
for reconnection
)
723 before trying to connect.
725 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.24-1
726 - Refactor fcgi
/check loggers to write pid
/thread id into single log file.
728 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.23-1
729 - Added
<region
> tag into download
-info XML output
730 - Changed sending locking.
732 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.22-1
733 - Guard multiple 'logical' xml writes against parallel write
735 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.21-1
736 - Implemented direct transaction merge.
737 - If reading size was
set to
0 map ~
0ULL size
, i.e. the whole file.
738 - Remove object from the storage
if its
history log says so.
739 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
740 DNET_FCGI_EMBED_PATTERN option.
742 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.20-1
743 - Fixed several fd leaks.
745 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.19-1
746 - Unmap
history file when failed to
read transaction.
748 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.18-1
749 - Guard OpenSSL_add_all_digests
() and initialize it only once per thread
751 - Force dnet_check_process_request
() to
wait for all sent transactions
, do
752 not wakeup after receiving reply from the first one.
754 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.17-1
755 - Fixed compilation warnings on
64bit platform
(uint64_t to unsigned long
756 long and void
* to unsigned long
)
757 - Try only requested transformation
function, do not
continue with the next
759 - Use errno to differentiate reconnection state.
761 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.15-1
762 - Made elliptics depend on eblob
763 - Updated checker's logger.
764 - Increase example
/check
/common.c waiting timeout.
765 - Added logs into file io backend listing processor.
767 * Sun Jul
26 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.12-1
768 - Let check applications to sleep longer waiting
for replies.
769 - Reduce number of ids sent via DNET_CMD_LIST
command to
1024 per reply.
770 - Mark states added via dnet_add_state
() as reconnect
-friendly.
771 - Do not add reconnection addresses which
do not have joining flags.
772 - Updated to the latest eblob lib
(moved blob code outside to libeblob
).
773 - Reschedule transaction's fire
time when
(non
-last
) reply is received.
774 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
776 * Sun Jul
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.11-1
777 - Added embedded URI parameter
, which will force timestamp to be embedded
778 with data. It is possible to embed other parameters too.
780 post
: wget
-O
/tmp
/1111 -S
--post
-file
=elliptics.spec
781 "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
×tamp
=123"
783 get
: wget
-O
/tmp
/1111 -S
--header
="If
-Modified
-Since
: Thu
, 01 Jan
1970
784 00:02:00 GMT" "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
&direct
=1"
785 - fixed random
hash selection
in fcgi frontend.
787 * Fri Jul
23 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.10-1
788 -return back addressing magic^W logic
in dnet_write_object_raw
()
790 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.9-1
791 - return back virtual datacenters.
793 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.8-1
794 - BLOB IO backend updates
(multiple threads
, index
, bug fixes
).
795 - file IO backend fixes
799 * Mon Jul
19 2010 Arkady L. Shane
<ashejn@yandex
-team.ru
> - 2.9.0.7-1
800 - initial build
for Fedora