Elliptics version update: 2.14.0.6
[elliptics.git] / elliptics-bf.spec
blob4571421bd207ea0ea2cfb13603b79f9cf75e2dc4
1 Summary: Distributed hash table storage
2 Name: elliptics
3 Version: 2.14.0.6
4 Release: 1%{?dist}
6 License: GPLv2+
7 Group: System Environment/Libraries
8 URL: http://www.ioremap.net/projects/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 %if 0%{?rhel} < 6
13 BuildRequires: python26-devel, boost141-python, boost141-devel
14 BuildRequires: boost141-iostreams, boost141-filesystem, boost141-thread, boost141-python, boost141-system
15 %else
16 BuildRequires: python-devel, boost-python, boost-devel, boost-iostreams, boost-filesystem, boost-thread, boost-python, boost-system
17 %endif
18 BuildRequires: eblob-devel >= 0.16.0
19 BuildRequires: smack
20 BuildRequires: automake autoconf libtool
22 Obsoletes: srw
24 %description
25 Elliptics network is a fault tolerant distributed hash table
26 object storage.
29 %package devel
30 Summary: Development files for %{name}
31 Group: Development/Libraries
32 Requires: %{name} = %{version}-%{release}
35 %description devel
36 Elliptics network is a fault tolerant distributed hash table
37 object storage.
39 This package contains libraries, header files and developer documentation
40 needed for developing software which uses the cairo graphics library.
42 %package python
43 Summary: Elliptics library Python binding
44 Group: Development/Libraries
45 Requires: %{name} = %{version}-%{release}
47 %description python
48 Elliptics Python Language bindings.
51 %package python-devel
52 Summary: Elliptics library Python binding
53 Group: Development/Libraries
54 Requires: elliptics-python = %{version}-%{release}
57 %description python-devel
58 Elliptics Python Language bindings development headers and libraries.
61 %package c++
62 Summary: Elliptics library C++ binding
63 Group: Development/Libraries
64 Requires: elliptics = %{version}-%{release}
67 %description c++
68 Elliptics library C++ language binding.
71 %package c++-devel
72 Summary: Elliptics library C++ binding development headers and libraries
73 Group: Development/Libraries
74 Requires: elliptics-devel = %{version}-%{release}
75 Requires: elliptics-c++ = %{version}-%{release}
78 %description c++-devel
79 Elliptics library C++ binding development headers and libraries
80 for building C++ applications with elliptics.
82 %prep
83 %setup -q
85 %build
86 export LDFLAGS="-Wl,-z,defs"
87 ./autogen.sh
88 %if 0%{?rhel} < 6
89 export PYTHON=/usr/bin/python26
90 CXXFLAGS="-pthread -I/usr/include/boost141" LDFLAGS="-L/usr/lib64/boost141" %configure --with-boost-libdir=/usr/lib64/boost141
91 %else
92 %configure
93 %endif
96 make %{?_smp_mflags}
98 %install
99 rm -rf %{buildroot}
101 make install DESTDIR=%{buildroot}
102 rm -f %{buildroot}%{_libdir}/*.a
103 rm -f %{buildroot}%{_libdir}/*.la
105 %post -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
109 %post python -p /sbin/ldconfig
110 %postun python -p /sbin/ldconfig
113 %post c++ -p /sbin/ldconfig
114 %postun c++ -p /sbin/ldconfig
117 %clean
118 rm -rf %{buildroot}
120 %files
121 %defattr(-,root,root,-)
122 %doc AUTHORS AUTHORS COPYING README
123 %{_bindir}/*
124 %{_libdir}/libelliptics.so.*
125 %{_libdir}/libelliptics_cocaine.so.*
128 %files devel
129 %defattr(-,root,root,-)
130 %{_includedir}/*
131 %{_libdir}/libelliptics.so
132 %{_libdir}/libelliptics_cocaine.so
134 %files python
135 %defattr(-,root,root,-)
136 %{_libdir}/libelliptics_python.so.*
139 %files python-devel
140 %defattr(-,root,root,-)
141 %{_libdir}/libelliptics_python.so
144 %files c++
145 %defattr(-,root,root,-)
146 %{_libdir}/libelliptics_cpp.so.*
149 %files c++-devel
150 %defattr(-,root,root,-)
151 %{_libdir}/libelliptics_cpp.so
154 %changelog
155 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.6-1
156 - Sink srw log into app + ".log" object in elliptics
158 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.5-1
159 - Added SMACK backend depends
161 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.4-1
162 - Drop cocaine plugin dependencies
164 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.3-1
165 - Added new cocaine debian package deps
166 - Drop cocaine deps in RHEL/Fedora build
168 * Thu Jun 21 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.2-1
169 - Build srw fix (use weak symbol for dnet_log_raw())
170 - Added new eblob bit to config documentation, drop unused parameters
171 - Fixed write response generation
173 * Fri Jun 15 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.1-1
174 - Use cocaine workers for server-side
175 - Drop dnet_attr structure
176 - Optimize read (do not send ack if there is data)
177 - Use ioremap::elliptics namespace
178 - Added ::push() - nonblocking exec
180 * Sun Apr 28 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.9-1
181 - Do not allow zero-sized reads
182 - Do not double-close python init file
184 * Sat Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.8-1
185 - Added new lookup() methods to c++/python bindings. Patch by Anton Kortunov <toshik@yandex-team.ru>
186 - If we fail to open log file, dup2() stdout/stderr to /dev/null in spawned worker process
188 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.7-1
189 - More mess with 012 file descriptors - dup them to /dev/null when going background, reopen to log file in srw worker
190 - Use correct F_SETFD/FD_CLOEXEC
191 - Use old-school fcntl() instead of accept4() and epoll_create1()
192 - Allow script execution without cmd-line
194 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.6-1
195 - Added srw config options
196 - Added O_CLOEXEC flags
197 - Added new configs (for nginx and fastcgi frontend) and python example
198 - Return sub data from smack_write() call - this is needed for fastcgi frontend
199 - Let dnet_ioclient write file by ID
200 - Added smack backend wrapper
202 * Fri Apr 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.5-1
203 - Build dependencies update
204 - Do not write metadata when appropirate bit is set in node->flags
205 - Update documentation about blob flags
207 * Fri Mar 23 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.4-1
208 - Updated state mixing algorithm
209 - Added defrag_timeout, defrag_percentage and blob_size options to file backend
211 * Mon Mar 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.3-1
212 - Allow ioclient to read/write data in different columns
213 - Hardlink script should overwrite data
214 - Fixed file read/write with different column
215 - Use correct pipe path, which includes pid
216 - Use correct structure size for dentries and extended logging
217 - Do not set name for main process
219 * Sun Mar 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.2-1
220 - Use exactly specified in config socket family
221 - Obsolete srw by ellipitcs
222 - Revert "Use X bits from operation key to find a lock instead of random hashing"
223 - Added proper sigchild handling
224 - spec update - added libsrw.so* files
225 - Dropped srw dependancy
227 * Sun Mar 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.1-1
228 - Added srw
230 * Wed Feb 29 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.12.0.1-1
231 - Depend on 0.15 eblob: added new defragmentation parameters into config
232 - Propagate prepare_write() and friends return values back to callers - changed API
234 * Sun Feb 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.7-1
235 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
236 - Updated python scripts to use new eblob class
237 - exec is reserved name in python, use exec_script for execution method name
239 * Thu Feb 16 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.6-1
240 - Added possibility to read metadata from file and dump to log
241 - Added remove_keys_from_storage_found_removed_in_eblob.py
242 - Added local merge iterator written in python. Is not optimal, but quite fast.
244 * Tue Feb 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.5-1
245 - Execute CHECK commands with NOLOCK flag
247 * Sat Feb 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.4-1
248 - Use correct eblob path for statvfs() request
250 * Mon Feb 8 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.3-1
251 - Set id.type to 0 where appropriate
252 - Request statistics with DNET_ATTR_NOLOCK flag set
253 - Fixed pohmelfs_rename.py
255 * Mon Feb 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.2-1
256 - Process checksum flags according to aflags and ioflags
258 * Wed Feb 1 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.1-1
259 - Added start/num parameters to iterate over selected number of blobs.
260 - Depend on 0.14.1 blob and higher where it is implemented.
262 * Thu Jan 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.15-1
263 - Added readdir script
264 - Dropped content length manipulation from srw/pohmelfs_inode_info_insert.py
265 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
267 * Tue Jan 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.14-1
268 - Reserve some space for directory content
269 - Added pohmelfs_read_latest_groups.py script
270 - Implemented prepare-latest helper, which returns timestamp sorted groups which contain requested id
271 - If we have more data to send, set only DNET_FLAGS_MORE flag, not erase others
272 - Rename cpp bindings
273 - Fixed range requests without limits
275 * Tue Jan 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.13-1
276 - Sort keys on server side in range requests
277 - Disable eblob_gen for now
278 - Address new binutils issues (gcc 4.6 compilation fixes)
280 * Wed Dec 21 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.12-1
281 - Trying to address new binutils issues
282 - Fill with zeroes all io threads structures
283 - Set io.num to content size+offset in write_data_wait() - it allows to use prepare/commit flags
285 * Tue Dec 20 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.11-1
286 - Implemented check for start/stop update timestamp
287 - Added cache tests in test.cpp
289 * Thu Dec 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.10-1
290 - Added configurable two-queue cache for read data by Anton Kortunov <toshic.toshic@gmail.com>
292 * Mon Dec 12 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.9-1
293 - Reopen log file on sighup
295 * Fri Dec 9 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.8-1
296 - Set DNET_FLAGS_NOLOCK for route/reverse lookup request/reply commands
297 - Added memory_test_pohmelfs() autotest
298 - Added gc calls into pohmelfs methods
299 - Fixed exception string generation for null ids
300 - Added small memory/leak test
302 * Fri Dec 2 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.7-1
303 - Use eblob_read_nocsum() if DNET_IO_FLAGS_NOCSUM is set
305 * Thu Dec 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.6-1
306 - Cleanup unused variables
307 - Fixed reply cmd->flags initialization
308 - Use boost::filesystem v2
309 - Fixes in bulk_read and bulk_write
311 * Mon Nov 28 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.5-1
312 - Implemented pool of non-blocking threads for recursive commands.
313 - Dropped metadata csum support in favour of eblob embedded checksums.
314 - Added bulk_write operation.
315 - Added sstable parser into python module
317 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.4-1
318 - Added nolocking IO thread
320 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.3-1
321 - Added oplock_num config parameter
322 - Added non-blocking thread checks
324 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.2-1
325 - Aflags/lock cleanups
327 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.1-1
328 - Added operations locks. Now all commands are processed with single-machine-atomicity
329 - Added server-side scripts
331 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.13-1
332 - Only perform blob write if io->size is not zero
334 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.12-1
335 - Initialize srw after node
337 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.11-1
338 - Do not chroot into history environment, since it is most likely incomplete
340 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.10-1
341 - Do not csum read when DNET_IO_FLAGS_NOCSUM ioflag is set
342 - When doing partial read, checksum whole file
344 * Sat Nov 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.9-1
345 - cpp tests update
346 - Return -ENOTSUP if srw is not initialized
347 - Do not reset join state to RECONNECT after it has been created
348 - Added stall_count as a configurable parameter
349 - Added BULK_READ command
351 * Tue Nov 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.8-1
352 - Fixed range counters
353 - Added ::remove() methods into python binding
354 - Remove all types if -1 as id->type is specified
355 - RHEL build must depend on eblob-devel >= 0.12.18 libsrw-devel >= 0.2.2
357 * Mon Nov 14 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.7-1
358 - Moved some objects from interface.h to packet.h
359 - Added range counters
360 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
361 - Use IP_TOS instead of SO_PRIORITY to set tos bits
362 - srw is called libsrw in rhel builds
363 - Depend on 0.12.18 eblob and 0.2.2 srw
365 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.6-1
366 - Depend on 0.2.1 srw and higher
368 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.5-1
369 - Added binary data support in srw
371 * Tue Nov 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.4-1
372 - Do not fail node initialization if srw is not initialized
374 * Mon Oct 31 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.3-1
375 - blob_send modified to send all columns if id.type == -1
376 - Do not depend elliptics build on libssl
377 - eblob/srw autoconf updates
378 - Do not return 1 from blob_write when data was compressed, return 0, since
379 there was no error
381 * Tue Oct 25 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.2-1
382 - Added srw dependency
383 - Do not call dnet_convert_io_attr for DNET_CMD_DEL command
385 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.1-1
386 - Decreased WRITE latency
387 - Use CORK for write blocks
389 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.0-1
390 - Added ioprio call inside check
391 - More example ioserv.conf comments
392 - Added client/server network priorities (man 7 socket -> IP_PRIORITY)
394 * Sat Oct 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.9-1
395 - Fixed memory allocation in range-delete
397 * Tue Oct 11 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.7-1
398 - Only set BLOB_DISK_CTL_NOCSUM if DNET_IO_FLAGS_NOCSUM is set
399 - Added dnet_get_routes function
400 - Added server-side scripting support
401 - Example ioserv.conf update
402 - Spec update
404 * Thu Dec 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.2-1
405 - Implemented multiple read in elliptics core and FCGI frontend.
406 - Implemented very user-friendly C++/Python interface.
407 - Extended FCGI xml output for POST request: added data crc, size,
408 per-group addresses and path to the destination object on file backend.
410 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.1-1
411 - Documentation update.
413 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.8-1
414 - Fixed fcgi reading with new groups URI.
416 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.7-1
417 - Implemented automatic groups selection by free space.
418 - Bug fixes.
420 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.6-1
421 - Fixed eblob_send().
422 - Use 50 check threads.
424 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.5-1
425 - Multi-threaded fsck.
426 - Bug fixes (including 2.9.4.4 version).
428 * Thu Nov 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.3-1
429 - Implemented bdb fsck (both merge and copy check).
431 * Thu Nov 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.2-1
432 - Switched to random ids (1024 ids are generated at first start)
434 * Fri Nov 19 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.1-1
435 - Switched to new addressing model
437 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.14-1
438 - Remove direct object if it can not be uploaded to the storage.
440 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.13-1
441 - Remove empty/broken history objects during merge.
443 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.12-1
444 - Added more debug about processed objects in fsck tools.
445 - Delete directly read object if its history can not be mapped.
446 - Return error from dnet_merge_direct() when merge falls back to direct
447 merge during common merge.
449 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.11-1
450 - Attempt to do direct merge when we can not parse non-direct history stored in main storage.
452 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.10-1
453 - Fixed bit directory generation in file_backend_get_dir_bits()
455 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.9-1
456 - Fixed state leak in lookup processing.
458 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.8-1
459 - Always use local address for succeeded local lookup.
461 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.7-1
462 - Kill state when check thread got error. (7)
463 - Extended fire time debug. (6)
465 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.5-1
466 - Update transaction fire time to include check timeout.
468 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.4-1
469 - Extend dnet_send_read_data() to get offset from parameters and do not abuse dnet_io_attr structure.
471 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.3-1
472 - Unmap history after selecting transaction with the last update time in dnet_merge_get_latest_transactions()
474 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
475 - Added full object ID dump and request error.
476 - Exit merge early if no id file was provided.
477 - Do not dereference state in dnet_read_complete() if it is NULL.
478 - Added -N (do not request ids and use prevously downloaded) option comment into fsck help.
480 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
481 - Extended alloc/free debug.
482 - Allow zero-sized writes.
484 * Wed Oct 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3-1
485 - New minor release. No changes from 2.9.2.32.
487 * Mon Oct 11 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.32-1
488 - Added configurable value to check header for remote node IP address.
489 - Added joining client check: returned address must be reachable to be
490 inserted into route table.
492 * Fri Oct 8 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.31-1
493 - Fixed LA sorting.
495 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.29-1
496 - Added id-by-LA generation and sorting.
497 - Debug cleanups.
499 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.28-1
500 - Added timed statistics request which also works as timed connection checker.
501 - Added seconds-only check time wait.
503 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.27-1
504 - Added keep-alive options.
506 * Mon Oct 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.26-1
507 - Unlink transaction and history after direct merge.
508 - Do not log error when state is NULL in completion callback.
510 * Sat Oct 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.25-1
511 - Added norequest flag to fsck util (will use existing file).
512 - Fixed remotes processing typo.
514 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.24-1
515 - Do not traverse the whole transaction tree after we found the
516 first one which fire time has not yet elapsed.
518 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.23-1
519 - Remove io_thread_num and max_pending config parameters.
520 - Added stack size parameter to check tools.
522 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.22-1
523 - Moved transaction debug output into the place where it can not dereference stale data.
524 - Decrease debug level for allocations.
525 - Added addrinfo null check. Should be useless though.
527 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.21-1
528 - Do not dereference null state in dnet_fcgi_read_complete.
530 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.20-1
531 - Added thread stack size parameter.
532 - Added malloc mmap threshold config parameter. (19)
534 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.18-1
535 - Really fixed recv state transaction processing leak.
537 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.16-1
538 -Do not try to dereferece null state. Happens when transaction is completed
539 on timeout.
540 - Use lineary (+60 seconds each turn) growing reconnection timeout. Added
541 reconnection limit of 1 day.
542 - Fixed recv state transaction processing leak.
544 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.15-1
545 - Compilation typo fixed.
547 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.14-1
548 - Fill all allocated memory with zeroes.
550 * Thu Sep 16 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.13-1
551 - Put transaction after it was executed. Its refcnt was increased during
552 search call.
553 - Do not try to dereference state when it can be null.
554 - Do not create unneded listening state when node does not join network. (12)
555 - Reset accept state on error.
556 - Do not join to states in state lists, since they can be freed in own
557 threads. (11)
558 - Drop transaction resending support. (10)
559 - Extended local command processing log. (9)
560 - Also print pid in common logger. (8)
561 - Use pthread_self() instead of getpid() to get uniq thread id. (7)
563 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.6-1
564 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was set for read command, do not
565 send data reply. Used in local stat command.
566 - Debug cleanup.
567 - From previous releases:
568 Do not deal with NULL transactions.
569 Start state IO thread after state initialization.
570 Join to io state thread instead of freeing it directly.
571 Do not exit from accept loop on error.
572 Initialize state list entry prior other usage.
574 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2-1
575 - Switched from libevent state machine to thread-per-client model.
577 * Fri Aug 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1.1-1
578 - Added DNET_FCGI_PUT_REGION config option to optionally enable region tag
579 - Added wildcard direct download pattern (*)
580 - Force direct download patterns to be checked against ID ending and
581 just by having this substring somewhere in the query.
583 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1-1
584 - New elliptics network release: 2.9.1
586 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.31-1
587 - Logger cleanups.
588 - Fixed resend locking bug.
590 * Mon Aug 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.30-1
591 - Fixed lock/unlock typo in dnet_data_ready().
593 * Sat Aug 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.29-1
594 - Refactor fcgi logging (29)
595 - Return read error when key was not found. Use right config file options. (28)
597 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.27-1
598 - Added sanity checks for embedded reading.
600 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.26-1
601 - Disabled per-client statistics request in fcgi daemon.
602 - Added subtle timeout and data rewrite when FCGX_PutStr() returns error.
604 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.25-1
605 - Copy resolved address into buffer (later used for reconnection)
606 before trying to connect.
608 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.24-1
609 - Refactor fcgi/check loggers to write pid/thread id into single log file.
611 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.23-1
612 - Added <region> tag into download-info XML output
613 - Changed sending locking.
615 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.22-1
616 - Guard multiple 'logical' xml writes against parallel write
618 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.21-1
619 - Implemented direct transaction merge.
620 - If reading size was set to 0 map ~0ULL size, i.e. the whole file.
621 - Remove object from the storage if its history log says so.
622 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
623 DNET_FCGI_EMBED_PATTERN option.
625 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.20-1
626 - Fixed several fd leaks.
628 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.19-1
629 - Unmap history file when failed to read transaction.
631 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.18-1
632 - Guard OpenSSL_add_all_digests() and initialize it only once per thread
633 group.
634 - Force dnet_check_process_request() to wait for all sent transactions, do
635 not wakeup after receiving reply from the first one.
637 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.17-1
638 - Fixed compilation warnings on 64bit platform (uint64_t to unsigned long
639 long and void * to unsigned long)
640 - Try only requested transformation function, do not continue with the next
641 one.
642 - Use errno to differentiate reconnection state.
644 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.15-1
645 - Made elliptics depend on eblob
646 - Updated checker's logger.
647 - Increase example/check/common.c waiting timeout.
648 - Added logs into file io backend listing processor.
650 * Sun Jul 26 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.12-1
651 - Let check applications to sleep longer waiting for replies.
652 - Reduce number of ids sent via DNET_CMD_LIST command to 1024 per reply.
653 - Mark states added via dnet_add_state() as reconnect-friendly.
654 - Do not add reconnection addresses which do not have joining flags.
655 - Updated to the latest eblob lib (moved blob code outside to libeblob).
656 - Reschedule transaction's fire time when (non-last) reply is received.
657 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
659 * Sun Jul 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.11-1
660 - Added embedded URI parameter, which will force timestamp to be embedded
661 with data. It is possible to embed other parameters too.
663 post: wget -O /tmp/1111 -S --post-file=elliptics.spec
664 "http://devfs1/test.mp3?name=qwerty.xml&embed&timestamp=123"
666 get: wget -O /tmp/1111 -S --header="If-Modified-Since: Thu, 01 Jan 1970
667 00:02:00 GMT" "http://devfs1/test.mp3?name=qwerty.xml&embed&direct=1"
668 - fixed random hash selection in fcgi frontend.
670 * Fri Jul 23 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.10-1
671 -return back addressing magic^W logic in dnet_write_object_raw()
673 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.9-1
674 - return back virtual datacenters.
676 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.8-1
677 - BLOB IO backend updates (multiple threads, index, bug fixes).
678 - file IO backend fixes
679 - python bindings
680 - c++ binding fixes
682 * Mon Jul 19 2010 Arkady L. Shane <ashejn@yandex-team.ru> - 2.9.0.7-1
683 - initial build for Fedora