Merge branch 'master' of http://toshik-nb-w7.ld.yandex.ru/gitweb/elliptics
[elliptics.git] / elliptics-bf.spec
blob9ce0e5577893be3f6415c113cda98f3eff72ac58
1 Summary: Distributed hash table storage
2 Name: elliptics
3 Version: 2.19.2.1
4 Release: 1%{?dist}
6 License: GPLv2+
7 Group: System Environment/Libraries
8 URL: http://www.ioremap.net/projects/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 %if 0%{?rhel} < 6
13 BuildRequires: python26-devel, boost141-python, boost141-devel
14 BuildRequires: boost141-iostreams, boost141-thread, boost141-python, boost141-system
15 %else
16 BuildRequires: python-devel, boost-python, boost-devel, boost-iostreams, boost-thread, boost-python, boost-system
17 %endif
18 BuildRequires: eblob-devel >= 0.17.1
19 BuildRequires: smack >= 0.5.0
20 BuildRequires: leveldb-devel
21 BuildRequires: cmake
23 Obsoletes: srw
25 %description
26 Elliptics network is a fault tolerant distributed hash table
27 object storage.
30 %package devel
31 Summary: Development files for %{name}
32 Group: Development/Libraries
33 Requires: %{name} = %{version}-%{release}
36 %description devel
37 Elliptics network is a fault tolerant distributed hash table
38 object storage.
40 This package contains libraries, header files and developer documentation
41 needed for developing software which uses the cairo graphics library.
43 %package python
44 Summary: Elliptics library Python binding
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
48 %description python
49 Elliptics Python Language bindings.
52 %package python-devel
53 Summary: Elliptics library Python binding
54 Group: Development/Libraries
55 Requires: elliptics-python = %{version}-%{release}
58 %description python-devel
59 Elliptics Python Language bindings development headers and libraries.
62 %package c++
63 Summary: Elliptics library C++ binding
64 Group: Development/Libraries
65 Requires: elliptics = %{version}-%{release}
68 %description c++
69 Elliptics library C++ language binding.
72 %package c++-devel
73 Summary: Elliptics library C++ binding development headers and libraries
74 Group: Development/Libraries
75 Requires: elliptics-devel = %{version}-%{release}
76 Requires: elliptics-c++ = %{version}-%{release}
79 %description c++-devel
80 Elliptics library C++ binding development headers and libraries
81 for building C++ applications with elliptics.
83 %prep
84 %setup -q
86 %build
87 export LDFLAGS="-Wl,-z,defs"
88 export DESTDIR="%{buildroot}"
89 %if 0%{?rhel} < 6
90 export PYTHON=/usr/bin/python26
91 CXXFLAGS="-pthread -I/usr/include/boost141" LDFLAGS="-L/usr/lib64/boost141" %{cmake} -DBoost_DIR=/usr/lib64/boost141 .
92 %else
93 %{cmake} .
94 %endif
95 make %{?_smp_mflags}
97 %install
98 rm -rf %{buildroot}
99 make install DESTDIR=%{buildroot}
100 rm -f %{buildroot}%{_libdir}/*.a
101 rm -f %{buildroot}%{_libdir}/*.la
103 %post -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
106 %post python -p /sbin/ldconfig
107 %postun python -p /sbin/ldconfig
109 %post c++ -p /sbin/ldconfig
110 %postun c++ -p /sbin/ldconfig
112 %clean
113 rm -rf %{buildroot}
115 %files
116 %defattr(-,root,root,-)
117 %doc README doc/design_notes.txt doc/io_storage_backend.txt
118 %{_bindir}/*
119 %{_libdir}/libelliptics.so.*
120 %{_libdir}/libelliptics_client.so.*
121 %{_libdir}/libelliptics_cocaine.so.*
122 %{_libdir}/libelliptics_cache.so.*
125 %files devel
126 %defattr(-,root,root,-)
127 %{_includedir}/*
128 %{_libdir}/libelliptics.so
129 %{_libdir}/libelliptics_client.so
130 %{_libdir}/libelliptics_cocaine.so
131 %{_libdir}/libelliptics_cache.so
133 %files python
134 %defattr(-,root,root,-)
135 %{_libdir}/libelliptics_python.so.*
136 %{python_sitelib}/elliptics*
139 %files python-devel
140 %defattr(-,root,root,-)
141 %{_libdir}/libelliptics_python.so
144 %files c++
145 %defattr(-,root,root,-)
146 %{_libdir}/libelliptics_cpp.so.*
149 %files c++-devel
150 %defattr(-,root,root,-)
151 %{_libdir}/libelliptics_cpp.so
154 %changelog
155 * Fri Oct 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.1
156 - Fixed precise build
158 * Fri Oct 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.0
159 - When creating new state we should not send auth/join commands to itself
160 - Return back periodic route table check
161 - Added LevelDB backend
163 * Thu Oct 25 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.1.0
164 - Depend elliptics-dev on elliptics with (>= ${Source-Version}) version
165 - Do not check for n->st when setting up new server node
166 - When it is called from dnet_server_node_create()->dnet_state_create()
167 - there is no n->st, and that's exactly the path where server
169 * Fri Oct 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.0.1
170 - Use autogenerated major/minor elliptics versions. Whole version is being read from debian/changelog file
171 - Fix CMake file with missing boost libraries
172 - Bump ABI version (missed from 2.18->2.19 upgrade)
173 - Drop site-packages from elliptics-client
174 - Depend on >= 0.9.4 cocaine
176 * Wed Oct 10 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.0.0
177 - Added sessions - this allows to configure and set per-request parameters (like groups)
179 * Wed Oct 10 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.2
180 - Fixed reply size calculation
181 - Unify srw log rules
182 - Fixed pool growing policy
183 - Updated debian package rules
185 * Mon Oct 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.1
186 - When running recovery-on-read do not write io attribute header
188 * Mon Oct 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.0
189 - Grow IO pools on demand
190 - Added automatic recovery on read command:
191 - if object didn't exist in previously read group,
192 - it will be written when read from the next group succeed
193 - Documentation update
194 - Added multicast autodiscovery
195 - If state is already exist, do not fail with error
196 - Fixed the ugliest debian python installation
197 - Added new python bindings
198 - Do not try to run command if srw was not initialized
199 - Populate cache on READ command when DNET_IO_FLAGS_CACHE ioflag is set
201 * Thu Sep 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.2.1
202 - Added c++/python bindings for cache write operations (including timeout)
203 - Added remove-from-disk cache operation: when such flag is set (at write time)"
204 - if object is removed from cache, it is also removed from disk
205 - Increase example number of non-blocking io threads
206 - Added 'overwrite commits write' comment
208 * Mon Sep 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.2
209 - dnet_backend_log_raw() should use dnet_backend_check_log_level() to check log level
210 - Added startup stack size check
211 - Cocaine job has to be created only when it can be queued
213 * Fri Sep 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.1
214 - Update version num
216 * Thu Sep 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.0.1
217 - New interface for execution, reply and chaining
218 - Do not strip rpath
219 - Fixed server node cleanup bug when it destroyed locks first while IO threads could still use them
220 - dnet_send_cmd_raw() must always wait for ack
221 - Fixed thread creation bug in app_watcher when application does not exist
222 - Added -g flag to elliptics build
223 - Use weak symbols instead of stubs in client lib, since server also links to it and in Fedora it ends up using stubs from client lib
224 - Search for 0mq only of cocaine is enabled
225 - Update debian packaging
226 - Fixed build-depends
228 * Fri Aug 31 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.4
229 - elliptics-client must replace old-school elliptics-2.10
231 * Thu Aug 30 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.3
232 - Added python-support to dep list
233 - Use correct package name in shlibs
235 * Wed Aug 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.2
236 - Switch to cmake from autoconf
238 * Mon Aug 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.1
239 - Depend on eblob 0.17.1 and higher
240 - Use log level instead of log mask
241 - Depend on smack 0.5.0 and higher
242 - Added cdbs dep
243 - Added in-memory (optionally disk-backed) LRU cache
244 - Get rid of boost-filesystem
245 - Split code (and debian package) to client/server libs
246 - New unlink interfaces
247 - Added ioflags to ioclient
248 - If lookup returned error, proceed read-latest with default order
249 - Let DNET_CMD_DEL use dnet_io_attr structure too
251 * Wed Aug 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.16.0.1
252 - Added possibility to start defragmentation on demand
253 - Added reserved 'hostname' word for local address
254 - Added cleanup call into node destruction path, which fixes double free error in config error path
255 - Implemented blocking exec commands
256 - Refactor pools of workers
257 - Set cocaine log level based on elliptics log mask
258 - Completely created client library
259 - Fixed json example path
261 * Tue Jul 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.15.0.1
262 - Send correct answer in smack_write
263 - New bulk_read()
264 - New event string for application invocation
265 - Corrected changelog
266 - Depend on smack 0.4.0 and higher
268 * Mon Jul 02 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.4
269 - Log all client job errorrs into app/.log file in elliptics
270 - Set nocsum flags in io-attr when it is set in global node's config
272 * Wed Jun 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.3-1
273 - Depend on smack 0.3.0 and higher
275 * Tue Jun 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.2-1
276 - Use smack_total_elements() to get number of records
278 * Mon Jun 25 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.1-1
279 - Disable signals in library and enable in server and ioclient
280 - Added cocaine library documentation
281 - Added smack configuration
282 - Sync with upstream smack repo
284 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.7-1
285 - Fixed typo in smack config parser
287 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.6-1
288 - Sink srw log into app + ".log" object in elliptics
290 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.5-1
291 - Added SMACK backend depends
293 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.4-1
294 - Drop cocaine plugin dependencies
296 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.3-1
297 - Added new cocaine debian package deps
298 - Drop cocaine deps in RHEL/Fedora build
300 * Thu Jun 21 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.2-1
301 - Build srw fix (use weak symbol for dnet_log_raw())
302 - Added new eblob bit to config documentation, drop unused parameters
303 - Fixed write response generation
305 * Fri Jun 15 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.1-1
306 - Use cocaine workers for server-side
307 - Drop dnet_attr structure
308 - Optimize read (do not send ack if there is data)
309 - Use ioremap::elliptics namespace
310 - Added ::push() - nonblocking exec
312 * Sun Apr 28 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.9-1
313 - Do not allow zero-sized reads
314 - Do not double-close python init file
316 * Sat Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.8-1
317 - Added new lookup() methods to c++/python bindings. Patch by Anton Kortunov <toshik@yandex-team.ru>
318 - If we fail to open log file, dup2() stdout/stderr to /dev/null in spawned worker process
320 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.7-1
321 - More mess with 012 file descriptors - dup them to /dev/null when going background, reopen to log file in srw worker
322 - Use correct F_SETFD/FD_CLOEXEC
323 - Use old-school fcntl() instead of accept4() and epoll_create1()
324 - Allow script execution without cmd-line
326 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.6-1
327 - Added srw config options
328 - Added O_CLOEXEC flags
329 - Added new configs (for nginx and fastcgi frontend) and python example
330 - Return sub data from smack_write() call - this is needed for fastcgi frontend
331 - Let dnet_ioclient write file by ID
332 - Added smack backend wrapper
334 * Fri Apr 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.5-1
335 - Build dependencies update
336 - Do not write metadata when appropirate bit is set in node->flags
337 - Update documentation about blob flags
339 * Fri Mar 23 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.4-1
340 - Updated state mixing algorithm
341 - Added defrag_timeout, defrag_percentage and blob_size options to file backend
343 * Mon Mar 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.3-1
344 - Allow ioclient to read/write data in different columns
345 - Hardlink script should overwrite data
346 - Fixed file read/write with different column
347 - Use correct pipe path, which includes pid
348 - Use correct structure size for dentries and extended logging
349 - Do not set name for main process
351 * Sun Mar 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.2-1
352 - Use exactly specified in config socket family
353 - Obsolete srw by ellipitcs
354 - Revert "Use X bits from operation key to find a lock instead of random hashing"
355 - Added proper sigchild handling
356 - spec update - added libsrw.so* files
357 - Dropped srw dependancy
359 * Sun Mar 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.1-1
360 - Added srw
362 * Wed Feb 29 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.12.0.1-1
363 - Depend on 0.15 eblob: added new defragmentation parameters into config
364 - Propagate prepare_write() and friends return values back to callers - changed API
366 * Sun Feb 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.7-1
367 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
368 - Updated python scripts to use new eblob class
369 - exec is reserved name in python, use exec_script for execution method name
371 * Thu Feb 16 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.6-1
372 - Added possibility to read metadata from file and dump to log
373 - Added remove_keys_from_storage_found_removed_in_eblob.py
374 - Added local merge iterator written in python. Is not optimal, but quite fast.
376 * Tue Feb 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.5-1
377 - Execute CHECK commands with NOLOCK flag
379 * Sat Feb 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.4-1
380 - Use correct eblob path for statvfs() request
382 * Mon Feb 8 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.3-1
383 - Set id.type to 0 where appropriate
384 - Request statistics with DNET_ATTR_NOLOCK flag set
385 - Fixed pohmelfs_rename.py
387 * Mon Feb 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.2-1
388 - Process checksum flags according to aflags and ioflags
390 * Wed Feb 1 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.1-1
391 - Added start/num parameters to iterate over selected number of blobs.
392 - Depend on 0.14.1 blob and higher where it is implemented.
394 * Thu Jan 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.15-1
395 - Added readdir script
396 - Dropped content length manipulation from srw/pohmelfs_inode_info_insert.py
397 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
399 * Tue Jan 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.14-1
400 - Reserve some space for directory content
401 - Added pohmelfs_read_latest_groups.py script
402 - Implemented prepare-latest helper, which returns timestamp sorted groups which contain requested id
403 - If we have more data to send, set only DNET_FLAGS_MORE flag, not erase others
404 - Rename cpp bindings
405 - Fixed range requests without limits
407 * Tue Jan 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.13-1
408 - Sort keys on server side in range requests
409 - Disable eblob_gen for now
410 - Address new binutils issues (gcc 4.6 compilation fixes)
412 * Wed Dec 21 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.12-1
413 - Trying to address new binutils issues
414 - Fill with zeroes all io threads structures
415 - Set io.num to content size+offset in write_data_wait() - it allows to use prepare/commit flags
417 * Tue Dec 20 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.11-1
418 - Implemented check for start/stop update timestamp
419 - Added cache tests in test.cpp
421 * Thu Dec 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.10-1
422 - Added configurable two-queue cache for read data by Anton Kortunov <toshic.toshic@gmail.com>
424 * Mon Dec 12 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.9-1
425 - Reopen log file on sighup
427 * Fri Dec 9 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.8-1
428 - Set DNET_FLAGS_NOLOCK for route/reverse lookup request/reply commands
429 - Added memory_test_pohmelfs() autotest
430 - Added gc calls into pohmelfs methods
431 - Fixed exception string generation for null ids
432 - Added small memory/leak test
434 * Fri Dec 2 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.7-1
435 - Use eblob_read_nocsum() if DNET_IO_FLAGS_NOCSUM is set
437 * Thu Dec 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.6-1
438 - Cleanup unused variables
439 - Fixed reply cmd->flags initialization
440 - Use boost::filesystem v2
441 - Fixes in bulk_read and bulk_write
443 * Mon Nov 28 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.5-1
444 - Implemented pool of non-blocking threads for recursive commands.
445 - Dropped metadata csum support in favour of eblob embedded checksums.
446 - Added bulk_write operation.
447 - Added sstable parser into python module
449 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.4-1
450 - Added nolocking IO thread
452 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.3-1
453 - Added oplock_num config parameter
454 - Added non-blocking thread checks
456 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.2-1
457 - Aflags/lock cleanups
459 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.1-1
460 - Added operations locks. Now all commands are processed with single-machine-atomicity
461 - Added server-side scripts
463 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.13-1
464 - Only perform blob write if io->size is not zero
466 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.12-1
467 - Initialize srw after node
469 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.11-1
470 - Do not chroot into history environment, since it is most likely incomplete
472 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.10-1
473 - Do not csum read when DNET_IO_FLAGS_NOCSUM ioflag is set
474 - When doing partial read, checksum whole file
476 * Sat Nov 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.9-1
477 - cpp tests update
478 - Return -ENOTSUP if srw is not initialized
479 - Do not reset join state to RECONNECT after it has been created
480 - Added stall_count as a configurable parameter
481 - Added BULK_READ command
483 * Tue Nov 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.8-1
484 - Fixed range counters
485 - Added ::remove() methods into python binding
486 - Remove all types if -1 as id->type is specified
487 - RHEL build must depend on eblob-devel >= 0.12.18 libsrw-devel >= 0.2.2
489 * Mon Nov 14 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.7-1
490 - Moved some objects from interface.h to packet.h
491 - Added range counters
492 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
493 - Use IP_TOS instead of SO_PRIORITY to set tos bits
494 - srw is called libsrw in rhel builds
495 - Depend on 0.12.18 eblob and 0.2.2 srw
497 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.6-1
498 - Depend on 0.2.1 srw and higher
500 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.5-1
501 - Added binary data support in srw
503 * Tue Nov 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.4-1
504 - Do not fail node initialization if srw is not initialized
506 * Mon Oct 31 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.3-1
507 - blob_send modified to send all columns if id.type == -1
508 - Do not depend elliptics build on libssl
509 - eblob/srw autoconf updates
510 - Do not return 1 from blob_write when data was compressed, return 0, since
511 there was no error
513 * Tue Oct 25 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.2-1
514 - Added srw dependency
515 - Do not call dnet_convert_io_attr for DNET_CMD_DEL command
517 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.1-1
518 - Decreased WRITE latency
519 - Use CORK for write blocks
521 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.0-1
522 - Added ioprio call inside check
523 - More example ioserv.conf comments
524 - Added client/server network priorities (man 7 socket -> IP_PRIORITY)
526 * Sat Oct 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.9-1
527 - Fixed memory allocation in range-delete
529 * Tue Oct 11 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.7-1
530 - Only set BLOB_DISK_CTL_NOCSUM if DNET_IO_FLAGS_NOCSUM is set
531 - Added dnet_get_routes function
532 - Added server-side scripting support
533 - Example ioserv.conf update
534 - Spec update
536 * Thu Dec 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.2-1
537 - Implemented multiple read in elliptics core and FCGI frontend.
538 - Implemented very user-friendly C++/Python interface.
539 - Extended FCGI xml output for POST request: added data crc, size,
540 per-group addresses and path to the destination object on file backend.
542 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.1-1
543 - Documentation update.
545 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.8-1
546 - Fixed fcgi reading with new groups URI.
548 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.7-1
549 - Implemented automatic groups selection by free space.
550 - Bug fixes.
552 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.6-1
553 - Fixed eblob_send().
554 - Use 50 check threads.
556 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.5-1
557 - Multi-threaded fsck.
558 - Bug fixes (including 2.9.4.4 version).
560 * Thu Nov 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.3-1
561 - Implemented bdb fsck (both merge and copy check).
563 * Thu Nov 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.2-1
564 - Switched to random ids (1024 ids are generated at first start)
566 * Fri Nov 19 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.1-1
567 - Switched to new addressing model
569 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.14-1
570 - Remove direct object if it can not be uploaded to the storage.
572 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.13-1
573 - Remove empty/broken history objects during merge.
575 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.12-1
576 - Added more debug about processed objects in fsck tools.
577 - Delete directly read object if its history can not be mapped.
578 - Return error from dnet_merge_direct() when merge falls back to direct
579 merge during common merge.
581 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.11-1
582 - Attempt to do direct merge when we can not parse non-direct history stored in main storage.
584 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.10-1
585 - Fixed bit directory generation in file_backend_get_dir_bits()
587 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.9-1
588 - Fixed state leak in lookup processing.
590 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.8-1
591 - Always use local address for succeeded local lookup.
593 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.7-1
594 - Kill state when check thread got error. (7)
595 - Extended fire time debug. (6)
597 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.5-1
598 - Update transaction fire time to include check timeout.
600 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.4-1
601 - Extend dnet_send_read_data() to get offset from parameters and do not abuse dnet_io_attr structure.
603 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.3-1
604 - Unmap history after selecting transaction with the last update time in dnet_merge_get_latest_transactions()
606 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
607 - Added full object ID dump and request error.
608 - Exit merge early if no id file was provided.
609 - Do not dereference state in dnet_read_complete() if it is NULL.
610 - Added -N (do not request ids and use prevously downloaded) option comment into fsck help.
612 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
613 - Extended alloc/free debug.
614 - Allow zero-sized writes.
616 * Wed Oct 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3-1
617 - New minor release. No changes from 2.9.2.32.
619 * Mon Oct 11 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.32-1
620 - Added configurable value to check header for remote node IP address.
621 - Added joining client check: returned address must be reachable to be
622 inserted into route table.
624 * Fri Oct 8 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.31-1
625 - Fixed LA sorting.
627 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.29-1
628 - Added id-by-LA generation and sorting.
629 - Debug cleanups.
631 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.28-1
632 - Added timed statistics request which also works as timed connection checker.
633 - Added seconds-only check time wait.
635 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.27-1
636 - Added keep-alive options.
638 * Mon Oct 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.26-1
639 - Unlink transaction and history after direct merge.
640 - Do not log error when state is NULL in completion callback.
642 * Sat Oct 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.25-1
643 - Added norequest flag to fsck util (will use existing file).
644 - Fixed remotes processing typo.
646 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.24-1
647 - Do not traverse the whole transaction tree after we found the
648 first one which fire time has not yet elapsed.
650 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.23-1
651 - Remove io_thread_num and max_pending config parameters.
652 - Added stack size parameter to check tools.
654 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.22-1
655 - Moved transaction debug output into the place where it can not dereference stale data.
656 - Decrease debug level for allocations.
657 - Added addrinfo null check. Should be useless though.
659 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.21-1
660 - Do not dereference null state in dnet_fcgi_read_complete.
662 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.20-1
663 - Added thread stack size parameter.
664 - Added malloc mmap threshold config parameter. (19)
666 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.18-1
667 - Really fixed recv state transaction processing leak.
669 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.16-1
670 -Do not try to dereferece null state. Happens when transaction is completed
671 on timeout.
672 - Use lineary (+60 seconds each turn) growing reconnection timeout. Added
673 reconnection limit of 1 day.
674 - Fixed recv state transaction processing leak.
676 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.15-1
677 - Compilation typo fixed.
679 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.14-1
680 - Fill all allocated memory with zeroes.
682 * Thu Sep 16 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.13-1
683 - Put transaction after it was executed. Its refcnt was increased during
684 search call.
685 - Do not try to dereference state when it can be null.
686 - Do not create unneded listening state when node does not join network. (12)
687 - Reset accept state on error.
688 - Do not join to states in state lists, since they can be freed in own
689 threads. (11)
690 - Drop transaction resending support. (10)
691 - Extended local command processing log. (9)
692 - Also print pid in common logger. (8)
693 - Use pthread_self() instead of getpid() to get uniq thread id. (7)
695 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.6-1
696 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was set for read command, do not
697 send data reply. Used in local stat command.
698 - Debug cleanup.
699 - From previous releases:
700 Do not deal with NULL transactions.
701 Start state IO thread after state initialization.
702 Join to io state thread instead of freeing it directly.
703 Do not exit from accept loop on error.
704 Initialize state list entry prior other usage.
706 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2-1
707 - Switched from libevent state machine to thread-per-client model.
709 * Fri Aug 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1.1-1
710 - Added DNET_FCGI_PUT_REGION config option to optionally enable region tag
711 - Added wildcard direct download pattern (*)
712 - Force direct download patterns to be checked against ID ending and
713 just by having this substring somewhere in the query.
715 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1-1
716 - New elliptics network release: 2.9.1
718 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.31-1
719 - Logger cleanups.
720 - Fixed resend locking bug.
722 * Mon Aug 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.30-1
723 - Fixed lock/unlock typo in dnet_data_ready().
725 * Sat Aug 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.29-1
726 - Refactor fcgi logging (29)
727 - Return read error when key was not found. Use right config file options. (28)
729 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.27-1
730 - Added sanity checks for embedded reading.
732 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.26-1
733 - Disabled per-client statistics request in fcgi daemon.
734 - Added subtle timeout and data rewrite when FCGX_PutStr() returns error.
736 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.25-1
737 - Copy resolved address into buffer (later used for reconnection)
738 before trying to connect.
740 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.24-1
741 - Refactor fcgi/check loggers to write pid/thread id into single log file.
743 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.23-1
744 - Added <region> tag into download-info XML output
745 - Changed sending locking.
747 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.22-1
748 - Guard multiple 'logical' xml writes against parallel write
750 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.21-1
751 - Implemented direct transaction merge.
752 - If reading size was set to 0 map ~0ULL size, i.e. the whole file.
753 - Remove object from the storage if its history log says so.
754 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
755 DNET_FCGI_EMBED_PATTERN option.
757 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.20-1
758 - Fixed several fd leaks.
760 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.19-1
761 - Unmap history file when failed to read transaction.
763 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.18-1
764 - Guard OpenSSL_add_all_digests() and initialize it only once per thread
765 group.
766 - Force dnet_check_process_request() to wait for all sent transactions, do
767 not wakeup after receiving reply from the first one.
769 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.17-1
770 - Fixed compilation warnings on 64bit platform (uint64_t to unsigned long
771 long and void * to unsigned long)
772 - Try only requested transformation function, do not continue with the next
773 one.
774 - Use errno to differentiate reconnection state.
776 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.15-1
777 - Made elliptics depend on eblob
778 - Updated checker's logger.
779 - Increase example/check/common.c waiting timeout.
780 - Added logs into file io backend listing processor.
782 * Sun Jul 26 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.12-1
783 - Let check applications to sleep longer waiting for replies.
784 - Reduce number of ids sent via DNET_CMD_LIST command to 1024 per reply.
785 - Mark states added via dnet_add_state() as reconnect-friendly.
786 - Do not add reconnection addresses which do not have joining flags.
787 - Updated to the latest eblob lib (moved blob code outside to libeblob).
788 - Reschedule transaction's fire time when (non-last) reply is received.
789 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
791 * Sun Jul 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.11-1
792 - Added embedded URI parameter, which will force timestamp to be embedded
793 with data. It is possible to embed other parameters too.
795 post: wget -O /tmp/1111 -S --post-file=elliptics.spec
796 "http://devfs1/test.mp3?name=qwerty.xml&embed&timestamp=123"
798 get: wget -O /tmp/1111 -S --header="If-Modified-Since: Thu, 01 Jan 1970
799 00:02:00 GMT" "http://devfs1/test.mp3?name=qwerty.xml&embed&direct=1"
800 - fixed random hash selection in fcgi frontend.
802 * Fri Jul 23 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.10-1
803 -return back addressing magic^W logic in dnet_write_object_raw()
805 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.9-1
806 - return back virtual datacenters.
808 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.8-1
809 - BLOB IO backend updates (multiple threads, index, bug fixes).
810 - file IO backend fixes
811 - python bindings
812 - c++ binding fixes
814 * Mon Jul 19 2010 Arkady L. Shane <ashejn@yandex-team.ru> - 2.9.0.7-1
815 - initial build for Fedora