Dropped srw dependancy
[elliptics.git] / elliptics-bf.spec
blob29eeba5716d9a630f4fcc5b29a135f7f9cb4a9b4
1 Summary: Distributed hash table storage
2 Name: elliptics
3 Version: 2.13.0.1
4 Release: 1%{?dist}
6 License: GPLv2+
7 Group: System Environment/Libraries
8 URL: http://www.ioremap.net/projects/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 BuildRequires: libtar-devel
13 %if 0%{?rhel} < 6
14 BuildRequires: python26-devel, boost141-python, boost141-devel
15 %else
16 BuildRequires: python-devel, boost-python, boost-devel
17 %endif
18 BuildRequires: eblob-devel >= 0.15.0
19 BuildRequires: automake autoconf libtool
21 %description
22 Elliptics network is a fault tolerant distributed hash table
23 object storage.
26 %package devel
27 Summary: Development files for %{name}
28 Group: Development/Libraries
29 Requires: %{name} = %{version}-%{release}
32 %description devel
33 Elliptics network is a fault tolerant distributed hash table
34 object storage.
36 This package contains libraries, header files and developer documentation
37 needed for developing software which uses the cairo graphics library.
39 %package python
40 Summary: Elliptics library Python binding
41 Group: Development/Libraries
42 Requires: %{name} = %{version}-%{release}
44 %description python
45 Elliptics Python Language bindings.
48 %package python-devel
49 Summary: Elliptics library Python binding
50 Group: Development/Libraries
51 Requires: elliptics-python = %{version}-%{release}
54 %description python-devel
55 Elliptics Python Language bindings development headers and libraries.
58 %package c++
59 Summary: Elliptics library C++ binding
60 Group: Development/Libraries
61 Requires: elliptics = %{version}-%{release}
64 %description c++
65 Elliptics library C++ language binding.
68 %package c++-devel
69 Summary: Elliptics library C++ binding development headers and libraries
70 Group: Development/Libraries
71 Requires: elliptics-devel = %{version}-%{release}
72 Requires: elliptics-c++ = %{version}-%{release}
75 %description c++-devel
76 Elliptics library C++ binding development headers and libraries
77 for building C++ applications with elliptics.
79 %prep
80 %setup -q
82 %build
83 export LDFLAGS="-Wl,-z,defs"
84 ./autogen.sh
85 %if 0%{?rhel} < 6
86 export PYTHON=/usr/bin/python26
87 CXXFLAGS="-pthread -I/usr/include/boost141" LDFLAGS="-L/usr/lib64/boost141" %configure --with-boost-libdir=/usr/lib64/boost141
88 %else
89 %configure
90 %endif
93 make %{?_smp_mflags}
95 %install
96 rm -rf %{buildroot}
98 make install DESTDIR=%{buildroot}
99 rm -f %{buildroot}%{_libdir}/*.a
100 rm -f %{buildroot}%{_libdir}/*.la
102 %post -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
106 %post python -p /sbin/ldconfig
107 %postun python -p /sbin/ldconfig
110 %post c++ -p /sbin/ldconfig
111 %postun c++ -p /sbin/ldconfig
114 %clean
115 rm -rf %{buildroot}
117 %files
118 %defattr(-,root,root,-)
119 %doc AUTHORS AUTHORS COPYING README
120 %{_bindir}/*
121 %{_libdir}/libelliptics.so.*
124 %files devel
125 %defattr(-,root,root,-)
126 %{_includedir}/*
127 %{_libdir}/libelliptics.so
129 %files python
130 %defattr(-,root,root,-)
131 %{_libdir}/libelliptics_python.so.*
134 %files python-devel
135 %defattr(-,root,root,-)
136 %{_libdir}/libelliptics_python.so
139 %files c++
140 %defattr(-,root,root,-)
141 %{_libdir}/libelliptics_cpp.so.*
144 %files c++-devel
145 %defattr(-,root,root,-)
146 %{_libdir}/libelliptics_cpp.so
149 %changelog
150 * Sun Mar 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.1-1
151 - Added srw
153 * Wed Feb 29 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.12.0.1-1
154 - Depend on 0.15 eblob: added new defragmentation parameters into config
155 - Propagate prepare_write() and friends return values back to callers - changed API
157 * Sun Feb 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.7-1
158 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
159 - Updated python scripts to use new eblob class
160 - exec is reserved name in python, use exec_script for execution method name
162 * Thu Feb 16 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.6-1
163 - Added possibility to read metadata from file and dump to log
164 - Added remove_keys_from_storage_found_removed_in_eblob.py
165 - Added local merge iterator written in python. Is not optimal, but quite fast.
167 * Tue Feb 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.5-1
168 - Execute CHECK commands with NOLOCK flag
170 * Sat Feb 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.4-1
171 - Use correct eblob path for statvfs() request
173 * Mon Feb 8 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.3-1
174 - Set id.type to 0 where appropriate
175 - Request statistics with DNET_ATTR_NOLOCK flag set
176 - Fixed pohmelfs_rename.py
178 * Mon Feb 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.2-1
179 - Process checksum flags according to aflags and ioflags
181 * Wed Feb 1 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.1-1
182 - Added start/num parameters to iterate over selected number of blobs.
183 - Depend on 0.14.1 blob and higher where it is implemented.
185 * Thu Jan 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.15-1
186 - Added readdir script
187 - Dropped content length manipulation from srw/pohmelfs_inode_info_insert.py
188 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
190 * Tue Jan 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.14-1
191 - Reserve some space for directory content
192 - Added pohmelfs_read_latest_groups.py script
193 - Implemented prepare-latest helper, which returns timestamp sorted groups which contain requested id
194 - If we have more data to send, set only DNET_FLAGS_MORE flag, not erase others
195 - Rename cpp bindings
196 - Fixed range requests without limits
198 * Tue Jan 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.13-1
199 - Sort keys on server side in range requests
200 - Disable eblob_gen for now
201 - Address new binutils issues (gcc 4.6 compilation fixes)
203 * Wed Dec 21 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.12-1
204 - Trying to address new binutils issues
205 - Fill with zeroes all io threads structures
206 - Set io.num to content size+offset in write_data_wait() - it allows to use prepare/commit flags
208 * Tue Dec 20 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.11-1
209 - Implemented check for start/stop update timestamp
210 - Added cache tests in test.cpp
212 * Thu Dec 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.10-1
213 - Added configurable two-queue cache for read data by Anton Kortunov <toshic.toshic@gmail.com>
215 * Mon Dec 12 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.9-1
216 - Reopen log file on sighup
218 * Fri Dec 9 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.8-1
219 - Set DNET_FLAGS_NOLOCK for route/reverse lookup request/reply commands
220 - Added memory_test_pohmelfs() autotest
221 - Added gc calls into pohmelfs methods
222 - Fixed exception string generation for null ids
223 - Added small memory/leak test
225 * Fri Dec 2 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.7-1
226 - Use eblob_read_nocsum() if DNET_IO_FLAGS_NOCSUM is set
228 * Thu Dec 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.6-1
229 - Cleanup unused variables
230 - Fixed reply cmd->flags initialization
231 - Use boost::filesystem v2
232 - Fixes in bulk_read and bulk_write
234 * Mon Nov 28 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.5-1
235 - Implemented pool of non-blocking threads for recursive commands.
236 - Dropped metadata csum support in favour of eblob embedded checksums.
237 - Added bulk_write operation.
238 - Added sstable parser into python module
240 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.4-1
241 - Added nolocking IO thread
243 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.3-1
244 - Added oplock_num config parameter
245 - Added non-blocking thread checks
247 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.2-1
248 - Aflags/lock cleanups
250 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.1-1
251 - Added operations locks. Now all commands are processed with single-machine-atomicity
252 - Added server-side scripts
254 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.13-1
255 - Only perform blob write if io->size is not zero
257 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.12-1
258 - Initialize srw after node
260 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.11-1
261 - Do not chroot into history environment, since it is most likely incomplete
263 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.10-1
264 - Do not csum read when DNET_IO_FLAGS_NOCSUM ioflag is set
265 - When doing partial read, checksum whole file
267 * Sat Nov 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.9-1
268 - cpp tests update
269 - Return -ENOTSUP if srw is not initialized
270 - Do not reset join state to RECONNECT after it has been created
271 - Added stall_count as a configurable parameter
272 - Added BULK_READ command
274 * Tue Nov 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.8-1
275 - Fixed range counters
276 - Added ::remove() methods into python binding
277 - Remove all types if -1 as id->type is specified
278 - RHEL build must depend on eblob-devel >= 0.12.18 libsrw-devel >= 0.2.2
280 * Mon Nov 14 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.7-1
281 - Moved some objects from interface.h to packet.h
282 - Added range counters
283 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
284 - Use IP_TOS instead of SO_PRIORITY to set tos bits
285 - srw is called libsrw in rhel builds
286 - Depend on 0.12.18 eblob and 0.2.2 srw
288 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.6-1
289 - Depend on 0.2.1 srw and higher
291 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.5-1
292 - Added binary data support in srw
294 * Tue Nov 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.4-1
295 - Do not fail node initialization if srw is not initialized
297 * Mon Oct 31 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.3-1
298 - blob_send modified to send all columns if id.type == -1
299 - Do not depend elliptics build on libssl
300 - eblob/srw autoconf updates
301 - Do not return 1 from blob_write when data was compressed, return 0, since
302 there was no error
304 * Tue Oct 25 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.2-1
305 - Added srw dependency
306 - Do not call dnet_convert_io_attr for DNET_CMD_DEL command
308 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.1-1
309 - Decreased WRITE latency
310 - Use CORK for write blocks
312 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.0-1
313 - Added ioprio call inside check
314 - More example ioserv.conf comments
315 - Added client/server network priorities (man 7 socket -> IP_PRIORITY)
317 * Sat Oct 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.9-1
318 - Fixed memory allocation in range-delete
320 * Tue Oct 11 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.7-1
321 - Only set BLOB_DISK_CTL_NOCSUM if DNET_IO_FLAGS_NOCSUM is set
322 - Added dnet_get_routes function
323 - Added server-side scripting support
324 - Example ioserv.conf update
325 - Spec update
327 * Thu Dec 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.2-1
328 - Implemented multiple read in elliptics core and FCGI frontend.
329 - Implemented very user-friendly C++/Python interface.
330 - Extended FCGI xml output for POST request: added data crc, size,
331 per-group addresses and path to the destination object on file backend.
333 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.1-1
334 - Documentation update.
336 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.8-1
337 - Fixed fcgi reading with new groups URI.
339 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.7-1
340 - Implemented automatic groups selection by free space.
341 - Bug fixes.
343 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.6-1
344 - Fixed eblob_send().
345 - Use 50 check threads.
347 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.5-1
348 - Multi-threaded fsck.
349 - Bug fixes (including 2.9.4.4 version).
351 * Thu Nov 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.3-1
352 - Implemented bdb fsck (both merge and copy check).
354 * Thu Nov 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.2-1
355 - Switched to random ids (1024 ids are generated at first start)
357 * Fri Nov 19 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.1-1
358 - Switched to new addressing model
360 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.14-1
361 - Remove direct object if it can not be uploaded to the storage.
363 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.13-1
364 - Remove empty/broken history objects during merge.
366 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.12-1
367 - Added more debug about processed objects in fsck tools.
368 - Delete directly read object if its history can not be mapped.
369 - Return error from dnet_merge_direct() when merge falls back to direct
370 merge during common merge.
372 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.11-1
373 - Attempt to do direct merge when we can not parse non-direct history stored in main storage.
375 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.10-1
376 - Fixed bit directory generation in file_backend_get_dir_bits()
378 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.9-1
379 - Fixed state leak in lookup processing.
381 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.8-1
382 - Always use local address for succeeded local lookup.
384 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.7-1
385 - Kill state when check thread got error. (7)
386 - Extended fire time debug. (6)
388 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.5-1
389 - Update transaction fire time to include check timeout.
391 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.4-1
392 - Extend dnet_send_read_data() to get offset from parameters and do not abuse dnet_io_attr structure.
394 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.3-1
395 - Unmap history after selecting transaction with the last update time in dnet_merge_get_latest_transactions()
397 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
398 - Added full object ID dump and request error.
399 - Exit merge early if no id file was provided.
400 - Do not dereference state in dnet_read_complete() if it is NULL.
401 - Added -N (do not request ids and use prevously downloaded) option comment into fsck help.
403 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
404 - Extended alloc/free debug.
405 - Allow zero-sized writes.
407 * Wed Oct 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3-1
408 - New minor release. No changes from 2.9.2.32.
410 * Mon Oct 11 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.32-1
411 - Added configurable value to check header for remote node IP address.
412 - Added joining client check: returned address must be reachable to be
413 inserted into route table.
415 * Fri Oct 8 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.31-1
416 - Fixed LA sorting.
418 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.29-1
419 - Added id-by-LA generation and sorting.
420 - Debug cleanups.
422 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.28-1
423 - Added timed statistics request which also works as timed connection checker.
424 - Added seconds-only check time wait.
426 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.27-1
427 - Added keep-alive options.
429 * Mon Oct 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.26-1
430 - Unlink transaction and history after direct merge.
431 - Do not log error when state is NULL in completion callback.
433 * Sat Oct 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.25-1
434 - Added norequest flag to fsck util (will use existing file).
435 - Fixed remotes processing typo.
437 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.24-1
438 - Do not traverse the whole transaction tree after we found the
439 first one which fire time has not yet elapsed.
441 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.23-1
442 - Remove io_thread_num and max_pending config parameters.
443 - Added stack size parameter to check tools.
445 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.22-1
446 - Moved transaction debug output into the place where it can not dereference stale data.
447 - Decrease debug level for allocations.
448 - Added addrinfo null check. Should be useless though.
450 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.21-1
451 - Do not dereference null state in dnet_fcgi_read_complete.
453 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.20-1
454 - Added thread stack size parameter.
455 - Added malloc mmap threshold config parameter. (19)
457 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.18-1
458 - Really fixed recv state transaction processing leak.
460 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.16-1
461 -Do not try to dereferece null state. Happens when transaction is completed
462 on timeout.
463 - Use lineary (+60 seconds each turn) growing reconnection timeout. Added
464 reconnection limit of 1 day.
465 - Fixed recv state transaction processing leak.
467 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.15-1
468 - Compilation typo fixed.
470 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.14-1
471 - Fill all allocated memory with zeroes.
473 * Thu Sep 16 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.13-1
474 - Put transaction after it was executed. Its refcnt was increased during
475 search call.
476 - Do not try to dereference state when it can be null.
477 - Do not create unneded listening state when node does not join network. (12)
478 - Reset accept state on error.
479 - Do not join to states in state lists, since they can be freed in own
480 threads. (11)
481 - Drop transaction resending support. (10)
482 - Extended local command processing log. (9)
483 - Also print pid in common logger. (8)
484 - Use pthread_self() instead of getpid() to get uniq thread id. (7)
486 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.6-1
487 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was set for read command, do not
488 send data reply. Used in local stat command.
489 - Debug cleanup.
490 - From previous releases:
491 Do not deal with NULL transactions.
492 Start state IO thread after state initialization.
493 Join to io state thread instead of freeing it directly.
494 Do not exit from accept loop on error.
495 Initialize state list entry prior other usage.
497 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2-1
498 - Switched from libevent state machine to thread-per-client model.
500 * Fri Aug 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1.1-1
501 - Added DNET_FCGI_PUT_REGION config option to optionally enable region tag
502 - Added wildcard direct download pattern (*)
503 - Force direct download patterns to be checked against ID ending and
504 just by having this substring somewhere in the query.
506 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1-1
507 - New elliptics network release: 2.9.1
509 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.31-1
510 - Logger cleanups.
511 - Fixed resend locking bug.
513 * Mon Aug 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.30-1
514 - Fixed lock/unlock typo in dnet_data_ready().
516 * Sat Aug 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.29-1
517 - Refactor fcgi logging (29)
518 - Return read error when key was not found. Use right config file options. (28)
520 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.27-1
521 - Added sanity checks for embedded reading.
523 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.26-1
524 - Disabled per-client statistics request in fcgi daemon.
525 - Added subtle timeout and data rewrite when FCGX_PutStr() returns error.
527 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.25-1
528 - Copy resolved address into buffer (later used for reconnection)
529 before trying to connect.
531 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.24-1
532 - Refactor fcgi/check loggers to write pid/thread id into single log file.
534 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.23-1
535 - Added <region> tag into download-info XML output
536 - Changed sending locking.
538 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.22-1
539 - Guard multiple 'logical' xml writes against parallel write
541 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.21-1
542 - Implemented direct transaction merge.
543 - If reading size was set to 0 map ~0ULL size, i.e. the whole file.
544 - Remove object from the storage if its history log says so.
545 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
546 DNET_FCGI_EMBED_PATTERN option.
548 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.20-1
549 - Fixed several fd leaks.
551 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.19-1
552 - Unmap history file when failed to read transaction.
554 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.18-1
555 - Guard OpenSSL_add_all_digests() and initialize it only once per thread
556 group.
557 - Force dnet_check_process_request() to wait for all sent transactions, do
558 not wakeup after receiving reply from the first one.
560 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.17-1
561 - Fixed compilation warnings on 64bit platform (uint64_t to unsigned long
562 long and void * to unsigned long)
563 - Try only requested transformation function, do not continue with the next
564 one.
565 - Use errno to differentiate reconnection state.
567 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.15-1
568 - Made elliptics depend on eblob
569 - Updated checker's logger.
570 - Increase example/check/common.c waiting timeout.
571 - Added logs into file io backend listing processor.
573 * Sun Jul 26 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.12-1
574 - Let check applications to sleep longer waiting for replies.
575 - Reduce number of ids sent via DNET_CMD_LIST command to 1024 per reply.
576 - Mark states added via dnet_add_state() as reconnect-friendly.
577 - Do not add reconnection addresses which do not have joining flags.
578 - Updated to the latest eblob lib (moved blob code outside to libeblob).
579 - Reschedule transaction's fire time when (non-last) reply is received.
580 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
582 * Sun Jul 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.11-1
583 - Added embedded URI parameter, which will force timestamp to be embedded
584 with data. It is possible to embed other parameters too.
586 post: wget -O /tmp/1111 -S --post-file=elliptics.spec
587 "http://devfs1/test.mp3?name=qwerty.xml&embed&timestamp=123"
589 get: wget -O /tmp/1111 -S --header="If-Modified-Since: Thu, 01 Jan 1970
590 00:02:00 GMT" "http://devfs1/test.mp3?name=qwerty.xml&embed&direct=1"
591 - fixed random hash selection in fcgi frontend.
593 * Fri Jul 23 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.10-1
594 -return back addressing magic^W logic in dnet_write_object_raw()
596 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.9-1
597 - return back virtual datacenters.
599 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.8-1
600 - BLOB IO backend updates (multiple threads, index, bug fixes).
601 - file IO backend fixes
602 - python bindings
603 - c++ binding fixes
605 * Mon Jul 19 2010 Arkady L. Shane <ashejn@yandex-team.ru> - 2.9.0.7-1
606 - initial build for Fedora