1 Summary: Distributed
hash table storage
7 Group: System Environment
/Libraries
8 URL: http
://www.ioremap.net
/projects
/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
13 BuildRequires
: python26
-devel
, boost141
-python
, boost141
-devel
14 BuildRequires
: boost141
-iostreams
, boost141
-thread
, boost141
-python
, boost141
-system
16 BuildRequires
: python
-devel
, boost
-python
, boost
-devel
, boost
-iostreams
, boost
-thread
, boost
-python
, boost
-system
18 BuildRequires
: eblob
-devel
>= 0.17.1
19 BuildRequires
: smack
>= 0.5.0
20 BuildRequires
: leveldb
-devel
26 Elliptics network is a fault tolerant distributed
hash table
31 Summary: Development files
for %{name}
32 Group: Development
/Libraries
33 Requires: %{name} = %{version}-%{release}
37 Elliptics network is a fault tolerant distributed
hash table
40 This package contains libraries
, header files and developer documentation
41 needed
for developing software which uses the cairo graphics library.
44 Summary: Elliptics library Python binding
45 Group: Development
/Libraries
46 Requires: %{name} = %{version}-%{release}
49 Elliptics Python Language bindings.
53 Summary: Elliptics library Python binding
54 Group: Development
/Libraries
55 Requires: elliptics
-python
= %{version}-%{release}
58 %description python
-devel
59 Elliptics Python Language bindings development headers and libraries.
63 Summary: Elliptics library C
++ binding
64 Group: Development
/Libraries
65 Requires: elliptics
= %{version}-%{release}
69 Elliptics library C
++ language binding.
73 Summary: Elliptics library C
++ binding development headers and libraries
74 Group: Development
/Libraries
75 Requires: elliptics
-devel
= %{version}-%{release}
76 Requires: elliptics
-c
++ = %{version}-%{release}
79 %description c
++-devel
80 Elliptics library C
++ binding development headers and libraries
81 for building C
++ applications with elliptics.
87 export LDFLAGS
="
-Wl
,-z
,defs"
88 export DESTDIR
="
%{buildroot}"
90 export PYTHON
=/usr
/bin
/python26
91 CXXFLAGS
="
-pthread
-I
/usr
/include
/boost141" LDFLAGS
="
-L
/usr
/lib64
/boost141"
%{cmake} -DBoost_DIR
=/usr
/lib64
/boost141 .
99 make install DESTDIR
=%{buildroot}
100 rm -f
%{buildroot}%{_libdir}/*.a
101 rm -f
%{buildroot}%{_libdir}/*.la
103 %post -p
/sbin
/ldconfig
104 %postun -p
/sbin
/ldconfig
106 %post python
-p
/sbin
/ldconfig
107 %postun python
-p
/sbin
/ldconfig
109 %post c
++ -p
/sbin
/ldconfig
110 %postun c
++ -p
/sbin
/ldconfig
116 %defattr(-,root
,root
,-)
117 %doc README doc
/design_notes.txt doc
/io_storage_backend.txt
119 %{_libdir}/libelliptics.so.
*
120 %{_libdir}/libelliptics_client.so.
*
121 %{_libdir}/libelliptics_cocaine.so.
*
122 %{_libdir}/libelliptics_cache.so.
*
126 %defattr(-,root
,root
,-)
128 %{_libdir}/libelliptics.so
129 %{_libdir}/libelliptics_client.so
130 %{_libdir}/libelliptics_cocaine.so
131 %{_libdir}/libelliptics_cache.so
134 %defattr(-,root
,root
,-)
135 %{_libdir}/libelliptics_python.so.
*
136 %{python_sitelib}/elliptics
*
140 %defattr(-,root
,root
,-)
141 %{_libdir}/libelliptics_python.so
145 %defattr(-,root
,root
,-)
146 %{_libdir}/libelliptics_cpp.so.
*
150 %defattr(-,root
,root
,-)
151 %{_libdir}/libelliptics_cpp.so
155 * Mon Nov
12 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.5
156 - Added atomic number of available IO threads
, only grow up pool
if we have blocked sph and there are no threads available.
158 * Mon Nov
12 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.4
159 - Added atomic number of available IO threads
, only grow up pool
if we have blocked sph and there are no threads available.
161 * Wed Nov
07 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.4
162 - Added temoporary debug
164 * Tue Nov
06 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.3
165 - Only enlarge non
-blocking pool when there is blocking sph
in the pool.
167 * Fri Nov
02 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.2
168 - Fixed python installation
in Lucid
169 - Remove signal setup
in library. Do not block signals on ioserv
exit
170 - Only write error message when real error occurs
in leveldb_backend_read
()
172 * Fri Oct
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.1
173 - Fixed precise build
175 * Fri Oct
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.0
176 - When creating new state we should not send auth
/join commands to itself
177 - Return back periodic route table check
178 - Added LevelDB backend
180 * Thu Oct
25 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.1.0
181 - Depend elliptics
-dev on elliptics with
(>= $
{Source-Version}) version
182 - Do not check
for n
->st when setting up new server node
183 - When it is called from dnet_server_node_create
()->dnet_state_create
()
184 - there is no n
->st
, and that's exactly the path where server
186 * Fri Oct
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.0.1
187 - Use autogenerated major
/minor elliptics versions. Whole version is being
read from debian
/changelog file
188 - Fix CMake file with missing boost libraries
189 - Bump ABI version
(missed from
2.18->2.19 upgrade
)
190 - Drop site
-packages from elliptics
-client
191 - Depend on
>= 0.9.4 cocaine
193 * Wed Oct
10 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.0.0
194 - Added sessions
- this allows to configure and
set per
-request parameters
(like groups
)
196 * Wed Oct
10 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.2
197 - Fixed reply size calculation
198 - Unify srw log rules
199 - Fixed pool growing policy
200 - Updated debian package rules
202 * Mon Oct
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.1
203 - When running recovery
-on
-read do not write io attribute header
205 * Mon Oct
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.0
206 - Grow IO pools on demand
207 - Added automatic recovery on
read command:
208 - if object didn't exist
in previously
read group
,
209 - it will be written when
read from the next group succeed
210 - Documentation update
211 - Added multicast autodiscovery
212 - If state is already exist
, do not fail with error
213 - Fixed the ugliest debian python installation
214 - Added new python bindings
215 - Do not try to run
command if srw was not initialized
216 - Populate cache on READ
command when DNET_IO_FLAGS_CACHE ioflag is
set
218 * Thu Sep
20 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.2.1
219 - Added c
++/python bindings
for cache write operations
(including timeout
)
220 - Added remove
-from
-disk cache operation
: when such flag is
set (at write
time)"
221 - if object is removed from cache
, it is also removed from disk
222 - Increase example number of non
-blocking io threads
223 - Added 'overwrite commits write' comment
225 * Mon Sep
17 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.1.2
226 - dnet_backend_log_raw
() should use dnet_backend_check_log_level
() to check log level
227 - Added startup stack size check
228 - Cocaine job has to be created only when it can be queued
230 * Fri Sep
14 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.1.1
233 * Thu Sep
13 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.0.1
234 - New interface
for execution
, reply and chaining
236 - Fixed server node cleanup bug when it destroyed locks first
while IO threads could still use them
237 - dnet_send_cmd_raw
() must always
wait for ack
238 - Fixed thread creation bug
in app_watcher when application does not exist
239 - Added
-g flag to elliptics build
240 - Use weak symbols instead of stubs
in client lib
, since server also links to it and
in Fedora it ends up using stubs from client lib
241 - Search
for 0mq only of cocaine is enabled
242 - Update debian packaging
243 - Fixed build
-depends
245 * Fri Aug
31 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.4
246 - elliptics
-client must replace old
-school elliptics
-2.10
248 * Thu Aug
30 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.3
249 - Added python
-support to dep list
250 - Use correct package name
in shlibs
252 * Wed Aug
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.2
253 - Switch to cmake from autoconf
255 * Mon Aug
20 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.1
256 - Depend on eblob
0.17.1 and higher
257 - Use log level instead of log mask
258 - Depend on smack
0.5.0 and higher
260 - Added
in-memory
(optionally disk
-backed
) LRU cache
261 - Get rid of boost
-filesystem
262 - Split code
(and debian package
) to client
/server libs
263 - New unlink interfaces
264 - Added ioflags to ioclient
265 - If lookup returned error
, proceed
read-latest with default order
266 - Let DNET_CMD_DEL use dnet_io_attr structure too
268 * Wed Aug
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.16.0.1
269 - Added possibility to start defragmentation on demand
270 - Added reserved 'hostname' word
for local address
271 - Added cleanup call into node destruction path
, which fixes double free error
in config error path
272 - Implemented blocking
exec commands
273 - Refactor pools of workers
274 - Set cocaine log level based on elliptics log mask
275 - Completely created client library
276 - Fixed json example path
278 * Tue Jul
24 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.15.0.1
279 - Send correct answer
in smack_write
281 - New event string
for application invocation
282 - Corrected changelog
283 - Depend on smack
0.4.0 and higher
285 * Mon Jul
02 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.4
286 - Log all client job errorrs into app
/.log file
in elliptics
287 - Set nocsum flags
in io
-attr when it is
set in global node's config
289 * Wed Jun
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.3-1
290 - Depend on smack
0.3.0 and higher
292 * Tue Jun
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.2-1
293 - Use smack_total_elements
() to get number of records
295 * Mon Jun
25 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.1-1
296 - Disable signals
in library and
enable in server and ioclient
297 - Added cocaine library documentation
298 - Added smack configuration
299 - Sync with upstream smack repo
301 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.7-1
302 - Fixed typo
in smack config parser
304 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.6-1
305 - Sink srw log into app
+ ".log" object
in elliptics
307 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.5-1
308 - Added SMACK backend depends
310 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.4-1
311 - Drop cocaine plugin dependencies
313 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.3-1
314 - Added new cocaine debian package deps
315 - Drop cocaine deps
in RHEL
/Fedora build
317 * Thu Jun
21 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.2-1
318 - Build srw fix
(use weak symbol
for dnet_log_raw
())
319 - Added new eblob bit to config documentation
, drop unused parameters
320 - Fixed write response generation
322 * Fri Jun
15 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.1-1
323 - Use cocaine workers
for server
-side
324 - Drop dnet_attr structure
325 - Optimize
read (do not send ack
if there is data
)
326 - Use ioremap
::elliptics namespace
327 - Added
::push
() - nonblocking
exec
329 * Sun Apr
28 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.9-1
330 - Do not allow zero
-sized reads
331 - Do not double
-close python init file
333 * Sat Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.8-1
334 - Added new lookup
() methods to c
++/python bindings.
Patch by Anton Kortunov
<toshik@yandex
-team.ru
>
335 - If we fail to open log file
, dup2
() stdout
/stderr to
/dev
/null
in spawned worker process
337 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.7-1
338 - More mess with
012 file descriptors
- dup them to
/dev
/null when going background
, reopen to log file
in srw worker
339 - Use correct F_SETFD
/FD_CLOEXEC
340 - Use old
-school fcntl
() instead of accept4
() and epoll_create1
()
341 - Allow script execution without cmd
-line
343 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.6-1
344 - Added srw config options
345 - Added O_CLOEXEC flags
346 - Added new configs
(for nginx and fastcgi frontend
) and python example
347 - Return sub data from smack_write
() call
- this is needed
for fastcgi frontend
348 - Let dnet_ioclient write file by ID
349 - Added smack backend wrapper
351 * Fri Apr
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.5-1
352 - Build dependencies update
353 - Do not write metadata when appropirate bit is
set in node
->flags
354 - Update documentation about blob flags
356 * Fri Mar
23 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.4-1
357 - Updated state mixing algorithm
358 - Added defrag_timeout
, defrag_percentage and blob_size options to file backend
360 * Mon Mar
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.3-1
361 - Allow ioclient to
read/write data
in different columns
362 - Hardlink script should overwrite data
363 - Fixed file
read/write with different column
364 - Use correct pipe path
, which includes pid
365 - Use correct structure size
for dentries and extended logging
366 - Do not
set name
for main process
368 * Sun Mar
13 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.2-1
369 - Use exactly specified
in config socket family
370 - Obsolete srw by ellipitcs
371 - Revert "Use X bits from operation key to find a lock instead of random hashing"
372 - Added proper sigchild handling
373 - spec update
- added libsrw.so
* files
374 - Dropped srw dependancy
376 * Sun Mar
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.1-1
379 * Wed Feb
29 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.12.0.1-1
380 - Depend on
0.15 eblob
: added new defragmentation parameters into config
381 - Propagate prepare_write
() and friends
return values back to callers
- changed API
383 * Sun Feb
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.7-1
384 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
385 - Updated python scripts to use new eblob class
386 - exec is reserved name
in python
, use exec_script
for execution method name
388 * Thu Feb
16 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.6-1
389 - Added possibility to
read metadata from file and dump to log
390 - Added remove_keys_from_storage_found_removed_in_eblob.py
391 - Added
local merge iterator written
in python. Is not optimal
, but quite fast.
393 * Tue Feb
14 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.5-1
394 - Execute CHECK commands with NOLOCK flag
396 * Sat Feb
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.4-1
397 - Use correct eblob path
for statvfs
() request
399 * Mon Feb
8 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.3-1
400 - Set id.
type to
0 where appropriate
401 - Request statistics with DNET_ATTR_NOLOCK flag
set
402 - Fixed pohmelfs_rename.py
404 * Mon Feb
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.2-1
405 - Process checksum flags according to aflags and ioflags
407 * Wed Feb
1 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.1-1
408 - Added start
/num parameters to iterate over selected number of blobs.
409 - Depend on
0.14.1 blob and higher where it is implemented.
411 * Thu Jan
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.15-1
412 - Added readdir script
413 - Dropped content length manipulation from srw
/pohmelfs_inode_info_insert.py
414 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
416 * Tue Jan
24 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.14-1
417 - Reserve some space
for directory content
418 - Added pohmelfs_read_latest_groups.py script
419 - Implemented prepare
-latest helper
, which returns timestamp sorted groups which contain requested id
420 - If we have more data to send
, set only DNET_FLAGS_MORE flag
, not erase others
421 - Rename cpp bindings
422 - Fixed range requests without limits
424 * Tue Jan
17 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.13-1
425 - Sort keys on server side
in range requests
426 - Disable eblob_gen
for now
427 - Address new binutils issues
(gcc
4.6 compilation fixes
)
429 * Wed Dec
21 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.12-1
430 - Trying to address new binutils issues
431 - Fill with zeroes all io threads structures
432 - Set io.num to content size
+offset
in write_data_wait
() - it allows to use prepare
/commit flags
434 * Tue Dec
20 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.11-1
435 - Implemented check
for start
/stop update timestamp
436 - Added cache tests
in test.cpp
438 * Thu Dec
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.10-1
439 - Added configurable two
-queue cache
for read data by Anton Kortunov
<toshic.toshic@gmail.com
>
441 * Mon Dec
12 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.9-1
442 - Reopen log file on sighup
444 * Fri Dec
9 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.8-1
445 - Set DNET_FLAGS_NOLOCK
for route
/reverse lookup request
/reply commands
446 - Added memory_test_pohmelfs
() autotest
447 - Added gc calls into pohmelfs methods
448 - Fixed exception string generation
for null ids
449 - Added small memory
/leak
test
451 * Fri Dec
2 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.7-1
452 - Use eblob_read_nocsum
() if DNET_IO_FLAGS_NOCSUM is
set
454 * Thu Dec
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.6-1
455 - Cleanup unused variables
456 - Fixed reply cmd
->flags initialization
457 - Use boost
::filesystem v2
458 - Fixes
in bulk_read and bulk_write
460 * Mon Nov
28 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.5-1
461 - Implemented pool of non
-blocking threads
for recursive commands.
462 - Dropped metadata csum support
in favour of eblob embedded checksums.
463 - Added bulk_write operation.
464 - Added sstable parser into python module
466 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.4-1
467 - Added nolocking IO thread
469 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.3-1
470 - Added oplock_num config parameter
471 - Added non
-blocking thread checks
473 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.2-1
474 - Aflags
/lock cleanups
476 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.1-1
477 - Added operations locks. Now all commands are processed with single
-machine
-atomicity
478 - Added server
-side scripts
480 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.13-1
481 - Only perform blob write
if io
->size is not zero
483 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.12-1
484 - Initialize srw after node
486 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.11-1
487 - Do not chroot into
history environment
, since it is most likely incomplete
489 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.10-1
490 - Do not csum
read when DNET_IO_FLAGS_NOCSUM ioflag is
set
491 - When doing partial
read, checksum whole file
493 * Sat Nov
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.9-1
495 - Return
-ENOTSUP
if srw is not initialized
496 - Do not reset join state to RECONNECT after it has been created
497 - Added stall_count as a configurable parameter
498 - Added BULK_READ
command
500 * Tue Nov
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.8-1
501 - Fixed range counters
502 - Added
::remove
() methods into python binding
503 - Remove all types
if -1 as id
->type is specified
504 - RHEL build must depend on eblob
-devel
>= 0.12.18 libsrw
-devel
>= 0.2.2
506 * Mon Nov
14 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.7-1
507 - Moved some objects from interface.h to packet.h
508 - Added range counters
509 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
510 - Use IP_TOS instead of SO_PRIORITY to
set tos bits
511 - srw is called libsrw
in rhel builds
512 - Depend on
0.12.18 eblob and
0.2.2 srw
514 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.6-1
515 - Depend on
0.2.1 srw and higher
517 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.5-1
518 - Added binary data support
in srw
520 * Tue Nov
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.4-1
521 - Do not fail node initialization
if srw is not initialized
523 * Mon Oct
31 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.3-1
524 - blob_send modified to send all columns
if id.
type == -1
525 - Do not depend elliptics build on libssl
526 - eblob
/srw autoconf updates
527 - Do not
return 1 from blob_write when data was compressed
, return 0, since
530 * Tue Oct
25 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.2-1
531 - Added srw dependency
532 - Do not call dnet_convert_io_attr
for DNET_CMD_DEL
command
534 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.1-1
535 - Decreased WRITE latency
536 - Use CORK
for write blocks
538 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.0-1
539 - Added ioprio call inside check
540 - More example ioserv.conf comments
541 - Added client
/server network priorities
(man
7 socket
-> IP_PRIORITY
)
543 * Sat Oct
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.9-1
544 - Fixed memory allocation
in range
-delete
546 * Tue Oct
11 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.7-1
547 - Only
set BLOB_DISK_CTL_NOCSUM
if DNET_IO_FLAGS_NOCSUM is
set
548 - Added dnet_get_routes
function
549 - Added server
-side scripting support
550 - Example ioserv.conf update
553 * Thu Dec
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.2-1
554 - Implemented multiple
read in elliptics core and FCGI frontend.
555 - Implemented very user
-friendly C
++/Python interface.
556 - Extended FCGI xml output
for POST request
: added data crc
, size
,
557 per
-group addresses and path to the destination object on file backend.
559 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.1-1
560 - Documentation update.
562 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.8-1
563 - Fixed fcgi reading with new groups URI.
565 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.7-1
566 - Implemented automatic groups selection by free space.
569 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.6-1
570 - Fixed eblob_send
().
571 - Use
50 check threads.
573 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.5-1
574 - Multi
-threaded fsck.
575 - Bug fixes
(including
2.9.4.4 version
).
577 * Thu Nov
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.3-1
578 - Implemented bdb fsck
(both merge and copy check
).
580 * Thu Nov
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.2-1
581 - Switched to random ids
(1024 ids are generated at first start
)
583 * Fri Nov
19 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.1-1
584 - Switched to new addressing model
586 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.14-1
587 - Remove direct object
if it can not be uploaded to the storage.
589 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.13-1
590 - Remove empty
/broken
history objects during merge.
592 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.12-1
593 - Added more debug about processed objects
in fsck tools.
594 - Delete directly
read object
if its
history can not be mapped.
595 - Return error from dnet_merge_direct
() when merge falls back to direct
596 merge during common merge.
598 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.11-1
599 - Attempt to
do direct merge when we can not parse non
-direct
history stored
in main storage.
601 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.10-1
602 - Fixed bit directory generation
in file_backend_get_dir_bits
()
604 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.9-1
605 - Fixed state leak
in lookup processing.
607 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.8-1
608 - Always use
local address
for succeeded
local lookup.
610 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.7-1
611 - Kill state when check thread got error.
(7)
612 - Extended fire
time debug.
(6)
614 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.5-1
615 - Update transaction fire
time to include check timeout.
617 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.4-1
618 - Extend dnet_send_read_data
() to get offset from parameters and
do not abuse dnet_io_attr structure.
620 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.3-1
621 - Unmap
history after selecting transaction with the last update
time in dnet_merge_get_latest_transactions
()
623 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
624 - Added full object ID dump and request error.
625 - Exit merge early
if no id file was provided.
626 - Do not dereference state
in dnet_read_complete
() if it is NULL.
627 - Added
-N
(do not request ids and use prevously downloaded
) option comment into fsck
help.
629 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
630 - Extended alloc
/free debug.
631 - Allow zero
-sized writes.
633 * Wed Oct
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3-1
634 - New minor release. No changes from
2.9.2.32.
636 * Mon Oct
11 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.32-1
637 - Added configurable value to check header
for remote node IP address.
638 - Added joining client check
: returned address must be reachable to be
639 inserted into route table.
641 * Fri Oct
8 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.31-1
644 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.29-1
645 - Added id
-by
-LA generation and sorting.
648 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.28-1
649 - Added timed statistics request which also works as timed connection checker.
650 - Added seconds
-only check
time wait.
652 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.27-1
653 - Added keep
-alive options.
655 * Mon Oct
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.26-1
656 - Unlink transaction and
history after direct merge.
657 - Do not log error when state is NULL
in completion callback.
659 * Sat Oct
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.25-1
660 - Added norequest flag to fsck util
(will use existing file
).
661 - Fixed remotes processing typo.
663 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.24-1
664 - Do not traverse the whole transaction tree after we found the
665 first one which fire
time has not yet elapsed.
667 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.23-1
668 - Remove io_thread_num and max_pending config parameters.
669 - Added stack size parameter to check tools.
671 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.22-1
672 - Moved transaction debug output into the place where it can not dereference stale data.
673 - Decrease debug level
for allocations.
674 - Added addrinfo null check. Should be useless though.
676 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.21-1
677 - Do not dereference null state
in dnet_fcgi_read_complete.
679 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.20-1
680 - Added thread stack size parameter.
681 - Added malloc mmap threshold config parameter.
(19)
683 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.18-1
684 - Really fixed recv state transaction processing leak.
686 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.16-1
687 -Do not try to dereferece null state. Happens when transaction is completed
689 - Use lineary
(+60 seconds each turn
) growing reconnection timeout. Added
690 reconnection limit of
1 day.
691 - Fixed recv state transaction processing leak.
693 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.15-1
694 - Compilation typo fixed.
696 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.14-1
697 - Fill all allocated memory with zeroes.
699 * Thu Sep
16 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.13-1
700 - Put transaction after it was executed. Its refcnt was increased during
702 - Do not try to dereference state when it can be null.
703 - Do not create unneded listening state when node does not join network.
(12)
704 - Reset accept state on error.
705 - Do not join to states
in state lists
, since they can be freed
in own
707 - Drop transaction resending support.
(10)
708 - Extended
local command processing log.
(9)
709 - Also print pid
in common logger.
(8)
710 - Use pthread_self
() instead of getpid
() to get uniq thread id.
(7)
712 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.6-1
713 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was
set for read command, do not
714 send data reply. Used
in local stat
command.
716 - From previous releases
:
717 Do not deal with NULL transactions.
718 Start state IO thread after state initialization.
719 Join to io state thread instead of freeing it directly.
720 Do not
exit from accept loop on error.
721 Initialize state list entry prior other usage.
723 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2-1
724 - Switched from libevent state machine to thread
-per
-client model.
726 * Fri Aug
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1.1-1
727 - Added DNET_FCGI_PUT_REGION config option to optionally
enable region tag
728 - Added wildcard direct download pattern
(*)
729 - Force direct download patterns to be checked against ID ending and
730 just by having this substring somewhere
in the query.
732 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1-1
733 - New elliptics network release
: 2.9.1
735 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.31-1
737 - Fixed resend locking bug.
739 * Mon Aug
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.30-1
740 - Fixed lock
/unlock typo
in dnet_data_ready
().
742 * Sat Aug
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.29-1
743 - Refactor fcgi logging
(29)
744 - Return
read error when key was not found. Use right config file options.
(28)
746 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.27-1
747 - Added sanity checks
for embedded reading.
749 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.26-1
750 - Disabled per
-client statistics request
in fcgi daemon.
751 - Added subtle timeout and data rewrite when FCGX_PutStr
() returns error.
753 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.25-1
754 - Copy resolved address into buffer
(later used
for reconnection
)
755 before trying to connect.
757 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.24-1
758 - Refactor fcgi
/check loggers to write pid
/thread id into single log file.
760 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.23-1
761 - Added
<region
> tag into download
-info XML output
762 - Changed sending locking.
764 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.22-1
765 - Guard multiple 'logical' xml writes against parallel write
767 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.21-1
768 - Implemented direct transaction merge.
769 - If reading size was
set to
0 map ~
0ULL size
, i.e. the whole file.
770 - Remove object from the storage
if its
history log says so.
771 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
772 DNET_FCGI_EMBED_PATTERN option.
774 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.20-1
775 - Fixed several fd leaks.
777 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.19-1
778 - Unmap
history file when failed to
read transaction.
780 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.18-1
781 - Guard OpenSSL_add_all_digests
() and initialize it only once per thread
783 - Force dnet_check_process_request
() to
wait for all sent transactions
, do
784 not wakeup after receiving reply from the first one.
786 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.17-1
787 - Fixed compilation warnings on
64bit platform
(uint64_t to unsigned long
788 long and void
* to unsigned long
)
789 - Try only requested transformation
function, do not
continue with the next
791 - Use errno to differentiate reconnection state.
793 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.15-1
794 - Made elliptics depend on eblob
795 - Updated checker's logger.
796 - Increase example
/check
/common.c waiting timeout.
797 - Added logs into file io backend listing processor.
799 * Sun Jul
26 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.12-1
800 - Let check applications to sleep longer waiting
for replies.
801 - Reduce number of ids sent via DNET_CMD_LIST
command to
1024 per reply.
802 - Mark states added via dnet_add_state
() as reconnect
-friendly.
803 - Do not add reconnection addresses which
do not have joining flags.
804 - Updated to the latest eblob lib
(moved blob code outside to libeblob
).
805 - Reschedule transaction's fire
time when
(non
-last
) reply is received.
806 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
808 * Sun Jul
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.11-1
809 - Added embedded URI parameter
, which will force timestamp to be embedded
810 with data. It is possible to embed other parameters too.
812 post
: wget
-O
/tmp
/1111 -S
--post
-file
=elliptics.spec
813 "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
×tamp
=123"
815 get
: wget
-O
/tmp
/1111 -S
--header
="If
-Modified
-Since
: Thu
, 01 Jan
1970
816 00:02:00 GMT" "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
&direct
=1"
817 - fixed random
hash selection
in fcgi frontend.
819 * Fri Jul
23 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.10-1
820 -return back addressing magic^W logic
in dnet_write_object_raw
()
822 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.9-1
823 - return back virtual datacenters.
825 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.8-1
826 - BLOB IO backend updates
(multiple threads
, index
, bug fixes
).
827 - file IO backend fixes
831 * Mon Jul
19 2010 Arkady L. Shane
<ashejn@yandex
-team.ru
> - 2.9.0.7-1
832 - initial build
for Fedora