Added temoporary debug
[elliptics.git] / elliptics-bf.spec
blob73e1a57f8b9b2ea0c629895a8cc16909ff2674fd
1 Summary: Distributed hash table storage
2 Name: elliptics
3 Version: 2.19.2.3
4 Release: 1%{?dist}
6 License: GPLv2+
7 Group: System Environment/Libraries
8 URL: http://www.ioremap.net/projects/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 %if 0%{?rhel} < 6
13 BuildRequires: python26-devel, boost141-python, boost141-devel
14 BuildRequires: boost141-iostreams, boost141-thread, boost141-python, boost141-system
15 %else
16 BuildRequires: python-devel, boost-python, boost-devel, boost-iostreams, boost-thread, boost-python, boost-system
17 %endif
18 BuildRequires: eblob-devel >= 0.17.1
19 BuildRequires: smack >= 0.5.0
20 BuildRequires: leveldb-devel
21 BuildRequires: cmake
23 Obsoletes: srw
25 %description
26 Elliptics network is a fault tolerant distributed hash table
27 object storage.
30 %package devel
31 Summary: Development files for %{name}
32 Group: Development/Libraries
33 Requires: %{name} = %{version}-%{release}
36 %description devel
37 Elliptics network is a fault tolerant distributed hash table
38 object storage.
40 This package contains libraries, header files and developer documentation
41 needed for developing software which uses the cairo graphics library.
43 %package python
44 Summary: Elliptics library Python binding
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
48 %description python
49 Elliptics Python Language bindings.
52 %package python-devel
53 Summary: Elliptics library Python binding
54 Group: Development/Libraries
55 Requires: elliptics-python = %{version}-%{release}
58 %description python-devel
59 Elliptics Python Language bindings development headers and libraries.
62 %package c++
63 Summary: Elliptics library C++ binding
64 Group: Development/Libraries
65 Requires: elliptics = %{version}-%{release}
68 %description c++
69 Elliptics library C++ language binding.
72 %package c++-devel
73 Summary: Elliptics library C++ binding development headers and libraries
74 Group: Development/Libraries
75 Requires: elliptics-devel = %{version}-%{release}
76 Requires: elliptics-c++ = %{version}-%{release}
79 %description c++-devel
80 Elliptics library C++ binding development headers and libraries
81 for building C++ applications with elliptics.
83 %prep
84 %setup -q
86 %build
87 export LDFLAGS="-Wl,-z,defs"
88 export DESTDIR="%{buildroot}"
89 %if 0%{?rhel} < 6
90 export PYTHON=/usr/bin/python26
91 CXXFLAGS="-pthread -I/usr/include/boost141" LDFLAGS="-L/usr/lib64/boost141" %{cmake} -DBoost_DIR=/usr/lib64/boost141 .
92 %else
93 %{cmake} .
94 %endif
95 make %{?_smp_mflags}
97 %install
98 rm -rf %{buildroot}
99 make install DESTDIR=%{buildroot}
100 rm -f %{buildroot}%{_libdir}/*.a
101 rm -f %{buildroot}%{_libdir}/*.la
103 %post -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
106 %post python -p /sbin/ldconfig
107 %postun python -p /sbin/ldconfig
109 %post c++ -p /sbin/ldconfig
110 %postun c++ -p /sbin/ldconfig
112 %clean
113 rm -rf %{buildroot}
115 %files
116 %defattr(-,root,root,-)
117 %doc README doc/design_notes.txt doc/io_storage_backend.txt
118 %{_bindir}/*
119 %{_libdir}/libelliptics.so.*
120 %{_libdir}/libelliptics_client.so.*
121 %{_libdir}/libelliptics_cocaine.so.*
122 %{_libdir}/libelliptics_cache.so.*
125 %files devel
126 %defattr(-,root,root,-)
127 %{_includedir}/*
128 %{_libdir}/libelliptics.so
129 %{_libdir}/libelliptics_client.so
130 %{_libdir}/libelliptics_cocaine.so
131 %{_libdir}/libelliptics_cache.so
133 %files python
134 %defattr(-,root,root,-)
135 %{_libdir}/libelliptics_python.so.*
136 %{python_sitelib}/elliptics*
139 %files python-devel
140 %defattr(-,root,root,-)
141 %{_libdir}/libelliptics_python.so
144 %files c++
145 %defattr(-,root,root,-)
146 %{_libdir}/libelliptics_cpp.so.*
149 %files c++-devel
150 %defattr(-,root,root,-)
151 %{_libdir}/libelliptics_cpp.so
154 %changelog
155 * Tue Nov 06 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.3
156 - Only enlarge non-blocking pool when there is blocking sph in the pool.
158 * Fri Nov 02 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.2
159 - Fixed python installation in Lucid
160 - Remove signal setup in library. Do not block signals on ioserv exit
161 - Only write error message when real error occurs in leveldb_backend_read()
163 * Fri Oct 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.1
164 - Fixed precise build
166 * Fri Oct 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.2.0
167 - When creating new state we should not send auth/join commands to itself
168 - Return back periodic route table check
169 - Added LevelDB backend
171 * Thu Oct 25 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.1.0
172 - Depend elliptics-dev on elliptics with (>= ${Source-Version}) version
173 - Do not check for n->st when setting up new server node
174 - When it is called from dnet_server_node_create()->dnet_state_create()
175 - there is no n->st, and that's exactly the path where server
177 * Fri Oct 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.0.1
178 - Use autogenerated major/minor elliptics versions. Whole version is being read from debian/changelog file
179 - Fix CMake file with missing boost libraries
180 - Bump ABI version (missed from 2.18->2.19 upgrade)
181 - Drop site-packages from elliptics-client
182 - Depend on >= 0.9.4 cocaine
184 * Wed Oct 10 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.19.0.0
185 - Added sessions - this allows to configure and set per-request parameters (like groups)
187 * Wed Oct 10 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.2
188 - Fixed reply size calculation
189 - Unify srw log rules
190 - Fixed pool growing policy
191 - Updated debian package rules
193 * Mon Oct 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.1
194 - When running recovery-on-read do not write io attribute header
196 * Mon Oct 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.0
197 - Grow IO pools on demand
198 - Added automatic recovery on read command:
199 - if object didn't exist in previously read group,
200 - it will be written when read from the next group succeed
201 - Documentation update
202 - Added multicast autodiscovery
203 - If state is already exist, do not fail with error
204 - Fixed the ugliest debian python installation
205 - Added new python bindings
206 - Do not try to run command if srw was not initialized
207 - Populate cache on READ command when DNET_IO_FLAGS_CACHE ioflag is set
209 * Thu Sep 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.2.1
210 - Added c++/python bindings for cache write operations (including timeout)
211 - Added remove-from-disk cache operation: when such flag is set (at write time)"
212 - if object is removed from cache, it is also removed from disk
213 - Increase example number of non-blocking io threads
214 - Added 'overwrite commits write' comment
216 * Mon Sep 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.2
217 - dnet_backend_log_raw() should use dnet_backend_check_log_level() to check log level
218 - Added startup stack size check
219 - Cocaine job has to be created only when it can be queued
221 * Fri Sep 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.1
222 - Update version num
224 * Thu Sep 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.0.1
225 - New interface for execution, reply and chaining
226 - Do not strip rpath
227 - Fixed server node cleanup bug when it destroyed locks first while IO threads could still use them
228 - dnet_send_cmd_raw() must always wait for ack
229 - Fixed thread creation bug in app_watcher when application does not exist
230 - Added -g flag to elliptics build
231 - Use weak symbols instead of stubs in client lib, since server also links to it and in Fedora it ends up using stubs from client lib
232 - Search for 0mq only of cocaine is enabled
233 - Update debian packaging
234 - Fixed build-depends
236 * Fri Aug 31 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.4
237 - elliptics-client must replace old-school elliptics-2.10
239 * Thu Aug 30 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.3
240 - Added python-support to dep list
241 - Use correct package name in shlibs
243 * Wed Aug 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.2
244 - Switch to cmake from autoconf
246 * Mon Aug 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.1
247 - Depend on eblob 0.17.1 and higher
248 - Use log level instead of log mask
249 - Depend on smack 0.5.0 and higher
250 - Added cdbs dep
251 - Added in-memory (optionally disk-backed) LRU cache
252 - Get rid of boost-filesystem
253 - Split code (and debian package) to client/server libs
254 - New unlink interfaces
255 - Added ioflags to ioclient
256 - If lookup returned error, proceed read-latest with default order
257 - Let DNET_CMD_DEL use dnet_io_attr structure too
259 * Wed Aug 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.16.0.1
260 - Added possibility to start defragmentation on demand
261 - Added reserved 'hostname' word for local address
262 - Added cleanup call into node destruction path, which fixes double free error in config error path
263 - Implemented blocking exec commands
264 - Refactor pools of workers
265 - Set cocaine log level based on elliptics log mask
266 - Completely created client library
267 - Fixed json example path
269 * Tue Jul 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.15.0.1
270 - Send correct answer in smack_write
271 - New bulk_read()
272 - New event string for application invocation
273 - Corrected changelog
274 - Depend on smack 0.4.0 and higher
276 * Mon Jul 02 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.4
277 - Log all client job errorrs into app/.log file in elliptics
278 - Set nocsum flags in io-attr when it is set in global node's config
280 * Wed Jun 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.3-1
281 - Depend on smack 0.3.0 and higher
283 * Tue Jun 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.2-1
284 - Use smack_total_elements() to get number of records
286 * Mon Jun 25 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.1-1
287 - Disable signals in library and enable in server and ioclient
288 - Added cocaine library documentation
289 - Added smack configuration
290 - Sync with upstream smack repo
292 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.7-1
293 - Fixed typo in smack config parser
295 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.6-1
296 - Sink srw log into app + ".log" object in elliptics
298 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.5-1
299 - Added SMACK backend depends
301 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.4-1
302 - Drop cocaine plugin dependencies
304 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.3-1
305 - Added new cocaine debian package deps
306 - Drop cocaine deps in RHEL/Fedora build
308 * Thu Jun 21 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.2-1
309 - Build srw fix (use weak symbol for dnet_log_raw())
310 - Added new eblob bit to config documentation, drop unused parameters
311 - Fixed write response generation
313 * Fri Jun 15 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.1-1
314 - Use cocaine workers for server-side
315 - Drop dnet_attr structure
316 - Optimize read (do not send ack if there is data)
317 - Use ioremap::elliptics namespace
318 - Added ::push() - nonblocking exec
320 * Sun Apr 28 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.9-1
321 - Do not allow zero-sized reads
322 - Do not double-close python init file
324 * Sat Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.8-1
325 - Added new lookup() methods to c++/python bindings. Patch by Anton Kortunov <toshik@yandex-team.ru>
326 - If we fail to open log file, dup2() stdout/stderr to /dev/null in spawned worker process
328 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.7-1
329 - More mess with 012 file descriptors - dup them to /dev/null when going background, reopen to log file in srw worker
330 - Use correct F_SETFD/FD_CLOEXEC
331 - Use old-school fcntl() instead of accept4() and epoll_create1()
332 - Allow script execution without cmd-line
334 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.6-1
335 - Added srw config options
336 - Added O_CLOEXEC flags
337 - Added new configs (for nginx and fastcgi frontend) and python example
338 - Return sub data from smack_write() call - this is needed for fastcgi frontend
339 - Let dnet_ioclient write file by ID
340 - Added smack backend wrapper
342 * Fri Apr 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.5-1
343 - Build dependencies update
344 - Do not write metadata when appropirate bit is set in node->flags
345 - Update documentation about blob flags
347 * Fri Mar 23 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.4-1
348 - Updated state mixing algorithm
349 - Added defrag_timeout, defrag_percentage and blob_size options to file backend
351 * Mon Mar 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.3-1
352 - Allow ioclient to read/write data in different columns
353 - Hardlink script should overwrite data
354 - Fixed file read/write with different column
355 - Use correct pipe path, which includes pid
356 - Use correct structure size for dentries and extended logging
357 - Do not set name for main process
359 * Sun Mar 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.2-1
360 - Use exactly specified in config socket family
361 - Obsolete srw by ellipitcs
362 - Revert "Use X bits from operation key to find a lock instead of random hashing"
363 - Added proper sigchild handling
364 - spec update - added libsrw.so* files
365 - Dropped srw dependancy
367 * Sun Mar 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.1-1
368 - Added srw
370 * Wed Feb 29 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.12.0.1-1
371 - Depend on 0.15 eblob: added new defragmentation parameters into config
372 - Propagate prepare_write() and friends return values back to callers - changed API
374 * Sun Feb 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.7-1
375 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
376 - Updated python scripts to use new eblob class
377 - exec is reserved name in python, use exec_script for execution method name
379 * Thu Feb 16 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.6-1
380 - Added possibility to read metadata from file and dump to log
381 - Added remove_keys_from_storage_found_removed_in_eblob.py
382 - Added local merge iterator written in python. Is not optimal, but quite fast.
384 * Tue Feb 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.5-1
385 - Execute CHECK commands with NOLOCK flag
387 * Sat Feb 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.4-1
388 - Use correct eblob path for statvfs() request
390 * Mon Feb 8 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.3-1
391 - Set id.type to 0 where appropriate
392 - Request statistics with DNET_ATTR_NOLOCK flag set
393 - Fixed pohmelfs_rename.py
395 * Mon Feb 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.2-1
396 - Process checksum flags according to aflags and ioflags
398 * Wed Feb 1 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.1-1
399 - Added start/num parameters to iterate over selected number of blobs.
400 - Depend on 0.14.1 blob and higher where it is implemented.
402 * Thu Jan 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.15-1
403 - Added readdir script
404 - Dropped content length manipulation from srw/pohmelfs_inode_info_insert.py
405 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
407 * Tue Jan 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.14-1
408 - Reserve some space for directory content
409 - Added pohmelfs_read_latest_groups.py script
410 - Implemented prepare-latest helper, which returns timestamp sorted groups which contain requested id
411 - If we have more data to send, set only DNET_FLAGS_MORE flag, not erase others
412 - Rename cpp bindings
413 - Fixed range requests without limits
415 * Tue Jan 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.13-1
416 - Sort keys on server side in range requests
417 - Disable eblob_gen for now
418 - Address new binutils issues (gcc 4.6 compilation fixes)
420 * Wed Dec 21 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.12-1
421 - Trying to address new binutils issues
422 - Fill with zeroes all io threads structures
423 - Set io.num to content size+offset in write_data_wait() - it allows to use prepare/commit flags
425 * Tue Dec 20 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.11-1
426 - Implemented check for start/stop update timestamp
427 - Added cache tests in test.cpp
429 * Thu Dec 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.10-1
430 - Added configurable two-queue cache for read data by Anton Kortunov <toshic.toshic@gmail.com>
432 * Mon Dec 12 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.9-1
433 - Reopen log file on sighup
435 * Fri Dec 9 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.8-1
436 - Set DNET_FLAGS_NOLOCK for route/reverse lookup request/reply commands
437 - Added memory_test_pohmelfs() autotest
438 - Added gc calls into pohmelfs methods
439 - Fixed exception string generation for null ids
440 - Added small memory/leak test
442 * Fri Dec 2 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.7-1
443 - Use eblob_read_nocsum() if DNET_IO_FLAGS_NOCSUM is set
445 * Thu Dec 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.6-1
446 - Cleanup unused variables
447 - Fixed reply cmd->flags initialization
448 - Use boost::filesystem v2
449 - Fixes in bulk_read and bulk_write
451 * Mon Nov 28 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.5-1
452 - Implemented pool of non-blocking threads for recursive commands.
453 - Dropped metadata csum support in favour of eblob embedded checksums.
454 - Added bulk_write operation.
455 - Added sstable parser into python module
457 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.4-1
458 - Added nolocking IO thread
460 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.3-1
461 - Added oplock_num config parameter
462 - Added non-blocking thread checks
464 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.2-1
465 - Aflags/lock cleanups
467 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.1-1
468 - Added operations locks. Now all commands are processed with single-machine-atomicity
469 - Added server-side scripts
471 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.13-1
472 - Only perform blob write if io->size is not zero
474 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.12-1
475 - Initialize srw after node
477 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.11-1
478 - Do not chroot into history environment, since it is most likely incomplete
480 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.10-1
481 - Do not csum read when DNET_IO_FLAGS_NOCSUM ioflag is set
482 - When doing partial read, checksum whole file
484 * Sat Nov 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.9-1
485 - cpp tests update
486 - Return -ENOTSUP if srw is not initialized
487 - Do not reset join state to RECONNECT after it has been created
488 - Added stall_count as a configurable parameter
489 - Added BULK_READ command
491 * Tue Nov 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.8-1
492 - Fixed range counters
493 - Added ::remove() methods into python binding
494 - Remove all types if -1 as id->type is specified
495 - RHEL build must depend on eblob-devel >= 0.12.18 libsrw-devel >= 0.2.2
497 * Mon Nov 14 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.7-1
498 - Moved some objects from interface.h to packet.h
499 - Added range counters
500 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
501 - Use IP_TOS instead of SO_PRIORITY to set tos bits
502 - srw is called libsrw in rhel builds
503 - Depend on 0.12.18 eblob and 0.2.2 srw
505 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.6-1
506 - Depend on 0.2.1 srw and higher
508 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.5-1
509 - Added binary data support in srw
511 * Tue Nov 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.4-1
512 - Do not fail node initialization if srw is not initialized
514 * Mon Oct 31 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.3-1
515 - blob_send modified to send all columns if id.type == -1
516 - Do not depend elliptics build on libssl
517 - eblob/srw autoconf updates
518 - Do not return 1 from blob_write when data was compressed, return 0, since
519 there was no error
521 * Tue Oct 25 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.2-1
522 - Added srw dependency
523 - Do not call dnet_convert_io_attr for DNET_CMD_DEL command
525 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.1-1
526 - Decreased WRITE latency
527 - Use CORK for write blocks
529 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.0-1
530 - Added ioprio call inside check
531 - More example ioserv.conf comments
532 - Added client/server network priorities (man 7 socket -> IP_PRIORITY)
534 * Sat Oct 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.9-1
535 - Fixed memory allocation in range-delete
537 * Tue Oct 11 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.7-1
538 - Only set BLOB_DISK_CTL_NOCSUM if DNET_IO_FLAGS_NOCSUM is set
539 - Added dnet_get_routes function
540 - Added server-side scripting support
541 - Example ioserv.conf update
542 - Spec update
544 * Thu Dec 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.2-1
545 - Implemented multiple read in elliptics core and FCGI frontend.
546 - Implemented very user-friendly C++/Python interface.
547 - Extended FCGI xml output for POST request: added data crc, size,
548 per-group addresses and path to the destination object on file backend.
550 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.1-1
551 - Documentation update.
553 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.8-1
554 - Fixed fcgi reading with new groups URI.
556 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.7-1
557 - Implemented automatic groups selection by free space.
558 - Bug fixes.
560 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.6-1
561 - Fixed eblob_send().
562 - Use 50 check threads.
564 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.5-1
565 - Multi-threaded fsck.
566 - Bug fixes (including 2.9.4.4 version).
568 * Thu Nov 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.3-1
569 - Implemented bdb fsck (both merge and copy check).
571 * Thu Nov 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.2-1
572 - Switched to random ids (1024 ids are generated at first start)
574 * Fri Nov 19 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.1-1
575 - Switched to new addressing model
577 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.14-1
578 - Remove direct object if it can not be uploaded to the storage.
580 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.13-1
581 - Remove empty/broken history objects during merge.
583 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.12-1
584 - Added more debug about processed objects in fsck tools.
585 - Delete directly read object if its history can not be mapped.
586 - Return error from dnet_merge_direct() when merge falls back to direct
587 merge during common merge.
589 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.11-1
590 - Attempt to do direct merge when we can not parse non-direct history stored in main storage.
592 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.10-1
593 - Fixed bit directory generation in file_backend_get_dir_bits()
595 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.9-1
596 - Fixed state leak in lookup processing.
598 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.8-1
599 - Always use local address for succeeded local lookup.
601 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.7-1
602 - Kill state when check thread got error. (7)
603 - Extended fire time debug. (6)
605 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.5-1
606 - Update transaction fire time to include check timeout.
608 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.4-1
609 - Extend dnet_send_read_data() to get offset from parameters and do not abuse dnet_io_attr structure.
611 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.3-1
612 - Unmap history after selecting transaction with the last update time in dnet_merge_get_latest_transactions()
614 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
615 - Added full object ID dump and request error.
616 - Exit merge early if no id file was provided.
617 - Do not dereference state in dnet_read_complete() if it is NULL.
618 - Added -N (do not request ids and use prevously downloaded) option comment into fsck help.
620 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
621 - Extended alloc/free debug.
622 - Allow zero-sized writes.
624 * Wed Oct 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3-1
625 - New minor release. No changes from 2.9.2.32.
627 * Mon Oct 11 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.32-1
628 - Added configurable value to check header for remote node IP address.
629 - Added joining client check: returned address must be reachable to be
630 inserted into route table.
632 * Fri Oct 8 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.31-1
633 - Fixed LA sorting.
635 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.29-1
636 - Added id-by-LA generation and sorting.
637 - Debug cleanups.
639 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.28-1
640 - Added timed statistics request which also works as timed connection checker.
641 - Added seconds-only check time wait.
643 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.27-1
644 - Added keep-alive options.
646 * Mon Oct 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.26-1
647 - Unlink transaction and history after direct merge.
648 - Do not log error when state is NULL in completion callback.
650 * Sat Oct 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.25-1
651 - Added norequest flag to fsck util (will use existing file).
652 - Fixed remotes processing typo.
654 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.24-1
655 - Do not traverse the whole transaction tree after we found the
656 first one which fire time has not yet elapsed.
658 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.23-1
659 - Remove io_thread_num and max_pending config parameters.
660 - Added stack size parameter to check tools.
662 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.22-1
663 - Moved transaction debug output into the place where it can not dereference stale data.
664 - Decrease debug level for allocations.
665 - Added addrinfo null check. Should be useless though.
667 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.21-1
668 - Do not dereference null state in dnet_fcgi_read_complete.
670 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.20-1
671 - Added thread stack size parameter.
672 - Added malloc mmap threshold config parameter. (19)
674 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.18-1
675 - Really fixed recv state transaction processing leak.
677 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.16-1
678 -Do not try to dereferece null state. Happens when transaction is completed
679 on timeout.
680 - Use lineary (+60 seconds each turn) growing reconnection timeout. Added
681 reconnection limit of 1 day.
682 - Fixed recv state transaction processing leak.
684 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.15-1
685 - Compilation typo fixed.
687 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.14-1
688 - Fill all allocated memory with zeroes.
690 * Thu Sep 16 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.13-1
691 - Put transaction after it was executed. Its refcnt was increased during
692 search call.
693 - Do not try to dereference state when it can be null.
694 - Do not create unneded listening state when node does not join network. (12)
695 - Reset accept state on error.
696 - Do not join to states in state lists, since they can be freed in own
697 threads. (11)
698 - Drop transaction resending support. (10)
699 - Extended local command processing log. (9)
700 - Also print pid in common logger. (8)
701 - Use pthread_self() instead of getpid() to get uniq thread id. (7)
703 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.6-1
704 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was set for read command, do not
705 send data reply. Used in local stat command.
706 - Debug cleanup.
707 - From previous releases:
708 Do not deal with NULL transactions.
709 Start state IO thread after state initialization.
710 Join to io state thread instead of freeing it directly.
711 Do not exit from accept loop on error.
712 Initialize state list entry prior other usage.
714 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2-1
715 - Switched from libevent state machine to thread-per-client model.
717 * Fri Aug 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1.1-1
718 - Added DNET_FCGI_PUT_REGION config option to optionally enable region tag
719 - Added wildcard direct download pattern (*)
720 - Force direct download patterns to be checked against ID ending and
721 just by having this substring somewhere in the query.
723 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1-1
724 - New elliptics network release: 2.9.1
726 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.31-1
727 - Logger cleanups.
728 - Fixed resend locking bug.
730 * Mon Aug 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.30-1
731 - Fixed lock/unlock typo in dnet_data_ready().
733 * Sat Aug 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.29-1
734 - Refactor fcgi logging (29)
735 - Return read error when key was not found. Use right config file options. (28)
737 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.27-1
738 - Added sanity checks for embedded reading.
740 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.26-1
741 - Disabled per-client statistics request in fcgi daemon.
742 - Added subtle timeout and data rewrite when FCGX_PutStr() returns error.
744 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.25-1
745 - Copy resolved address into buffer (later used for reconnection)
746 before trying to connect.
748 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.24-1
749 - Refactor fcgi/check loggers to write pid/thread id into single log file.
751 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.23-1
752 - Added <region> tag into download-info XML output
753 - Changed sending locking.
755 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.22-1
756 - Guard multiple 'logical' xml writes against parallel write
758 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.21-1
759 - Implemented direct transaction merge.
760 - If reading size was set to 0 map ~0ULL size, i.e. the whole file.
761 - Remove object from the storage if its history log says so.
762 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
763 DNET_FCGI_EMBED_PATTERN option.
765 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.20-1
766 - Fixed several fd leaks.
768 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.19-1
769 - Unmap history file when failed to read transaction.
771 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.18-1
772 - Guard OpenSSL_add_all_digests() and initialize it only once per thread
773 group.
774 - Force dnet_check_process_request() to wait for all sent transactions, do
775 not wakeup after receiving reply from the first one.
777 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.17-1
778 - Fixed compilation warnings on 64bit platform (uint64_t to unsigned long
779 long and void * to unsigned long)
780 - Try only requested transformation function, do not continue with the next
781 one.
782 - Use errno to differentiate reconnection state.
784 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.15-1
785 - Made elliptics depend on eblob
786 - Updated checker's logger.
787 - Increase example/check/common.c waiting timeout.
788 - Added logs into file io backend listing processor.
790 * Sun Jul 26 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.12-1
791 - Let check applications to sleep longer waiting for replies.
792 - Reduce number of ids sent via DNET_CMD_LIST command to 1024 per reply.
793 - Mark states added via dnet_add_state() as reconnect-friendly.
794 - Do not add reconnection addresses which do not have joining flags.
795 - Updated to the latest eblob lib (moved blob code outside to libeblob).
796 - Reschedule transaction's fire time when (non-last) reply is received.
797 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
799 * Sun Jul 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.11-1
800 - Added embedded URI parameter, which will force timestamp to be embedded
801 with data. It is possible to embed other parameters too.
803 post: wget -O /tmp/1111 -S --post-file=elliptics.spec
804 "http://devfs1/test.mp3?name=qwerty.xml&embed&timestamp=123"
806 get: wget -O /tmp/1111 -S --header="If-Modified-Since: Thu, 01 Jan 1970
807 00:02:00 GMT" "http://devfs1/test.mp3?name=qwerty.xml&embed&direct=1"
808 - fixed random hash selection in fcgi frontend.
810 * Fri Jul 23 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.10-1
811 -return back addressing magic^W logic in dnet_write_object_raw()
813 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.9-1
814 - return back virtual datacenters.
816 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.8-1
817 - BLOB IO backend updates (multiple threads, index, bug fixes).
818 - file IO backend fixes
819 - python bindings
820 - c++ binding fixes
822 * Mon Jul 19 2010 Arkady L. Shane <ashejn@yandex-team.ru> - 2.9.0.7-1
823 - initial build for Fedora