Merge pull request #4 from oktocat/master
[elliptics.git] / elliptics-bf.spec
blob1185f1f16aa191c55feb102ca0ac97042b9d227b
1 Summary: Distributed hash table storage
2 Name: elliptics
3 Version: 2.17.0.4
4 Release: 1%{?dist}
6 License: GPLv2+
7 Group: System Environment/Libraries
8 URL: http://www.ioremap.net/projects/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 %if 0%{?rhel} < 6
13 BuildRequires: python26-devel, boost141-python, boost141-devel
14 BuildRequires: boost141-iostreams, boost141-thread, boost141-python, boost141-system
15 %else
16 BuildRequires: python-devel, boost-python, boost-devel, boost-iostreams, boost-thread, boost-python, boost-system
17 %endif
18 BuildRequires: eblob-devel >= 0.17.1
19 BuildRequires: smack >= 0.5.0
20 BuildRequires: cmake
22 Obsoletes: srw
24 %description
25 Elliptics network is a fault tolerant distributed hash table
26 object storage.
29 %package devel
30 Summary: Development files for %{name}
31 Group: Development/Libraries
32 Requires: %{name} = %{version}-%{release}
35 %description devel
36 Elliptics network is a fault tolerant distributed hash table
37 object storage.
39 This package contains libraries, header files and developer documentation
40 needed for developing software which uses the cairo graphics library.
42 %package python
43 Summary: Elliptics library Python binding
44 Group: Development/Libraries
45 Requires: %{name} = %{version}-%{release}
47 %description python
48 Elliptics Python Language bindings.
51 %package python-devel
52 Summary: Elliptics library Python binding
53 Group: Development/Libraries
54 Requires: elliptics-python = %{version}-%{release}
57 %description python-devel
58 Elliptics Python Language bindings development headers and libraries.
61 %package c++
62 Summary: Elliptics library C++ binding
63 Group: Development/Libraries
64 Requires: elliptics = %{version}-%{release}
67 %description c++
68 Elliptics library C++ language binding.
71 %package c++-devel
72 Summary: Elliptics library C++ binding development headers and libraries
73 Group: Development/Libraries
74 Requires: elliptics-devel = %{version}-%{release}
75 Requires: elliptics-c++ = %{version}-%{release}
78 %description c++-devel
79 Elliptics library C++ binding development headers and libraries
80 for building C++ applications with elliptics.
82 %prep
83 %setup -q
85 %build
86 export LDFLAGS="-Wl,-z,defs"
87 export DESTDIR="%{buildroot}"
88 %if 0%{?rhel} < 6
89 export PYTHON=/usr/bin/python26
90 CXXFLAGS="-pthread -I/usr/include/boost141" LDFLAGS="-L/usr/lib64/boost141" %{cmake} -DBoost_DIR=/usr/lib64/boost141 .
91 %else
92 %{cmake} .
93 %endif
94 make %{?_smp_mflags}
96 %install
97 rm -rf %{buildroot}
98 make install DESTDIR=%{buildroot}
99 rm -f %{buildroot}%{_libdir}/*.a
100 rm -f %{buildroot}%{_libdir}/*.la
102 %post -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
105 %post python -p /sbin/ldconfig
106 %postun python -p /sbin/ldconfig
108 %post c++ -p /sbin/ldconfig
109 %postun c++ -p /sbin/ldconfig
111 %clean
112 rm -rf %{buildroot}
114 %files
115 %defattr(-,root,root,-)
116 %doc README doc/design_notes.txt doc/io_storage_backend.txt
117 %{_bindir}/*
118 %{_libdir}/libelliptics.so.*
119 %{_libdir}/libelliptics_client.so.*
120 %{_libdir}/libelliptics_cocaine.so.*
121 %{_libdir}/libelliptics_cache.so.*
124 %files devel
125 %defattr(-,root,root,-)
126 %{_includedir}/*
127 %{_libdir}/libelliptics.so
128 %{_libdir}/libelliptics_client.so
129 %{_libdir}/libelliptics_cocaine.so
130 %{_libdir}/libelliptics_cache.so
132 %files python
133 %defattr(-,root,root,-)
134 %{_libdir}/libelliptics_python.so.*
135 %{python_sitelib}/elliptics*
138 %files python-devel
139 %defattr(-,root,root,-)
140 %{_libdir}/libelliptics_python.so
143 %files c++
144 %defattr(-,root,root,-)
145 %{_libdir}/libelliptics_cpp.so.*
148 %files c++-devel
149 %defattr(-,root,root,-)
150 %{_libdir}/libelliptics_cpp.so
153 %changelog
154 * Fri Aug 31 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.4
155 - elliptics-client must replace old-school elliptics-2.10
157 * Thu Aug 30 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.3
158 - Added python-support to dep list
159 - Use correct package name in shlibs
161 * Wed Aug 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.2
162 - Switch to cmake from autoconf
164 * Mon Aug 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.1
165 - Depend on eblob 0.17.1 and higher
166 - Use log level instead of log mask
167 - Depend on smack 0.5.0 and higher
168 - Added cdbs dep
169 - Added in-memory (optionally disk-backed) LRU cache
170 - Get rid of boost-filesystem
171 - Split code (and debian package) to client/server libs
172 - New unlink interfaces
173 - Added ioflags to ioclient
174 - If lookup returned error, proceed read-latest with default order
175 - Let DNET_CMD_DEL use dnet_io_attr structure too
177 * Wed Aug 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.16.0.1
178 - Added possibility to start defragmentation on demand
179 - Added reserved 'hostname' word for local address
180 - Added cleanup call into node destruction path, which fixes double free error in config error path
181 - Implemented blocking exec commands
182 - Refactor pools of workers
183 - Set cocaine log level based on elliptics log mask
184 - Completely created client library
185 - Fixed json example path
187 * Tue Jul 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.15.0.1
188 - Send correct answer in smack_write
189 - New bulk_read()
190 - New event string for application invocation
191 - Corrected changelog
192 - Depend on smack 0.4.0 and higher
194 * Mon Jul 02 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.4
195 - Log all client job errorrs into app/.log file in elliptics
196 - Set nocsum flags in io-attr when it is set in global node's config
198 * Wed Jun 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.3-1
199 - Depend on smack 0.3.0 and higher
201 * Tue Jun 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.2-1
202 - Use smack_total_elements() to get number of records
204 * Mon Jun 25 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.1-1
205 - Disable signals in library and enable in server and ioclient
206 - Added cocaine library documentation
207 - Added smack configuration
208 - Sync with upstream smack repo
210 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.7-1
211 - Fixed typo in smack config parser
213 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.6-1
214 - Sink srw log into app + ".log" object in elliptics
216 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.5-1
217 - Added SMACK backend depends
219 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.4-1
220 - Drop cocaine plugin dependencies
222 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.3-1
223 - Added new cocaine debian package deps
224 - Drop cocaine deps in RHEL/Fedora build
226 * Thu Jun 21 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.2-1
227 - Build srw fix (use weak symbol for dnet_log_raw())
228 - Added new eblob bit to config documentation, drop unused parameters
229 - Fixed write response generation
231 * Fri Jun 15 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.1-1
232 - Use cocaine workers for server-side
233 - Drop dnet_attr structure
234 - Optimize read (do not send ack if there is data)
235 - Use ioremap::elliptics namespace
236 - Added ::push() - nonblocking exec
238 * Sun Apr 28 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.9-1
239 - Do not allow zero-sized reads
240 - Do not double-close python init file
242 * Sat Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.8-1
243 - Added new lookup() methods to c++/python bindings. Patch by Anton Kortunov <toshik@yandex-team.ru>
244 - If we fail to open log file, dup2() stdout/stderr to /dev/null in spawned worker process
246 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.7-1
247 - More mess with 012 file descriptors - dup them to /dev/null when going background, reopen to log file in srw worker
248 - Use correct F_SETFD/FD_CLOEXEC
249 - Use old-school fcntl() instead of accept4() and epoll_create1()
250 - Allow script execution without cmd-line
252 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.6-1
253 - Added srw config options
254 - Added O_CLOEXEC flags
255 - Added new configs (for nginx and fastcgi frontend) and python example
256 - Return sub data from smack_write() call - this is needed for fastcgi frontend
257 - Let dnet_ioclient write file by ID
258 - Added smack backend wrapper
260 * Fri Apr 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.5-1
261 - Build dependencies update
262 - Do not write metadata when appropirate bit is set in node->flags
263 - Update documentation about blob flags
265 * Fri Mar 23 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.4-1
266 - Updated state mixing algorithm
267 - Added defrag_timeout, defrag_percentage and blob_size options to file backend
269 * Mon Mar 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.3-1
270 - Allow ioclient to read/write data in different columns
271 - Hardlink script should overwrite data
272 - Fixed file read/write with different column
273 - Use correct pipe path, which includes pid
274 - Use correct structure size for dentries and extended logging
275 - Do not set name for main process
277 * Sun Mar 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.2-1
278 - Use exactly specified in config socket family
279 - Obsolete srw by ellipitcs
280 - Revert "Use X bits from operation key to find a lock instead of random hashing"
281 - Added proper sigchild handling
282 - spec update - added libsrw.so* files
283 - Dropped srw dependancy
285 * Sun Mar 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.1-1
286 - Added srw
288 * Wed Feb 29 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.12.0.1-1
289 - Depend on 0.15 eblob: added new defragmentation parameters into config
290 - Propagate prepare_write() and friends return values back to callers - changed API
292 * Sun Feb 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.7-1
293 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
294 - Updated python scripts to use new eblob class
295 - exec is reserved name in python, use exec_script for execution method name
297 * Thu Feb 16 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.6-1
298 - Added possibility to read metadata from file and dump to log
299 - Added remove_keys_from_storage_found_removed_in_eblob.py
300 - Added local merge iterator written in python. Is not optimal, but quite fast.
302 * Tue Feb 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.5-1
303 - Execute CHECK commands with NOLOCK flag
305 * Sat Feb 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.4-1
306 - Use correct eblob path for statvfs() request
308 * Mon Feb 8 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.3-1
309 - Set id.type to 0 where appropriate
310 - Request statistics with DNET_ATTR_NOLOCK flag set
311 - Fixed pohmelfs_rename.py
313 * Mon Feb 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.2-1
314 - Process checksum flags according to aflags and ioflags
316 * Wed Feb 1 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.1-1
317 - Added start/num parameters to iterate over selected number of blobs.
318 - Depend on 0.14.1 blob and higher where it is implemented.
320 * Thu Jan 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.15-1
321 - Added readdir script
322 - Dropped content length manipulation from srw/pohmelfs_inode_info_insert.py
323 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
325 * Tue Jan 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.14-1
326 - Reserve some space for directory content
327 - Added pohmelfs_read_latest_groups.py script
328 - Implemented prepare-latest helper, which returns timestamp sorted groups which contain requested id
329 - If we have more data to send, set only DNET_FLAGS_MORE flag, not erase others
330 - Rename cpp bindings
331 - Fixed range requests without limits
333 * Tue Jan 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.13-1
334 - Sort keys on server side in range requests
335 - Disable eblob_gen for now
336 - Address new binutils issues (gcc 4.6 compilation fixes)
338 * Wed Dec 21 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.12-1
339 - Trying to address new binutils issues
340 - Fill with zeroes all io threads structures
341 - Set io.num to content size+offset in write_data_wait() - it allows to use prepare/commit flags
343 * Tue Dec 20 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.11-1
344 - Implemented check for start/stop update timestamp
345 - Added cache tests in test.cpp
347 * Thu Dec 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.10-1
348 - Added configurable two-queue cache for read data by Anton Kortunov <toshic.toshic@gmail.com>
350 * Mon Dec 12 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.9-1
351 - Reopen log file on sighup
353 * Fri Dec 9 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.8-1
354 - Set DNET_FLAGS_NOLOCK for route/reverse lookup request/reply commands
355 - Added memory_test_pohmelfs() autotest
356 - Added gc calls into pohmelfs methods
357 - Fixed exception string generation for null ids
358 - Added small memory/leak test
360 * Fri Dec 2 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.7-1
361 - Use eblob_read_nocsum() if DNET_IO_FLAGS_NOCSUM is set
363 * Thu Dec 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.6-1
364 - Cleanup unused variables
365 - Fixed reply cmd->flags initialization
366 - Use boost::filesystem v2
367 - Fixes in bulk_read and bulk_write
369 * Mon Nov 28 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.5-1
370 - Implemented pool of non-blocking threads for recursive commands.
371 - Dropped metadata csum support in favour of eblob embedded checksums.
372 - Added bulk_write operation.
373 - Added sstable parser into python module
375 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.4-1
376 - Added nolocking IO thread
378 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.3-1
379 - Added oplock_num config parameter
380 - Added non-blocking thread checks
382 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.2-1
383 - Aflags/lock cleanups
385 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.1-1
386 - Added operations locks. Now all commands are processed with single-machine-atomicity
387 - Added server-side scripts
389 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.13-1
390 - Only perform blob write if io->size is not zero
392 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.12-1
393 - Initialize srw after node
395 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.11-1
396 - Do not chroot into history environment, since it is most likely incomplete
398 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.10-1
399 - Do not csum read when DNET_IO_FLAGS_NOCSUM ioflag is set
400 - When doing partial read, checksum whole file
402 * Sat Nov 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.9-1
403 - cpp tests update
404 - Return -ENOTSUP if srw is not initialized
405 - Do not reset join state to RECONNECT after it has been created
406 - Added stall_count as a configurable parameter
407 - Added BULK_READ command
409 * Tue Nov 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.8-1
410 - Fixed range counters
411 - Added ::remove() methods into python binding
412 - Remove all types if -1 as id->type is specified
413 - RHEL build must depend on eblob-devel >= 0.12.18 libsrw-devel >= 0.2.2
415 * Mon Nov 14 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.7-1
416 - Moved some objects from interface.h to packet.h
417 - Added range counters
418 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
419 - Use IP_TOS instead of SO_PRIORITY to set tos bits
420 - srw is called libsrw in rhel builds
421 - Depend on 0.12.18 eblob and 0.2.2 srw
423 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.6-1
424 - Depend on 0.2.1 srw and higher
426 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.5-1
427 - Added binary data support in srw
429 * Tue Nov 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.4-1
430 - Do not fail node initialization if srw is not initialized
432 * Mon Oct 31 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.3-1
433 - blob_send modified to send all columns if id.type == -1
434 - Do not depend elliptics build on libssl
435 - eblob/srw autoconf updates
436 - Do not return 1 from blob_write when data was compressed, return 0, since
437 there was no error
439 * Tue Oct 25 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.2-1
440 - Added srw dependency
441 - Do not call dnet_convert_io_attr for DNET_CMD_DEL command
443 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.1-1
444 - Decreased WRITE latency
445 - Use CORK for write blocks
447 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.0-1
448 - Added ioprio call inside check
449 - More example ioserv.conf comments
450 - Added client/server network priorities (man 7 socket -> IP_PRIORITY)
452 * Sat Oct 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.9-1
453 - Fixed memory allocation in range-delete
455 * Tue Oct 11 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.7-1
456 - Only set BLOB_DISK_CTL_NOCSUM if DNET_IO_FLAGS_NOCSUM is set
457 - Added dnet_get_routes function
458 - Added server-side scripting support
459 - Example ioserv.conf update
460 - Spec update
462 * Thu Dec 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.2-1
463 - Implemented multiple read in elliptics core and FCGI frontend.
464 - Implemented very user-friendly C++/Python interface.
465 - Extended FCGI xml output for POST request: added data crc, size,
466 per-group addresses and path to the destination object on file backend.
468 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.1-1
469 - Documentation update.
471 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.8-1
472 - Fixed fcgi reading with new groups URI.
474 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.7-1
475 - Implemented automatic groups selection by free space.
476 - Bug fixes.
478 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.6-1
479 - Fixed eblob_send().
480 - Use 50 check threads.
482 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.5-1
483 - Multi-threaded fsck.
484 - Bug fixes (including 2.9.4.4 version).
486 * Thu Nov 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.3-1
487 - Implemented bdb fsck (both merge and copy check).
489 * Thu Nov 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.2-1
490 - Switched to random ids (1024 ids are generated at first start)
492 * Fri Nov 19 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.1-1
493 - Switched to new addressing model
495 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.14-1
496 - Remove direct object if it can not be uploaded to the storage.
498 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.13-1
499 - Remove empty/broken history objects during merge.
501 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.12-1
502 - Added more debug about processed objects in fsck tools.
503 - Delete directly read object if its history can not be mapped.
504 - Return error from dnet_merge_direct() when merge falls back to direct
505 merge during common merge.
507 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.11-1
508 - Attempt to do direct merge when we can not parse non-direct history stored in main storage.
510 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.10-1
511 - Fixed bit directory generation in file_backend_get_dir_bits()
513 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.9-1
514 - Fixed state leak in lookup processing.
516 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.8-1
517 - Always use local address for succeeded local lookup.
519 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.7-1
520 - Kill state when check thread got error. (7)
521 - Extended fire time debug. (6)
523 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.5-1
524 - Update transaction fire time to include check timeout.
526 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.4-1
527 - Extend dnet_send_read_data() to get offset from parameters and do not abuse dnet_io_attr structure.
529 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.3-1
530 - Unmap history after selecting transaction with the last update time in dnet_merge_get_latest_transactions()
532 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
533 - Added full object ID dump and request error.
534 - Exit merge early if no id file was provided.
535 - Do not dereference state in dnet_read_complete() if it is NULL.
536 - Added -N (do not request ids and use prevously downloaded) option comment into fsck help.
538 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
539 - Extended alloc/free debug.
540 - Allow zero-sized writes.
542 * Wed Oct 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3-1
543 - New minor release. No changes from 2.9.2.32.
545 * Mon Oct 11 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.32-1
546 - Added configurable value to check header for remote node IP address.
547 - Added joining client check: returned address must be reachable to be
548 inserted into route table.
550 * Fri Oct 8 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.31-1
551 - Fixed LA sorting.
553 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.29-1
554 - Added id-by-LA generation and sorting.
555 - Debug cleanups.
557 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.28-1
558 - Added timed statistics request which also works as timed connection checker.
559 - Added seconds-only check time wait.
561 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.27-1
562 - Added keep-alive options.
564 * Mon Oct 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.26-1
565 - Unlink transaction and history after direct merge.
566 - Do not log error when state is NULL in completion callback.
568 * Sat Oct 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.25-1
569 - Added norequest flag to fsck util (will use existing file).
570 - Fixed remotes processing typo.
572 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.24-1
573 - Do not traverse the whole transaction tree after we found the
574 first one which fire time has not yet elapsed.
576 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.23-1
577 - Remove io_thread_num and max_pending config parameters.
578 - Added stack size parameter to check tools.
580 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.22-1
581 - Moved transaction debug output into the place where it can not dereference stale data.
582 - Decrease debug level for allocations.
583 - Added addrinfo null check. Should be useless though.
585 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.21-1
586 - Do not dereference null state in dnet_fcgi_read_complete.
588 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.20-1
589 - Added thread stack size parameter.
590 - Added malloc mmap threshold config parameter. (19)
592 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.18-1
593 - Really fixed recv state transaction processing leak.
595 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.16-1
596 -Do not try to dereferece null state. Happens when transaction is completed
597 on timeout.
598 - Use lineary (+60 seconds each turn) growing reconnection timeout. Added
599 reconnection limit of 1 day.
600 - Fixed recv state transaction processing leak.
602 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.15-1
603 - Compilation typo fixed.
605 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.14-1
606 - Fill all allocated memory with zeroes.
608 * Thu Sep 16 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.13-1
609 - Put transaction after it was executed. Its refcnt was increased during
610 search call.
611 - Do not try to dereference state when it can be null.
612 - Do not create unneded listening state when node does not join network. (12)
613 - Reset accept state on error.
614 - Do not join to states in state lists, since they can be freed in own
615 threads. (11)
616 - Drop transaction resending support. (10)
617 - Extended local command processing log. (9)
618 - Also print pid in common logger. (8)
619 - Use pthread_self() instead of getpid() to get uniq thread id. (7)
621 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.6-1
622 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was set for read command, do not
623 send data reply. Used in local stat command.
624 - Debug cleanup.
625 - From previous releases:
626 Do not deal with NULL transactions.
627 Start state IO thread after state initialization.
628 Join to io state thread instead of freeing it directly.
629 Do not exit from accept loop on error.
630 Initialize state list entry prior other usage.
632 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2-1
633 - Switched from libevent state machine to thread-per-client model.
635 * Fri Aug 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1.1-1
636 - Added DNET_FCGI_PUT_REGION config option to optionally enable region tag
637 - Added wildcard direct download pattern (*)
638 - Force direct download patterns to be checked against ID ending and
639 just by having this substring somewhere in the query.
641 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1-1
642 - New elliptics network release: 2.9.1
644 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.31-1
645 - Logger cleanups.
646 - Fixed resend locking bug.
648 * Mon Aug 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.30-1
649 - Fixed lock/unlock typo in dnet_data_ready().
651 * Sat Aug 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.29-1
652 - Refactor fcgi logging (29)
653 - Return read error when key was not found. Use right config file options. (28)
655 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.27-1
656 - Added sanity checks for embedded reading.
658 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.26-1
659 - Disabled per-client statistics request in fcgi daemon.
660 - Added subtle timeout and data rewrite when FCGX_PutStr() returns error.
662 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.25-1
663 - Copy resolved address into buffer (later used for reconnection)
664 before trying to connect.
666 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.24-1
667 - Refactor fcgi/check loggers to write pid/thread id into single log file.
669 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.23-1
670 - Added <region> tag into download-info XML output
671 - Changed sending locking.
673 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.22-1
674 - Guard multiple 'logical' xml writes against parallel write
676 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.21-1
677 - Implemented direct transaction merge.
678 - If reading size was set to 0 map ~0ULL size, i.e. the whole file.
679 - Remove object from the storage if its history log says so.
680 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
681 DNET_FCGI_EMBED_PATTERN option.
683 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.20-1
684 - Fixed several fd leaks.
686 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.19-1
687 - Unmap history file when failed to read transaction.
689 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.18-1
690 - Guard OpenSSL_add_all_digests() and initialize it only once per thread
691 group.
692 - Force dnet_check_process_request() to wait for all sent transactions, do
693 not wakeup after receiving reply from the first one.
695 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.17-1
696 - Fixed compilation warnings on 64bit platform (uint64_t to unsigned long
697 long and void * to unsigned long)
698 - Try only requested transformation function, do not continue with the next
699 one.
700 - Use errno to differentiate reconnection state.
702 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.15-1
703 - Made elliptics depend on eblob
704 - Updated checker's logger.
705 - Increase example/check/common.c waiting timeout.
706 - Added logs into file io backend listing processor.
708 * Sun Jul 26 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.12-1
709 - Let check applications to sleep longer waiting for replies.
710 - Reduce number of ids sent via DNET_CMD_LIST command to 1024 per reply.
711 - Mark states added via dnet_add_state() as reconnect-friendly.
712 - Do not add reconnection addresses which do not have joining flags.
713 - Updated to the latest eblob lib (moved blob code outside to libeblob).
714 - Reschedule transaction's fire time when (non-last) reply is received.
715 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
717 * Sun Jul 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.11-1
718 - Added embedded URI parameter, which will force timestamp to be embedded
719 with data. It is possible to embed other parameters too.
721 post: wget -O /tmp/1111 -S --post-file=elliptics.spec
722 "http://devfs1/test.mp3?name=qwerty.xml&embed&timestamp=123"
724 get: wget -O /tmp/1111 -S --header="If-Modified-Since: Thu, 01 Jan 1970
725 00:02:00 GMT" "http://devfs1/test.mp3?name=qwerty.xml&embed&direct=1"
726 - fixed random hash selection in fcgi frontend.
728 * Fri Jul 23 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.10-1
729 -return back addressing magic^W logic in dnet_write_object_raw()
731 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.9-1
732 - return back virtual datacenters.
734 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.8-1
735 - BLOB IO backend updates (multiple threads, index, bug fixes).
736 - file IO backend fixes
737 - python bindings
738 - c++ binding fixes
740 * Mon Jul 19 2010 Arkady L. Shane <ashejn@yandex-team.ru> - 2.9.0.7-1
741 - initial build for Fedora