Elliptics version update: 2.18.3.0
[elliptics.git] / elliptics-bf.spec
blobb70cde283ccb5244f1241557e606af200eae4158
1 Summary: Distributed hash table storage
2 Name: elliptics
3 Version: 2.18.3.0
4 Release: 1%{?dist}
6 License: GPLv2+
7 Group: System Environment/Libraries
8 URL: http://www.ioremap.net/projects/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 %if 0%{?rhel} < 6
13 BuildRequires: python26-devel, boost141-python, boost141-devel
14 BuildRequires: boost141-iostreams, boost141-thread, boost141-python, boost141-system
15 %else
16 BuildRequires: python-devel, boost-python, boost-devel, boost-iostreams, boost-thread, boost-python, boost-system
17 %endif
18 BuildRequires: eblob-devel >= 0.17.1
19 BuildRequires: smack >= 0.5.0
20 BuildRequires: cmake
22 Obsoletes: srw
24 %description
25 Elliptics network is a fault tolerant distributed hash table
26 object storage.
29 %package devel
30 Summary: Development files for %{name}
31 Group: Development/Libraries
32 Requires: %{name} = %{version}-%{release}
35 %description devel
36 Elliptics network is a fault tolerant distributed hash table
37 object storage.
39 This package contains libraries, header files and developer documentation
40 needed for developing software which uses the cairo graphics library.
42 %package python
43 Summary: Elliptics library Python binding
44 Group: Development/Libraries
45 Requires: %{name} = %{version}-%{release}
47 %description python
48 Elliptics Python Language bindings.
51 %package python-devel
52 Summary: Elliptics library Python binding
53 Group: Development/Libraries
54 Requires: elliptics-python = %{version}-%{release}
57 %description python-devel
58 Elliptics Python Language bindings development headers and libraries.
61 %package c++
62 Summary: Elliptics library C++ binding
63 Group: Development/Libraries
64 Requires: elliptics = %{version}-%{release}
67 %description c++
68 Elliptics library C++ language binding.
71 %package c++-devel
72 Summary: Elliptics library C++ binding development headers and libraries
73 Group: Development/Libraries
74 Requires: elliptics-devel = %{version}-%{release}
75 Requires: elliptics-c++ = %{version}-%{release}
78 %description c++-devel
79 Elliptics library C++ binding development headers and libraries
80 for building C++ applications with elliptics.
82 %prep
83 %setup -q
85 %build
86 export LDFLAGS="-Wl,-z,defs"
87 export DESTDIR="%{buildroot}"
88 %if 0%{?rhel} < 6
89 export PYTHON=/usr/bin/python26
90 CXXFLAGS="-pthread -I/usr/include/boost141" LDFLAGS="-L/usr/lib64/boost141" %{cmake} -DBoost_DIR=/usr/lib64/boost141 .
91 %else
92 %{cmake} .
93 %endif
94 make %{?_smp_mflags}
96 %install
97 rm -rf %{buildroot}
98 make install DESTDIR=%{buildroot}
99 rm -f %{buildroot}%{_libdir}/*.a
100 rm -f %{buildroot}%{_libdir}/*.la
102 %post -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
105 %post python -p /sbin/ldconfig
106 %postun python -p /sbin/ldconfig
108 %post c++ -p /sbin/ldconfig
109 %postun c++ -p /sbin/ldconfig
111 %clean
112 rm -rf %{buildroot}
114 %files
115 %defattr(-,root,root,-)
116 %doc README doc/design_notes.txt doc/io_storage_backend.txt
117 %{_bindir}/*
118 %{_libdir}/libelliptics.so.*
119 %{_libdir}/libelliptics_client.so.*
120 %{_libdir}/libelliptics_cocaine.so.*
121 %{_libdir}/libelliptics_cache.so.*
124 %files devel
125 %defattr(-,root,root,-)
126 %{_includedir}/*
127 %{_libdir}/libelliptics.so
128 %{_libdir}/libelliptics_client.so
129 %{_libdir}/libelliptics_cocaine.so
130 %{_libdir}/libelliptics_cache.so
132 %files python
133 %defattr(-,root,root,-)
134 %{_libdir}/libelliptics_python.so.*
135 %{python_sitelib}/elliptics*
138 %files python-devel
139 %defattr(-,root,root,-)
140 %{_libdir}/libelliptics_python.so
143 %files c++
144 %defattr(-,root,root,-)
145 %{_libdir}/libelliptics_cpp.so.*
148 %files c++-devel
149 %defattr(-,root,root,-)
150 %{_libdir}/libelliptics_cpp.so
153 %changelog
154 * Mon Oct 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.3.0
155 - Grow IO pools on demand
156 - Added automatic recovery on read command:
157 - if object didn't exist in previously read group,
158 - it will be written when read from the next group succeed
159 - Documentation update
160 - Added multicast autodiscovery
161 - If state is already exist, do not fail with error
162 - Fixed the ugliest debian python installation
163 - Added new python bindings
164 - Do not try to run command if srw was not initialized
165 - Populate cache on READ command when DNET_IO_FLAGS_CACHE ioflag is set
167 * Thu Sep 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.2.1
168 - Added c++/python bindings for cache write operations (including timeout)
169 - Added remove-from-disk cache operation: when such flag is set (at write time)"
170 - if object is removed from cache, it is also removed from disk
171 - Increase example number of non-blocking io threads
172 - Added 'overwrite commits write' comment
174 * Mon Sep 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.2
175 - dnet_backend_log_raw() should use dnet_backend_check_log_level() to check log level
176 - Added startup stack size check
177 - Cocaine job has to be created only when it can be queued
179 * Fri Sep 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.1.1
180 - Update version num
182 * Thu Sep 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.18.0.1
183 - New interface for execution, reply and chaining
184 - Do not strip rpath
185 - Fixed server node cleanup bug when it destroyed locks first while IO threads could still use them
186 - dnet_send_cmd_raw() must always wait for ack
187 - Fixed thread creation bug in app_watcher when application does not exist
188 - Added -g flag to elliptics build
189 - Use weak symbols instead of stubs in client lib, since server also links to it and in Fedora it ends up using stubs from client lib
190 - Search for 0mq only of cocaine is enabled
191 - Update debian packaging
192 - Fixed build-depends
194 * Fri Aug 31 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.4
195 - elliptics-client must replace old-school elliptics-2.10
197 * Thu Aug 30 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.3
198 - Added python-support to dep list
199 - Use correct package name in shlibs
201 * Wed Aug 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.2
202 - Switch to cmake from autoconf
204 * Mon Aug 20 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.17.0.1
205 - Depend on eblob 0.17.1 and higher
206 - Use log level instead of log mask
207 - Depend on smack 0.5.0 and higher
208 - Added cdbs dep
209 - Added in-memory (optionally disk-backed) LRU cache
210 - Get rid of boost-filesystem
211 - Split code (and debian package) to client/server libs
212 - New unlink interfaces
213 - Added ioflags to ioclient
214 - If lookup returned error, proceed read-latest with default order
215 - Let DNET_CMD_DEL use dnet_io_attr structure too
217 * Wed Aug 08 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.16.0.1
218 - Added possibility to start defragmentation on demand
219 - Added reserved 'hostname' word for local address
220 - Added cleanup call into node destruction path, which fixes double free error in config error path
221 - Implemented blocking exec commands
222 - Refactor pools of workers
223 - Set cocaine log level based on elliptics log mask
224 - Completely created client library
225 - Fixed json example path
227 * Tue Jul 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.15.0.1
228 - Send correct answer in smack_write
229 - New bulk_read()
230 - New event string for application invocation
231 - Corrected changelog
232 - Depend on smack 0.4.0 and higher
234 * Mon Jul 02 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.4
235 - Log all client job errorrs into app/.log file in elliptics
236 - Set nocsum flags in io-attr when it is set in global node's config
238 * Wed Jun 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.3-1
239 - Depend on smack 0.3.0 and higher
241 * Tue Jun 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.2-1
242 - Use smack_total_elements() to get number of records
244 * Mon Jun 25 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.1.1-1
245 - Disable signals in library and enable in server and ioclient
246 - Added cocaine library documentation
247 - Added smack configuration
248 - Sync with upstream smack repo
250 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.7-1
251 - Fixed typo in smack config parser
253 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.6-1
254 - Sink srw log into app + ".log" object in elliptics
256 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.5-1
257 - Added SMACK backend depends
259 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.4-1
260 - Drop cocaine plugin dependencies
262 * Fri Jun 22 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.3-1
263 - Added new cocaine debian package deps
264 - Drop cocaine deps in RHEL/Fedora build
266 * Thu Jun 21 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.2-1
267 - Build srw fix (use weak symbol for dnet_log_raw())
268 - Added new eblob bit to config documentation, drop unused parameters
269 - Fixed write response generation
271 * Fri Jun 15 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.14.0.1-1
272 - Use cocaine workers for server-side
273 - Drop dnet_attr structure
274 - Optimize read (do not send ack if there is data)
275 - Use ioremap::elliptics namespace
276 - Added ::push() - nonblocking exec
278 * Sun Apr 28 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.9-1
279 - Do not allow zero-sized reads
280 - Do not double-close python init file
282 * Sat Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.8-1
283 - Added new lookup() methods to c++/python bindings. Patch by Anton Kortunov <toshik@yandex-team.ru>
284 - If we fail to open log file, dup2() stdout/stderr to /dev/null in spawned worker process
286 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.7-1
287 - More mess with 012 file descriptors - dup them to /dev/null when going background, reopen to log file in srw worker
288 - Use correct F_SETFD/FD_CLOEXEC
289 - Use old-school fcntl() instead of accept4() and epoll_create1()
290 - Allow script execution without cmd-line
292 * Fri Apr 27 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.6-1
293 - Added srw config options
294 - Added O_CLOEXEC flags
295 - Added new configs (for nginx and fastcgi frontend) and python example
296 - Return sub data from smack_write() call - this is needed for fastcgi frontend
297 - Let dnet_ioclient write file by ID
298 - Added smack backend wrapper
300 * Fri Apr 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.5-1
301 - Build dependencies update
302 - Do not write metadata when appropirate bit is set in node->flags
303 - Update documentation about blob flags
305 * Fri Mar 23 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.4-1
306 - Updated state mixing algorithm
307 - Added defrag_timeout, defrag_percentage and blob_size options to file backend
309 * Mon Mar 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.3-1
310 - Allow ioclient to read/write data in different columns
311 - Hardlink script should overwrite data
312 - Fixed file read/write with different column
313 - Use correct pipe path, which includes pid
314 - Use correct structure size for dentries and extended logging
315 - Do not set name for main process
317 * Sun Mar 13 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.2-1
318 - Use exactly specified in config socket family
319 - Obsolete srw by ellipitcs
320 - Revert "Use X bits from operation key to find a lock instead of random hashing"
321 - Added proper sigchild handling
322 - spec update - added libsrw.so* files
323 - Dropped srw dependancy
325 * Sun Mar 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.13.0.1-1
326 - Added srw
328 * Wed Feb 29 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.12.0.1-1
329 - Depend on 0.15 eblob: added new defragmentation parameters into config
330 - Propagate prepare_write() and friends return values back to callers - changed API
332 * Sun Feb 19 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.7-1
333 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
334 - Updated python scripts to use new eblob class
335 - exec is reserved name in python, use exec_script for execution method name
337 * Thu Feb 16 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.6-1
338 - Added possibility to read metadata from file and dump to log
339 - Added remove_keys_from_storage_found_removed_in_eblob.py
340 - Added local merge iterator written in python. Is not optimal, but quite fast.
342 * Tue Feb 14 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.5-1
343 - Execute CHECK commands with NOLOCK flag
345 * Sat Feb 11 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.4-1
346 - Use correct eblob path for statvfs() request
348 * Mon Feb 8 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.3-1
349 - Set id.type to 0 where appropriate
350 - Request statistics with DNET_ATTR_NOLOCK flag set
351 - Fixed pohmelfs_rename.py
353 * Mon Feb 6 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.2-1
354 - Process checksum flags according to aflags and ioflags
356 * Wed Feb 1 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.1.1-1
357 - Added start/num parameters to iterate over selected number of blobs.
358 - Depend on 0.14.1 blob and higher where it is implemented.
360 * Thu Jan 26 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.15-1
361 - Added readdir script
362 - Dropped content length manipulation from srw/pohmelfs_inode_info_insert.py
363 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
365 * Tue Jan 24 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.14-1
366 - Reserve some space for directory content
367 - Added pohmelfs_read_latest_groups.py script
368 - Implemented prepare-latest helper, which returns timestamp sorted groups which contain requested id
369 - If we have more data to send, set only DNET_FLAGS_MORE flag, not erase others
370 - Rename cpp bindings
371 - Fixed range requests without limits
373 * Tue Jan 17 2012 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.13-1
374 - Sort keys on server side in range requests
375 - Disable eblob_gen for now
376 - Address new binutils issues (gcc 4.6 compilation fixes)
378 * Wed Dec 21 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.12-1
379 - Trying to address new binutils issues
380 - Fill with zeroes all io threads structures
381 - Set io.num to content size+offset in write_data_wait() - it allows to use prepare/commit flags
383 * Tue Dec 20 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.11-1
384 - Implemented check for start/stop update timestamp
385 - Added cache tests in test.cpp
387 * Thu Dec 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.10-1
388 - Added configurable two-queue cache for read data by Anton Kortunov <toshic.toshic@gmail.com>
390 * Mon Dec 12 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.9-1
391 - Reopen log file on sighup
393 * Fri Dec 9 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.8-1
394 - Set DNET_FLAGS_NOLOCK for route/reverse lookup request/reply commands
395 - Added memory_test_pohmelfs() autotest
396 - Added gc calls into pohmelfs methods
397 - Fixed exception string generation for null ids
398 - Added small memory/leak test
400 * Fri Dec 2 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.7-1
401 - Use eblob_read_nocsum() if DNET_IO_FLAGS_NOCSUM is set
403 * Thu Dec 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.6-1
404 - Cleanup unused variables
405 - Fixed reply cmd->flags initialization
406 - Use boost::filesystem v2
407 - Fixes in bulk_read and bulk_write
409 * Mon Nov 28 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.5-1
410 - Implemented pool of non-blocking threads for recursive commands.
411 - Dropped metadata csum support in favour of eblob embedded checksums.
412 - Added bulk_write operation.
413 - Added sstable parser into python module
415 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.4-1
416 - Added nolocking IO thread
418 * Thu Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.3-1
419 - Added oplock_num config parameter
420 - Added non-blocking thread checks
422 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.2-1
423 - Aflags/lock cleanups
425 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.11.0.1-1
426 - Added operations locks. Now all commands are processed with single-machine-atomicity
427 - Added server-side scripts
429 * Wed Nov 23 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.13-1
430 - Only perform blob write if io->size is not zero
432 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.12-1
433 - Initialize srw after node
435 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.11-1
436 - Do not chroot into history environment, since it is most likely incomplete
438 * Tue Nov 22 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.10-1
439 - Do not csum read when DNET_IO_FLAGS_NOCSUM ioflag is set
440 - When doing partial read, checksum whole file
442 * Sat Nov 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.9-1
443 - cpp tests update
444 - Return -ENOTSUP if srw is not initialized
445 - Do not reset join state to RECONNECT after it has been created
446 - Added stall_count as a configurable parameter
447 - Added BULK_READ command
449 * Tue Nov 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.8-1
450 - Fixed range counters
451 - Added ::remove() methods into python binding
452 - Remove all types if -1 as id->type is specified
453 - RHEL build must depend on eblob-devel >= 0.12.18 libsrw-devel >= 0.2.2
455 * Mon Nov 14 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.7-1
456 - Moved some objects from interface.h to packet.h
457 - Added range counters
458 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
459 - Use IP_TOS instead of SO_PRIORITY to set tos bits
460 - srw is called libsrw in rhel builds
461 - Depend on 0.12.18 eblob and 0.2.2 srw
463 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.6-1
464 - Depend on 0.2.1 srw and higher
466 * Thu Nov 3 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.5-1
467 - Added binary data support in srw
469 * Tue Nov 1 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.4-1
470 - Do not fail node initialization if srw is not initialized
472 * Mon Oct 31 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.3-1
473 - blob_send modified to send all columns if id.type == -1
474 - Do not depend elliptics build on libssl
475 - eblob/srw autoconf updates
476 - Do not return 1 from blob_write when data was compressed, return 0, since
477 there was no error
479 * Tue Oct 25 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.2-1
480 - Added srw dependency
481 - Do not call dnet_convert_io_attr for DNET_CMD_DEL command
483 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.1-1
484 - Decreased WRITE latency
485 - Use CORK for write blocks
487 * Wed Oct 19 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.4.0-1
488 - Added ioprio call inside check
489 - More example ioserv.conf comments
490 - Added client/server network priorities (man 7 socket -> IP_PRIORITY)
492 * Sat Oct 15 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.9-1
493 - Fixed memory allocation in range-delete
495 * Tue Oct 11 2011 Evgeniy Polyakov <zbr@ioremap.net> - 2.10.3.7-1
496 - Only set BLOB_DISK_CTL_NOCSUM if DNET_IO_FLAGS_NOCSUM is set
497 - Added dnet_get_routes function
498 - Added server-side scripting support
499 - Example ioserv.conf update
500 - Spec update
502 * Thu Dec 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.2-1
503 - Implemented multiple read in elliptics core and FCGI frontend.
504 - Implemented very user-friendly C++/Python interface.
505 - Extended FCGI xml output for POST request: added data crc, size,
506 per-group addresses and path to the destination object on file backend.
508 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.5.1-1
509 - Documentation update.
511 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.8-1
512 - Fixed fcgi reading with new groups URI.
514 * Fri Dec 3 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.7-1
515 - Implemented automatic groups selection by free space.
516 - Bug fixes.
518 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.6-1
519 - Fixed eblob_send().
520 - Use 50 check threads.
522 * Thu Dec 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.5-1
523 - Multi-threaded fsck.
524 - Bug fixes (including 2.9.4.4 version).
526 * Thu Nov 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.3-1
527 - Implemented bdb fsck (both merge and copy check).
529 * Thu Nov 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.2-1
530 - Switched to random ids (1024 ids are generated at first start)
532 * Fri Nov 19 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.4.1-1
533 - Switched to new addressing model
535 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.14-1
536 - Remove direct object if it can not be uploaded to the storage.
538 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.13-1
539 - Remove empty/broken history objects during merge.
541 * Tue Nov 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.12-1
542 - Added more debug about processed objects in fsck tools.
543 - Delete directly read object if its history can not be mapped.
544 - Return error from dnet_merge_direct() when merge falls back to direct
545 merge during common merge.
547 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.11-1
548 - Attempt to do direct merge when we can not parse non-direct history stored in main storage.
550 * Sat Nov 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.10-1
551 - Fixed bit directory generation in file_backend_get_dir_bits()
553 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.9-1
554 - Fixed state leak in lookup processing.
556 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.8-1
557 - Always use local address for succeeded local lookup.
559 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.7-1
560 - Kill state when check thread got error. (7)
561 - Extended fire time debug. (6)
563 * Thu Oct 21 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.5-1
564 - Update transaction fire time to include check timeout.
566 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.4-1
567 - Extend dnet_send_read_data() to get offset from parameters and do not abuse dnet_io_attr structure.
569 * Wed Oct 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.3-1
570 - Unmap history after selecting transaction with the last update time in dnet_merge_get_latest_transactions()
572 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
573 - Added full object ID dump and request error.
574 - Exit merge early if no id file was provided.
575 - Do not dereference state in dnet_read_complete() if it is NULL.
576 - Added -N (do not request ids and use prevously downloaded) option comment into fsck help.
578 * Mon Oct 18 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3.2-1
579 - Extended alloc/free debug.
580 - Allow zero-sized writes.
582 * Wed Oct 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.3-1
583 - New minor release. No changes from 2.9.2.32.
585 * Mon Oct 11 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.32-1
586 - Added configurable value to check header for remote node IP address.
587 - Added joining client check: returned address must be reachable to be
588 inserted into route table.
590 * Fri Oct 8 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.31-1
591 - Fixed LA sorting.
593 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.29-1
594 - Added id-by-LA generation and sorting.
595 - Debug cleanups.
597 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.28-1
598 - Added timed statistics request which also works as timed connection checker.
599 - Added seconds-only check time wait.
601 * Wed Oct 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.27-1
602 - Added keep-alive options.
604 * Mon Oct 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.26-1
605 - Unlink transaction and history after direct merge.
606 - Do not log error when state is NULL in completion callback.
608 * Sat Oct 2 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.25-1
609 - Added norequest flag to fsck util (will use existing file).
610 - Fixed remotes processing typo.
612 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.24-1
613 - Do not traverse the whole transaction tree after we found the
614 first one which fire time has not yet elapsed.
616 * Thu Sep 30 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.23-1
617 - Remove io_thread_num and max_pending config parameters.
618 - Added stack size parameter to check tools.
620 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.22-1
621 - Moved transaction debug output into the place where it can not dereference stale data.
622 - Decrease debug level for allocations.
623 - Added addrinfo null check. Should be useless though.
625 * Mon Sep 20 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.21-1
626 - Do not dereference null state in dnet_fcgi_read_complete.
628 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.20-1
629 - Added thread stack size parameter.
630 - Added malloc mmap threshold config parameter. (19)
632 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.18-1
633 - Really fixed recv state transaction processing leak.
635 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.16-1
636 -Do not try to dereferece null state. Happens when transaction is completed
637 on timeout.
638 - Use lineary (+60 seconds each turn) growing reconnection timeout. Added
639 reconnection limit of 1 day.
640 - Fixed recv state transaction processing leak.
642 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.15-1
643 - Compilation typo fixed.
645 * Fri Sep 17 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.14-1
646 - Fill all allocated memory with zeroes.
648 * Thu Sep 16 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.13-1
649 - Put transaction after it was executed. Its refcnt was increased during
650 search call.
651 - Do not try to dereference state when it can be null.
652 - Do not create unneded listening state when node does not join network. (12)
653 - Reset accept state on error.
654 - Do not join to states in state lists, since they can be freed in own
655 threads. (11)
656 - Drop transaction resending support. (10)
657 - Extended local command processing log. (9)
658 - Also print pid in common logger. (8)
659 - Use pthread_self() instead of getpid() to get uniq thread id. (7)
661 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2.6-1
662 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was set for read command, do not
663 send data reply. Used in local stat command.
664 - Debug cleanup.
665 - From previous releases:
666 Do not deal with NULL transactions.
667 Start state IO thread after state initialization.
668 Join to io state thread instead of freeing it directly.
669 Do not exit from accept loop on error.
670 Initialize state list entry prior other usage.
672 * Tue Sep 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.2-1
673 - Switched from libevent state machine to thread-per-client model.
675 * Fri Aug 13 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1.1-1
676 - Added DNET_FCGI_PUT_REGION config option to optionally enable region tag
677 - Added wildcard direct download pattern (*)
678 - Force direct download patterns to be checked against ID ending and
679 just by having this substring somewhere in the query.
681 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.1-1
682 - New elliptics network release: 2.9.1
684 * Tue Aug 10 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.31-1
685 - Logger cleanups.
686 - Fixed resend locking bug.
688 * Mon Aug 9 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.30-1
689 - Fixed lock/unlock typo in dnet_data_ready().
691 * Sat Aug 7 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.29-1
692 - Refactor fcgi logging (29)
693 - Return read error when key was not found. Use right config file options. (28)
695 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.27-1
696 - Added sanity checks for embedded reading.
698 * Thu Aug 6 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.26-1
699 - Disabled per-client statistics request in fcgi daemon.
700 - Added subtle timeout and data rewrite when FCGX_PutStr() returns error.
702 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.25-1
703 - Copy resolved address into buffer (later used for reconnection)
704 before trying to connect.
706 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.24-1
707 - Refactor fcgi/check loggers to write pid/thread id into single log file.
709 * Thu Aug 5 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.23-1
710 - Added <region> tag into download-info XML output
711 - Changed sending locking.
713 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.22-1
714 - Guard multiple 'logical' xml writes against parallel write
716 * Wed Aug 4 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.21-1
717 - Implemented direct transaction merge.
718 - If reading size was set to 0 map ~0ULL size, i.e. the whole file.
719 - Remove object from the storage if its history log says so.
720 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
721 DNET_FCGI_EMBED_PATTERN option.
723 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.20-1
724 - Fixed several fd leaks.
726 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.19-1
727 - Unmap history file when failed to read transaction.
729 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.18-1
730 - Guard OpenSSL_add_all_digests() and initialize it only once per thread
731 group.
732 - Force dnet_check_process_request() to wait for all sent transactions, do
733 not wakeup after receiving reply from the first one.
735 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.17-1
736 - Fixed compilation warnings on 64bit platform (uint64_t to unsigned long
737 long and void * to unsigned long)
738 - Try only requested transformation function, do not continue with the next
739 one.
740 - Use errno to differentiate reconnection state.
742 * Sun Jul 28 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.15-1
743 - Made elliptics depend on eblob
744 - Updated checker's logger.
745 - Increase example/check/common.c waiting timeout.
746 - Added logs into file io backend listing processor.
748 * Sun Jul 26 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.12-1
749 - Let check applications to sleep longer waiting for replies.
750 - Reduce number of ids sent via DNET_CMD_LIST command to 1024 per reply.
751 - Mark states added via dnet_add_state() as reconnect-friendly.
752 - Do not add reconnection addresses which do not have joining flags.
753 - Updated to the latest eblob lib (moved blob code outside to libeblob).
754 - Reschedule transaction's fire time when (non-last) reply is received.
755 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
757 * Sun Jul 25 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.11-1
758 - Added embedded URI parameter, which will force timestamp to be embedded
759 with data. It is possible to embed other parameters too.
761 post: wget -O /tmp/1111 -S --post-file=elliptics.spec
762 "http://devfs1/test.mp3?name=qwerty.xml&embed&timestamp=123"
764 get: wget -O /tmp/1111 -S --header="If-Modified-Since: Thu, 01 Jan 1970
765 00:02:00 GMT" "http://devfs1/test.mp3?name=qwerty.xml&embed&direct=1"
766 - fixed random hash selection in fcgi frontend.
768 * Fri Jul 23 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.10-1
769 -return back addressing magic^W logic in dnet_write_object_raw()
771 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.9-1
772 - return back virtual datacenters.
774 * Thu Jul 22 2010 Evgeniy Polyakov <zbr@ioremap.net> - 2.9.0.8-1
775 - BLOB IO backend updates (multiple threads, index, bug fixes).
776 - file IO backend fixes
777 - python bindings
778 - c++ binding fixes
780 * Mon Jul 19 2010 Arkady L. Shane <ashejn@yandex-team.ru> - 2.9.0.7-1
781 - initial build for Fedora