New interface for execution, reply and chaining
[elliptics.git] / debian / rules
blob6e101cf8d8a9fd8941f358434b50a1927001cd4c
1 #!/usr/bin/make -f
3 include /usr/share/cdbs/1/rules/debhelper.mk
4 include /usr/share/cdbs/1/class/cmake.mk
6 DEB_CMAKE_EXTRA_FLAGS := -DCMAKE_BUILD_TYPE=RelWithDebInfo
8 DEB_DH_STRIP_ARGS := --dbg-package=elliptics-dbg
9 DEB_DH_MAKESHLIBS_ARGS_elliptics := -V "elliptics (>= $(shell head -n1 debian/changelog | sed -e 's/.*[(]//' | sed -e 's/[)].*//' | tr -d '\n' | cut -d . -f 1-3))"
10 DEB_DH_MAKESHLIBS_ARGS_elliptics-client := -V "elliptics-client (>= $(shell head -n1 debian/changelog | sed -e 's/.*[(]//' | sed -e 's/[)].*//' | tr -d '\n' | cut -d . -f 1-3))"
11 DEB_COMPRESS_EXCLUDE := .conf
13 binary-post-install/elliptics-client::
14 rm debian/elliptics-client/usr/bin/dnet_ioserv