1 Summary: Distributed
hash table storage
7 Group: System Environment
/Libraries
8 URL: http
://www.ioremap.net
/projects
/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
13 BuildRequires
: python26
-devel
, boost141
-python
, boost141
-devel
14 BuildRequires
: boost141
-iostreams
, boost141
-filesystem
, boost141
-thread
, boost141
-python
, boost141
-system
16 BuildRequires
: python
-devel
, boost
-python
, boost
-devel
, boost
-iostreams
, boost
-filesystem
, boost
-thread
, boost
-python
, boost
-system
18 BuildRequires
: eblob
-devel
>= 0.15.0
19 BuildRequires
: automake autoconf libtool
24 Elliptics network is a fault tolerant distributed
hash table
29 Summary: Development files
for %{name}
30 Group: Development
/Libraries
31 Requires: %{name} = %{version}-%{release}
35 Elliptics network is a fault tolerant distributed
hash table
38 This package contains libraries
, header files and developer documentation
39 needed
for developing software which uses the cairo graphics library.
42 Summary: Elliptics library Python binding
43 Group: Development
/Libraries
44 Requires: %{name} = %{version}-%{release}
47 Elliptics Python Language bindings.
51 Summary: Elliptics library Python binding
52 Group: Development
/Libraries
53 Requires: elliptics
-python
= %{version}-%{release}
56 %description python
-devel
57 Elliptics Python Language bindings development headers and libraries.
61 Summary: Elliptics library C
++ binding
62 Group: Development
/Libraries
63 Requires: elliptics
= %{version}-%{release}
67 Elliptics library C
++ language binding.
71 Summary: Elliptics library C
++ binding development headers and libraries
72 Group: Development
/Libraries
73 Requires: elliptics
-devel
= %{version}-%{release}
74 Requires: elliptics
-c
++ = %{version}-%{release}
77 %description c
++-devel
78 Elliptics library C
++ binding development headers and libraries
79 for building C
++ applications with elliptics.
85 export LDFLAGS
="
-Wl
,-z
,defs"
88 export PYTHON
=/usr
/bin
/python26
89 CXXFLAGS
="
-pthread
-I
/usr
/include
/boost141" LDFLAGS
="
-L
/usr
/lib64
/boost141"
%configure --with
-boost
-libdir
=/usr
/lib64
/boost141
100 make install DESTDIR
=%{buildroot}
101 rm -f
%{buildroot}%{_libdir}/*.a
102 rm -f
%{buildroot}%{_libdir}/*.la
104 %post -p
/sbin
/ldconfig
105 %postun -p
/sbin
/ldconfig
108 %post python
-p
/sbin
/ldconfig
109 %postun python
-p
/sbin
/ldconfig
112 %post c
++ -p
/sbin
/ldconfig
113 %postun c
++ -p
/sbin
/ldconfig
120 %defattr(-,root
,root
,-)
121 %doc AUTHORS AUTHORS COPYING README
123 %{_libdir}/libelliptics.so.
*
124 %{_libdir}/libsrw.so.
*
128 %defattr(-,root
,root
,-)
130 %{_libdir}/libelliptics.so
134 %defattr(-,root
,root
,-)
135 %{_libdir}/libelliptics_python.so.
*
139 %defattr(-,root
,root
,-)
140 %{_libdir}/libelliptics_python.so
144 %defattr(-,root
,root
,-)
145 %{_libdir}/libelliptics_cpp.so.
*
149 %defattr(-,root
,root
,-)
150 %{_libdir}/libelliptics_cpp.so
154 * Sun Apr
28 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.9-1
155 - Do not allow zero
-sized reads
156 - Do not double
-close python init file
158 * Sat Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.8-1
159 - Added new lookup
() methods to c
++/python bindings.
Patch by Anton Kortunov
<toshik@yandex
-team.ru
>
160 - If we fail to open log file
, dup2
() stdout
/stderr to
/dev
/null
in spawned worker process
162 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.7-1
163 - More mess with
012 file descriptors
- dup them to
/dev
/null when going background
, reopen to log file
in srw worker
164 - Use correct F_SETFD
/FD_CLOEXEC
165 - Use old
-school fcntl
() instead of accept4
() and epoll_create1
()
166 - Allow script execution without cmd
-line
168 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.6-1
169 - Added srw config options
170 - Added O_CLOEXEC flags
171 - Added new configs
(for nginx and fastcgi frontend
) and python example
172 - Return sub data from smack_write
() call
- this is needed
for fastcgi frontend
173 - Let dnet_ioclient write file by ID
174 - Added smack backend wrapper
176 * Fri Apr
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.5-1
177 - Build dependencies update
178 - Do not write metadata when appropirate bit is
set in node
->flags
179 - Update documentation about blob flags
181 * Fri Mar
23 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.4-1
182 - Updated state mixing algorithm
183 - Added defrag_timeout
, defrag_percentage and blob_size options to file backend
185 * Mon Mar
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.3-1
186 - Allow ioclient to
read/write data
in different columns
187 - Hardlink script should overwrite data
188 - Fixed file
read/write with different column
189 - Use correct pipe path
, which includes pid
190 - Use correct structure size
for dentries and extended logging
191 - Do not
set name
for main process
193 * Sun Mar
13 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.2-1
194 - Use exactly specified
in config socket family
195 - Obsolete srw by ellipitcs
196 - Revert "Use X bits from operation key to find a lock instead of random hashing"
197 - Added proper sigchild handling
198 - spec update
- added libsrw.so
* files
199 - Dropped srw dependancy
201 * Sun Mar
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.1-1
204 * Wed Feb
29 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.12.0.1-1
205 - Depend on
0.15 eblob
: added new defragmentation parameters into config
206 - Propagate prepare_write
() and friends
return values back to callers
- changed API
208 * Sun Feb
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.7-1
209 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
210 - Updated python scripts to use new eblob class
211 - exec is reserved name
in python
, use exec_script
for execution method name
213 * Thu Feb
16 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.6-1
214 - Added possibility to
read metadata from file and dump to log
215 - Added remove_keys_from_storage_found_removed_in_eblob.py
216 - Added
local merge iterator written
in python. Is not optimal
, but quite fast.
218 * Tue Feb
14 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.5-1
219 - Execute CHECK commands with NOLOCK flag
221 * Sat Feb
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.4-1
222 - Use correct eblob path
for statvfs
() request
224 * Mon Feb
8 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.3-1
225 - Set id.
type to
0 where appropriate
226 - Request statistics with DNET_ATTR_NOLOCK flag
set
227 - Fixed pohmelfs_rename.py
229 * Mon Feb
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.2-1
230 - Process checksum flags according to aflags and ioflags
232 * Wed Feb
1 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.1-1
233 - Added start
/num parameters to iterate over selected number of blobs.
234 - Depend on
0.14.1 blob and higher where it is implemented.
236 * Thu Jan
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.15-1
237 - Added readdir script
238 - Dropped content length manipulation from srw
/pohmelfs_inode_info_insert.py
239 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
241 * Tue Jan
24 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.14-1
242 - Reserve some space
for directory content
243 - Added pohmelfs_read_latest_groups.py script
244 - Implemented prepare
-latest helper
, which returns timestamp sorted groups which contain requested id
245 - If we have more data to send
, set only DNET_FLAGS_MORE flag
, not erase others
246 - Rename cpp bindings
247 - Fixed range requests without limits
249 * Tue Jan
17 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.13-1
250 - Sort keys on server side
in range requests
251 - Disable eblob_gen
for now
252 - Address new binutils issues
(gcc
4.6 compilation fixes
)
254 * Wed Dec
21 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.12-1
255 - Trying to address new binutils issues
256 - Fill with zeroes all io threads structures
257 - Set io.num to content size
+offset
in write_data_wait
() - it allows to use prepare
/commit flags
259 * Tue Dec
20 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.11-1
260 - Implemented check
for start
/stop update timestamp
261 - Added cache tests
in test.cpp
263 * Thu Dec
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.10-1
264 - Added configurable two
-queue cache
for read data by Anton Kortunov
<toshic.toshic@gmail.com
>
266 * Mon Dec
12 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.9-1
267 - Reopen log file on sighup
269 * Fri Dec
9 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.8-1
270 - Set DNET_FLAGS_NOLOCK
for route
/reverse lookup request
/reply commands
271 - Added memory_test_pohmelfs
() autotest
272 - Added gc calls into pohmelfs methods
273 - Fixed exception string generation
for null ids
274 - Added small memory
/leak
test
276 * Fri Dec
2 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.7-1
277 - Use eblob_read_nocsum
() if DNET_IO_FLAGS_NOCSUM is
set
279 * Thu Dec
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.6-1
280 - Cleanup unused variables
281 - Fixed reply cmd
->flags initialization
282 - Use boost
::filesystem v2
283 - Fixes
in bulk_read and bulk_write
285 * Mon Nov
28 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.5-1
286 - Implemented pool of non
-blocking threads
for recursive commands.
287 - Dropped metadata csum support
in favour of eblob embedded checksums.
288 - Added bulk_write operation.
289 - Added sstable parser into python module
291 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.4-1
292 - Added nolocking IO thread
294 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.3-1
295 - Added oplock_num config parameter
296 - Added non
-blocking thread checks
298 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.2-1
299 - Aflags
/lock cleanups
301 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.1-1
302 - Added operations locks. Now all commands are processed with single
-machine
-atomicity
303 - Added server
-side scripts
305 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.13-1
306 - Only perform blob write
if io
->size is not zero
308 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.12-1
309 - Initialize srw after node
311 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.11-1
312 - Do not chroot into
history environment
, since it is most likely incomplete
314 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.10-1
315 - Do not csum
read when DNET_IO_FLAGS_NOCSUM ioflag is
set
316 - When doing partial
read, checksum whole file
318 * Sat Nov
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.9-1
320 - Return
-ENOTSUP
if srw is not initialized
321 - Do not reset join state to RECONNECT after it has been created
322 - Added stall_count as a configurable parameter
323 - Added BULK_READ
command
325 * Tue Nov
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.8-1
326 - Fixed range counters
327 - Added
::remove
() methods into python binding
328 - Remove all types
if -1 as id
->type is specified
329 - RHEL build must depend on eblob
-devel
>= 0.12.18 libsrw
-devel
>= 0.2.2
331 * Mon Nov
14 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.7-1
332 - Moved some objects from interface.h to packet.h
333 - Added range counters
334 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
335 - Use IP_TOS instead of SO_PRIORITY to
set tos bits
336 - srw is called libsrw
in rhel builds
337 - Depend on
0.12.18 eblob and
0.2.2 srw
339 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.6-1
340 - Depend on
0.2.1 srw and higher
342 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.5-1
343 - Added binary data support
in srw
345 * Tue Nov
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.4-1
346 - Do not fail node initialization
if srw is not initialized
348 * Mon Oct
31 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.3-1
349 - blob_send modified to send all columns
if id.
type == -1
350 - Do not depend elliptics build on libssl
351 - eblob
/srw autoconf updates
352 - Do not
return 1 from blob_write when data was compressed
, return 0, since
355 * Tue Oct
25 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.2-1
356 - Added srw dependency
357 - Do not call dnet_convert_io_attr
for DNET_CMD_DEL
command
359 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.1-1
360 - Decreased WRITE latency
361 - Use CORK
for write blocks
363 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.0-1
364 - Added ioprio call inside check
365 - More example ioserv.conf comments
366 - Added client
/server network priorities
(man
7 socket
-> IP_PRIORITY
)
368 * Sat Oct
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.9-1
369 - Fixed memory allocation
in range
-delete
371 * Tue Oct
11 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.7-1
372 - Only
set BLOB_DISK_CTL_NOCSUM
if DNET_IO_FLAGS_NOCSUM is
set
373 - Added dnet_get_routes
function
374 - Added server
-side scripting support
375 - Example ioserv.conf update
378 * Thu Dec
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.2-1
379 - Implemented multiple
read in elliptics core and FCGI frontend.
380 - Implemented very user
-friendly C
++/Python interface.
381 - Extended FCGI xml output
for POST request
: added data crc
, size
,
382 per
-group addresses and path to the destination object on file backend.
384 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.1-1
385 - Documentation update.
387 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.8-1
388 - Fixed fcgi reading with new groups URI.
390 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.7-1
391 - Implemented automatic groups selection by free space.
394 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.6-1
395 - Fixed eblob_send
().
396 - Use
50 check threads.
398 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.5-1
399 - Multi
-threaded fsck.
400 - Bug fixes
(including
2.9.4.4 version
).
402 * Thu Nov
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.3-1
403 - Implemented bdb fsck
(both merge and copy check
).
405 * Thu Nov
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.2-1
406 - Switched to random ids
(1024 ids are generated at first start
)
408 * Fri Nov
19 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.1-1
409 - Switched to new addressing model
411 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.14-1
412 - Remove direct object
if it can not be uploaded to the storage.
414 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.13-1
415 - Remove empty
/broken
history objects during merge.
417 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.12-1
418 - Added more debug about processed objects
in fsck tools.
419 - Delete directly
read object
if its
history can not be mapped.
420 - Return error from dnet_merge_direct
() when merge falls back to direct
421 merge during common merge.
423 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.11-1
424 - Attempt to
do direct merge when we can not parse non
-direct
history stored
in main storage.
426 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.10-1
427 - Fixed bit directory generation
in file_backend_get_dir_bits
()
429 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.9-1
430 - Fixed state leak
in lookup processing.
432 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.8-1
433 - Always use
local address
for succeeded
local lookup.
435 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.7-1
436 - Kill state when check thread got error.
(7)
437 - Extended fire
time debug.
(6)
439 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.5-1
440 - Update transaction fire
time to include check timeout.
442 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.4-1
443 - Extend dnet_send_read_data
() to get offset from parameters and
do not abuse dnet_io_attr structure.
445 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.3-1
446 - Unmap
history after selecting transaction with the last update
time in dnet_merge_get_latest_transactions
()
448 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
449 - Added full object ID dump and request error.
450 - Exit merge early
if no id file was provided.
451 - Do not dereference state
in dnet_read_complete
() if it is NULL.
452 - Added
-N
(do not request ids and use prevously downloaded
) option comment into fsck
help.
454 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
455 - Extended alloc
/free debug.
456 - Allow zero
-sized writes.
458 * Wed Oct
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3-1
459 - New minor release. No changes from
2.9.2.32.
461 * Mon Oct
11 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.32-1
462 - Added configurable value to check header
for remote node IP address.
463 - Added joining client check
: returned address must be reachable to be
464 inserted into route table.
466 * Fri Oct
8 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.31-1
469 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.29-1
470 - Added id
-by
-LA generation and sorting.
473 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.28-1
474 - Added timed statistics request which also works as timed connection checker.
475 - Added seconds
-only check
time wait.
477 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.27-1
478 - Added keep
-alive options.
480 * Mon Oct
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.26-1
481 - Unlink transaction and
history after direct merge.
482 - Do not log error when state is NULL
in completion callback.
484 * Sat Oct
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.25-1
485 - Added norequest flag to fsck util
(will use existing file
).
486 - Fixed remotes processing typo.
488 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.24-1
489 - Do not traverse the whole transaction tree after we found the
490 first one which fire
time has not yet elapsed.
492 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.23-1
493 - Remove io_thread_num and max_pending config parameters.
494 - Added stack size parameter to check tools.
496 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.22-1
497 - Moved transaction debug output into the place where it can not dereference stale data.
498 - Decrease debug level
for allocations.
499 - Added addrinfo null check. Should be useless though.
501 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.21-1
502 - Do not dereference null state
in dnet_fcgi_read_complete.
504 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.20-1
505 - Added thread stack size parameter.
506 - Added malloc mmap threshold config parameter.
(19)
508 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.18-1
509 - Really fixed recv state transaction processing leak.
511 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.16-1
512 -Do not try to dereferece null state. Happens when transaction is completed
514 - Use lineary
(+60 seconds each turn
) growing reconnection timeout. Added
515 reconnection limit of
1 day.
516 - Fixed recv state transaction processing leak.
518 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.15-1
519 - Compilation typo fixed.
521 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.14-1
522 - Fill all allocated memory with zeroes.
524 * Thu Sep
16 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.13-1
525 - Put transaction after it was executed. Its refcnt was increased during
527 - Do not try to dereference state when it can be null.
528 - Do not create unneded listening state when node does not join network.
(12)
529 - Reset accept state on error.
530 - Do not join to states
in state lists
, since they can be freed
in own
532 - Drop transaction resending support.
(10)
533 - Extended
local command processing log.
(9)
534 - Also print pid
in common logger.
(8)
535 - Use pthread_self
() instead of getpid
() to get uniq thread id.
(7)
537 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.6-1
538 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was
set for read command, do not
539 send data reply. Used
in local stat
command.
541 - From previous releases
:
542 Do not deal with NULL transactions.
543 Start state IO thread after state initialization.
544 Join to io state thread instead of freeing it directly.
545 Do not
exit from accept loop on error.
546 Initialize state list entry prior other usage.
548 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2-1
549 - Switched from libevent state machine to thread
-per
-client model.
551 * Fri Aug
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1.1-1
552 - Added DNET_FCGI_PUT_REGION config option to optionally
enable region tag
553 - Added wildcard direct download pattern
(*)
554 - Force direct download patterns to be checked against ID ending and
555 just by having this substring somewhere
in the query.
557 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1-1
558 - New elliptics network release
: 2.9.1
560 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.31-1
562 - Fixed resend locking bug.
564 * Mon Aug
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.30-1
565 - Fixed lock
/unlock typo
in dnet_data_ready
().
567 * Sat Aug
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.29-1
568 - Refactor fcgi logging
(29)
569 - Return
read error when key was not found. Use right config file options.
(28)
571 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.27-1
572 - Added sanity checks
for embedded reading.
574 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.26-1
575 - Disabled per
-client statistics request
in fcgi daemon.
576 - Added subtle timeout and data rewrite when FCGX_PutStr
() returns error.
578 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.25-1
579 - Copy resolved address into buffer
(later used
for reconnection
)
580 before trying to connect.
582 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.24-1
583 - Refactor fcgi
/check loggers to write pid
/thread id into single log file.
585 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.23-1
586 - Added
<region
> tag into download
-info XML output
587 - Changed sending locking.
589 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.22-1
590 - Guard multiple 'logical' xml writes against parallel write
592 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.21-1
593 - Implemented direct transaction merge.
594 - If reading size was
set to
0 map ~
0ULL size
, i.e. the whole file.
595 - Remove object from the storage
if its
history log says so.
596 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
597 DNET_FCGI_EMBED_PATTERN option.
599 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.20-1
600 - Fixed several fd leaks.
602 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.19-1
603 - Unmap
history file when failed to
read transaction.
605 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.18-1
606 - Guard OpenSSL_add_all_digests
() and initialize it only once per thread
608 - Force dnet_check_process_request
() to
wait for all sent transactions
, do
609 not wakeup after receiving reply from the first one.
611 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.17-1
612 - Fixed compilation warnings on
64bit platform
(uint64_t to unsigned long
613 long and void
* to unsigned long
)
614 - Try only requested transformation
function, do not
continue with the next
616 - Use errno to differentiate reconnection state.
618 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.15-1
619 - Made elliptics depend on eblob
620 - Updated checker's logger.
621 - Increase example
/check
/common.c waiting timeout.
622 - Added logs into file io backend listing processor.
624 * Sun Jul
26 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.12-1
625 - Let check applications to sleep longer waiting
for replies.
626 - Reduce number of ids sent via DNET_CMD_LIST
command to
1024 per reply.
627 - Mark states added via dnet_add_state
() as reconnect
-friendly.
628 - Do not add reconnection addresses which
do not have joining flags.
629 - Updated to the latest eblob lib
(moved blob code outside to libeblob
).
630 - Reschedule transaction's fire
time when
(non
-last
) reply is received.
631 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
633 * Sun Jul
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.11-1
634 - Added embedded URI parameter
, which will force timestamp to be embedded
635 with data. It is possible to embed other parameters too.
637 post
: wget
-O
/tmp
/1111 -S
--post
-file
=elliptics.spec
638 "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
×tamp
=123"
640 get
: wget
-O
/tmp
/1111 -S
--header
="If
-Modified
-Since
: Thu
, 01 Jan
1970
641 00:02:00 GMT" "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
&direct
=1"
642 - fixed random
hash selection
in fcgi frontend.
644 * Fri Jul
23 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.10-1
645 -return back addressing magic^W logic
in dnet_write_object_raw
()
647 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.9-1
648 - return back virtual datacenters.
650 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.8-1
651 - BLOB IO backend updates
(multiple threads
, index
, bug fixes
).
652 - file IO backend fixes
656 * Mon Jul
19 2010 Arkady L. Shane
<ashejn@yandex
-team.ru
> - 2.9.0.7-1
657 - initial build
for Fedora