3 include /usr
/share
/cdbs
/1/rules
/debhelper.mk
4 include /usr
/share
/cdbs
/1/class
/cmake.mk
6 DEB_CMAKE_EXTRA_FLAGS
:= -DCMAKE_BUILD_TYPE
=RelWithDebInfo
8 DEB_DH_STRIP_ARGS
:= --dbg-package
=elliptics-dbg
9 DEB_DH_MAKESHLIBS_ARGS_elliptics
:= -V
"elliptics (>= $(shell head -n1 debian/changelog | sed -e 's/.*[(]//' | sed -e 's/[)].*//' | tr -d '\n' | cut -d . -f 1-3))"
10 DEB_DH_MAKESHLIBS_ARGS_elliptics-client
:= -V
"elliptics-client (>= $(shell head -n1 debian/changelog | sed -e 's/.*[(]//' | sed -e 's/[)].*//' | tr -d '\n' | cut -d . -f 1-3))"
11 DEB_COMPRESS_EXCLUDE
:= .conf
13 DEB_PYTHON_SYSTEM
:= pycentral
14 DEB_PYTHON_MODULE_PACKAGES
:= elliptics-client
15 export DH_PYCENTRAL
=nomove
17 DEB_PYTHON_INSTALL_ARGS_ALL
= --install-layout
=deb
--install-lib
=`python -c "from distutils import sysconfig; print sysconfig.get_python_lib(),"`
18 include /usr
/share
/cdbs
/1/class
/python-distutils.mk
20 include /usr
/share
/cdbs
/1/class
/python-module.mk
22 binary-install
/elliptics-client
::
23 cp bindings
/python
/*.py
$(DEB_BUILDDIR
)/bindings
/python
/
24 mv
$(cdbs_python_destdir
)/usr
/lib
/python
*/site-packages
/* $(cdbs_python_destdir
)/..
/elliptics-client
/`python -c "from distutils import sysconfig; print sysconfig.get_python_lib(),"`/; echo
-n
25 rm -rf
$(cdbs_python_destdir
)/usr
/lib
/python
*/site-packages
; echo
-n
28 binary-post-install
/elliptics-client
::
29 rm debian
/elliptics-client
/usr
/bin
/dnet_ioserv