ThirdParty:: new compilation recipe for gcc 4.9.2 and 4.8.4
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / libccmio-2.6.1.spec
blob99d84a05fccf4ce4c7671c99199b3a90cb06508f
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for libccmio-2.6.1
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Author:
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package %{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath %{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 # regenerate the RPM.
61 %define _prefix %{_WM_THIRD_PARTY_DIR}
63 %define name libccmio
64 %define release %{_WM_OPTIONS}
65 %define version 2.6.1
67 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
70 Summary: libccmio
71 License: Unkown
72 Name: %{name}
73 Version: %{version}
74 Release: %{release}
75 URL: https://wci.llnl.gov/codes/visit/3rd_party
76 Source: %url/%{name}-%{version}.tar.gz
77 Prefix: %{_prefix}
78 Group: Development/Tools
79 Patch0: libccmio-2.6.1.patch_0
81 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
83 %description
84 %{summary}
86 %prep
87 %setup -q
88 %patch0 -p1
90 %build
91 [ -n "$WM_CC" ] && export CC="$WM_CC"
92 [ -n "$WM_FC" ] && export FC="$WM_FC"
93 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
94 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
95 [ -n "$WM_FCFLAGS" ] && export FCFLAGS="$WM_FCFLAGS"
96 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
97 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
98 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
100 %ifos darwin
101 # Missing configuration files for Mac OS X
102 [ ! -d config/i386-apple-darwin10 ] && cp -r config/i386-apple-darwin8 config/i386-apple-darwin10
103 [ ! -d config/i386-apple-darwin11 ] && cp -r config/i386-apple-darwin8 config/i386-apple-darwin11
104 [ ! -d config/i386-apple-darwin12 ] && cp -r config/i386-apple-darwin8 config/i386-apple-darwin12
105 [ ! -d config/i386-apple-darwin13 ] && cp -r config/i386-apple-darwin8 config/i386-apple-darwin13
106 %endif
107 # Warning:
108 # 1: The name of the ADF library will be renamed to libadf_ccmio since this
109 # is an old version of ADF, and the author modified the source code
110 # 2: The name of the CGNS library will be renamed to libcgns_ccmio as well
111 # since this is an old version of CGNS.
113 # This way, the libraries libadf_ccmio and libcgns_ccmio will not get in
114 # conflict with any other packages that might depend on a newer version
115 # of libadf or libcgns
117 unset RELEASE
118 unset DEBUG
119 unset STATIC
120 unset SHARED
121 if [ -d libadf ]; then ( cd libadf; RELEASE=1 SHARED=1 make -f Makefile.qmake all; ) fi
122 if [ -d libccmio ]; then ( cd libccmio; RELEASE=1 SHARED=1 make -f Makefile.qmake all; ) fi
124 # We don't need libcgns_ccmio. We keep it here as a reference
125 #if [ -d libcgns ]; then cd libcgns; RELEASE=1 SHARED=1 make -f Makefile.qmake all; fi
127 %install
128 # Manual installation
129 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include/libccmio
130 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/lib
131 libsdir=`find ./lib -name release-shared`
132 mv ${libsdir}/* $RPM_BUILD_ROOT/%{_installPrefix}/lib
133 cp libccmio/*.h $RPM_BUILD_ROOT/%{_installPrefix}/include/libccmio
135 # Creation of foam-extend specific .csh and .sh files"
137 echo ""
138 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
139 echo ""
141 # Generate package specific .sh file for foam-extend
143 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
144 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
145 # Load %{name}-%{version} libraries and binaries if available
146 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
148 export LIBCCMIO_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
149 export LIBCCMIO_BIN_DIR=\$LIBCCMIO_DIR/bin
150 export LIBCCMIO_LIB_DIR=\$LIBCCMIO_DIR/lib
151 export LIBCCMIO_INCLUDE_DIR=\$LIBCCMIO_DIR/include
153 # Enable access to the package runtime applications and libraries
154 [ -d \$LIBCCMIO_BIN_DIR ] && _foamAddPath \$LIBCCMIO_BIN_DIR
155 [ -d \$LIBCCMIO_LIB_DIR ] && _foamAddLib \$LIBCCMIO_LIB_DIR
157 DOT_SH_EOF
160 # Generate package specific .csh file for foam-extend
162 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
163 # Load %{name}-%{version} libraries and binaries if available
164 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
165 setenv LIBCCMIO_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
166 setenv LIBCCMIO_BIN_DIR \$LIBCCMIO_DIR/bin
167 setenv LIBCCMIO_LIB_DIR \$LIBCCMIO_DIR/lib
168 setenv LIBCCMIO_INCLUDE_DIR \$LIBCCMIO_DIR/include
170 if ( -e \$LIBCCMIO_BIN_DIR ) then
171 _foamAddPath \$LIBCCMIO_BIN_DIR
172 endif
174 if ( -e \$LIBCCMIO_LIB_DIR ) then
175 _foamAddLib \$LIBCCMIO_LIB_DIR
176 endif
177 DOT_CSH_EOF
179 #finally, generate a .tgz file for systems where using rpm for installing packages
180 # as a non-root user might be a problem.
181 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
184 %clean
185 rm -rf %{buildroot}
187 %Files
188 %defattr(-,root,root)
189 %{_installPrefix}/*