ThirdParty:: new compilation recipe for gcc 4.9.2 and 4.8.4
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / mesquite-2.1.2.spec
blob2441aabb4a7bd78a149168a20310f78da2a586b0
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for mesquite-2.1.2
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Author:
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 # Contributor:
34 # Philippose Rajan : patch0 for gcc 4.6.x
36 #------------------------------------------------------------------------------
38 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
39 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
40 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
42 # Disable the generation of debuginfo packages
43 %define debug_package %{nil}
45 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
46 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
47 %define _tmppath %{_topdir}/tmp
49 # Will install the package directly $WM_THIRD_PARTY_DIR
50 # Some comments about package relocation:
51 # By using this prefix for the Prefix: parameter in this file, you will make this
52 # package relocatable.
54 # This is fine, as long as your software is itself relocatable.
56 # Simply take note that libraries built with libtool are not relocatable because the
57 # prefix we specify will be hard-coded in the library .la files.
58 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
60 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
61 # not be able to reutilize this RPM, even though it is relocatable. You will need to
62 # regenerate the RPM.
64 %define _prefix %{_WM_THIRD_PARTY_DIR}
66 %define name mesquite
67 %define release %{_WM_OPTIONS}
68 %define version 2.1.2
70 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
72 BuildRoot: %{buildroot}
73 Summary: mesquite
74 License: Unkown
75 Name: %{name}
76 Version: %{version}
77 Release: %{release}
78 URL: http://downloads.sourceforge.net/project/openfoam-extend/foam-extend-3.0/ThirdParty/
79 Source: %url/%{name}-%{version}.tar.gz
80 Prefix: %{_prefix}
81 Group: Development/Tools
82 Patch0: mesquite-2.1.2_patch0
84 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
86 %description
87 %{summary}
89 %prep
90 %setup -q
92 %patch0 -p1
94 %build
95 # export WM settings in a form that GNU configure recognizes
96 [ -n "$WM_CC" ] && export CC="$WM_CC"
97 [ -n "$WM_FC" ] && export FC="$WM_FC"
98 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
99 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
100 [ -n "$WM_FCFLAGS" ] && export FCFLAGS="$WM_FCFLAGS"
101 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
102 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
104 ./configure \
105 --prefix=%{_installPrefix} \
106 --libdir=%{_installPrefix}/lib \
107 --enable-release \
108 --disable-debug-assertions \
109 --disable-igeom \
110 --disable-imesh \
111 --disable-irel \
112 --enable-shared \
113 --without-cppunit \
114 --enable-trap-fpe \
115 --disable-function-timers
117 # Remove the file include/Mesquite_all_headers.hpp
118 # This file will be regenerated during the compilation process
119 [ -e include/Mesquite_all_headers.hpp ] && rm -f include/Mesquite_all_headers.hpp
121 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
122 make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -mtune=native -fPIC"
124 %install
125 make install DESTDIR=$RPM_BUILD_ROOT
127 # Creation of foam-extend specific .csh and .sh files"
129 echo ""
130 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
131 echo ""
133 # Generate package specific .sh file for foam-extend
135 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
136 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
137 # Load %{name}-%{version} libraries and binaries if available
138 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
140 export MESQUITE_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
141 export MESQUITE_BIN_DIR=\$MESQUITE_DIR/bin
142 export MESQUITE_LIB_DIR=\$MESQUITE_DIR/lib
143 export MESQUITE_INCLUDE_DIR=\$MESQUITE_DIR/include
145 # Enable access to the package runtime applications and libraries
146 [ -d \$MESQUITE_BIN_DIR ] && _foamAddPath \$MESQUITE_BIN_DIR
147 [ -d \$MESQUITE_LIB_DIR ] && _foamAddLib \$MESQUITE_LIB_DIR
148 DOT_SH_EOF
151 # Generate package specific .csh file for foam-extend
153 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
154 # Load %{name}-%{version} libraries and binaries if available
155 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
156 setenv MESQUITE_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
157 setenv MESQUITE_BIN_DIR \$MESQUITE_DIR/bin
158 setenv MESQUITE_LIB_DIR \$MESQUITE_DIR/lib
159 setenv MESQUITE_INCLUDE_DIR \$MESQUITE_DIR/include
161 if ( -e \$MESQUITE_BIN_DIR ) then
162 _foamAddPath \$MESQUITE_BIN_DIR
163 endif
165 if ( -e \$MESQUITE_LIB_DIR ) then
166 _foamAddLib \$MESQUITE_LIB_DIR
167 endif
168 DOT_CSH_EOF
170 #finally, generate a .tgz file for systems where using rpm for installing packages
171 # as a non-root user might be a problem.
172 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
175 %clean
176 rm -rf %{buildroot}
178 %files
179 %defattr(-,root,root)
180 %{_installPrefix}