ThirdParty:: new compilation recipe for gcc 4.9.2 and 4.8.4
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / openmpi-1.5.spec
blob5452dba6e4deea83541ed6c7fdcbb9a00c19df48
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for openmpi-1.5
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Author:
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package %{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath %{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 # regenerate the RPM.
61 %define _prefix %{_WM_THIRD_PARTY_DIR}
63 %define name openmpi
64 %define release %{_WM_OPTIONS}
65 %define version 1.5
67 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
70 Summary: openmpi
71 License: Unkown
72 Name: %{name}
73 Version: %{version}
74 Release: %{release}
75 URL: http://www.open-mpi.org/software/ompi/v1.5/downloads
76 Source: %url/%{name}-%{version}.tar.gz
77 Prefix: %{_prefix}
78 Group: Development/Tools
81 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
83 %description
84 %{summary}
86 %prep
87 %setup -q
89 %build
90 # export WM settings in a form that GNU configure recognizes
91 [ -n "$WM_CC" ] && export CC="$WM_CC"
92 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
93 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
94 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
95 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
97 unset mpiWith
98 # enable GridEngine if it appears to be in use
99 if [ -n "$SGE_ROOT" ]
100 then
101 mpiWith="$mpiWith --with-sge"
102 else
103 mpiWith="$mpiWith --without-sge"
104 mpiWith="$mpiWith --enable-mca-no-build=ras-gridengine,pls-gridengine"
107 # Infiniband support
108 # if [ -d /usr/local/ofed -a -d /usr/local/ofed/lib64 ]
109 # then
110 # mpiWith="$mpiWith --with-openib=/usr/local/ofed"
111 # mpiWith="$mpiWith --with-openib-libdir=/usr/local/ofed/lib64"
112 # fi
114 ./configure \
115 --prefix=%{_installPrefix} \
116 --exec_prefix=%{_installPrefix} \
117 --disable-mpirun-prefix-by-default \
118 --disable-orterun-prefix-by-default \
119 --enable-shared --disable-static \
120 --disable-mpi-f77 \
121 --disable-mpi-f90 \
122 --disable-mpi-cxx \
123 --without-slurm \
124 --disable-mpi-profile \
125 $mpiWith \
128 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
129 make -j $WM_NCOMPPROCS
131 %install
132 make install DESTDIR=$RPM_BUILD_ROOT
134 # Creation of foam-extend specific .csh and .sh files"
136 echo ""
137 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
138 echo ""
140 # Generate package specific .sh file for foam-extend
142 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
143 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
144 # Load %{name}-%{version} libraries and binaries
145 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
146 export OPENMPI_DIR=\$WM_THIRD_PARTY_DIR/packages/openmpi-1.5/platforms/\$WM_OPTIONS
147 export OPENMPI_BIN_DIR=\$OPENMPI_DIR/bin
148 export OPENMPI_LIB_DIR=\$OPENMPI_DIR/lib
150 # Enable access to the package runtime applications and libraries
151 [ -d \$OPENMPI_BIN_DIR ] && _foamAddPath \$OPENMPI_BIN_DIR
152 [ -d \$OPENMPI_LIB_DIR ] && _foamAddLib \$OPENMPI_LIB_DIR
154 export MPI_HOME=\$OPENMPI_DIR
155 export MPI_ARCH_PATH=\$MPI_HOME
156 export OPAL_PREFIX=\$MPI_ARCH_PATH
158 # We initialize the rest of the environment using mpicc --showme:
159 export OPENMPI_INCLUDE_DIR="\`mpicc --showme:incdirs\`"
160 export OPENMPI_COMPILE_FLAGS="\`mpicc --showme:compile\`"
161 export OPENMPI_LINK_FLAGS="\`mpicc --showme:link\`"
163 # Set the foam-extend compilation flags
164 export PINC=\$OPENMPI_COMPILE_FLAGS
165 export PLIBS=\$OPENMPI_LINK_FLAGS
168 if [ "\$FOAM_VERBOSE" -a "\$PS1" ]
169 then
170 echo " Environment variables defined for OpenMPI:"
171 echo " OPENMPI_BIN_DIR : \$OPENMPI_BIN_DIR"
172 echo " OPENMPI_LIB_DIR : \$OPENMPI_LIB_DIR"
173 echo " OPENMPI_INCLUDE_DIR : \$OPENMPI_INCLUDE_DIR"
174 echo " OPENMPI_COMPILE_FLAGS : \$OPENMPI_COMPILE_FLAGS"
175 echo " OPENMPI_LINK_FLAGS : \$OPENMPI_LINK_FLAGS"
176 echo ""
177 echo " MPI_HOME : \$MPI_HOME"
178 echo " MPI_ARCH_PATH : \$MPI_ARCH_PATH"
179 echo " OPAL_PREFIX : \$OPAL_PREFIX"
180 echo " PINC : \$PINC"
181 echo " PLIBS : \$PLIBS"
183 DOT_SH_EOF
186 # Generate package specific .csh file for foam-extend
188 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
189 # Load %{name}-%{version} libraries and binaries
190 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
191 setenv OPENMPI_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
192 setenv OPENMPI_BIN_DIR \$OPENMPI_DIR/bin
193 setenv OPENMPI_LIB_DIR \$OPENMPI_DIR/lib
195 # Enable access to the package runtime applications and libraries
196 if ( -e \$OPENMPI_BIN_DIR ) then
197 _foamAddPath \$OPENMPI_BIN_DIR
198 endif
200 if ( -e \$OPENMPI_LIB_DIR ) then
201 _foamAddLib \$OPENMPI_LIB_DIR
202 endif
204 setenv MPI_HOME \$OPENMPI_DIR
205 setenv MPI_ARCH_PATH \$MPI_HOME
206 setenv OPAL_PREFIX \$MPI_ARCH_PATH
208 # We initialize the rest of the environment using mpicc --showme:
209 setenv OPENMPI_INCLUDE_DIR "\`mpicc --showme:incdirs\`"
210 setenv OPENMPI_COMPILE_FLAGS "\`mpicc --showme:compile\`"
211 setenv OPENMPI_LINK_FLAGS "\`mpicc --showme:link\`"
213 # Set the foam-extend compilation flags
214 setenv PINC \`echo \$OPENMPI_COMPILE_FLAGS\`
215 setenv PLIBS \`echo \$OPENMPI_LINK_FLAGS\`
218 if (\$?FOAM_VERBOSE && \$?prompt) then
219 echo " Environment variables defined for OpenMPI:"
220 echo " OPENMPI_BIN_DIR : \$OPENMPI_BIN_DIR"
221 echo " OPENMPI_LIB_DIR : \$OPENMPI_LIB_DIR"
222 echo " OPENMPI_INCLUDE_DIR : \$OPENMPI_INCLUDE_DIR"
223 echo " OPENMPI_COMPILE_FLAGS : \$OPENMPI_COMPILE_FLAGS"
224 echo " OPENMPI_LINK_FLAGS : \$OPENMPI_LINK_FLAGS"
225 echo ""
226 echo " MPI_HOME : \$MPI_HOME"
227 echo " MPI_ARCH_PATH : \$MPI_ARCH_PATH"
228 echo " OPAL_PREFIX : \$OPAL_PREFIX"
229 echo " PINC : \$PINC"
230 echo " PLIBS : \$PLIBS"
231 endif
232 DOT_CSH_EOF
234 #finally, generate a .tgz file for systems where using rpm for installing packages
235 # as a non-root user might be a problem.
236 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
239 %clean
240 rm -rf %{buildroot}
242 %files
243 %defattr(-,root,root)
244 %{_installPrefix}/*