1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for ParMGridGen-1.0
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
63 %define name ParMGridGen
64 %define release
%{_WM_OPTIONS}
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
75 URL: http
://www.mgnet.org
/mgnet
/Codes
/parmgridgen
76 Source: %url/%{name}-%{version}.tar.gz
78 Group: Development
/Tools
79 Patch0: ParMGridGen
-1.0.patch_darwin
80 Patch1: ParMGridGen
-1.0.patch
82 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
97 [ -n "$WM_CC"
] && export CC
="$WM_CC"
98 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
99 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
100 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
101 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
102 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
104 make -j $WM_NCOMPPROCS CC
=$CC
107 # Manual installation
108 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/include
/Lib
109 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/include
/IMlib
110 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/lib
112 cp .
/MGridGen
/Lib
/*.h $RPM_BUILD_ROOT
/%{_installPrefix}/include
/Lib
113 cp .
/MGridGen
/IMlib
/*.h $RPM_BUILD_ROOT
/%{_installPrefix}/include
/IMlib
115 cp .
/MGridGen
/IMlib
/libIMlib.
* $RPM_BUILD_ROOT
/%{_installPrefix}/lib
116 cp .
/MGridGen
/Lib
/libMGridGen.
* $RPM_BUILD_ROOT
/%{_installPrefix}/lib
118 # Creation of foam-extend specific .csh and .sh files"
121 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
124 # Generate package specific .sh file for foam-extend
126 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
127 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
128 # Load %{name}-%{version} libraries and binaries if available
129 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
131 export PARMGRIDGEN_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
132 export PARMGRIDGEN_BIN_DIR
=\$PARMGRIDGEN_DIR
/bin
133 export PARMGRIDGEN_LIB_DIR
=\$PARMGRIDGEN_DIR
/lib
134 export PARMGRIDGEN_INCLUDE_DIR
=\$PARMGRIDGEN_DIR
/include
136 # Enable access to the runtime package applications and libraries
137 [ -d \$PARMGRIDGEN_BIN_DIR
] && _foamAddPath \$PARMGRIDGEN_BIN_DIR
138 [ -d \$PARMGRIDGEN_LIB_DIR
] && _foamAddLib \$PARMGRIDGEN_LIB_DIR
142 # Generate package specific .csh file for foam-extend
144 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
145 # Load %{name}-%{version} libraries and binaries if available
146 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
147 setenv PARMGRIDGEN_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
148 setenv PARMGRIDGEN_BIN_DIR \$PARMGRIDGEN_DIR
/bin
149 setenv PARMGRIDGEN_LIB_DIR \$PARMGRIDGEN_DIR
/lib
150 setenv PARMGRIDGEN_INCLUDE_DIR \$PARMGRIDGEN_DIR
/include
152 if ( -e \$PARMGRIDGEN_BIN_DIR
) then
153 _foamAddPath \$PARMGRIDGEN_BIN_DIR
156 if ( -e \$PARMGRIDGEN_LIB_DIR
) then
157 _foamAddLib \$PARMGRIDGEN_LIB_DIR
161 #finally, generate a .tgz file for systems where using rpm for installing packages
162 # as a non-root user might be a problem.
163 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
170 %defattr(-,root
,root
)
171 %{_installPrefix}/include
172 %{_installPrefix}/lib
/*
173 %{_installPrefix}/etc
/*