1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for ParaView-3.12.0
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2012)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
64 %define release
%{_WM_OPTIONS}
65 %define version
3.12.0
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
75 URL: http
://www.paraview.org
/files
/v3.12
/
76 Source: %url/%{name}-%{version}.tar.gz
78 Group: Development
/Tools
79 Patch0: ParaView
-3.12.0.patch_darwin
80 Patch1: paraview
-gcc47.patch
82 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
84 #--------------------------------------------------------------------------
86 # Here, we define default compiling options for cmake
88 # One can override the option on the commande line : --define='MACRO EXPR'
90 %{!?_withVerbose: %define _withVerbose false}
91 %{!?_withMesa: %define _withMesa false}
92 %{!?_withMPI: %define _withMPI true}
93 %{!?_withPython: %define _withPython true}
94 %{!?_withQt: %define _withQt true}
95 %{!?_qmakePath: %define _qmakePath Undefined}
96 %{!?_mesaIncludePath: %define _mesaIncludePath Undefined}
97 %{!?_mesaLibPath: %define _mesaLibPath Undefined}
98 %{!?_pythonLibPath: %define _pythonLibPath Undefined}
100 #--------------------------------------------------------------------------
116 # set CMake cache variables
122 CMAKE_VARIABLES
="$CMAKE_VARIABLES
-D$
1"
127 # export WM settings in a form that GNU configure recognizes
128 [ -n "$WM_CC"
] && export CC
="$WM_CC"
129 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
130 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
131 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
132 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
136 echo "Compilation options
:"
137 echo " _withVerbose
: %{_withVerbose}"
138 echo " _withMesa
: %{_withMesa}"
139 echo " _withMPI
: %{_withMPI}"
140 echo " _withPython
: %{_withPython}"
141 echo " _withQt
: %{_withQt}"
142 echo " _qmakePath
: %{_qmakePath}"
143 echo " _mesaIncludePath
: %{_mesaIncludePath}"
144 echo " _mesaLibPath
: %{_mesaLibPath}"
145 echo " _pythonLibPath
: %{_pythonLibPath}"
149 # start with these general settings
150 addCMakeVariable VTK_USE_TK
:BOOL
=OFF
151 addCMakeVariable BUILD_SHARED_LIBS
:BOOL
=ON VTK_USE_RPATH
:BOOL
=OFF
152 addCMakeVariable CMAKE_BUILD_TYPE
:STRING
=Release
154 # include development files in "make install"
155 addCMakeVariable PARAVIEW_INSTALL_DEVELOPMENT
:BOOL
=ON
157 # new alternative to "make HTMLDocumentation"
158 addCMakeVariable PARAVIEW_GENERATE_PROXY_DOCUMENTATION
:BOOL
=ON
161 # Additional installation rules for Mac OS X
162 addCMakeVariable PARAVIEW_EXTRA_INSTALL_RULES_FILE
:FILEPATH
=%{_topdir}/BUILD/%{name}-%{version}/Applications
/ParaView
-3.12.0_extra_install_Darwin.cmake
165 # Add the value of _qmakePath for QT_QMAKE_EXECUTABLE
166 addCMakeVariable QT_QMAKE_EXECUTABLE
:FILEPATH
=%{_qmakePath}
168 echo "CMAKE_VARIABLES
: $CMAKE_VARIABLES"
172 # The configuration of Paraview will be using the environment variable MACOSX_DEPLOYMENT_TARGET.
173 # This variable was initialized using 'sw_vers -productVersion' in etc/bashrc.
174 # We need to get rid of the revision number from this string. eg turn "10.7.5" into "10.7"
175 v
=( $
{MACOSX_DEPLOYMENT_TARGET
//.
/ } )
176 export MACOSX_DEPLOYMENT_TARGET
="$
{v
[0]}.$
{v
[1]}"
177 echo "Resetting MACOSX_DEPLOYMENT_TARGET to $
{MACOSX_DEPLOYMENT_TARGET
}"
184 -DCMAKE_INSTALL_PREFIX
:PATH
=%{_installPrefix} \
188 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
189 make -j $WM_NCOMPPROCS
192 # On OpenSUSE, rpmbuild, will choke when detecting unreferenced symlinks
193 # created during installation.
194 # Qt version 4.6.3 will generate some unreferenced symlinks when
195 # ParaView is compiled and installed. By enabling the following
196 # environment variable, the command brp-symlink will still complain
197 # about missing link targets, but it won't stop rpmbuild from generating
199 # For all other Unix distros, this is a no-op.
200 export NO_BRP_STALE_LINK_ERROR
=yes
203 make install DESTDIR
=$RPM_BUILD_ROOT
205 # Creation of foam-extend specific .csh and .sh files"
208 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
211 # Generate package specific .sh file for foam-extend
213 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
214 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
215 # Load %{name}-%{version} libraries and binaries if available
216 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
218 export PARAVIEW_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
219 export PARAVIEW_BIN_DIR
=\$PARAVIEW_DIR
/bin
220 export PARAVIEW_LIB_DIR
=\$PARAVIEW_DIR
/lib
221 export PARAVIEW_INCLUDE_DIR
=\$PARAVIEW_DIR
/include
223 export PARAVIEW_VERSION
=%{version}
225 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
226 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
227 # specified directory to see if a given library is a paraview plugin.
228 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
229 # startup of paraview or even make paraview crash on startup.
230 export PV_PLUGIN_PATH
=\$FOAM_LIBBIN
/paraview_plugins
232 [ -d \$PARAVIEW_LIB_DIR
/paraview
-3.12 ] && _foamAddLib \$PARAVIEW_LIB_DIR
/paraview
-3.12
234 # Enable access to the package applications if present
235 [ -d \$PARAVIEW_BIN_DIR
] && _foamAddPath \$PARAVIEW_BIN_DIR
237 # Additional binary path if running on Mac OS X
238 [ -d \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
] && _foamAddPath \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
243 # Generate package specific .csh file for foam-extend
245 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
246 # Load %{name}-%{version} libraries and binaries if available
247 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
248 setenv PARAVIEW_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
249 setenv PARAVIEW_BIN_DIR \$PARAVIEW_DIR
/bin
250 setenv PARAVIEW_LIB_DIR \$PARAVIEW_DIR
/lib
251 setenv PARAVIEW_INCLUDE_DIR \$PARAVIEW_DIR
/include
253 setenv PARAVIEW_VERSION
%{version}
255 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
256 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
257 # specified directory to see if a given library is a paraview plugin.
258 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
259 # startup of paraview or even make paraview crash on startup.
260 setenv PV_PLUGIN_PATH \$FOAM_LIBBIN
/paraview_plugins
262 if ( -e \$PARAVIEW_BIN_DIR
) then
263 _foamAddPath \$PARAVIEW_BIN_DIR
266 if ( -e \$PARAVIEW_LIB_DIR
/paraview
-3.12 ) then
267 _foamAddLib \$PARAVIEW_LIB_DIR
/paraview
-3.12
271 # Additional binary path if running on Mac OS X
272 if ( -e \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
) then
273 _foamAddPath \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
277 #finally, generate a .tgz file for systems where using rpm for installing packages
278 # as a non-root user might be a problem.
279 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
281 # Make sure we clean the installation directory. Somehow, make install generates files there. Need to revisit this eventually.
282 (rm -rf
%{_prefix}/packages/%{name}-%{version} )
285 rm -rf $RPM_BUILD_ROOT
286 rm -rf
%{_prefix}/packages/%{name}-%{version}
289 %defattr(-,root
,root
)