1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for ParaView-3.8.1
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
64 %define release
%{_WM_OPTIONS}
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
75 URL: http
://www.paraview.org
/files
/v3.8
/
76 Source: %url/%{name}-%{version}.tar.gz
78 Group: Development
/Tools
79 Patch0: ParaView
-3.8.1.patch_darwin
81 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
83 #--------------------------------------------------------------------------
85 # Here, we define default compiling options for cmake
87 # One can override the option on the commande line : --define='MACRO EXPR'
89 %{!?_withVerbose: %define _withVerbose false}
90 %{!?_withMesa: %define _withMesa false}
91 %{!?_withMPI: %define _withMPI false}
92 %{!?_withPython: %define _withPython false}
93 %{!?_withQt: %define _withQt true}
94 %{!?_qmakePath: %define _qmakePath Undefined}
95 %{!?_mesaIncludePath: %define _mesaIncludePath Undefined}
96 %{!?_mesaLibPath: %define _mesaLibPath Undefined}
97 %{!?_pythonLibPath: %define _pythonLibPath Undefined}
99 #--------------------------------------------------------------------------
113 # set CMake cache variables
119 CMAKE_VARIABLES
="$CMAKE_VARIABLES
-D$
1"
124 # export WM settings in a form that GNU configure recognizes
125 [ -n "$WM_CC"
] && export CC
="$WM_CC"
126 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
127 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
128 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
129 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
133 echo "Compilation options
:"
134 echo " _withVerbose
: %{_withVerbose}"
135 echo " _withMesa
: %{_withMesa}"
136 echo " _withMPI
: %{_withMPI}"
137 echo " _withPython
: %{_withPython}"
138 echo " _withQt
: %{_withQt}"
139 echo " _qmakePath
: %{_qmakePath}"
140 echo " _mesaIncludePath
: %{_mesaIncludePath}"
141 echo " _mesaLibPath
: %{_mesaLibPath}"
142 echo " _pythonLibPath
: %{_pythonLibPath}"
146 # start with these general settings
147 addCMakeVariable VTK_USE_TK
:BOOL
=OFF
148 addCMakeVariable BUILD_SHARED_LIBS
:BOOL
=ON VTK_USE_RPATH
:BOOL
=OFF
149 addCMakeVariable CMAKE_BUILD_TYPE
:STRING
=Release
151 # include development files in "make install"
152 addCMakeVariable PARAVIEW_INSTALL_DEVELOPMENT
:BOOL
=ON
154 # new alternative to "make HTMLDocumentation"
155 addCMakeVariable PARAVIEW_GENERATE_PROXY_DOCUMENTATION
:BOOL
=ON
158 # Additional installation rules for Mac OS X
159 addCMakeVariable PARAVIEW_EXTRA_INSTALL_RULES_FILE
:FILEPATH
=%{_topdir}/BUILD/%{name}-%{version}/Applications
/ParaView
-3.8.1_extra_install_Darwin.cmake
162 # Add the value of _qmakePath for QT_QMAKE_EXECUTABLE
163 addCMakeVariable QT_QMAKE_EXECUTABLE
:FILEPATH
=%{_qmakePath}
165 echo "CMAKE_VARIABLES
: $CMAKE_VARIABLES"
171 -DCMAKE_INSTALL_PREFIX
:PATH
=%{_installPrefix} \
175 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
176 make -j $WM_NCOMPPROCS
179 # On OpenSUSE, rpmbuild, will choke when detecting unreferenced symlinks
180 # created during installation.
181 # Qt version 4.6.3 will generate some unreferenced symlinks when
182 # ParaView is compiled and installed. By enabling the following
183 # environment variable, the command brp-symlink will still complain
184 # about missing link targets, but it won't stop rpmbuild from generating
186 # For all other Unix distros, this is a no-op.
187 export NO_BRP_STALE_LINK_ERROR
=yes
190 make install DESTDIR
=$RPM_BUILD_ROOT
192 # Creation of foam-extend specific .csh and .sh files"
195 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
198 # Generate package specific .sh file for foam-extend
200 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
201 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
202 # Load %{name}-%{version} libraries and binaries if available
203 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
205 export PARAVIEW_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
206 export PARAVIEW_BIN_DIR
=\$PARAVIEW_DIR
/bin
207 export PARAVIEW_LIB_DIR
=\$PARAVIEW_DIR
/lib
208 export PARAVIEW_INCLUDE_DIR
=\$PARAVIEW_DIR
/include
/paraview
-3.8
210 export PARAVIEW_VERSION
=%{version}
212 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
213 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
214 # specified directory to see if a given library is a paraview plugin.
215 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
216 # startup of paraview or even make paraview crash on startup.
217 export PV_PLUGIN_PATH
=\$FOAM_LIBBIN
/paraview_plugins
219 [ -d \$PARAVIEW_LIB_DIR
/paraview
-3.8 ] && _foamAddLib \$PARAVIEW_LIB_DIR
/paraview
-3.8
221 # Enable access to the package applications if present
222 [ -d \$PARAVIEW_BIN_DIR
] && _foamAddPath \$PARAVIEW_BIN_DIR
224 # Additional binary path if running on Mac OS X
225 [ -d \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
] && _foamAddPath \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
230 # Generate package specific .csh file for foam-extend
232 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
233 # Load %{name}-%{version} libraries and binaries if available
234 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
235 setenv PARAVIEW_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
236 setenv PARAVIEW_BIN_DIR \$PARAVIEW_DIR
/bin
237 setenv PARAVIEW_LIB_DIR \$PARAVIEW_DIR
/lib
238 setenv PARAVIEW_INCLUDE_DIR \$PARAVIEW_DIR
/include
/paraview
-3.8
240 setenv PARAVIEW_VERSION
%{version}
242 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
243 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
244 # specified directory to see if a given library is a paraview plugin.
245 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
246 # startup of paraview or even make paraview crash on startup.
247 setenv PV_PLUGIN_PATH \$FOAM_LIBBIN
/paraview_plugins
249 if ( -e \$PARAVIEW_BIN_DIR
) then
250 _foamAddPath \$PARAVIEW_BIN_DIR
253 if ( -e \$PARAVIEW_LIB_DIR
/paraview
-3.8 ) then
254 _foamAddLib \$PARAVIEW_LIB_DIR
/paraview
-3.8
258 # Additional binary path if running on Mac OS X
259 if ( -e \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
) then
260 _foamAddPath \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
264 #finally, generate a .tgz file for systems where using rpm for installing packages
265 # as a non-root user might be a problem.
266 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
271 %defattr(-,root
,root
)