Switch all URLs from ftp.gnu.org to ftpmirror.gnu.org, along with usng http instead...
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / ParaView-4.3.1.spec
blob28436acbfcad4d6ad331e39349562b3d982e138c
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for ParaView-4.3.1
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Authors:
31 # Martin Beaudoin, Hydro-Quebec, (2010)
32 # Andreas Feymark, Chalmers University of Technology, (2013)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package %{nil}
43 # Turning off the Fascist build policy
44 # Useful for debugging the install section
45 %define _unpackaged_files_terminate_build 0
47 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
48 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
49 %define _tmppath %{_topdir}/tmp
51 # Will install the package directly $WM_THIRD_PARTY_DIR
52 # Some comments about package relocation:
53 # By using this prefix for the Prefix: parameter in this file, you will make this
54 # package relocatable.
56 # This is fine, as long as your software is itself relocatable.
58 # Simply take note that libraries built with libtool are not relocatable because the
59 # prefix we specify will be hard-coded in the library .la files.
60 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
62 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
63 # not be able to reutilize this RPM, even though it is relocatable. You will need to
64 # regenerate the RPM.
66 %define _prefix %{_WM_THIRD_PARTY_DIR}
68 %define name ParaView
69 %define release %{_WM_OPTIONS}
70 %define version 4.3.1
72 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
74 BuildRoot: %{buildroot}
75 Summary: ParaView
76 License: Unkown
77 Name: %{name}
78 Version: %{version}
79 Release: %{release}
80 URL: http://www.paraview.org/files/v4.3/
81 Source: %url/%{name}-v%{version}-source.tar.gz
82 Prefix: %{_prefix}
83 Group: Development/Tools
84 Patch0: ParaView-4.3.1.patch_darwin
86 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
88 #--------------------------------------------------------------------------
90 # Here, we define default compiling options for cmake
92 # One can override the option on the commande line : --define='MACRO EXPR'
94 %{!?_withVerbose: %define _withVerbose false}
95 %{!?_withMesa: %define _withMesa false}
96 %{!?_withMPI: %define _withMPI false}
97 %{!?_withPython: %define _withPython false}
98 %{!?_withQt: %define _withQt true}
99 %{!?_qmakePath: %define _qmakePath Undefined}
100 %{!?_mesaIncludePath: %define _mesaIncludePath Undefined}
101 %{!?_mesaLibPath: %define _mesaLibPath Undefined}
102 %{!?_pythonLibPath: %define _pythonLibPath Undefined}
104 #--------------------------------------------------------------------------
106 %description
107 %{summary}
109 %prep
110 %setup -q -n %{name}-v%{version}-source
112 %ifos darwin
113 %patch0 -p1
114 %endif
116 %build
118 # set CMake cache variables
120 addCMakeVariable()
122 while [ -n "$1" ]
124 CMAKE_VARIABLES="$CMAKE_VARIABLES -D$1"
125 shift
126 done
129 # export WM settings in a form that GNU configure recognizes
130 [ -n "$WM_CC" ] && export CC="$WM_CC"
131 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
132 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
133 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
134 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
136 set +x
137 echo ""
138 echo "Compilation options:"
139 echo " _withVerbose : %{_withVerbose}"
140 echo " _withMesa : %{_withMesa}"
141 echo " _withMPI : %{_withMPI}"
142 echo " _withPython : %{_withPython}"
143 echo " _withQt : %{_withQt}"
144 echo " _qmakePath : %{_qmakePath}"
145 echo " _mesaIncludePath : %{_mesaIncludePath}"
146 echo " _mesaLibPath : %{_mesaLibPath}"
147 echo " _pythonLibPath : %{_pythonLibPath}"
148 echo ""
149 set -x
151 # start with these general settings
152 addCMakeVariable BUILD_SHARED_LIBS:BOOL=ON
153 addCMakeVariable CMAKE_BUILD_TYPE:STRING=Release
154 addCMakeVariable BUILD_TESTING:BOOL=OFF
156 # We build with Python. This is ust too useful
157 addCMakeVariable PARAVIEW_ENABLE_PYTHON:BOOL=ON
159 # include development files in "make install"
160 addCMakeVariable PARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON
162 %ifos darwin
163 # Additional installation rules for Mac OSX
164 addCMakeVariable PARAVIEW_EXTRA_INSTALL_RULES_FILE:FILEPATH=%{_topdir}/BUILD/%{name}-v%{version}-source/Applications/ParaView-4.3.1_extra_install_Darwin.cmake
166 # We activate the new Unix-style installation for Mac OS X
167 addCMakeVariable PARAVIEW_DO_UNIX_STYLE_INSTALLS:BOOL=ON
169 # Recent version of Mac OSX (Yosemite) cannot compile ParaView with the gcc compiler
170 # Using clang instead
171 CC=clang
172 CXX=clang++
173 %endif
175 # Add the value of _qmakePath for QT_QMAKE_EXECUTABLE
176 addCMakeVariable QT_QMAKE_EXECUTABLE:FILEPATH=%{_qmakePath}
178 echo "CMAKE_VARIABLES: $CMAKE_VARIABLES"
180 mkdir -p ./buildObj
181 cd ./buildObj
183 cmake \
184 -DCMAKE_INSTALL_PREFIX:PATH=%{_installPrefix} \
185 $CMAKE_VARIABLES \
188 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
189 make -j $WM_NCOMPPROCS
191 %install
192 # On OpenSUSE, rpmbuild, will choke when detecting unreferenced symlinks
193 # created during installation.
194 # Qt version 4.6.3 will generate some unreferenced symlinks when
195 # ParaView is compiled and installed. By enabling the following
196 # environment variable, the command brp-symlink will still complain
197 # about missing link targets, but it won't stop rpmbuild from generating
198 # the final rpm.
199 # For all other Unix distros, this is a no-op.
200 export NO_BRP_STALE_LINK_ERROR=yes
202 cd buildObj
203 make install DESTDIR=$RPM_BUILD_ROOT
205 %ifos darwin
206 # Cleaning up some strange install side effect from option
207 # PARAVIEW_DO_UNIX_STYLE_INSTALLS
208 # Need to revisit this section eventually.
209 if [ -d "$RPM_BUILD_ROOT/$RPM_BUILD_ROOT" ]; then
210 mv $RPM_BUILD_ROOT/$RPM_BUILD_ROOT/%{_installPrefix}/bin/* $RPM_BUILD_ROOT/%{_installPrefix}/bin
212 %endif
214 # Creation of foam-extend specific .csh and .sh files"
216 echo ""
217 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
218 echo ""
220 # Generate package specific .sh file for foam-extend
222 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
223 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
224 # Load %{name}-%{version} libraries and binaries if available
225 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
227 export PARAVIEW_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
228 export PARAVIEW_BIN_DIR=\$PARAVIEW_DIR/bin
229 export PARAVIEW_LIB_DIR=\$PARAVIEW_DIR/lib
230 export PARAVIEW_INCLUDE_DIR=\$PARAVIEW_DIR/include/paraview-4.3
232 export PARAVIEW_VERSION=%{version}
234 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
235 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
236 # specified directory to see if a given library is a paraview plugin.
237 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
238 # startup of paraview or even make paraview crash on startup.
239 export PV_PLUGIN_PATH=\$FOAM_LIBBIN/paraview_plugins
241 [ -d \$PARAVIEW_LIB_DIR/paraview-4.3 ] && _foamAddLib \$PARAVIEW_LIB_DIR/paraview-4.3
243 # Enable access to the package applications if present
244 [ -d \$PARAVIEW_BIN_DIR ] && _foamAddPath \$PARAVIEW_BIN_DIR
246 # Additional binary path if running on Mac OS X
247 [ -d \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS ] && _foamAddPath \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS
249 DOT_SH_EOF
252 # Generate package specific .csh file for foam-extend
254 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
255 # Load %{name}-%{version} libraries and binaries if available
256 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
257 setenv PARAVIEW_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
258 setenv PARAVIEW_BIN_DIR \$PARAVIEW_DIR/bin
259 setenv PARAVIEW_LIB_DIR \$PARAVIEW_DIR/lib
260 setenv PARAVIEW_INCLUDE_DIR \$PARAVIEW_DIR/include/paraview-4.3
262 setenv PARAVIEW_VERSION %{version}
264 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
265 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
266 # specified directory to see if a given library is a paraview plugin.
267 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
268 # startup of paraview or even make paraview crash on startup.
269 setenv PV_PLUGIN_PATH \$FOAM_LIBBIN/paraview_plugins
271 if ( -e \$PARAVIEW_BIN_DIR ) then
272 _foamAddPath \$PARAVIEW_BIN_DIR
273 endif
275 if ( -e \$PARAVIEW_LIB_DIR/paraview-4.3 ) then
276 _foamAddLib \$PARAVIEW_LIB_DIR/paraview-4.3
277 endif
280 # Additional binary path if running on Mac OS X
281 if ( -e \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS ) then
282 _foamAddPath \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS
283 endif
284 DOT_CSH_EOF
286 #finally, generate a .tgz file for systems where using rpm for installing packages
287 # as a non-root user might be a problem.
288 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
290 %clean
292 %files
293 %defattr(-,root,root)
294 %{_installPrefix}