Switch all URLs from ftp.gnu.org to ftpmirror.gnu.org, along with usng http instead...
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / openmpi-1.6.5.spec
blob5309fc3c295464c96aed1fdc011c879e4b96edf4
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for openmpi-1.6.3
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Author:
31 # Martin Beaudoin, Hydro-Quebec, (2013)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package %{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath %{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 # regenerate the RPM.
61 %define _prefix %{_WM_THIRD_PARTY_DIR}
63 %define name openmpi
64 %define release %{_WM_OPTIONS}
65 %define version 1.6.5
67 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
70 Summary: openmpi
71 License: Unkown
72 Name: %{name}
73 Version: %{version}
74 Release: %{release}
75 URL: http://www.open-mpi.org/software/ompi/v1.6/downloads
76 Source: %url/%{name}-%{version}.tar.gz
77 Prefix: %{_prefix}
78 Group: Development/Tools
81 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
83 #--------------------------------------------------------------------------
85 # Here, we define default compiling options for openmpi
87 # One can override the option on the commande line : --define='MACRO EXPR'
89 %{!?_configureAdditionalArgs: %define _configureAdditionalArgs Undefined}
92 %description
93 %{summary}
95 %prep
96 %setup -q
99 %build
100 # export WM settings in a form that GNU configure recognizes
101 [ -n "$WM_CC" ] && export CC="$WM_CC"
102 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
103 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
104 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
105 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
107 set +x
108 echo ""
109 echo "Compilation options:"
110 echo " _configureAdditionalArgs : %{_configureAdditionalArgs}"
111 echo ""
112 set -x
114 unset mpiWith
115 # Enable GridEngine if it appears to be in use
116 # If you don't want any integration with SGE, simply unset the SGE
117 # environment variable
118 if [ -n "$SGE_ROOT" ]
119 then
120 mpiWith="$mpiWith --with-sge"
121 else
122 mpiWith="$mpiWith --without-sge"
123 mpiWith="$mpiWith --enable-mca-no-build=ras-gridengine,pls-gridengine"
126 # Infiniband support
127 # Adjust according to your local paths
128 # if [ -d /usr/local/ofed -a -d /usr/local/ofed/lib64 ]
129 # then
130 # mpiWith="$mpiWith --with-openib=/usr/local/ofed"
131 # mpiWith="$mpiWith --with-openib-libdir=/usr/local/ofed/lib64"
132 # fi
134 ./configure \
135 --prefix=%{_installPrefix} \
136 --exec_prefix=%{_installPrefix} \
137 --enable-mpirun-prefix-by-default \
138 --enable-orterun-prefix-by-default \
139 --enable-shared \
140 --disable-static \
141 --disable-mpi-f77 \
142 --disable-mpi-f90 \
143 --disable-mpi-cxx \
144 --without-slurm \
145 --enable-mpi-profile $mpiWith \
146 --disable-vt \
147 `echo %{?_configureAdditionalArgs}`
149 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
150 make -j $WM_NCOMPPROCS
152 %install
153 make install DESTDIR=$RPM_BUILD_ROOT
155 # Creation of foam-extend specific .csh and .sh files"
157 echo ""
158 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
159 echo ""
161 # Generate package specific .sh file for foam-extend
163 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
164 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
165 # Load %{name}-%{version} libraries and binaries
166 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
167 export OPENMPI_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
168 export OPENMPI_BIN_DIR=\$OPENMPI_DIR/bin
169 export OPENMPI_LIB_DIR=\$OPENMPI_DIR/lib
171 # Enable access to the package runtime applications and libraries
172 [ -d \$OPENMPI_BIN_DIR ] && _foamAddPath \$OPENMPI_BIN_DIR
173 [ -d \$OPENMPI_LIB_DIR ] && _foamAddLib \$OPENMPI_LIB_DIR
175 export MPI_HOME=\$OPENMPI_DIR
176 export MPI_ARCH_PATH=\$MPI_HOME
177 export OPAL_PREFIX=\$MPI_ARCH_PATH
179 # We initialize the rest of the environment using mpicc --showme:
180 export OPENMPI_INCLUDE_DIR="\`mpicc --showme:incdirs\`"
181 export OPENMPI_COMPILE_FLAGS="\`mpicc --showme:compile\`"
182 export OPENMPI_LINK_FLAGS="\`mpicc --showme:link\`"
184 # Set the foam-extend compilation flags
185 export PINC=\$OPENMPI_COMPILE_FLAGS
186 export PLIBS=\$OPENMPI_LINK_FLAGS
189 if [ "\$FOAM_VERBOSE" -a "\$PS1" ]
190 then
191 echo " Environment variables defined for OpenMPI:"
192 echo " OPENMPI_BIN_DIR : \$OPENMPI_BIN_DIR"
193 echo " OPENMPI_LIB_DIR : \$OPENMPI_LIB_DIR"
194 echo " OPENMPI_INCLUDE_DIR : \$OPENMPI_INCLUDE_DIR"
195 echo " OPENMPI_COMPILE_FLAGS : \$OPENMPI_COMPILE_FLAGS"
196 echo " OPENMPI_LINK_FLAGS : \$OPENMPI_LINK_FLAGS"
197 echo ""
198 echo " MPI_HOME : \$MPI_HOME"
199 echo " MPI_ARCH_PATH : \$MPI_ARCH_PATH"
200 echo " OPAL_PREFIX : \$OPAL_PREFIX"
201 echo " PINC : \$PINC"
202 echo " PLIBS : \$PLIBS"
204 DOT_SH_EOF
207 # Generate package specific .csh file for foam-extend
209 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
210 # Load %{name}-%{version} libraries and binaries
211 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
212 setenv OPENMPI_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
213 setenv OPENMPI_BIN_DIR \$OPENMPI_DIR/bin
214 setenv OPENMPI_LIB_DIR \$OPENMPI_DIR/lib
216 # Enable access to the package runtime applications and libraries
217 if ( -e \$OPENMPI_BIN_DIR ) then
218 _foamAddPath \$OPENMPI_BIN_DIR
219 endif
221 if ( -e \$OPENMPI_LIB_DIR ) then
222 _foamAddLib \$OPENMPI_LIB_DIR
223 endif
225 setenv MPI_HOME \$OPENMPI_DIR
226 setenv MPI_ARCH_PATH \$MPI_HOME
227 setenv OPAL_PREFIX \$MPI_ARCH_PATH
229 # We initialize the rest of the environment using mpicc --showme:
230 setenv OPENMPI_INCLUDE_DIR "\`mpicc --showme:incdirs\`"
231 setenv OPENMPI_COMPILE_FLAGS "\`mpicc --showme:compile\`"
232 setenv OPENMPI_LINK_FLAGS "\`mpicc --showme:link\`"
234 # Set the foam-extend compilation flags
235 setenv PINC "\$OPENMPI_COMPILE_FLAGS"
236 setenv PLIBS "\$OPENMPI_LINK_FLAGS"
239 if (\$?FOAM_VERBOSE && \$?prompt) then
240 echo " Environment variables defined for OpenMPI:"
241 echo " OPENMPI_BIN_DIR : \$OPENMPI_BIN_DIR"
242 echo " OPENMPI_LIB_DIR : \$OPENMPI_LIB_DIR"
243 echo " OPENMPI_INCLUDE_DIR : \$OPENMPI_INCLUDE_DIR"
244 echo " OPENMPI_COMPILE_FLAGS : \$OPENMPI_COMPILE_FLAGS"
245 echo " OPENMPI_LINK_FLAGS : \$OPENMPI_LINK_FLAGS"
246 echo ""
247 echo " MPI_HOME : \$MPI_HOME"
248 echo " MPI_ARCH_PATH : \$MPI_ARCH_PATH"
249 echo " OPAL_PREFIX : \$OPAL_PREFIX"
250 echo " PINC : \$PINC"
251 echo " PLIBS : \$PLIBS"
252 endif
253 DOT_CSH_EOF
255 #finally, generate a .tgz file for systems where using rpm for installing packages
256 # as a non-root user might be a problem.
257 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
260 %clean
261 rm -rf %{buildroot}
263 %files
264 %defattr(-,root,root)
265 %{_installPrefix}