1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for scotch-5.1.10b
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
64 %define release
%{_WM_OPTIONS}
65 %define version
5.1.10b
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
75 URL: https
://gforge.inria.fr
/frs
/download.php
/27583
76 Source: %url/%{name}-%{version}.tar.gz
78 Group: Development
/Tools
79 Patch0: scotch
-5.1.10b_patch_0
81 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
87 %setup -q
-n
%{name}_%{version}
92 # export WM settings in a form that GNU configure recognizes
93 [ -n "$WM_CC"
] && export CC
="$WM_CC"
94 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
95 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
96 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
97 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
100 # Here, unfortunately, some hand tweaking might be necessary if your system is not running Linux or MacOS X
102 ln
-s Make.inc
/Makefile.inc.i686_mac_darwin10.shlib Makefile.inc
104 ln
-s Make.inc
/Makefile.inc.i686_pc_linux2.shlib Makefile.inc
107 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
108 make -j $WM_NCOMPPROCS scotch CC
="$WM_CC" CXX
="$WM_CXX" CCD
="$WM_CC" CCS
="$WM_CC" AR
="$WM_CC"
109 make -j $WM_NCOMPPROCS ptscotch AR
="$WM_CC"
113 mkdir -p $RPM_BUILD_ROOT
%{_installPrefix}
114 make install prefix
=$RPM_BUILD_ROOT
%{_installPrefix}
116 # Creation of foam-extend specific .csh and .sh files"
119 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
122 # Generate package specific .sh file for foam-extend
124 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
125 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
126 # Load %{name}-%{version} libraries and binaries if available
127 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
129 export SCOTCH_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
130 export SCOTCH_BIN_DIR
=\$SCOTCH_DIR
/bin
131 export SCOTCH_LIB_DIR
=\$SCOTCH_DIR
/lib
132 export SCOTCH_INCLUDE_DIR
=\$SCOTCH_DIR
/include
134 # Enable access to the runtime package applications and libraries
135 [ -d \$SCOTCH_BIN_DIR
] && _foamAddPath \$SCOTCH_BIN_DIR
136 [ -d \$SCOTCH_LIB_DIR
] && _foamAddLib \$SCOTCH_LIB_DIR
140 # Generate package specific .csh file for foam-extend
142 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
143 # Load %{name}-%{version} libraries and binaries if available
144 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
145 setenv SCOTCH_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
146 setenv SCOTCH_BIN_DIR \$SCOTCH_DIR
/bin
147 setenv SCOTCH_LIB_DIR \$SCOTCH_DIR
/lib
148 setenv SCOTCH_INCLUDE_DIR \$SCOTCH_DIR
/include
150 if ( -e \$SCOTCH_BIN_DIR
) then
151 _foamAddPath \$SCOTCH_BIN_DIR
154 if ( -e \$SCOTCH_LIB_DIR
) then
155 _foamAddLib \$SCOTCH_LIB_DIR
159 #finally, generate a .tgz file for systems where using rpm for installing packages
160 # as a non-root user might be a problem.
161 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
168 %defattr(-,root
,root
)