1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for scotch-6.0.4
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2015)
32 #------------------------------------------------------------------------------
34 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
35 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
36 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
38 # Disable the generation of debuginfo packages
39 %define debug_package
%{nil}
41 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
42 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
43 %define _tmppath
%{_topdir}/tmp
45 # Will install the package directly $WM_THIRD_PARTY_DIR
46 # Some comments about package relocation:
47 # By using this prefix for the Prefix: parameter in this file, you will make this
48 # package relocatable.
50 # This is fine, as long as your software is itself relocatable.
52 # Simply take note that libraries built with libtool are not relocatable because the
53 # prefix we specify will be hard-coded in the library .la files.
54 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
56 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
57 # not be able to reutilize this RPM, even though it is relocatable. You will need to
60 %define _prefix
%{_WM_THIRD_PARTY_DIR}
63 %define release
%{_WM_OPTIONS}
66 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
68 BuildRoot: %{buildroot}
74 URL: https
://gforge.inria.fr
/frs
/download.php
/file
/34618/
75 Source: %url/%{name}_%{version}.tar.gz
77 Group: Development
/Tools
78 Patch0: scotch
-6.0.4_patch_0
79 Patch1: scotch
-6.0.4_patch_darwin
81 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
87 %setup -q
-n
%{name}_%{version}
96 # export WM settings in a form that GNU configure recognizes
97 # [ -n "$WM_CC" ] && export CC="$WM_CC"
98 # [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
99 # [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS *****"
100 # [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
101 # [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
104 # Here, unfortunately, some hand tweaking might be necessary if your system is not running Linux or MacOS X
106 ln
-s Make.inc
/Makefile.inc.i686_mac_darwin10.shlib Makefile.inc
108 ln
-s Make.inc
/Makefile.inc.i686_pc_linux2.shlib Makefile.inc
111 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
112 make -j $WM_NCOMPPROCS scotch CC
="$WM_CC" CXX
="$WM_CXX" CCD
="$WM_CC" CCS
="$WM_CC" AR
="$WM_CC"
113 make -j $WM_NCOMPPROCS ptscotch AR
="$WM_CC"
117 mkdir -p $RPM_BUILD_ROOT
%{_installPrefix}
118 make install prefix
=$RPM_BUILD_ROOT
%{_installPrefix}
120 # Creation of foam-extend specific .csh and .sh files"
123 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
126 # Generate package specific .sh file for foam-extend
128 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
129 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
130 # Load %{name}-%{version} libraries and binaries if available
131 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
133 export SCOTCH_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
134 export SCOTCH_BIN_DIR
=\$SCOTCH_DIR
/bin
135 export SCOTCH_LIB_DIR
=\$SCOTCH_DIR
/lib
136 export SCOTCH_INCLUDE_DIR
=\$SCOTCH_DIR
/include
138 # Enable access to the runtime package applications and libraries
139 [ -d \$SCOTCH_BIN_DIR
] && _foamAddPath \$SCOTCH_BIN_DIR
140 [ -d \$SCOTCH_LIB_DIR
] && _foamAddLib \$SCOTCH_LIB_DIR
144 # Generate package specific .csh file for foam-extend
146 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
147 # Load %{name}-%{version} libraries and binaries if available
148 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
149 setenv SCOTCH_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
150 setenv SCOTCH_BIN_DIR \$SCOTCH_DIR
/bin
151 setenv SCOTCH_LIB_DIR \$SCOTCH_DIR
/lib
152 setenv SCOTCH_INCLUDE_DIR \$SCOTCH_DIR
/include
154 if ( -e \$SCOTCH_BIN_DIR
) then
155 _foamAddPath \$SCOTCH_BIN_DIR
158 if ( -e \$SCOTCH_LIB_DIR
) then
159 _foamAddLib \$SCOTCH_LIB_DIR
163 #finally, generate a .tgz file for systems where using rpm for installing packages
164 # as a non-root user might be a problem.
165 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
172 %defattr(-,root
,root
)