Merge branch 'master' of ssh://git.code.sf.net/p/foam-extend/foam-extend-3.2
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / ParMetis-3.1.1.spec
blobf755b22bdf3012a854c6bc7974c10a06cdce4d6f
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for ParMetis-3.1.1
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Author:
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package %{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath %{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 # regenerate the RPM.
61 %define _prefix %{_WM_THIRD_PARTY_DIR}
63 %define name ParMetis
64 %define release %{_WM_OPTIONS}
65 %define version 3.1.1
67 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
70 Summary: ParMetis
71 License: Unkown
72 Name: %{name}
73 Version: %{version}
74 Release: %{release}
75 URL: http://glaros.dtc.umn.edu/gkhome/fetch/sw/parmetis/OLD
76 Source: %url/%{name}-%{version}.tar.gz
77 Prefix: %{_prefix}
78 Group: Development/Tools
79 Patch0: ParMetis-3.1.1.patch_darwin
80 Patch1: ParMetis-3.1.1.patch
82 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
84 %description
85 %{summary}
87 %prep
88 %setup -q
90 %ifos darwin
91 %patch0 -p1
92 %else
93 %patch1 -p1
94 %endif
96 %build
97 [ -n "$WM_CC" ] && export CC="$WM_CC"
98 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
99 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
100 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
101 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
103 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
104 make -j $WM_NCOMPPROCS
107 %install
108 # Manual installation
109 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include/ParMETISLib
110 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/lib
112 cp *.h $RPM_BUILD_ROOT/%{_installPrefix}/include
113 cp ParMETISLib/*.h $RPM_BUILD_ROOT/%{_installPrefix}/include/ParMETISLib
115 cp METISLib/libmetis-parmetis.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
116 cp ParMETISLib/libparmetis.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
118 # Creation of foam-extend specific .csh and .sh files"
120 echo ""
121 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
122 echo ""
124 # Generate package specific .sh file for foam-extend
126 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
127 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
128 # Load %{name}-%{version} libraries and binaries if available
129 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
131 export PARMETIS_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
132 export PARMETIS_BIN_DIR=\$PARMETIS_DIR/bin
133 export PARMETIS_LIB_DIR=\$PARMETIS_DIR/lib
134 export PARMETIS_INCLUDE_DIR=\$PARMETIS_DIR/include
136 # Enable access to the runtime package applications and libraries
137 [ -d \$PARMETIS_BIN_DIR ] && _foamAddPath \$PARMETIS_BIN_DIR
138 [ -d \$PARMETIS_LIB_DIR ] && _foamAddLib \$PARMETIS_LIB_DIR
140 DOT_SH_EOF
143 # Generate package specific .csh file for foam-extend
145 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
146 # Load %{name}-%{version} libraries and binaries if available
147 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
148 setenv PARMETIS_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
149 setenv PARMETIS_BIN_DIR \$PARMETIS_DIR/bin
150 setenv PARMETIS_LIB_DIR \$PARMETIS_DIR/lib
151 setenv PARMETIS_INCLUDE_DIR \$PARMETIS_DIR/include
153 if ( -e \$PARMETIS_BIN_DIR ) then
154 _foamAddPath \$PARMETIS_BIN_DIR
155 endif
157 if ( -e \$PARMETIS_LIB_DIR ) then
158 _foamAddLib \$PARMETIS_LIB_DIR
159 endif
160 DOT_CSH_EOF
162 #finally, generate a .tgz file for systems where using rpm for installing packages
163 # as a non-root user might be a problem.
164 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
167 %clean
168 rm -rf %{buildroot}
170 %Files
171 %defattr(-,root,root)
172 %{_installPrefix}/*