1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for qt-everywhere-opensource-src-4.7.4
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2012)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
63 %define name qt
-everywhere
-opensource
-src
64 %define release
%{_WM_OPTIONS}
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 %define _unpackaged_files_terminate_build
0
70 %define _missing_doc_files_terminate_build
0
72 BuildRoot: %{buildroot}
73 Summary: qt
-everywhere
-opensource
-src
78 URL: http
://get.qt.nokia.com
/qt
/source/qt
-everywhere
-opensource
-src
79 Source: %url/%{name}-%{version}.tar.gz
81 Group: Development
/Tools
84 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
93 # export WM settings in a form that GNU configure recognizes
94 [ -n "$WM_CC"
] && export CC
="$WM_CC"
95 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
96 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
97 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
98 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
101 -opensource
--confirm
-license
=yes \
103 -nomake examples
-nomake demos \
104 --prefix
=%{_installPrefix}
106 # Explicitely specify LD_LIBRARY_PATH so it can find QT own libraries
107 export LD_LIBRARY_PATH
=$LD_LIBRARY_PATH
:%{_builddir}/%{name}-%{version}/lib
109 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
110 make -j $WM_NCOMPPROCS
113 # Makefiles generated by qmake do not to support the DESTDIR= option
114 # We need to use the INSTALL_ROOT= option instead
115 make install INSTALL_ROOT
=$RPM_BUILD_ROOT
117 # Creation of foam-extend specific .csh and .sh files"
120 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
123 # Generate package specific .sh file for foam-extend
125 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
126 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
127 # Load %{name}-%{version} libraries and binaries if available
128 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
130 export QT_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
131 export QT_BIN_DIR
=\$QT_DIR
/bin
132 export QT_LIB_DIR
=\$QT_DIR
/lib
134 # Enable access to the runtime package applications
135 [ -d \$QT_BIN_DIR
] && _foamAddPath \$QT_BIN_DIR
136 [ -d \$QT_LIB_DIR
] && _foamAddLib \$QT_LIB_DIR
140 # Generate package specific .csh file for foam-extend
142 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
143 # Load %{name}-%{version} libraries and binaries if available
144 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
145 setenv QT_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
146 setenv QT_BIN_DIR \$QT_DIR
/bin
147 setenv QT_LIB_DIR \$QT_DIR
/lib
149 if ( -e \$QT_BIN_DIR
) then
150 _foamAddPath \$QT_BIN_DIR
153 if ( -e \$QT_LIB_DIR
) then
154 _foamAddLib \$QT_LIB_DIR
158 #finally, generate a .tgz file for systems where using rpm for installing packages
159 # as a non-root user might be a problem.
160 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
167 %defattr(-,root
,root
)