Bumped ThirdParty (scotch-6.0.0, metis-5.1.0, ParMetis-4.0.3) / Updates for gcc 4.8.1
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / ParMetis-4.0.3.spec
blobe80904226cf6be5672aafdc02fa01cd30f350923
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for ParMetis-4.0.3
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package %{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath %{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in this file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
60 # regenerate the RPM.
62 %define _prefix %{_WM_THIRD_PARTY_DIR}
64 %define name parmetis
65 %define release %{_WM_OPTIONS}
66 %define version 4.0.3
68 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
71 Summary: parmetis
72 License: Unkown
73 Name: %{name}
74 Version: %{version}
75 Release: %{release}
76 URL: http://glaros.dtc.umn.edu/gkhome/fetch/sw/parmetis
77 Source: %url/%{name}-%{version}.tar.gz
78 Prefix: %{_prefix}
79 Group: Development/Tools
80 Patch0: ParMetis-3.1.1.patch_darwin
81 Patch1: ParMetis-3.1.1.patch
83 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
85 %description
86 %{summary}
88 %prep
89 %setup -q
91 %ifos darwin
92 %patch0 -p1
93 #%else
94 #patch1 -p1
95 %endif
97 %build
98 [ -n "$WM_CC" ] && export CC="$WM_CC"
99 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
100 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
101 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
102 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
104 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
105 make config
106 make -j $WM_NCOMPPROCS
109 %install
110 # Manual installation
111 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include/ParMETISLib
112 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/lib
114 cp include/*.h $RPM_BUILD_ROOT/%{_installPrefix}/include
115 cp metis/libmetis/*.h $RPM_BUILD_ROOT/%{_installPrefix}/include/ParMETISLib
117 cp build/*/libparmetis/lib* $RPM_BUILD_ROOT/%{_installPrefix}/lib
118 cp build/*/libmetis/lib* $RPM_BUILD_ROOT/%{_installPrefix}/lib
120 # Creation of OpenFOAM specific .csh and .sh files"
122 echo ""
123 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
124 echo ""
126 # Generate package specific .sh file for OpenFOAM
128 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
129 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
130 # Load %{name}-%{version} libraries and binaries if available
131 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
133 export PARMETIS_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
134 export PARMETIS_BIN_DIR=\$PARMETIS_DIR/bin
135 export PARMETIS_LIB_DIR=\$PARMETIS_DIR/lib
136 export PARMETIS_INCLUDE_DIR=\$PARMETIS_DIR/include
138 # Enable access to the runtime package applications and libraries
139 [ -d \$PARMETIS_BIN_DIR ] && _foamAddPath \$PARMETIS_BIN_DIR
140 [ -d \$PARMETIS_LIB_DIR ] && _foamAddLib \$PARMETIS_LIB_DIR
142 DOT_SH_EOF
145 # Generate package specific .csh file for OpenFOAM
147 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
148 # Load %{name}-%{version} libraries and binaries if available
149 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
150 setenv PARMETIS_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
151 setenv PARMETIS_BIN_DIR \$PARMETIS_DIR/bin
152 setenv PARMETIS_LIB_DIR \$PARMETIS_DIR/lib
153 setenv PARMETIS_INCLUDE_DIR \$PARMETIS_DIR/include
155 if ( -e \$PARMETIS_BIN_DIR ) then
156 _foamAddPath \$PARMETIS_BIN_DIR
157 endif
159 if ( -e \$PARMETIS_LIB_DIR ) then
160 _foamAddLib \$PARMETIS_LIB_DIR
161 endif
162 DOT_CSH_EOF
164 #finally, generate a .tgz file for systems where using rpm for installing packages
165 # as a non-root user might be a problem.
166 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
169 %clean
170 rm -rf %{buildroot}
172 %Files
173 %defattr(-,root,root)
174 %{_installPrefix}/*