civ2civ3: improve README.civ2civ3 text.
[freeciv.git] / data / hex2t / tiles.spec
blob749bbaa570166cd941abcd7fc99efe8741750451
2 [spec]
4 ; Format and options of this spec file:
5 options = "+Freeciv-spec-Devel-2015-Mar-25"
7 [info]
9 artists = "
10 Tatu Rissanen <tatu.rissanen@hut.fi>
11 Jeff Mallatt <jjm@codewell.com> (miscellaneous)
12 Tommy <yobbo3@hotmail.com> (hex mode)
13 Daniel Markstedt <himasaram@spray.se> (added dithering)
16 [file]
17 gfx = "hex2t/tiles"
19 [grid_main]
21 x_top_left = 1
22 y_top_left = 1
23 dx = 40
24 dy = 72
25 pixel_border = 1
27 tiles = { "row", "column","tag"
29 ; Roads
31 0, 0, "road.road_n"
32 0, 1, "road.road_ne"
33 0, 2, "road.road_e"
34 0, 7, "road.road_se"
35 0, 3, "road.road_s"
36 0, 4, "road.road_sw"
37 0, 5, "road.road_w"
38 0, 6, "road.road_nw"
40 0, 8, "road.road_isolated"
42 ; Rails
44 1, 0, "road.rail_n"
45 1, 1, "road.rail_ne"
46 1, 2, "road.rail_e"
47 1, 7, "road.rail_se"
48 1, 3, "road.rail_s"
49 1, 4, "road.rail_sw"
50 1, 5, "road.rail_w"
51 1, 6, "road.rail_nw"
53 1, 8, "road.rail_isolated"
56 ; Maglevs
58 2, 0, "road.maglev_n"
59 2, 1, "road.maglev_ne"
60 2, 2, "road.maglev_e"
61 2, 7, "road.maglev_se"
62 2, 3, "road.maglev_s"
63 2, 4, "road.maglev_sw"
64 2, 5, "road.maglev_w"
65 2, 6, "road.maglev_nw"
67 2, 8, "road.maglev_isolated"
69 ; terrain : if more t.whateverN are given it picks one randomly for each tile.
70 ; for example with t.desert1 and t.desert2.
71 ; ... actually in this tileset it doesn't even use these
72 ; as the second ocean layer is drawn over the top of them
73 ; but it's useful to know ...
75 3, 0, "t.l0.desert1"
76 7, 6, "t.l0.desert2"
77 7, 7, "t.l0.desert3"
79 3, 1, "t.l0.plains1"
80 3, 2, "t.l0.grassland1"
81 3, 3, "t.l0.forest1"
82 3, 4, "t.l0.hills1"
83 3, 5, "t.l0.mountains1"
84 3, 6, "t.l0.tundra1"
85 3, 7, "t.l0.arctic1"
86 3, 8, "t.l0.swamp1"
88 7, 9, "t.l0.inaccessible1"
90 ; FIXME: The same sprite is drawn twice on top of each other here.
91 3, 3, "t.l0.jungle1"
92 3, 9, "t.l1.jungle1"
94 ; more ocean in overlays
95 ; 3, 10, "t.l0.coast1"
96 ; 7, 8, "t.l0.coast2"
97 ; 3, 11, "t.l0.floor1"
99 ; Terrain special resources:
101 4, 0, "ts.oasis"
102 5, 0, "ts.oil"
103 4, 1, "ts.buffalo"
104 5, 1, "ts.wheat"
105 5, 2, "ts.grassland_resources", "ts.river_resources"
106 4, 3, "ts.pheasant"
107 5, 3, "ts.silk"
108 4, 4, "ts.coal"
109 5, 4, "ts.wine"
110 4, 5, "ts.gold"
111 5, 5, "ts.iron"
112 4, 6, "ts.tundra_game"
113 5, 6, "ts.furs"
114 4, 7, "ts.arctic_ivory"
115 5, 7, "ts.arctic_oil"
116 4, 8, "ts.peat"
117 5, 8, "ts.spice"
118 4, 9, "ts.gems"
119 5, 9, "ts.fruit"
120 4, 10, "ts.fish"
121 5, 10, "ts.whales"
123 6, 7, "ts.seals"
124 6, 8, "ts.forest_game"
125 6, 9, "ts.horses"
128 ; extras
130 6, 0, "tx.oil_mine", "tx.oil_rig"
131 6, 1, "tx.mine"
132 6, 2, "tx.irrigation"
133 6, 3, "tx.farmland"
134 6, 4, "tx.pollution"
135 6, 5, "tx.fallout"
136 6, 6, "tx.village"
138 ; random stuff
140 7, 0, "t.dither_tile"
141 7, 0, "tx.darkness"
142 7, 2, "mask.tile"
143 7, 3, "t.coast_color"
145 7, 4, "user.attention"
146 7, 5, "tx.fog"
148 ; darkness
150 8, 0, "tx.darkness_n"
151 8, 1, "tx.darkness_ne"
152 8, 2, "tx.darkness_e"
153 8, 3, "tx.darkness_s"
154 8, 4, "tx.darkness_sw"
155 8, 5, "tx.darkness_w"
157 ; goto path
159 8, 6, "path.step" ; turn boundary within path
160 8, 7, "path.exhausted_mp" ; tip of path, no MP left
161 8, 8, "path.normal" ; tip of path with MP remaining
162 8, 9, "path.waypoint"
165 [grid_upkeep]
167 x_top_left = 452
168 y_top_left = 455
169 dx = 40
170 dy = 28
171 pixel_border = 1
173 tiles = { "row", "column","tag"
175 ; Unit upkeep in city dialog:
176 ; These should probably be handled differently and have
177 ; a different size...
179 0, 0, "upkeep.shield"
180 1, 0, "upkeep.gold"
181 2, 0, "upkeep.gold2"
182 3, 0, "upkeep.food"
183 4, 0, "upkeep.food2"
184 5, 0, "upkeep.unhappy"
185 6, 0, "upkeep.unhappy2"