2 ; The names
for city tiles are not free and must follow the following rules.
3 ; The names consists of 'style name'
+ '_'
+ 'index'. The style name is as
4 ; specified
in cities.ruleset file and the index only defines the
read order
5 ; of the images. The definitions are
read starting with index
0 till the first
6 ; missing value The index is checked against the city bonus of effect
7 ; EFT_CITY_IMG and the resulting image is used to draw the city on the tile.
9 ; Obviously the first tile must be 'style_name'_city_0 and the sizes must be
10 ; in ascending order. There must also be a 'style_name'_wall_0 tile used to
11 ; draw the wall and an occupied tile to indicate a military units
in a city.
12 ; The maximum number of images is only limited by the maximum size of a city
13 ; (currently MAX_CITY_SIZE
= 255).
18 ; Format and options of this spec file
:
19 options
= "
+Freeciv
-spec
-Devel
-2015-Mar
-25"
25 Steam Age by Smiley
, www.firstcultural.com
26 City walls by Hogne Håskjold
30 gfx
= "amplio
/medievalcities"
40 tiles
= { "row"
, "column"
, "tag"
42 ; used by all city styles
44 2, 11, "city.european_occupied_0"
45 2, 11, "city.industrial_occupied_0"
51 0, 0, "city.european_city_0"
52 0, 1, "city.european_city_1"
53 0, 2, "city.european_city_2"
54 0, 3, "city.european_city_3"
55 0, 4, "city.european_city_4"
56 0, 5, "city.european_wall_0"
57 0, 6, "city.european_wall_1"
58 0, 7, "city.european_wall_2"
59 0, 8, "city.european_wall_3"
60 0, 9, "city.european_wall_4"
62 1, 0, "city.industrial_city_0"
63 1, 1, "city.industrial_city_1"
64 1, 2, "city.industrial_city_2"
65 1, 3, "city.industrial_city_3"
66 1, 4, "city.industrial_city_4"
67 1, 5, "city.industrial_wall_0"
68 1, 6, "city.industrial_wall_1"
69 1, 7, "city.industrial_wall_2"
70 1, 8, "city.industrial_wall_3"
71 1, 9, "city.industrial_wall_4"