2 ; The names
for city tiles are not free and must follow the following rules.
3 ; The names consists of 'style name'
+ '_'
+ 'index'. The style name is as
4 ; specified
in cities.ruleset file and the index only defines the
read order
5 ; of the images. The definitions are
read starting with index
0 till the first
6 ; missing value The index is checked against the city bonus of effect
7 ; EFT_CITY_IMG and the resulting image is used to draw the city on the tile.
9 ; Obviously the first tile must be 'style_name'_city_0 and the sizes must be
10 ; in ascending order. There must also be a 'style_name'_wall_0 tile used to
11 ; draw the wall and an occupied tile to indicate a military units
in a city.
12 ; The maximum number of images is only limited by the maximum size of a city
13 ; (currently MAX_CITY_SIZE
= 255).
18 ; Format and options of this spec file
:
19 options
= "
+Freeciv
-spec
-Devel
-2015-Mar
-25"
24 Jerzy Klek
<jekl@altavista.net
>
26 european style based on trident tileset by
27 Tatu Rissanen
<tatu.rissanen@hut.
fi>
28 Marco Saupe
<msaupe@saale
-net.de
> (reworked classic
, industrial and modern
)
30 Vincent Croisier
<vincent.croisier@advalvas.be
> (ruins
)
34 gfx
= "isotrident
/cities"
43 tiles
= { "row"
, "column"
, "tag"
51 ; used by all city styles
54 0, 1, "base.airbase_mg"
55 0, 2, "tx.airbase_full"
56 0, 4, "base.fortress_fg"
57 0, 5, "base.fortress_bg"
58 0, 6, "extra.ruins_mg"
64 1, 0, "city.european_city_0"
65 1, 1, "city.european_city_1"
66 1, 2, "city.european_city_2"
67 ;1, 3, "city.european_wall"
68 1, 4, "city.european_occupied_0"
69 1, 5, "city.european_wall_0"
70 1, 6, "city.european_wall_1"
71 1, 7, "city.european_wall_2"
74 5, 0, "city.classical_city_0"
75 5, 1, "city.classical_city_1"
76 5, 2, "city.classical_city_2"
77 ;5, 3, "city.classical_wall"
78 5, 4, "city.classical_occupied_0"
79 5, 5, "city.classical_wall_0"
80 5, 6, "city.classical_wall_1"
81 5, 7, "city.classical_wall_2"
83 2, 0, "city.industrial_city_0"
84 2, 1, "city.industrial_city_1"
85 2, 2, "city.industrial_city_2"
86 ;2, 3, "city.industrial_wall"
87 2, 4, "city.industrial_occupied_0"
88 2, 5, "city.industrial_wall_0"
89 2, 6, "city.industrial_wall_1"
90 2, 7, "city.industrial_wall_2"
92 6, 0, "city.electricage_city_0"
93 6, 1, "city.electricage_city_1"
94 6, 2, "city.electricage_city_2"
95 ;6, 3, "city.electricage_wall"
96 6, 4, "city.electricage_occupied_0"
97 6, 5, "city.electricage_wall_0"
98 6, 6, "city.electricage_wall_1"
99 6, 7, "city.electricage_wall_2"
101 3, 0, "city.modern_city_0"
102 3, 1, "city.modern_city_1"
103 3, 2, "city.modern_city_2"
104 ;3, 3, "city.modern_wall"
105 3, 4, "city.modern_occupied_0"
106 3, 5, "city.modern_wall_0"
107 3, 6, "city.modern_wall_1"
108 3, 7, "city.modern_wall_2"
110 4, 0, "city.postmodern_city_0"
111 4, 1, "city.postmodern_city_1"
112 4, 2, "city.postmodern_city_2"
113 ;4, 3, "city.postmodern_wall"
114 4, 4, "city.postmodern_occupied_0"
115 4, 5, "city.postmodern_wall_0"
116 4, 6, "city.postmodern_wall_1"
117 4, 7, "city.postmodern_wall_2"