Make enum type conversion explicit.
[freeciv.git] / data / isotrident / morecities.spec
blobd76292aad9bc408e4c473748b6c1eede8c5c2470
2 ; The names for city tiles are not free and must follow the following rules.
3 ; The names consists of 'style name' + '_' + 'index'. The style name is as
4 ; specified in cities.ruleset file and the index only defines the read order
5 ; of the images. The definitions are read starting with index 0 till the first
6 ; missing value The index is checked against the city bonus of effect
7 ; EFT_CITY_IMG and the resulting image is used to draw the city on the tile.
9 ; Obviously the first tile must be 'style_name'_city_0 and the sizes must be
10 ; in ascending order. There must also be a 'style_name'_wall_0 tile used to
11 ; draw the wall and an occupied tile to indicate a military units in a city.
12 ; The maximum number of images is only limited by the maximum size of a city
13 ; (currently MAX_CITY_SIZE = 255).
16 [spec]
18 ; Format and options of this spec file:
19 options = "+Freeciv-spec-Devel-2015-Mar-25"
21 [info]
23 artists = "
24 Jerzy Klek <jekl@altavista.net>
26 european style based on trident tileset by
27 Tatu Rissanen <tatu.rissanen@hut.fi>
28 Marco Saupe <msaupe@saale-net.de> (reworked classic, industrial and modern)
31 [file]
32 gfx = "isotrident/morecities"
34 [grid_main]
36 x_top_left = 0
37 y_top_left = 0
38 dx = 64
39 dy = 48
41 tiles = { "row", "column", "tag"
43 ; city tiles
46 0, 0, "city.asian_city_0"
47 0, 1, "city.asian_city_1"
48 0, 2, "city.asian_city_2"
49 ;1, 3, "city.asian_wall"
50 0, 4, "city.asian_occupied_0"
51 0, 5, "city.asian_wall_0"
52 0, 6, "city.asian_wall_1"
53 0, 7, "city.asian_wall_2"
56 1, 0, "city.tropical_city_0"
57 1, 1, "city.tropical_city_1"
58 1, 2, "city.tropical_city_2"
59 ;5, 3, "city.tropical_wall"
60 1, 4, "city.tropical_occupied_0"
61 1, 5, "city.tropical_wall_0"
62 1, 6, "city.tropical_wall_1"
63 1, 7, "city.tropical_wall_2"