2 # Made with the iad of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Also some stuff taken from debmake scripts, by Cristopt Lameter.
6 # Uncomment this to turn on verbose mode.
9 CLIENTS
:= gtk2
,gtk3
,xaw
,sdl
,qt
11 CONFIG_PARAMS
:= --cache-file
=$(shell pwd
)/config.cache \
12 --prefix=/usr
--datadir=/usr
/share
/games
--bindir=/usr
/games \
13 --enable-client
=$(CLIENTS
) --with-xaw3d
--enable-svnrev \
21 (cd build
&& ..
/autogen.sh
$(CONFIG_PARAMS
) && $(MAKE
))
32 -rm -f debian
/*~ Makefile Makefile.bak core
*/Makefile
34 install: install-stamp
35 install-stamp
: build-stamp
41 (cd build
; $(MAKE
) DESTDIR
=`pwd`/..
/debian
/tmp
install)
42 # Temporary kludge because the potfiles are not getting installed
43 (cd build
/po
; $(MAKE
) prefix=`pwd`/..
/..
/debian
/tmp
/usr
install)
44 # cp debian/freeciv.desktop debian/tmp/usr/share/gnome/apps/Games
48 # Build architecture-independent files here (ie none).
51 # Build architecture-dependent files here.
52 binary-arch
: build
install
72 @echo
'source and diff are obsolete - use dpkg-source -b' >&2 ; false
74 binary
: binary-indep binary-arch
75 .PHONY
: build
clean binary-indep binary-arch binary