Fix attribution of settings output to correct server command.
[freeciv.git] / debian / rules
blob557e3eb7235331a88d598f1dc997502928bc1ee9
1 #!/usr/bin/make -f
2 # Made with the iad of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Also some stuff taken from debmake scripts, by Cristopt Lameter.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 CLIENTS := gtk2,gtk3,xaw,sdl,qt
11 CONFIG_PARAMS := --cache-file=$(shell pwd)/config.cache \
12 --prefix=/usr --datadir=/usr/share/games --bindir=/usr/games \
13 --enable-client=$(CLIENTS) --with-xaw3d --enable-svnrev \
14 --enable-shared
16 build: build-stamp
17 build-stamp:
18 dh_testdir
20 mkdir build
21 (cd build && ../autogen.sh $(CONFIG_PARAMS) && $(MAKE))
23 touch build-stamp
25 clean:
26 dh_testdir
27 dh_testroot
28 -rm -Rf build
29 -rm -f config.cache
30 dh_clean
32 -rm -f debian/*~ Makefile Makefile.bak core */Makefile
34 install: install-stamp
35 install-stamp: build-stamp
36 dh_testdir
37 dh_testroot
38 dh_clean -k
39 dh_installdirs
41 (cd build; $(MAKE) DESTDIR=`pwd`/../debian/tmp install)
42 # Temporary kludge because the potfiles are not getting installed
43 (cd build/po; $(MAKE) prefix=`pwd`/../../debian/tmp/usr install)
44 # cp debian/freeciv.desktop debian/tmp/usr/share/gnome/apps/Games
46 touch install-stamp
48 # Build architecture-independent files here (ie none).
49 binary-indep:
51 # Build architecture-dependent files here.
52 binary-arch: build install
53 dh_testdir
54 dh_testroot
55 dh_installdocs
56 dh_installexamples
57 dh_installmenu
58 # dh_installman
59 dh_installchangelogs
60 dh_install
61 dh_strip
62 dh_compress
63 dh_fixperms
64 dh_installdeb
65 dh_makeshlibs
66 dh_shlibdeps
67 dh_gencontrol
68 dh_md5sums
69 dh_builddeb
71 source diff:
72 @echo 'source and diff are obsolete - use dpkg-source -b' >&2 ; false
74 binary: binary-indep binary-arch
75 .PHONY: build clean binary-indep binary-arch binary