2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
8 # These are used for cross-compiling and for saving the configure script
9 # from having to guess our platform (since we know it already)
10 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
11 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
15 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
20 ifeq (,$(findstring nostrip
,$(DEB_BUILD_OPTIONS
)))
25 -test ! -x .
/configure
&& ( aclocal
; autoheader
; automake
--add-missing
; autoreconf
)
28 config.status
: configure
30 # Add here commands to configure the package.
31 .
/configure
--prefix=/usr
--disable-run-updatemenu
36 build-stamp
: config.status
38 # Add here commands to compile the package.
40 #/usr/bin/docbook-to-man debian/fvwm-themes.sgml > fvwm-themes.1
46 # Add here commands to clean up after the build process.
49 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
50 cp
-f
/usr
/share
/misc
/config.sub config.sub
52 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
53 cp
-f
/usr
/share
/misc
/config.guess config.guess
64 # Add here commands to install the package into debian/fvwm-themes.
65 $(MAKE
) prefix=$(CURDIR
)/debian
/fvwm-themes
/usr ROOT_PREFIX
=$(CURDIR
)/debian
/fvwm-themes
mandir=$(CURDIR
)/debian
/fvwm-themes
/usr
/share
/man
install
68 # Build architecture-independent files here.
69 binary-indep
: build
install
70 chmod
0644 $(CURDIR
)/debian
/fvwm-themes
/usr
/share
/fvwm
/themes
/cde
/background
/pattern
73 # We have nothing to do by default.
74 # Build architecture-dependent files here.
76 binary-arch
: build
install
77 cp
-f debian
/base-control debian
/control
78 cp
-f debian
/base-changelog debian
/changelog
81 dh_installchangelogs ChangeLog
103 dh_shlibdeps debian
/fvwm-themes
/usr
/bin
/*
109 binary
: binary-indep binary-arch
110 .PHONY
: build
clean binary-indep binary-arch binary
install