mask e-file for removal.
[gentoo-china-overlay.git] / gnome-extra / docky / docky-2.0.1.ebuild
blob15108c0f1ff641883ddd1e89617af7cb4ad28520
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="2"
7 inherit gnome2-utils mono eutils
9 DESCRIPTION="Docky is a full fledged dock application that makes opening \
10 common applications and managing windows easier and quicker."
11 HOMEPAGE="https://launchpad.net/docky"
12 SRC_URI="http://launchpad.net/${PN}/2.0/${PV}/+download/${P}.tar.gz"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
19 # keep the same dependence as gnome-do
20 RDEPEND=">=dev-lang/mono-2.0
21 >=dev-dotnet/gconf-sharp-2.24.0
22 >=dev-dotnet/gtk-sharp-2.12.6
23 >=dev-dotnet/glade-sharp-2.12.6
24 dev-dotnet/dbus-sharp
25 dev-dotnet/dbus-glib-sharp
26 >=dev-dotnet/gnome-desktop-sharp-2.24.0
27 >=dev-dotnet/gnome-keyring-sharp-1.0.0
28 >=dev-dotnet/gnome-sharp-2.24.0
29 >=dev-dotnet/gnomevfs-sharp-2.24.0
30 >=dev-dotnet/wnck-sharp-2.24.0
31 >=dev-dotnet/art-sharp-2.24.0
32 >=dev-dotnet/rsvg-sharp-2.24.0
33 dev-dotnet/mono-addins
34 dev-dotnet/notify-sharp
35 !<gnome-extra/gnome-do-plugins-0.8"
36 DEPEND="${RDEPEND}
37 >=dev-util/intltool-0.35
38 dev-util/pkgconfig"
40 RESTRICT="mirror"
42 src_install() {
43 emake install DESTDIR="${D}" || die "Install failed"
46 pkg_preinst() { gnome2_icon_savelist; }
47 pkg_postinst() { gnome2_icon_cache_update; }
48 pkg_postrm() { gnome2_icon_cache_update; }