mask e-file for removal.
[gentoo-china-overlay.git] / net-misc / gemanx / gemanx-0.1.0.1.ebuild
blobf3d0bb51885dedb6c42cebfb3d523a94cb8b10bb
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="2"
7 MY_P="${PN}-gtk2-${PV}"
8 DESCRIPTION="GeMan X is a branch of PCMan X."
9 HOMEPAGE="http://code.google.com/p/gemanx/"
10 SRC_URI="http://gemanx.googlecode.com/files/${MY_P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="debug +imageview iplookup libnotify mmx socks5"
17 RDEPEND="
18 imageview? (
19 net-misc/curl
20 sys-apps/file )
21 >=x11-libs/gtk+-2.4
22 libnotify? ( x11-libs/libnotify )
23 x11-libs/libXft"
24 DEPEND="${RDEPEND}
25 dev-util/intltool"
27 S=${WORKDIR}/${MY_P}
28 RESTRICT="primaryuri"
30 src_configure() {
31 econf \
32 $(use_enable debug) \
33 $(use_enable imageview) \
34 $(use_enable iplookup) \
35 $(use_enable libnotify) \
36 $(use_enable mmx) \
37 $(use_enable socks5 proxy)
40 src_install() {
41 emake DESTDIR="${D}" install || die "Install failed"