mask e-file for removal.
[gentoo-china-overlay.git] / x11-themes / humanity-icon-theme / humanity-icon-theme-0.5.3.2.ebuild
blob6d93b9cbbd17b2eec21c487dde542b6f93381774
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="2"
7 inherit gnome2-utils
9 DESCRIPTION="Elementary Icons for Humans."
10 HOMEPAGE="https://launchpad.net/humanity"
11 SRC_URI="mirror://ubuntu/pool/main/h/${PN}/${PN}_${PV}_all.deb"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
16 IUSE=""
18 RDEPEND="
19         >=x11-misc/icon-naming-utils-0.8.90
20         media-gfx/imagemagick
21         >=gnome-base/librsvg-2.26.0
22         >=x11-themes/hicolor-icon-theme-0.10"
23 DEPEND=""
25 S=${WORKDIR}
26 RESTRICT="binchecks mirror strip"
28 src_unpack() {
29         default_src_unpack
30         unpack ./data.tar.gz
33 src_install() {
34         cp -r usr "${D}"
37 pkg_preinst() { gnome2_icon_savelist; }
38 pkg_postinst() { gnome2_icon_cache_update; }
39 pkg_postrm() { gnome2_icon_cache_update; }